Supported upgrade paths for SnapCenter 4.0

SnapCenter deployments without SnapCenter Plug-in for NAS File Services

After upgrading to SnapCenter Server 4.0, you must have the required licenses to add or modify storage systems.

SnapCenter deployments with SnapCenter Plug-in for NAS File Services

SnapCenter Server 4.0 does not support the SnapCenter Plug-in for NAS File Services. If you are using the SnapCenter Plug-in for NAS File Services with an earlier version of SnapCenter, you should review the upgrade paths that are supported and the tasks that are to be performed.

Existing setup Tasks to upgrade to SnapCenter 4.0
SnapCenter 2.0 or 3.0 You can perform one of the following tasks:
  1. Upgrade the SnapCenter Server, SnapCenter Plug-in for NAS File Services, SnapCenter Plug-ins Package for Windows (if applicable), and SnapCenter Plug-ins Package for Linux (if applicable) to version 3.0.1.
  2. Uninstall SnapCenter Plug-in for NAS File Services 3.0.1.
  3. Upgrade the SnapCenter Server, SnapCenter Plug-ins Package for Windows (if applicable), and SnapCenter Plug-ins Package for Linux (if applicable) from version 3.0.1 to version 4.0.

OR

  1. Uninstall the following components:
    1. Uninstall the SnapCenter Plug-ins Package for Windows (if applicable) and SnapCenter Plug-ins Package for Linux (if applicable).
    2. Uninstall the SnapCenter Server and SnapCenter Plug-in for NAS File Services.
    Note: When you uninstall your setup, you lose all of your backup metadata.
  2. Install SnapCenter Server 4.0 and version 4.0 of the SnapCenter Plug-ins Package for Windows (if applicable) and SnapCenter Plug-ins Package for Linux (if applicable).
SnapCenter 3.0.1 You can perform one of the following tasks:
  1. Uninstall SnapCenter Plug-in for NAS File Services 3.0.1.
  2. Upgrade the SnapCenter Server, SnapCenter Plug-ins Package for Windows (if applicable), and SnapCenter Plug-ins Package for Linux (if applicable) from version 3.0.1 to version 4.0.

OR

  1. Uninstall the following components:
    1. Uninstall the SnapCenter Plug-ins Package for Windows (if applicable) and SnapCenter Plug-ins Package for Linux (if applicable).
    2. Uninstall the SnapCenter Plug-in for NAS File Services.
    3. Uninstall the SnapCenter Server.
    Note: When you uninstall your setup, you lose all of your backup metadata.
  2. Install SnapCenter Server 4.0 and version 4.0 of the SnapCenter Plug-ins Package for Windows (if applicable) and SnapCenter Plug-ins Package for Linux (if applicable).