SnapCenter Plug-ins Package for Linux installation fails due to improper uninstallation

Description

The SnapCenter Plug-ins Package for Linux installation might fail if the uninstallation was not performed properly.

Error message

An instance of SnapCenter plug-in for Oracle is already installed

Corrective action

  1. List the RPM packages: rpm -qa | grep netapp-snapcenter-plugin
  2. Delete the RPM packages: rpm -e netapp-snapcenter-plugin-loader netapp-snapcenter-plugin-oracle netapp-snapcenter-plugin-unix
  3. Remove the /var/.com.zerog.registry.xml file manually.
  4. Verify if the SPL service is running by entering the following command: Ps -ef | grep spl
  5. If SPL service is still running, kill the process by running the following command: Kill -9 process_id