Upgrading SnapCenter Plug-in for VMware vSphere

Each release of SnapCenter contains an updated SnapCenter Server and plug-in package updates. The updates for SnapCenter Plug-ins Package for Windows include an update for SnapCenter Plug-in for VMware vSphere that is distributed with the SnapCenter installer.

Before you begin

You must upgrade the SnapCenter Server before you can upgrade the Plug-in for VMware vSphere hosts.

About this task

The following upgrade paths are supported for the Plug-in for VMware vSphere:
From version... You can upgrade to version...
2.0 3.0, 3.0.1, 4.0
3.0 3.0.1, 4.0
3.0.1 4.0

Steps

  1. In the left navigation pane of the SnapCenter GUI, click Hosts.
  2. Verify that Managed Hosts is selected at the top.
  3. Select the host for which you want to upgrade the plug-in package.
  4. Click Modify in the toolbar.
  5. In the Modify page, select Upgrade plug-ins.
    Note: All the plug-ins in the package gets selected but only the plug-ins that were installed with the earlier version of SnapCenter are upgraded and the remaining plug-ins are not installed. You must use the Add plug-ins option to install any new plug-in.
    If the Plug-in for VMware vSphere is installed on the SnapCenter host, then the Modify Port option is not active for the Plug-in for VMware vSphere. If the Plug-in for VMware vSphere is installed on a dedicated host, then the Modify Port option is active for the Plug-in for VMware vSphere.
  6. Select Skip preinstall checks if you do not want to validate whether the host meets the requirements to upgrade the plug-in.
  7. Click Next.
    If you have not selected the Skip preinstall checks check box, the host is validated to see if it meets the requirements to install the plug-in. The disk space, RAM, PowerShell version, .NET version, and location are validated against the minimum requirements. If the minimum requirements are not met, appropriate error or warning messages are displayed. After fixing the issue, click Validate to re-validate the requirements.
    Note: If the error is related to disk space or RAM, you can either update the web.config located at C:\Program Files\NetApp\SnapCenter WebApp or PowerShell config files located at C:\Windows\System32\WindowsPowerShell\v1.0\Modules\SnapCenter\ to modify the default values. If the error is related to remaining parameters you must fix the issue and then validate the requirements again.
  8. Review the summary, and then click Finish.
    The upgrade operation also registers the Plug-in for VMware vSphere with the vSphere web client in vCenter.

After you finish