Niveles de compatibilidad de firmware

Los comandos de script y los parámetros de comandos no funcionan en todas las versiones de firmware de la controladora. Los comandos de script incluidos en las siguientes secciones indican el nivel de firmware mínimo necesario para su ejecución. En los comandos de script, los niveles de firmware se indican bajo el encabezado "Nivel de firmware mínimo". En esta lista, se describe la forma de interpretar la información sobre los niveles de firmware.
  • Si un comando de script no indica el nivel de firmware mínimo de una controladora, es posible ejecutar ese comando y todos los parámetros asociados en cualquier nivel de firmware de la controladora.
  • Un número de firmware de la controladora sin información explicativa indica que el nivel de firmware se aplica a todo el comando de script y a todos los parámetros asociados.
  • Un número de firmware de la controladora asociado a un parámetro indica el nivel de firmware mínimo necesario para ejecutar el parámetro.
Nota: El nivel de firmware mínimo de una controladora indica la compatibilidad con el software que emite el comando, además de la compatibilidad con todo el software de administración del almacenamiento afectado por el uso. Las funcionalidades de compatibilidad con la interfaz de línea de comandos dependen del hardware que se usa. Cuando se introduce un comando no compatible, se muestra un mensaje de error.

Ejemplos de niveles de compatibilidad de firmware

El comando create hostGroup tiene la siguiente sección.

Nivel de firmware mínimo

8.10

Este nivel indica que todo el comando de script se ejecuta con un nivel de firmware mínimo de la controladora de 8.10.

El comando create ssdCache tiene la siguiente sección.

Nivel de firmware mínimo

7.84

8.20.11 - Se añadió el parámetro securityType.

Estas notas indican que el comando de script y todos los parámetros, excepto securityType, se ejecutan con un nivel de firmware mínimo de la controladora de 7.84. El parámetro securityType se ejecuta con un nivel de firmware mínimo de la controladora de 8.20_M3.