Erreur lors de la suppression d'un datastore après modification des paramètres réseau
Problème
Après avoir modifié l'adresse IP de l'appliance virtuelle pour VSC, VASA Provider et SRA, une erreur s'affiche lors de l'utilisation de l'interface VSC pour effectuer certaines opérations. Par exemple, la suppression d'un datastore ou la tentative d'accès au serveur VASA Provider sur l'hôte ESXi.
Cause
VCenter Server n'utilise pas l'adresse IP mise à jour et continue d'utiliser l'ancienne adresse IP pour passer des appels vers VASA Provider.
Action corrective
Lorsque l'adresse IP de l'appliance virtuelle pour VSC, VASA Provider et SRA est modifiée, vous devez effectuer les opérations suivantes :
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Annuler l'enregistrement de VSC à partir de vCenter Server.
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L'accès
https://<vcenter_ip>/mob
. -
Cliquez sur
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Connectez-vous au serveur vCenter en tant que racine à l'aide de putty.
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Passez au répertoire vsphere-client-sérénité à l'aide de :
cd /etc/vmware/vsphere-client/vc-packages/vsphere-client-serenity
. -
Arrêtez le service vSphere client: À l'aide de
vsphere-client stop
. -
Supprimez les répertoires contenant les extensions de l'interface utilisateur :
rm -rf com.netapp*
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Démarrez le service vSphere client: À l'aide de
vsphere-client start
.Cette opération peut prendre plusieurs minutes pour que le client vSphere redémarre et s'initialise correctement.
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Passez au répertoire vSphere-ui sérénité avec :
/etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/
. -
Arrêtez le service vSphere UI: À l'aide de
vsphere-ui stop
. -
Supprimez les répertoires contenant les extensions de l'interface utilisateur :
rm -rf com.netapp*
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Démarrez l'interface utilisateur vSphere à l'aide des éléments suivants :
service-control --start vsphere-ui
.