日本語は機械翻訳による参考訳です。内容に矛盾や不一致があった場合には、英語の内容が優先されます。

Python クライアントライブラリを使用するための準備

寄稿者 dmp-netapp このページの PDF をダウンロード

Python クライアントライブラリを使用する前に、環境を準備する必要があります。

基本的な要件

Python 3.5 以降を使用する必要があります。また、次のパッケージも必要です。

  • requests 2.22.1 以降

  • 要求 - 工具ベルト 0.9.1 以降

  • marshmallow 3.2.1 以降

パッケージの名前とバージョン

Python クライアントライブラリパッケージの名前は、 * netapp_ontap * です。パッケージに関連付けられているバージョンは、ライブラリの生成元である ONTAP のメジャーバージョンとマイナーバージョンの番号、および ONTAP リリース内のクライアントのマイナーバージョンを組み合わせたものです。たとえば、有効なバージョン番号は 9.6.1 、 9.6.2 、 9.7.1 などです。

インストール

Python Package Index ( PyPi ) Web サイトから、 pip を使用して netapp_ontap パッケージをインストールする必要があります。

ドキュメントおよびその他のリソース

ドキュメントやその他のリソースへのリンクについては、 NetApp Developer Network を参照してください。