准备使用 ONTAP Python 客户端库

在使用 Python 客户端库之前,应准备环境。

基本要求

必须使用 Python 3.5 或更高版本。还需要以下软件包:
  • 请求 2.21.0 或更高版本
  • MarshmAllow 3.2.1 或更高版本

软件包名称和版本

Python 客户端库包的名称是 NetApp_ONTAP 。与该软件包关联的版本是从该库生成的 ONTAP 主版本和次版本号的组合、以及 ONTAP 版本中客户端的次版本。例如,有效的版本号包括: 9.1.1 、 9.6.2 和 9.1.1 。

安装

您必须使用 Pip 从 Python 软件包索引 (PYPI) 网站安装 NetApp_ONTAP 软件包。

文档和其他资源

有关《》文档和其他资源的链接,请参见 NetApp 开发人员网络。