Compatible ONTAP versions for SnapMirror relationships

You should verify that the source and destination volumes are running compatible ONTAP versions before creating a SnapMirror data protection relationship.

Note: Version-independence is not supported for SVM replication.

SnapMirror DR relationships

For SnapMirror relationships of type DP and policy type async-mirror:
Note: In the following table, the column on the left indicates the ONTAP version on the source volume, and the top row indicates the ONTAP versions you can have on your destination volume.
Source Destination
  8.2 8.3 9.0 9.1 9.2 9.3 9.4 9.5 9.6 9.7 9.8 9.9.1
8.2 Yes Yes Yes No No No No No No No No No
8.3 No Yes Yes Yes No No No No No No No No
9.0 No No Yes Yes Yes No No No No No No No
9.1 No No No Yes Yes Yes No No No No No No
9.2 No No No No Yes Yes Yes No No No No No
9.3 No No No No No Yes Yes Yes No No No No
9.4 No No No No No No Yes Yes Yes No No No
9.5 No No No No No No No Yes Yes Yes No No
9.6 No No No No No No No No Yes Yes Yes No
9.7 No No No No No No No No No Yes Yes Yes
9.8 No No No No No No No No No No Yes Yes
9.9.1 No No No No No No No No No No No Yes
Note: Interoperability is not bidirectional.

Unified replication relationships

For SnapMirror relationships of type XDP, using on premises or Cloud Volumes ONTAP releases:
Note: The asterisk (*) after the release version indicates a Cloud Volumes ONTAP-only release.
Table 1. Interoperability for ONTAP version 9.3 and later
ONTAP version… Interoperates with previous ONTAP versions…
  9.3 9.4 9.5 9.6 9.7 9.8 9.9.0* 9.9.1
9.3 Yes - - - - - - -
9.4 Yes Yes - - - - - -
9.5 Yes Yes Yes - - - - -
9.6 Yes No Yes Yes - - - -
9.7 Yes No Yes Yes Yes - - -
9.8 Yes No Yes Yes Yes Yes - -
9.9.0* No No Yes Yes Yes Yes Yes -
9.9.1 No No Yes Yes Yes Yes Yes Yes
Note: Locate the higher, more recent ONTAP version in the left column, and in the right column locate the lower ONTAP version to determine interoperability. Interoperability is bidirectional.
Table 2. Interoperability for ONTAP version 8.3.x through ONTAP 9.2
ONTAP version… Interoperates with previous ONTAP versions…
  8.3.x 8.3.2 P4 9.0 9.1 9.2
8.3.x Yes - - - -
8.3.2 P4 Yes Yes - - -
9.0 Yes Yes Yes - -
9.1 Yes Yes Yes Yes -
9.2 No Yes Yes Yes Yes
Note: Locate the higher, more recent ONTAP version in the left column, and in the right column locate the lower ONTAP version to determine interoperability. Interoperability is bidirectional.