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Notice to Users
Single Mailbox Recovery software has been developed, copyrighted, and licensed by
KLDiscovery Ontrack, LLC. Use of the software is governed by the terms and conditions
of the end user license agreement contained within the software.

This manual should not be construed as any representation or warranty with respect to
the software named herein. Occasionally, changes or variations exist in the software
that are not reflected in the manual.

Generally, if such changes or variations are known to exist and affect the product
significantly, a release note or Read Me file will accompany the Administration Guide,
or will be available on the website. In that event, please read the release notes or Read
Me file before using the product.
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Introduction
Overview
Welcome to NetApp® Single Mailbox Recovery, the mailbox recovery software that saves time,
money, and resources when recovering Microsoft® Exchange Server data.

Single Mailbox Recovery works with your existing Microsoft Exchange Server backup architecture
and procedures, and enables you to recover individual mailboxes, folders, messages,
attachments, and even calendar, notes, and tasks directly to your production Microsoft
Exchange Server or any PST file. This eliminates time-consuming and expensive single mailbox
(brick-level) backups. This powerful software also lets you search and create a copy of all
archived email that matches a given keyword or criteria.

Because Single Mailbox Recovery can work in conjunction with your existing NetApp®
SnapManager® for Microsoft® Exchange andNetApp® SnapCenter® Plug-in for Microsoft®
Exchange Server environments, you can continue to use SnapManager or SnapCenter to
perform full, online backups of Exchange databases using NetApp Snapshot™ technology. This
technology enables you to retain many Exchange backups on aNetApp storage system with
minimal storage requirements for each incremental backup. Later, whenever you need to
restore previously deleted, individual Microsoft Exchange Server mail items, use Single Mailbox
Recovery to rapidly locate and then restore the items—at any level of granularity—directly to an
existing mailbox on your production Microsoft Exchange Server or to a new or existing offline
Outlook PST file.

n To restore mail items from an Exchange database (EDB) file in a SnapManager backup set
snapshot, connect to the LUN in the snapshot on the storage system and then use Single
Mailbox Recovery to restore the mail items directly from the SnapManager-created
Snapshot copy.

n To restore mail items from an Exchange database (EDB) file in a SnapCenter backup set
snapshot, mount the selected SnapCenter snapshot using Single Mailbox Recovery.

n To restore mail items from an EDB file in a tape or disk backup created using an Exchange-
aware backup application, first use the appropriate application-specific Single Mailbox
Recovery ExtractWizard agent to read the Exchange Server backup directly from the
backup media and restore the Exchange database to any alternate location where you
can perform Single Mailbox Recovery processes. You can then use Single Mailbox
Recovery to restore the mail items from the database. The use of a Single Mailbox
Recovery ExtractWizard agent also enables you to use Single Mailbox Recovery to restore
Exchange mail items from an archived copy of a SnapManager-based full backup set
created by a supported, Exchange-aware backup application run in copy mode.

n To restore mail items from anOutlook PST file located on any alternate location where you
can perform Single Mailbox Recovery processes, use the Single Mailbox Recovery PST
agent.
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Single Mailbox Recovery locates and restores Microsoft Exchange Server mail items without the
assistance of the Microsoft Exchange Server, thereby eliminating the need for a recovery server.
In contrast, most backup programs let you restore Microsoft Exchange Server data only to the
same or duplicate server from which it was backed up.

Five Major Reasons for Using Single Mailbox
Recovery
There are five primary ways you can benefit from using Single Mailbox Recovery:

1. Minimize the time to restore an individual mailbox.
Single Mailbox Recovery can slash restore time, making it possible to restore mail items from a
previous full backup directly into your production Microsoft Exchange Server, or directly into a
new or existing PST file. This eliminates the need for a recovery server and the extra steps
required to separately import mail back into Microsoft Exchange Server or Microsoft® Office
Outlook®.

2. Eliminate backups of an individual mailbox.
Single Mailbox Recovery eliminates the need to back up individual mailboxes because they
can be restored directly from a Microsoft Exchange Server Database (EDB) file.

3. Minimize the time to locate all email matching specific criteria.
Single Mailbox Recovery includes an Advanced Find feature that can search across all
mailboxes in an archive EDB file, rather than searching one mailbox at a time or bringing an old
backup back online for analysis. And you can search by a variety of criteria, including keywords,
subject, date and specific users.

4. Minimize storage space and the cost required to store and archive your backups.
Because you do not need to back up mailboxes individually doing a brick-level backup, you
eliminate the backup space, cost, and time associated with performing brick-level backups.

5. Minimize the time to back up all mailboxes.
Single Mailbox Recovery eliminates the need to back up mailboxes individually. Normally,
companies do a full Microsoft Exchange Server backup, and then run a second process to back
up "Very Important Mailboxes" (VIMs) individually as well. Single Mailbox Recovery eliminates this
second process.

Other Documents
In addition to this guide, you should be familiar with the Release Notes and reference guides (as
well as the most current information) and have them at hand, available for reference during
installation and administration.

Note: All of the documents can be found on the NetApp Support Site (NSS) site at
http://support.netapp.com.
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Release Notes
The NetApp® Single Mailbox Recovery Release Notes document contains additional
information about the Single Mailbox Recovery, including:

n Supported environments
n Installing and uninstalling Single Mailbox Recovery
n Single Mailbox Recovery licensing
n Single Mailbox Recovery agents
n Upgrading from previous versions
n Technical support

Reference Documents
You should have the following documents readily available for reference.

For detailed information about... Read
Connecting LUNs SnapDrive Installation and

Administration Guide for the version of
SnapDrive that you are using.

Configuring a Windows server Microsoft Windows documentation

Configuring Microsoft Outlook Microsoft Outlook documentation

Configuring Microsoft Exchange Microsoft Exchange documentation

Installing or upgrading SnapDrive™ software SnapDrive Installation and
Administration Guide for the version of
SnapDrive that you are using.

For the Most Current Information
The following documents contain the most current information about NetApp products.

For detailed information about... Read
Compatible versions of SnapDrive and
Data ONTAP® software

SnapDrive/ONTAP Compatibility Matrix

SnapDrive system requirements:
* Operating system
* Hardware platform
* Network

SnapDrive NSS Description page for the version of
SnapDrive that you are using

Single Mailbox Recovery installation
requirements

Single Mailbox Recovery NSS Description page

3



Getting Help
NetApp provides you with the following ways to get help with Single Mailbox Recovery:

n Online Help
n Technical Support

Online Help
Online Help includes all of the information in the user guide. You can quickly access this
information using the following online Help tabs:

n Contents: Displays a hierarchical view, similar to the Contents of the user guide.
n Index: Provides a list of key words to locate specific topics.
n Search: Offers a full-search of the Help file.

To start online Help
Do one of the following:

n On the Help menu, click Contents.

n Click on the toolbar.

n Press the F1 key.

Context Sensitive Help
You can click the Help button that appears on many of the dialog boxes when using Single
Mailbox Recovery to open the online Help topic related to the current task.

Tooltip
When you position the pointer over a tool or control and pause, a message box appears with a
definition of your selected item.

Technical Support
If you have questions or problems not answered in the user guide or the online Help (F1), call our
Technical Support group. When reporting an issue, please include any information that might
help us diagnose the problem. The following details are often the most helpful:

n The version of Single Mailbox Recovery you are using (on the Help menu, click About).
n The versions of the Windows® operating systems and Microsoft Office Outlook that you

are running.
n The version of Microsoft Exchange Server that contained the source EDB file.
n The circumstances and sequence of steps that led to the problem.
n The text of the error messages (if any appeared), and the contents of the Details window.
n A list of other Windows-based programs that you were running when the error occurred.
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See "Contact Information" at the beginning of this user guide.
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Chapter 1: Looking at the Interface
Overview
This chapter describes the parts of the main window of Single Mailbox Recovery and shows you
how to preview messages, view details of an EDB, PST, or CAS file, and change the view.

Main Window
The main window is where you do most of your work. This window displays the source EDB or PST
file(s) or Content Analysis Store (CAS), as well as the target PST file(s), Microsoft Exchange Server,
or CAS. The target acts as a container for the restored files. The various work areas and controls
are described in the following sections.

Figure 1-1: The main windowwith four panes

Key items on the Single Mailbox Recoverymain window:

1. Menu Bar
2. Toolbar
3. Source Location
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4. Source Pane
5. Source Message List
6. Target Location
7. Target Pane
8. Target Message List
9. Status Bar

Note: In the illustration above, the Source pane displays an EDB file, but it could just as easily
display a PST file, CAS, or evenmultiple EDB and PST files. The Target pane displays a PST that
acts as a container for restored files. Keep inmind that the Target pane could just as easily
display aMicrosoft Exchange Server.

Source Pane
The Source pane displays the data you intend to recover, such as the EDB file(s) or a content
analysis store (CAS).

Figure 1-2: Example of Source pane (description of icons in table below)

Icon Description
Sources Root Node contains one or more source data stores that are pre-pended
with a "SourceX" where X is a number starting with 1 and is incremented for each
additional source opened. You can select the sources root node as your search
source.

Source EDB File (for example, ) contains the Microsoft Exchange
Server Information Store data. Click the plus sign (+) next to an EDB file to expand its
contents.
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Icon Description

Mailbox (for example, , Archive, and Public Folder) contain the
Microsoft Office Outlook folders. Click the plus sign (+) next to a mailbox to expand
its contents.

Microsoft Office Outlook Folders (for example, Inbox, Contacts, Tasks)
contain Microsoft Office Outlook message items. Select a folder to view its
contents in the Source Message list.

Source CAS File (for example, ) contains the content analysis store data

created to analyze content based on certain criteria.

CAS Profile Folder (for example, ) contains the results of a content
analysis.

Inaccessible Mailboxwhich displays if a mailbox is inaccessible. An inaccessible
mailbox presents no visible content.
Target mailbox access is controlled by the target Microsoft Exchange Server.

Status indicator noting that Single Mailbox Recovery is licensed for the Agent for
Administrative Services and that it is connected to Single Mailbox Recovery
Administrative Server. This icon is located in the Status Bar of the Single Mailbox
Recovery main window.

Status indicator noting that Single Mailbox Recovery is either not licensed for the
Agent for Administrative Services or it is licensed but not connected to the Single
Mailbox Recovery Administrative Server. This icon is located in the Status Bar of the
Single Mailbox Recovery main window.

Source Message List
The Source Message list displays the message items in the Microsoft Office Outlook folder that
you selected in the Source pane. This folder is one of the Microsoft Office Outlook folders (for
example, Inbox, Contacts, Tasks).

Figure 1-3: The Source Message list (displaying messages in an Inbox)

8



The Source Message list displays metadata about the message items in six columns. The
metadata includes file type; attachments, if any; message sender; subject; date; and status.
The Sent Items folder also displays the "To" column. For more information on the message list, see
"Sorting Messages in the Message Lists" on page 14.

The source content analysis store message list includes file type; Database #, Database, and
Path. The source content analysis store profile folder message list includes file type; Attachment,
if any; From; Subject; Create Date; Database #; Folder, and Status. For more information on
content analysis stores, see "Content Analysis Store" on page 155.

Target Pane
The Target pane can display one or more target PST files and/or one or more target mailbox,
public folders and mailboxes from a Microsoft Exchange Server, and content analysis stores
(CAS) with profile folders. The target acts as a container for your restored files. If a target is a
newly created PST file, it defaults to Microsoft Office Outlook folders. If a target is an existing PST
file or Microsoft Exchange Server, it shows whatever folders are in the target. It is into these
folders that you paste and restore your message items. For information on restoring message
items, see "Restoring Microsoft Exchange Server Data" on page 114.

Target panes for
PST files

Target pane for a CAS file Target pane for a Microsoft
Exchange Server

Figure 1-4: Target panes with PST, CAS, andMicrosoft Exchange Server files
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Target Message List (Restored Messages)
The Target Message list displays the message items in the Microsoft Office Outlook folder that
you selected in the Target pane. If the target is a newly created PST file or CAS, the Outlook
folders and message list will be empty. If the target is an existing PST file, CAS file, or Microsoft
Exchange Server, or if you have restored message items to a newly created PST file, you can
select a folder in the Target pane to display messages in the Target Message list.

Figure 1-5: Target Message list displaying restoredmessages

The Target Message list displays metadata about the message items in five columns (instead of
six columns in the Source Message list). The metadata includes file type; attachments, if any;
message sender; Subject; and Create Date. The Sent Items folder also displays the "To" column.
For more information on the message list, see "Sorting Messages in the Message Lists" on page
14.

The target content analysis store message list includes file type; Database #, Database, and
Path. The target content analysis store profile folder message list includes file type; attachment,
if any; From; Subject; Create Date; Database #; Folder; and Status. For more information on
content analysis stores, see "Content Analysis Store" on page 155.

Menu Bar

Figure 1-6: The menu bar in the main window

The menu bar contains all of the commands for Single Mailbox Recovery. The menu commands,
submenu commands, and resulting windows are discussed fully in the chapters that focus on
those specific commands. See the Index to quickly locate the pages on which a menu
command is discussed.

Help Menu - Administrative Services
The Administrative Services option is available in the Help menu when the Single Mailbox
Recovery Administrative Server for Administrative Services is active. It displays information
regarding the Single Mailbox Recovery Administrative Server that Single Mailbox Recovery is
connected to and the services that are being used.
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Note: During normal operation, the auditing service (if activated) does not alter the behavior of
Single Mailbox Recovery.

Toolbar

Figure 1-7: The Button Toolbar in the main window

The buttons on the toolbar perform the following functions:

Toolbar
Button

Function

Open Source opens the Source Selection page of the Data Wizard, where you can
navigate to and select a source Microsoft Exchange Server Database (EDB), PST, or
CAS file. The EDB, PST, or CAS file contains the message items you want to restore.

Open Target PST opens the Open Target PST dialog box, where you can navigate to
and select a target Personal Folders (PST) file. The target PST file is a container for
restored message items.

Open Target Microsoft Exchange Server opens the Target Selection page of the
Data Wizard, where you select the type and path of the target location for the data
you want to restore.

Create/Open Content Analysis Store displays the Create Content Analysis File
window, where you can open an existing content analysis store or to create a new
one in the Target pane.

Copy copies into the Clipboard the selected message(s) in the Source Message list;
or the selected folder, mailbox, or EDB file in the Source pane.

Paste inserts the items from the Clipboard into the selected folder in the Target pane.
If you want to retain the directory structure of the restored messages, you must use
the Paste Special command instead of the Paste command or Paste button.

Export displays the Export window, where you can export messages to a local or
network drive destination. You can choose to save exported messages as plain text
files (.txt), Microsoft Office Outlook files (.msg), or Outlook Data files (.pst).

Search displays the Find window, where you can specify the desired search criteria
for finding messages in the Source pane.

Preview Pane displays the Preview pane on the Single Mailbox Recovery main
window, where you can read a message without opening it.
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Toolbar
Button

Function

View Help displays Single Mailbox Recovery Online Help, which includes all of the
information in this user guide. You can quickly access the Online Help information
using its Contents, Index, Search, and Favorite tabs.

Message Table View is only available when a message in the Source Message list is
highlighted. It opens a Message Table View of that message and any message
related to it.

Attachment Table View is only available when a message with an attachment in the
Source Message list is highlighted. It opens an Attachment Table View of that
message and attachment and all related messages and attachments.

Conversation View is only available when a message in the Source Message list is
highlighted. It shows the thread of that message with indentations to indicate the
responses to each e-mail.

Shortcut Menu
You can access many of the same commands available on the menu bar and toolbar by right-
clicking the mouse to view a shortcut menu. The contents of the shortcut menu depend on
whether you right-click in the Source or Target pane. This manual explains how to use
commands on the menu bar and toolbar, and does not always specify when you can use the
shortcut menu. Once you become familiar with Single Mailbox Recovery, the commands
available to you on the shortcut menu should become apparent.

Previewing and Opening Messages
In the Preview pane, you can read the contents of a message item and open attachments. You
can preview a message located in either the Source Message list or the Target Message list. The
information displayed in the Message Header is different for messages, calendars, contacts,
tasks, and distribution lists.

To open the preview pane
Do one of the following:

n On the View menu, click Preview Pane.

n On the toolbar, click the Preview Pane icon in the toolbar.

To hide the preview pane

n Repeat one of the previous steps.

Tip: Hiding the Preview pane will allow you to scroll through messages faster.
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To display a message in the preview pane

1. In the Source or Target Message list, select a message.

2. Open the Preview pane by clicking on the Preview Pane icon in the toolbar.

Figure 1-8: Preview pane for amessage

To open a message in its own window

n In the Source or Target Message list, double-click a message.

Changing the View
You can change the view in the Single Mailbox Recovery window by hiding the toolbar or status
bar, by using split bars; by sorting message lists; and by refreshing the screen.

Viewing or Hiding the Toolbar and Status Bar
The toolbar and status bar appear by default in the main Single Mailbox Recovery window, but
you can easily hide them.

To hide the toolbar or status bar

n On the View menu, click Toolbar or Status Bar. The check mark no longer appears next to
the name of the toolbar or status bar.

To view the toolbar or status bar

n On the View menu, click Toolbar or Status Bar. The check mark appears next to the name
of the toolbar or status bar.

Resizing Panes Separated by a Split Bar
You can use a split bar (the horizontal or vertical double line that separates two panes) to
increase the area within one pane while simultaneously decreasing the area within the
adjacent pane. The Source pane, Source Message list, Target pane, Target Message list, and
Preview pane all border a split bar.
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To resize panes separated by a split bar

1. Position the pointer over a split bar between the two panes on either the vertical or
horizontal split bar.

Figure 1-9: Before dragging the split bar between the Target Message list and the Preview
pane

2. When the pointer becomes a double-headed arrow, drag it to resize the pane.

Sorting Messages in the Message Lists
You can sort messages in the Source and Target Message lists based on attachments, message
sender, subject, date, and status. In addition, the Source Message list lets you sort messages
based on status, and the Sent Items folder lets you sort items based on the "To" heading. Sorting
messages on the From column, for example, can help to identify messages from a specific
sender.

To sort a message list

1. Click a column heading to sort the messages based on that heading. For most headings,
an arrow appears indicating the sort direction. An up arrow indicates that the messages
appear in ascending (A-Z) order. A down arrow indicates that the messages appear in
descending (Z-A) order.

2. To reverse the order of the messages based on that column heading, click the column
heading again. Notice the arrow reverses directions.
An example of sorting messages:

l If you click the attachment column heading, messages are sorted in ascending
order based on this heading, even though no arrow appears. This means that
messages with attachments appear at the top of the message list, while messages
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with no attachments appear at the bottom of the document list. If you click the
attachment column heading again, the order is reversed.

Note: The view settings (sort order and columnwidth) for a folder or mailbox are saved
until you close the data store.

Refreshing the Screen
You may want to refresh the screen occasionally when you are connected to a target Microsoft
Exchange Server. That is because the information on the server may change while you are
connected.

To refresh the screen
Do one of the following:

n On the View menu, click Refresh.
n Press the F5 key.

Opening Attachments
If you have the appropriate program installed on your computer, Single Mailbox Recovery loads
the application to view the selected attachment (for example, to view an .xls file attachment,
Single Mailbox Recovery will launch Microsoft® Excel®).

If no associated program is available for the attachment's file type, Single Mailbox Recovery
presents a message window saying the attachment cannot be viewed.

Note: Single Mailbox Recovery cannot view attached embedded graphics in HTMLmessages.

To open an attachment in an openmessage

1. In the message list, double-click a message that has the Attachment icon next to its
name.

2. Click the Attachment icon on the right side of the message header. A pop-up window
lists the attachments for the selected message.

3. Click the name of the attachment you want to view.

To open an attachment in the preview pane

1. In the message list, select a message that has the Attachment icon next to its name.

2. Open the Preview pane. In the Single Mailbox Recovery main window, click the Preview

Pane icon . In the Find window, select the Preview check box.
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3. Click the Attachment icon on the right side of the message header in the Preview
pane. A pop-up window lists the attachments for the selected message.

4. Click the name of the attachment you want to view.

Saving Attachments
A "save attachments" option is available on the File menu and paperclip menu of an open
message, as well as on the paperclip menu of the Preview pane. The Save Attachments window
lists the attachments for the selected message and lets you select the attachments you want to
save.

To save attachments in an openmessage

1. In the Source or Target Message list, double-click a message that has the Attachment
icon next to its name.

2. In the open message, do one of the following:
l On the File menu, click Save Attachments.

l Click the Attachment icon on the right side of the message header, and then click
Save Attachments.

3. In the Save Attachments window, select one or more attachments, and click OK.
4. In the Browse For Folderwindow, select a location for the attachment(s), and click OK.

To save attachments in the preview pane

1. In the Source or Target Message list, select a message that has the Attachment icon
next to its name.

2. In the Preview pane, click the Attachment icon on the right side of the message
header, and then click Save Attachments.

3. In the Save Attachments window, select one or more attachments, and click OK.
4. In the Browse For Folderwindow, select a location for the attachment(s), and click OK.

Viewing the Properties of an EDB File, PST File,
CAS File, CAS Profile Folder, Folder, or Mailbox
Single Mailbox Recovery makes it easy to view the properties of a source PST file, EDB file, CAS
file, CAS profile folder, mailbox, or folder.

Note:Only accessible mailboxes can produce property reports. For CAS files, inaccessible
mailboxes within that data store are not included in the totals.
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Note:When the Show Recoverable Items preference is enabled, the Recoverable Items folder,
subfolders, andmessages will appear in the folder andmessage counts in the EDB properties. If
the preference is cleared, the Recoverable Items folders andmessages are not included in the
folder andmessage counts.

To view the properties

1. In the Source pane, right-click an EDB file, PST file, CAS file, CAS profile folder, mailbox, or
folder.

2. On the shortcut menu, click Properties. One of the following Properties dialog boxes
appears:

Figure 1-10: EDB File Properties dialog box

Note: The Save button is only available for Microsoft Exchange Server 2010 and earlier
databases. Click Save to save the Microsoft Exchange Server name to your hard drive.
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Figure 1-11: PST File Properties dialog box

Figure 1-12: Content Analysis Store (CAS) File dialog box

Figure 1-13: Content Analysis Store (CAS) Profile Folder dialog box
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Figure 1-14: Properties of aMailbox dialog box

An alternate way to view the properties of an EDB or PST file

Once you have viewed the properties of the source EDB or PST file as described above, you can
then display the properties in the Preview pane.

1. Open the Preview pane by clicking the Preview Pane icon on the toolbar or by clicking
the View menu and pointing to Preview Pane.

2. Click the source EDB or PST file in the Source pane and click Properties.

Figure 1-15: Properties of an EDB File

Performing an Integrity Check
You can perform an integrity check on messages, folders, mailboxes, PST files, CAS files, CAS
profile folders, EDB files, and live Microsoft Exchange Server target search results. During the
integrity check, Single Mailbox Recovery verifies that it can read all folder and message
properties from the selected source.

To perform an integrity check

1. In the Source pane, select an EDB file, PST file, CAS file, CAS profile folder, mailbox, folder,
or message(s).
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2. Do one of the following:
l On the Tools menu, click Integrity Check. The Integrity Check window appears.
l Right-click the item and click Integrity Check in the shortcut menu.

3. Click Print to print a copy of the integrity check.
4. Click Save to save a copy of the integrity check to file.

Creating a Mailbox List
You can create a text file with a list of all mailboxes available in an EDB source file.

Note: This is similar to the -list command line parameter.

To create anmailbox list

1. In the Source pane, select an EDB file.
2. Do one of the following:

l Right-click the EDB files and select Create Mailbox List in the shortcut menu.
l Press Ctrl+Alt+L.

3. On the Save mailbox list dialog box, select the path and enter a File name, then click
Save.

Viewing Deleted Messages
Single Mailbox Recovery can view and restore deleted messages that are held in the EDB file.
These messages appear with the value "Deleted" in the Status column of the Source Message
list. If deleted messages have been purged from the EDB file due to the deleted retention
schedule, Single Mailbox Recovery cannot view or restore these messages.

Content analysis store deleted messages in both the Source and Target panes also appear with
the value "Deleted" in the Status column of the message list.

Viewing Deleted Items in Microsoft Exchange Server
Databases
Deleted items do not have the same functionality as items from earlier databases. Instead of
being stored in the folder they were deleted from, they are stored in a separate "Recoverable
Items" folder.

Note: The Recover Items folder only appears when using Microsoft Exchange Server 2010
databases and later.
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By default, this separate folder does not appear in the source tree under the mailbox. A
preference setting allows you to view this folder in the source tree, making the deleted items
accessible to you. For more information, see Setting Preferences in the "Security Tab" on page
24.

Recoverable Items Folder
When the Recoverable Items folder is visible, the subfolders are accessible as well, including:

n Audits: Holds audit log entries for the mailbox, if audit logging is enabled on the Microsoft
Exchange Server.

n Calendar Logging: Holds calendar changes that occur within a mailbox.
n Deletions: Holds messages that have been removed from the Inbox using the Delete key,

menu item, or shortcut key.
n DiscoveryHolds: Holds all items that meet the hold query parameters and are purged.
n Purges: Holds messages that have been removed from a mailbox via the "Recover

Deleted Items" tool in Microsoft Office Outlook when a legal hold is set for a mailbox.
n Versions: Holds sent and received messages that were edited by a user in a mailbox for

which a legal hold was set.

You can perform source operations on the messages in these folders, including copying and
exporting. The messages in Recoverable Items and its subfolders are also included in searching,
creating reports, integrity checks, and property counts.

Note: Viewing the Recoverable Items folder applies to sources only. It is not visible in target
mailboxes.

Setting Preferences
The Preferences dialog box allows you to streamline Single Mailbox Recovery operations. Most
of the preference settings in the four tabs are selected by default. There are two exceptions: the
"Display new PST when PST limit is reached" setting in the Target Options tab, and the "Enable
Tamper-Proof Target" setting in the Security tab. If you change the settings, they are stored and
reloaded on the next run of Single Mailbox Recovery.

General Tab
The General tab governs the tasks that Single Mailbox Recovery performs.
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Figure 1-16: The General tab in the Preferences dialog box

To change the General preference settings

1. On the Edit menu, click Preferences, then click General.
2. Select or clear the following check boxes as desired:

n Run Data Wizard on startup: The Data Wizard will launch every time you open Single
Mailbox Recovery.

Note: Does not apply if "Run Backup Selection on startup" is selected.

n Check for duplicate messages during copy and export: When restoring Microsoft
Exchange Server data, Single Mailbox Recovery does not copy duplicates of a message
to the destination folder if a message already exists in the destination folder. Selecting this
preference setting results in slower copy performance.

n Check for duplicate messages during search: Single Mailbox Recovery will not return
duplicates of a message during a search. For example, if the same message exists in two
or more data stores, only the first message found is listed in the search results. Selecting
this preference setting results in slower search performance.

n Append to existing PST files during export: If selected, Single Mailbox Recovery updates
previously exported PST files with new messages from the export process. If cleared, a new
PST file is created when exporting data.

n Run Backup Selection on startup: The Backup Selection will launch every time you open
Single Mailbox Recovery.

n Dismount backup during closing source: If selected, mounted backups will automatically
dismount on closing of source.

Target Options Tab
The Target Options tab governs the target-related tasks that Single Mailbox Recovery performs.
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Figure 1-17: The Target Options tab in the Preferences dialog box

To change the Target Options preference settings

1. On the Edit menu, click Preferences, then click Target Options.
2. In the PST Options group, select or clear the following check boxes as desired:

n Create new PST folders when PST message/folder limits are reached: Single Mailbox
Recovery automatically creates new folders (for example, Inbox) when the 16,383
messages/folder limit is reached. After Single Mailbox Recovery creates a new
folder, it continues to restore Microsoft Exchange Server data where it left off. For
more information, see "Limits for PST and Folder Targets" on page 116.

n Display new PST when PST limit is reached: When the limit for a PST is reached in the
Target pane, Single Mailbox Recovery automatically displays the overflow PST.

n Create Unicode PSTs: If selected, Single Mailbox Recovery always creates Unicode
PSTs. If cleared, Single Mailbox Recovery creates non-Unicode PSTs.

Note: The default maximum size for Unicode PST files is typically set by the locally
installed version of Microsoft Office Outlook. For information on adjusting this
limitation, see https://support.microsoft.com/en-us/kb/832925.

n Limit maximum PST file size: If selected, Single Mailbox Recovery automatically
creates a new PST file when the MB size is reached during export. For more
information, see "Setting a Global Limit for PST Files" on page 110
Note: The MB field should not exceed 48640.

3. In the Microsoft Exchange Server group, select or clear the following check boxes as
desired:
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n Encrypt data connection with Microsoft Exchange Server: If selected, Single
Mailbox Recovery will use an encrypted connection to send data to the Microsoft
Exchange Server. Clear this if you are using an unencrypted connection.

n Use Autodiscover to detect Microsoft Exchange Server connection settings: If
selected, Single Mailbox Recovery attempts to use Autodiscover to detect profile
settings for connecting to the target Microsoft Exchange Server.

n Use Outlook Anywhere to connect to Microsoft Exchange Server: If selected, Single
Mailbox Recovery uses Outlook Anywhere settings to connect to the target
Microsoft Exchange Server. For more information, see "Outlook Anywhere and
Autodiscover" on page 31.

n Always prompt for credentials when connecting to a single mailbox: If selected,
Single Mailbox Recovery requests a username and password each time it connects
to a mailbox on a Microsoft Exchange Server. This option requires a user to provide
credentials when connecting to a single mailbox, even when the logged in user is
connecting to their own mailbox, or when managed passwords are set up for the
Microsoft Exchange Server.

4. In the Mailbox Creation group, select or clear the following check boxes as desired:
n Allow mailbox creation during copy: If selected and a mailbox copy is initiated by

you, mailboxes can be created during a mailbox copy. If it is cleared, mailbox
creation cannot take place during copy. This setting has no effect on manual
mailbox creation.

Security Tab
The Security tab controls the level of information available to the user when using the
application and governs the tasks that person can perform.

The options in the Security tab are modifiable by default only by users that belong to the
Administrator Group. The options are stored in the registry: HKEY_LOCAL_
MACHINE\Software\NetApp\SMBR.

The Single Mailbox Recovery Installation program sets this registry key to have read/write access
to users in the Administrators group and read-only access to any user in the Users group.

The settings on the Security tab can also be set and managed by an Administrator using the
Settings service on the Single Mailbox Recovery Administrative Server. In that situation, you need
to contact your OAS administrator to change the settings on the Security tab.
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Figure 1-18: The Security tab in the Preferences dialog box

To change the security preference settings

1. On the Edit menu, click Preferences, then click Security.
2. Select or clear the following check boxes as desired:

n Allow preview of messages: If this option is not selected, you will not have the ability to
open or preview messages in the source or target.

n Enable Tamper-Proof Target: If this option is selected, Single Mailbox Recovery does not
allow you to delete messages or folders in the target or have the ability to rename folders
in the target. You only have the ability to add (copy) to the target.

n Allow Bcc field to be included when restoring or searching messages: If this option is
selected, Single Mailbox Recovery includes Bcc information when restoring or searching
messages. This means that a recipient is able to see Bcc recipients that he or she was not
intended to see. It also means that searching with the "Sent to" option returns messages
for Bcc recipients.

n Enable Message Views: If this option is selected, it makes the Message Views available.
n List inaccessible mailboxes: When Single Mailbox Recovery connects to a Microsoft

Exchange Server, it can display both accessible and inaccessible mailboxes. If this option
is selected, the inaccessible mailboxes listed in the directory appear and are display-only.

n Note: Clearing this option while you have mailboxes open refreshes the mailbox list and no
longer displays the inaccessible mailboxes.

n Show Recoverable Items: Selecting this option allows the "Recoverable Items" folder to
be displayed under your mailbox, enabling you to have access to any deleted items. It
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also provides access to the "Purges" and "Versions" folders, which are also sub-folders of
"Recoverable Items."

Note: This setting only applies to Microsoft Exchange Server 2010 and later.

Important: Selecting the Show Recoverable Items preference causes your
Microsoft Exchange Server 2010 and later EDB sources to close. A warning
message appears giving you the option to cancel or continue changing the
setting.

n Enable Multi-Tenant Support: If this option is selected, multi-tenant support is enabled. This
allows you to filter a source or target from a list of Microsoft Exchange Server 2010 through
SP3 hosted organizations or Microsoft Exchange Server 2010 SP2 and later Address Book
Policies (ABPs). It also selects and opens all mailboxes or displays mailboxes not contained
in any hosted organization (hosted environment only).
l Enforce ABP or Hosted Organization for current user: If this option is selected, you

cannot select from a list of hosted organizations or Address Book Policies (ABPs) from
source or target dialog boxes. Rather, you are limited to opening only the mailboxes
included in the Global Address List (GAL) of your assigned ABP or mailboxes contained
in the hosted organization to which you belong.

Note: This option is only available when Enable Multi-tenant Support is selected.

l Show deleted or unrecognized mailboxes: When this option is selected, Single
Mailbox Recovery opens mailboxes not found in the current environment. These
unrecognized mailboxes may have been previously present in the environment and
were deleted or are mailboxes from a different environment. Unrecognized mailboxes
are opened and displayed in the source tree, in conjunction with the selected ABP or
organization mailboxes. This option only applies to the opening of source EDBs.

Note: This option is only available when Enable Multi-tenant Support is selected.

Warnings Tab
The Warnings tab controls whether or not warning messages appear when various tasks are
performed.
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Figure 1-19: The Warnings tab in the Preferences dialog box

To change the warnings preference settings

1. On the Edit menu, click Preferences, then click Warnings.
2. Select or clear the following check boxes as desired:

n Show warning when logs specified but not found: Single Mailbox Recovery warns you
when opening an EDB file if no .log files were found at the specified directory.

n Show warning when no log file path specified: Single Mailbox Recovery warns you when
opening an EDB file if a .log file path has not been specified.

n Show warning when copying to Microsoft Exchange Server root: Single Mailbox Recovery
warns you when you are about to copy a large amount of data to the Microsoft Exchange
Server root.

n Show warning when opening a Microsoft Exchange Server and a Microsoft Exchange
Server is already open: This warning appears when you attempt to connect to either a
single mailbox or all mailboxes on a Microsoft Exchange Server when a target Microsoft
Exchange Server connection is already open in Single Mailbox Recovery.

Auto Support Tab
Use the Auto Support tab to govern whether messages about the following Single Mailbox
Recovery and Single Mailbox Recovery ExtractWizard tasks, when performed, are sent to the
NetApp storage appliance:
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Task Message Details Single Mailbox
Recovery

Single Mailbox
Recovery

ExtractWizard
Start of application Two messages:

1. Start of application.

2. Environment application was
started in.

X X

Abnormal exit of
application

Details of the exit

Note: The storage appliance can
be configured to automatically
forward this to NetApp.

X X

Opening a data set Details of a dataset and
information about the storage
appliance (if Single Mailbox
Recovery is running from a
different machine than Snap
Manager for Exchange).

X

Opening a backup Details of backup and
information about the storage
appliance (if Single Mailbox
Recovery is running from a
different machine than Snap
Manager for Exchange).

X

Restoring data Details of source and target used
for restoring data

X

Figure 1-20: The Auto Support tab in the Preferences dialog box

To change the auto support settings

1. On the Edit menu, click Preferences, then click Auto Support.
2. Select or clear the following check box as desired, then enter the required information in

the text boxes:

n Enable Auto Support: If selected, Single Mailbox Recovery logs usage information and
customer configuration data to the NetApp storage appliance.

n Storage Appliance: Enter the name or IP address of the NetApp storage appliance where
the Auto Support messages are logged.

n Username: Enter a username for an account with permissions to log an ASUP message on
the NetApp storage appliance.

n Password: Enter the password for account with permissions to log an ASUP message on
the NetApp storage appliance.
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Chapter 2: Using Single Mailbox
Recovery
Overview
This chapter describes how to open a source EDB file or PST file and specify a target PST file or
target Exchange server. The following topics are covered:

Running the Backup Selection. This section describes the Backup Selection, which guides you
through the loading backup files into Single Mailbox.

Running the Data Wizard. This section describes the Data Wizard, which guides you through the
reading of EDB files or PST files into Single Mailbox Recovery and shows you how to specify the
target PST file or Exchange server.

Opening the source and target from the main window. Instead of using the Data Wizard to open
the source databases and target mailboxes, you can use individual commands from the Single
Mailbox Recovery main window.

Opening multiple sources and targets. This section describes how you can display multiple
sources in the Source pane Single Mailbox Recovery main window and how you can display
multiple targets in the Target pane of the Single Mailbox Recovery main window.

Closing sources and targets. This section describes how to close sources and targets from the
Single Mailbox Recovery main window.

Backup Selection
At the start of Single Mailbox Recovery, the Backup Selection window displays the backups
available on the Microsoft Exchange Server. Use this window to select a backups and create a
local folder with a copy of its EDB file and logs. This is then available as a source on the Single
Mailbox Recovery DataWizard.

The Backup Selection list contains detailed information about the backup ID, its name, type,
and creation time.

To manually open the Backup Selection window

n Do one of the following:
l On the File menu, click Open backup.

-or-
l Press Ctrl+B.
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To mount a backup

1. On the SnapCenter authentication window, enter the following

Field Description

Base URL The SnapCenter URL

User
name

Your SnapCenter URL user credentials

Password

Exch
Server

The Microsoft Exchange server name or IP address (required only on
machine other than the Microsoft Exchange server)

2. Click Ok.
3. On the Backup Selection window, select the database from the Database Name drop

list.
4. If you choose, select a backup date range to filter the backups in view by timestamp.
5. Click Load.
6. Select Local Mount Location and click Mount/Launch.

Mailbox Criteria
When selecting the EDB Source Files, you can use the "Mailbox Criteria (optional)" box to limit
the number of mailboxes that are opened and displayed in the Source pane. This box appears
on the Source Selection dialog box (opened by clicking File then Open Source) or the Source
Selection page of the Data Wizard.

When you enter a string in the Mailbox Criteria box, Single Mailbox Recovery matches your entry
against the display name and alias of the mailboxes to select data in the source database. Only
mailboxes matching your entries are displayed on the Source pane.

Note:WithMicrosoft Exchange Server 2013 and later, Single Mailbox Recoverymatches your
MailboxCriteria box string entry against the display name only.

The mailbox criteria uses a simple "string contains" match and is not case sensitive. You can use a
semi-colon to separate and enter multiple strings. If you want to include a semi-colon in one of
your entries, use double quotes around that entry.

Mailbox criteria only works with mailbox stores, it does not work with public folder stores. If you
use mailbox criteria on a public folder store, it is not used and all public folders are opened.

Note: Anymailboxes which do not match the entered string do not appear in the Source pane
and are not included in any subsequent tasks, such as searching, copying, and exporting of the
entire database.
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Multi-Tenancy Support
Microsoft Exchange Server 2010 and later includes features that aid multi-tenancy deployments.
Single Mailbox Recovery provides support for the Exchange Hosted Organizations feature
(introduced in Microsoft Exchange Server 2010 SP1) and Address Book Policies (introduced in
Microsoft Exchange Server 2010 SP2).

When selecting the Microsoft Exchange Server 2010 and later EDB Source File or Target Server,
you can use the Multi-Tenancy Criteria box to limit the number of mailboxes that are opened
and displayed in the Source and Target panes. The Multi-Tenancy Criteria box appears on the
following pages of the Data Wizard:

n Source Selection page
n Target Selection page

When Multi-Tenancy Support is enabled, you can filter a source or target from a list of hosted
organizations or Address Book Policies (ABPs), as well as select and open all mailboxes or view
mailboxes not contained in any hosted organization (hosted environment only).

Activate Multi-Tenancy Support using the Security tab on the Preferences dialog box. For more
information, see "Security Tab" on page 24.

Outlook Anywhere and Autodiscover
In Microsoft Exchange Server, the Outlook Anywhere feature (also known as RPC over HTTP)
allows clients to connect using HTTP. This enables users outside of an organization's network to
connect to the Microsoft Exchange Server without having to use a VPN. Outlook Anywhere is
supported by Microsoft Outlook 2003 and later, and Microsoft Exchange Server 2007 and later.

Note:Microsoft Outlook 2003 is not supported for Microsoft Exchange Server 2013 or later.

With Microsoft Exchange Server 2013 and later, Direct RPC access to the Microsoft Exchange
Server is no longer supported, so Outlook Anywhere is required to connect to the server.

Single Mailbox Recovery supports connecting to a Microsoft Exchange Server target using
Outlook Anywhere

Note:WithMicrosoft Outlook 2016 and later, only connection with Autodiscover is supported.

Autodiscover simplifies the process of connecting to a Microsoft Exchange Server by returning
the connection settings when requested by a client application. Clients such as Microsoft
Outlook can retrieve the connection settings by issuing a request to Autodiscover with the user's
SMTP email address. These settings are then used to configure the user's profile and connect.
Autodiscover is supported by Microsoft Outlook 2007 and later, and Microsoft Exchange Server
2007 and later.

Note:Microsoft Exchange Server 2007 is not supported for Microsoft Outlook 2016 or later.
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Single Mailbox Recovery supports using Autodiscover when connecting to a Microsoft Exchange
Server target.

If you are using Outlook Anywhere to connect to a target Microsoft Exchange Server, Single
Mailbox Recovery uses Autodiscover to determine the correct connection policies. If
Autodiscover is not in use or cannot determine the connection polices, the Outlook Anywhere
page appears.

The Outlook Anywhere page follows the Target Selection page on the Data Wizard and records
the protocol and verification method used when Single Mailbox Recovery connects to a target
Microsoft Exchange Server. The Outlook Anywhere page displays the values from the most
recent successful connection using Outlook Anywhere. The values are empty if no previous
connection exists.

You can configure Single Mailbox Recovery to use Outlook Anywhere and Autodiscover on the
Target Options tab of the Preference dialog box, where the Microsoft Exchange Server group
contains the following check boxes:

n Use Autodiscover to detect Microsoft Exchange Server connection settings
n Use Outlook Anywhere to connect to Microsoft Exchange Server

The following table explains the actions Single Mailbox Recovery performs based on the possible
combinations of selecting or clearing these two check boxes.

Use Autodis-
cover to detect

Microsoft
Exchange
Server con-

nection settings

Use Outlook
Anywhere to
connect to
Microsoft
Exchange
Server

Action

Selected (and
Autodiscover

response
successful)

Selected Single Mailbox Recovery connects to the target Microsoft
Exchange Server with Outlook Anywhere using the settings
returned by Autodiscover.

Selected (and
Autodiscover

not contacted)

Selected If a server name was entered on the Target Selection page,
Outlook Anywhere page appears. If no server name was
entered, an error message appears and the wizard stays on
the Target Selection page.

Selected (and
Autodiscover

response
successful)

Cleared Single Mailbox Recovery connects to the target Microsoft
Exchange Server with RPC over TCP/IP using the server
returned by Autodiscover.
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Use Autodis-
cover to detect

Microsoft
Exchange
Server con-

nection settings

Use Outlook
Anywhere to
connect to
Microsoft
Exchange
Server

Action

Selected (and
Autodiscover

not contacted)

Cleared If a server name was entered on the Target Selection page,
Single Mailbox Recovery connects to the target Microsoft
Exchange Server with RCP over TCP/IP. If no server name was
entered, an error message appears and the wizard stays on
the Target Selection page.

Cleared Selected The Outlook Anywhere page appears.

Cleared Cleared Single Mailbox Recovery connects to the target Microsoft
Exchange Server with RCP over TCP/IP.

For more information, see "Target Options Tab" on page 22.

Connecting to Office 365
When connecting to a hybrid environment (where both on-premise and Office 365 mailboxes
are present), the following apply:

n Selecting All Mailboxes (on-premise) filters out Office 365 mailboxes and displays only on-
premise mailboxes.

n Mailbox creation creates mailboxes in the on-premise environment, but only if
connecting to on-premise mailboxes. This includes connect-to-all.

n Copy edb to root of server (with mailbox creation) "Creates mailboxes in the on-premise
environment, but only if connecting to on-premise mailboxes. This includes connect-to-
all.

n Copy mailbox to root of server (with mailbox creation) "Creates mailboxes in the on-
premise environment, but only if connecting to on-premise mailboxes. This includes
connect-to-all

n Multi-tenancy filters out Office 365 mailboxes and displays only on-premise mailboxes. If
the ABP contains both on-premise and Office 365, only on-premise mailboxes are
displayed. If ABP contains only Office 365 mailboxes, no mailboxes are displayed.

Keyboard Shortcuts
The following table contains keyboard shortcuts for many of the common tasks performed when
using Single Mailbox Recovery.

Menu Bar Keyboard Shortcut
File Menu

Open Source Ctrl+S
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Menu Bar Keyboard Shortcut
Open Backup Ctrl+B

Open Target PST Ctrl+T

Open Target Microsoft Exchange Server Ctrl+E

Close Store Ctrl+L

Use Data Wizard Ctrl+W

Exit Alt+F4

Edit Menu

Copy Selection to Clipboard Ctrl+C

Paste Copied Item(s) Ctrl+V

Paste Special Ctrl+Y

Delete DEL

Rename Ctrl+R

New Folder Ctrl+N

New Mailbox Ctrl+M

Move To Folder (Microsoft Exchange Server as a target - Find window) Ctrl+Shift+V

Cut (Microsoft Exchange Server as a target - Find window) Ctrl+X

View Menu

Refresh Screen F5

Tools Menu

Export Ctrl+P

Export Organizational Forms Ctrl+G

Create Mailbox List Ctrl+Alt+L

Integrity Check Ctrl+I

Create Reports Ctrl+Q

Find F3

Online Help

View Help F1

Opening a Microsoft Exchange Server as a Target
You can open live Microsoft Exchange Servers as a target within Single Mailbox Recovery using
the Data Wizard or Main Window. This means you can connect to one live Microsoft Exchange
Server at a time, establishing a single mailbox connection or connecting to all accessible
mailboxes and displaying a list of the mailboxes found in that Microsoft Exchange Server. A status
indicator tells you if you have permission rights to view a mailbox.
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Note: The Microsoft Exchange Server as a target feature is only supported if the system running
Single Mailbox Recovery is on the same domain as the Microsoft Exchange Server.

Recommendation: If connecting to a Microsoft Exchange Server 2010 CAS Array, use the fully
qualified domain name of the CAS Array for the Server Name (for example,
casarray.domain.name).

Mailbox Access
When connecting to a single mailbox, the Target pane populates with only the specified single
mailbox. When connecting to all mailboxes on a Microsoft Exchange Server, the Target pane
populates with the list of mailboxes found in that Microsoft Exchange Server.

Note: You can connect to only one live Microsoft Exchange Server at a time. If you attempt to
connect to an additional live Microsoft Exchange Server while a server is already open, the
current server connection closes.

If your Administrator is running Single Mailbox Recovery Administrative Server and has the
Mailbox Permission plug-in activated, your access to mailboxes within a mailbox store (private
EDB file) may be affected depending on the permission settings.

If permission to access a mailbox is denied, you are not able to access the contents of that
specific mailbox. The inaccessible mailbox either in the Source or Target pane displays with an
inaccessible icon , or is hidden depending on your Preference setting. For more information,
see "Setting Preferences" on page 21.

Note: Contact your Single Mailbox Recovery Administrative Server systems administrator if you
need access to inaccessible mailboxes.

An EDB file that is denied access through the Single Mailbox Recovery Administrative Server
Mailbox Permission setting affects:

n Find Window: An inaccessible mailbox's contents cannot be processed during a search.
n Message Views: Any message items in an inaccessible mailbox are not displayed in a

Conversation Table View or an Attachment Table View.
n CAS as a Target: Only accessible mailbox messages in the EDB source are processed

when populating a CAS profile.
n Exporting: Inaccessible mailboxes cannot be exported.
n Copying: Inaccessible mailboxes cannot be copied.
n Integrity Checking: Inaccessible mailboxes cannot have an Integrity Check performed on

them.
n Properties: An inaccessible mailbox's properties cannot be viewed.
n Reports: Reports cannot be generated for inaccessible mailboxes.

Connection Interruption
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If errors are encountered that interrupt the communication between Single Mailbox Recovery
and the Single Mailbox Recovery Administrative Server, an error appears. You can choose to
retry the failed communication attempt. If the error is transient (for example, a temporary
network failure) and has been addressed, retrying allows Single Mailbox Recovery to continue.

Note: If the error cannot be overcome, or more than 8minutes has passed since the fault
occurred, a successful retry is not possible.

Mailbox Functions
Paste, Paste Special, folder creation, folder renaming, and the search functions are available
for the accessible mailboxes. A mailbox or server cannot be renamed.

Using the Data Wizard
The Data Wizard guides you through the loading of EDB or PST files into Single Mailbox Recovery,
and shows you how to specify the target PST file or Exchange server.

Configuring Single Mailbox Recovery
If Single Mailbox Recovery Administrative Server is connected and activated, you may have to
manually locate a server if Single Mailbox Recovery cannot locate one automatically. By
default, the automatic location is attempted. If it fails, an error message appears.

If you select "No," Single Mailbox Recovery closes. If you select "Yes," the Connection Point
Manager window appears.
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Figure 2-1: Connection Point Manager

To add a server

1. Clear Use Active Directory to locate server if it is selected.
2. Click Add. The Server Information window appears.

Figure 2-2: Enter Server Information

3. Enter the Server address name or IP address and click OK.
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Before You Use the Data Wizard
The following information describes what you need to do in order to be able to select the
source of the mail items you want to recover.

If the Source
File is...

Then do this:

An EDB file
stored in a LUN
on a storage
system

NOTE: This
includes
SnapVault
secondary
storage system
configurations

1. Use the SnapDrive Connect Wizard to connect that LUN to an available
drive letter on the Single Mailbox Recovery server. For details, see
"Connecting Virtual Disks" in SnapDrive Installation and Administration Guide.
When you select the source Exchange database, the mounted LUN will be
your source drive.

NOTE: Do not use the Data ONTAP LUN cloning feature to clone a virtual disk
backed by a Snapshot copy that is connected using SnapDrive. SnapDrive
considers such a disk to be temporary, and it deletes the disk upon
disconnect.

2. Verify that there is sufficient hard drive space available to store temporary
files that Single Mailbox Recovery creates. For details, see "Verifying Hard
Drive Space for .idx and .dat Files" on page 183.

CAUTION: Unmount this LUN as soon as your Single Mailbox Recovery restore
operation is completed. Avoid maintaining a connection to a LUN in a
Snapshot copy during a period when the storage system volume containing
that LUN is scheduled for update Snapshot copies. While a LUN in a Snapshot
copy is mounted, if one or more Snapshot copies are taken of the volume
containing the LUN, a "busy Snapshot copy" will result, and you will be unable
to unmount or delete that LUN until all the more recent Snapshot copies are
deleted.

An EDB file in a
Snapshot
created using
SnapCenter

1. Run Backup Selection.

2. To connect to SnapCenter, provide the SnapCenter URL credentials (and
optionally the Microsoft Exchange server name or IP), then click Load.

3. Select Backup.

4. To populate the Single Mailbox Recovery DataWizard, select Local Mount
Location and click andMount/Launch.
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If the Source
File is...

Then do this:

An EDB file in a
backup
created using
a supported
backup
application
other than
SnapManager
or SnapCenter

1. Use Single Mailbox Recovery ExtractWizard to restore the files to a location
accessible from the Single Mailbox Recovery server.

2. If the backup is an offline backup or in an online incremental or differential
backup, organize the files for use by Single Mailbox Recovery. For details, see
"Organizing Files Extracted From Other Backup Applications" on page 160.

3. Verify that there is sufficient hard drive space available to store temporary
files that Single Mailbox Recovery creates. For details, see "Verifying Hard
Drive Space for .idx and .dat Files" on page 183.

A PST file Enable the PST source agent. For details, see "PST Source Agent" and "Task III:
View and Enable Agents" in the Release Notes.

NOTE: You cannot open the same PST file as both source and target. Also,
due to the database nature of the PST file and MAPI subsystem, PSTs opened
as source will be modified.

Opening the Data Wizard
The first time you start Single Mailbox Recovery, the Data Wizard opens at the Source Selection
page.

When working in the main window, you can return to the Data Wizard at any time.

To manually start the Data Wizard

n On the File menu, click Use Wizard.

Data Wizard: Source Selection
On the Source Selection page of the Data Wizard, specify the type and path of the source from
the following options:

n A PST file
n An EDB file
n A Content Analysis Store

Note:

n If you do not want to select a source file at this time, click Skip.
n If you do not want to run the Data Wizard every time you start Single Mailbox Recovery,

clear the Run on Startup check box.
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To specify a PST file as the source

1. On the Source Selection page, click Outlook Data File (*.pst) in Select Source list.
Note: You can also openMicrosoft Explorer, click the PST file you want to open as the
source, then drag it to the Select Source list and skip the next step.

Figure 2-3: Selecting a PST file as the source

2. In the Outlook Data File (*.pst) box, click Browse to open the Create PST File window and
locate the source PST file.

3. Click Next.

To specify an EDB file as the source

1. On the Source Selection page, click EDB File (*.edb) in Select Source list.
Note: You can also openMicrosoft Explorer, click the EDB file you want to open as the
source, then drag it to the Select Source list and skip to step 6.
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Figure 2-4: Selecting an EDB file as the source

2. In the EDB Path (*.edb) box, click Browse and use the Open window to locate the source
EDB file.

3. In the Log File Path (*.log, *.pat, *.chk) box, click Browse to and use the Browse For Folder
window to choose the log files associated with the source EDB file.

Important: After you select an EDB file, the Log File Path box defaults to the source EDB file
path, even if the log files are not in the same directory as the source EDB file. Therefore,
make sure you enter the correct log file path in the Log File Path box.

4. In the Temporary File Path (*.idx, *.dat, *lkp) box, accept the default location for .idx and
.dat files, or specify a new location if they require more hard drive space.

5. If you want to view a filtered display of mailboxes in the Source pane, use the Mailbox
Criteria (optional) box. For more information, see "MailboxCriteria" on page 30.

6. If multi-tenancy support is enabled, do one of the following in the Multi-Tenancy Criteria
box:

n If "Enforce ABP or Hosted Organization for current user" is not selected on the
Security tab on the Preferences dialog box, use the Multi-Tenancy Criteria box to
select hosted organizations or Address Book Policies from source or target dialog
boxes.

n If "Enforce ABP or Hosted Organization for current user" is selected on the Security
tab on the Preferences dialog box, use the Multi-Tenancy Criteria box to view the
organization or assigned address book policy.
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Figure 2-5: Selecting an EDB file as the source with multi-tenancy support

7. Click Next.

To specify a Content Analysis Store as the source

1. On the Source Selection page, click Content Analysis Store (*.cas) in Select Source list.
Note: You can also openMicrosoft Explorer, click the CAS you want to open as the
source, then drag it to the Select Source list and skip the next step.
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Figure 2-6: Selecting a CAS as the source

2. In the Content Analysis Store Path (*.cas) box, click Browse to open the Create Content
Analysis File window and locate the source CAS.

3. Click Next.

The EDB or PST file appears in the Single Mailbox Recovery Source pane.

Figure 2-7: Source pane for an EDB file
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Tip: You can use Windows Explorer to open an EDB, PST, or CAS file. In Windows Explorer, double-
click the file or drag into the Single Mailbox Recovery Source pane.

Data Wizard: Target Selection
On the Target Selection page of the Data Wizard, specify the type and path of the target
location for the data you want to restore from the following options:

n A PST file
n A Content Analysis Store (CAS)
n A Microsoft Exchange Server as the target for a single mailbox (either on-premise or with

Office 365 and with or without Outlook Anywhere)
n A Microsoft Exchange Server as the target for all mailboxes
n A Microsoft Exchange Server as the target for specific mailboxes with multi-tenancy

support

An option to open Public Folders is available upon connection to a Microsoft Exchange Server.
Single Mailbox Recovery connects to all public folders hosted by the target Microsoft Exchange
server, not specific databases or Public Folders mailboxes.

Note: Click Skip if you do not want to select a target file at this time.

To specify a PST file as the target for restored data

1. On the Target Selection page, click Outlook Data File (*.pst) in Select Target list.
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Figure 2-8: Selecting the PST File option on the Target Selection page

2. Do one of the following:
l If you know the target PST file path, type it in the Outlook Data File (.pst) box.
l Click Browse to open the Create PST File window and navigate to the desired

location. Create a new PST file by typing a name in the File name box, or select an
existing PST file. Next, click Open. The path of the target PST file appears in the Target
PST File Path box.

3. Click Next.

To specify a content analysis store

1. On the Target Selection page, click Content Analysis Store (*.cas) in Select Target list.
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Figure 2-9: Selecting Content Analysis Store on the Target Selection page

2. Do one of the following:
l If you know the target CAS file path, enter it in the Content Analysis Store Path box.
l Click Browse to open the Create Content Analysis File window. and navigate to the

desired location. Create a new CAS file by typing a name in the File name box or
select an existing CAS file. Next, click Open. The path of the target CAS file appears in
the Content Analysis Store Path box.

3. Click Next.

To specify a Microsoft Exchange Server as the target for a single mailbox (on-premise or Office
365)

1. On the Target Selection page, click Single Mailbox (on-premise or Office 365) in Select
Target list.
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Figure 2-10: Selecting Single Mailbox (on-premise or Office 365) displays the target
Microsoft Exchange Server

2. In the E-mail Address box, type the email address name.

Tip: If you are not using Autodiscover and you do not know the full name of the mailbox,
type the first letter of the mailbox in the E-mail Address box, and click Next. In the Check
Name window that appears, select the mailbox from the list, and clickOK. If you are
using Autodiscover, youmust type the full email address in the E-mail Address box.

3. WithConnect To Public Folders selected, you can open public folders as a target for
restoring public folders or messages. If you do not want to restore to public folders, clear
this check box. For more information, see "Restoring to Public Folders" on page 126.

4. The Connect using Autodiscover check box determines whether Single Mailbox Recovery
will use Autodiscover to connect to Microsoft Exchange Server. The default setting is
selected or cleared using the Target Options tab on the Preferences window. Do one of
the following:
l Select to connect to the target using Autodiscover. For more information, see "Target
Options Tab" on page 22and "Outlook Anywhere and Autodiscover" on page 31.

l Clear and then use the Connection type drop-down list to select either "Exchange On-
Premise" or "Office 365."
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5. If you are not connected to a domain, the Enter Password window appears. In this
window, enter a user name that has full rights to the mailbox, a password, and a domain
name. Then click OK. This window may appear again, which requires you to reenter this
information.

6. Click Next.

To specify a Microsoft Exchange Server as the target for all mailboxes

1. On the Target Selection page, click All Mailboxes (on-premise) in Select Target list.

Figure 2-11: Selecting All Mailboxes (on-premise) displays the target Microsoft Exchange
Server

2. In the Domain Controller and Server Name boxes, the domain controller and server names
auto-populate.

Note: For Microsoft Exchange Server 2010, specify the name of the Client Access Server
(CAS) that provides access to the mailboxes you want to access (not the mailbox server,
unless the mailbox server has the client access role installed).

Note: The mailboxes foundwill depend on both the Domain Controller andMicrosoft
Exchange Server entered. Only those mailboxes accessible through the enteredMicrosoft
Exchange Server and listed in the Active Directory of the given Domain Controller will
attempt to be opened.
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Note: For Microsoft Exchange Server 2013 or later, specify the name of any of your
Microsoft Exchange 2013 or later Servers, or leave this field blank to auto detect. The
mailboxes found depend on the Domain Controller with only those mailboxes listed in the
Active Directory of the given Domain Controller opened, subject to permissions.

3. WithConnect to Public Folders selected, you can open public folders as a target for
restoring public folders or messages. If you do not want to restore to public folders, clear
this check box. For more information, see "Restoring to Public Folders" on page 126.

4. If you are not connected to a domain, the Enter Password window appears. In this
window, enter a user name that has full rights to the mailbox, a password, and a domain
name. Then click OK. This window may appear again, which requires you to reenter this
information.

5. Click Next.

To specify a Microsoft Exchange Server as the target for specific mailboxes with multi-tenancy
support

1. On the Target Selection page, click Specified Mailboxes (on-premise) in Select Target
list.

2. Do one of the following:
l If "Enforce ABP or Hosted Organization for current user" is cleared on the Security tab

on the Preferences dialog box, use the Multi-Tenancy Criteria box to select hosted
organizations or Address Book Policies from source or target dialog boxes.

l If "Enforce ABP or Hosted Organization for current user" is selected on the Security tab
on the Preferences dialog box, use the Multi-Tenancy Criteria box to view the
organization or assigned address book policy.
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Figure 2-12: Selecting SpecifiedMailbox (on-premise) displays the target Microsoft
Exchange Server

3. In the Domain Controller and Server Name boxes, the domain controller and server names
auto-populate.

Note: For Microsoft Exchange Server 2010, specify the name of the Client Access Server
(CAS) that provides access to the mailboxes you want to access (not the mailbox server,
unless the mailbox server has the client access role installed).

Note: The mailboxes foundwill depend on both the Domain Controller andMicrosoft
Exchange Server entered. Only those mailboxes accessible through the enteredMicrosoft
Exchange Server and listed in the Active Directory of the given Domain Controller will
attempt to be opened.

Note: For Microsoft Exchange Server 2013 or later, specify the name of any of your
Microsoft Exchange 2013 or later Servers, or leave this field blank to auto detect. The
mailboxes found depend on the Domain Controller with only those mailboxes listed in the
Active Directory of the given Domain Controller opened, subject to permissions.

4. WithConnect to Public Folders selected, you can open public folders as a target for
restoring public folders or messages. If you do not want to restore to public folders, clear
this check box. For more information, see "Restoring to Public Folders" on page 126.
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5. If you are not connected to a domain, the Enter Password window appears. Enter a user
name that has full rights to the mailbox, a password, and a domain name, then click OK.
This window may appear again, requiring you to reenter this information.

6. Click Next.

Data Wizard: Outlook Anywhere
With the Outlook Anywhere page, you can adjust the settings for using Outlook Anywhere to
connect to the target Microsoft Exchange Server. This page appears if you are using Outlook
Anywhere, but not Autodiscover, to connect to Microsoft Exchange Server. This page also
appears if you are using Outlook Anywhere and Autodiscover to connect, but the Autodiscover
service cannot be contacted.

If Single Mailbox Recovery is configured to use Outlook Anywhere, but "Connect using
Autodiscover" is not selected on the Data Wizard: Target Selection page, the Outlook
Anywhere page appears so you can configure the Outlook Anywhere connection. If "Connect
using Autodiscover" is selected, the Outlook Anywhere page does not appear, as Autodiscover
automatically configures the connection.

Note: The Outlook Anywhere page displays the values from the most recent successful
connection using Outlook Anywhere. The values are empty if no previous connection exists.

Figure 2-13: Outlook Anywhere page

To complete the Outlook Anywhere page

1. On the Outlook Anywhere page, do the following:
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n In the http:// drop-down list, enter or select the URL to use when connecting the
Microsoft Exchange proxy server.

n If you want to connect using only secure sockets layer, select Connect using SSL
only and enter the connection URL in the https:// drop-down list. You can require
the use of an authentication of certificate by selecting Only connect to proxy
servers that have principal name in their certificate and entering or selecting the
principal name.

2. Select from the following to use HTTP on the first connection, and TCP/IP on all subsequent
connections based on the speed of your network:

n On fast networks, connect using HTTP first, then connect using TC/IP
n On slow networks, connect using HTTP first, then connect using TC/IP

Note:Outlook defines a fast connection as a connection that is faster than 128 kilobits per
second (Kbps).

3. In the Use this authentication when connecting to my proxy server for Exchange drop-
down list, select from the following:

n Basic: Basic authentication uses clear text to send user and password information
for authentication. If selected, the Connect using SSL only box is selected
automatically and cannot be changed. This prevents passwords from being sent to
the Microsoft Exchange proxy server in clear text when Basic authentication is used.

n NTLM Authentication: If selected, NTLM authentication is used. This is a
challenge/response scheme in which a hash of the password is used for
authentication. The password is not sent over the network.

n Negotiate Authentication: If selected, Kerberos is used for authentication, if
possible. Otherwise, NTLM authentication is used.

4. Click Next.

Data Wizard: Connection Settings
With the Connection Settings page, you can adjust the settings to connect to the target
Microsoft Exchange Server. This page appears if Autodiscover fails to connect to the target
server or Autodiscover is not enabled in on the Preferences dialog box.
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Figure 2-14: Connection Settings page

To complete the Connection Settings page

1. On the Connection settings page, type the server name of the Target Server.
2. In the Security drop-down list, select the method of security when logging on to the target

server network.
3. The Connect using Outlook Anywhere check box determines whether Single Mailbox

Recovery will use Outlook Anywhere (also known as RPC over HTTP) to connect to
Microsoft Exchange Server. The default setting is selected or cleared using the Target
Options tab on the Preferences window. If you choose Connect using Outlook Anywhere,
do the following:

n In the https:// drop-down list, enter or select the URL to use when connecting the
Microsoft Exchange proxy server.

n If you want to connect using only secure sockets layer, select Connect using SSL
only and enter the connection URL in the https:// drop-down list. You can require
the use of an authentication of certificate by selecting Only connect to proxy
servers that have principal name in their certificate and entering or selecting the
principal name.

4. Select from the following to use HTTP on the first connection, and TCP/IP on all subsequent
connections based on the speed of your network:

n On fast networks, connect using HTTP first, then connect using TC/IP
n On slow networks, connect using HTTP first, then connect using TC/IP
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Note:Outlook defines a fast connection as a connection that is faster than 128 kilobits per
second (Kbps).

5. In the Use this authentication when connecting to my proxy server for Exchange drop-
down list, select from the following:

n Basic: Basic authentication uses clear text to send user and password information
for authentication. If selected, the Connect using SSL only box is selected
automatically and cannot be changed. This prevents passwords from being sent to
the Microsoft Exchange proxy server in clear text when Basic authentication is used.

n NTLM Authentication: If selected, NTLM authentication is used. This is a
challenge/response scheme in which a hash of the password is used for
authentication. The password is not sent over the network.

n Negotiate Authentication: If selected, Kerberos is used for authentication, if
possible. Otherwise, NTLM authentication is used.

6. Click Next.

Data Wizard: Now Processing Data File
The Now Processing Data File page of the Data Wizard reports the processing of the EDB file in
three stages:

1. Pre-scanning the log files (integrity check)
2. Scanning the log files (playing the log files)
3. Hashing the EDB file (building a folder hierarchy)

When the processing is complete, the Data Wizard closes.

Note: If Single Mailbox Recovery encounters bad or missing log files during log playing, you will
be given the option to continue without playing the logs. If you choose to continue, Single
Mailbox Recovery processes the EDB without logs.

Results of Data Wizard
When you complete the Data Wizard, the Source and Target panes in the main window now
contain a source EDB file, PST file, CAS, target PST file, a target Microsoft Exchange Server, or
target CAS.
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Source pane with a PST
file

Source pane with an EDB file Source pane with CAS files

Figure 2-15: Source panes with PST, EDB, andCAS files

Target pane with a
PST file

Target pane for a Microsoft
Exchange Server

Target pane with CAS files
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Figure 2-16: Target panes for PST files, Microsoft Exchange Server, and CAS file

Opening the Source Database and Target
Mailboxes from the Main Window
Instead of using the Data Wizard to open the source databases and target mailboxes, you can
open them from the main window.

Before You Open the Source Database from the Main
Window
The following information describes what you need to do in order to be able to select the
source of the mail items you want to recover.

If the Source
File is...

Then do this:

An EDB file
stored in a LUN
on a storage
system

Note: This
includes
SnapVault
secondary
storage system
configurations.

1. Use the SnapDrive Connect Wizard to connect that LUN to an available
drive letter on the Single Mailbox Recovery server. For details, see
"Connecting Virtual Disks" in SnapDrive Installation and Administration Guide.
When you select the source Exchange database, the mounted LUN will be
your source drive.

Note: Do not use the DataONTAP LUN cloning feature to clone a virtual disk
backed by a Snapshot copy that is connected using SnapDrive. SnapDrive
considers such a disk to be temporary, and it deletes the disk upon
disconnect.

2. Verify that there is sufficient hard drive space available to store temporary
files that Single Mailbox Recovery creates. For details, see "Verifying Hard
Drive Space for .idx and .dat Files" on page 161.

CAUTION: Unmount this LUN as soon as your Single Mailbox Recovery restore
operation is completed. Avoid maintaining a connection to a LUN in a
Snapshot copy during a period when the storage system volume containing
that LUN is scheduled for update Snapshot copies. While a LUN in a Snapshot
copy is mounted, if one or more Snapshot copies are taken of the volume
containing the LUN, a "busy Snapshot copy" will result, and you will be unable
to unmount or delete that LUN until all the more recent Snapshot copies are
deleted.
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If the Source
File is...

Then do this:

An EDB file in a
Snapshot
created using
SnapCenter

1. Run Backup Selection.

2. To connect to SnapCenter, provide the SnapCenter URL credentials (and
optionally the Microsoft Exchange server name or IP), then click Load.

3. Select Backup.

4. To populate the Single Mailbox Recovery DataWizard, select Local Mount
Location and click Mount/Launch.

An EDB file in a
backup
created using
a supported
backup
application
other than
SnapManager
or SnapCenter

1. Use Single Mailbox Recovery ExtractWizard to restore the files to a location
accessible from the Single Mailbox Recovery server.

2. If the backup is an offline backup or in an online incremental or differential
backup, organize the files for use by Single Mailbox Recovery. For details, see
"Organizing Files Extracted from Other Backup Applications" on page 182.

3. Verify that there is sufficient hard drive space available to store temporary
files that Single Mailbox Recovery creates. For details, see "Verifying Hard
Drive Space for .idx and .dat Files" on page 183.

A PST file Enable the PST source agent. For details, see "PST Source Agent" and "Task III:
View and Enable Agents" in the Release Notes.

Note: You cannot open the same PST file as both source and target. Also, due
to the database nature of the PST file andMAPI subsystem, PSTs opened as
source will be modified.

Opening a Source and a Target from the Main Window
The section explains how to perform the following tasks from the Main Window:

n "To open a source file" on page 58.
n "To open an existing target PST" on page 58.
n "To create a new target PST" on page 58.
n "To open an existing target content analysis store" on page 59.
n "To open a new target content analysis store" on page 59.
n "To open a Microsoft Exchange Server as the target for restored data for a single mailbox

(on-premise or Office 365)" on page 59
n "To open a Microsoft Exchange Server as the target for restored data for all mailboxes" on

page 60
n "To open a Microsoft Exchange Server as the target for restored data for Specific

Mailboxes with multi-tenancy support" on page 60
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To open a source file

1. Do one of the following:
n On the File menu, click Open Source.

n On the toolbar, click the Open Source icon .

Important: Before you select a source EDB file in the window below, see "Before You
Open the Source Database from the Main Window" on page 56.

2. Follow the instructions in the "Data Wizard: Source Selection" topic "Data Wizard: Source
Selection " on page 39.

3. Click OK. The EDB, PST, or CAS file appears in the Single Mailbox Recovery Source pane.

To open an existing target PST

1. Do one of the following:
n On the File menu, point to Open\Create Target, thenOpen Target PST, and click

Open Existing.

n On the toolbar, click the Open Target PST icon .

2. In the Open Target PST window, navigate to the desired location, and select an existing
PST file.

3. Click Open. The PST file appears in the Single Mailbox Recovery Target pane.

Tip: In Windows Explorer, you can drag a PST file into the Single Mailbox Recovery target
pane.

To create a new target PST

1. On the File menu, point to Open\Create Target, thenOpen Target PST, and click Create
New.

2. In the Create PST File window, navigate to the desired location. You may want to create a
new folder.

3. In the File name box, type a name for the new PST file.
4. Click Open. The PST file appears in the Single Mailbox Recovery Target pane.

Note:WithMicrosoft Office Outlook 2003, you have to choose between the 97 and 2003
version of the PST.
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Figure 2-17: Target pane for a PST file

To open an existing target content analysis store

1. Do one of the following:
n On the File menu, point to Open\Create Target, then click Open Target Content

Analysis Store and click Opening Existing...

n On the toolbar, click the Open Target Content Analysis Store icon .

2. In the Opening a Content Analysis File window, navigate to desired location and select
an existing CAS file.

3. Click Open. The CAS file appears in the Single Mailbox Recovery Target pane.

To open a new target content analysis store

1. Do one of the following:
n On the File menu, point to Open\Create Target, then click Open Target Content

Analysis Store and click Create New....

n On the toolbar, click the Open Target Content Analysis Store icon

2. In the Create Content Analysis File window, navigate to desired location and type a File
Name for the new CAS file.

3. Click Open. The CAS file appears in the Single Mailbox Recovery Target pane.

To open a Microsoft Exchange Server as the target for restored data for a single mailbox (on-
premise or Office 365)

1. Do one of the following to display the Target Selection page of the Data Wizard:
n On the File menu, click Open\Create Target, then click Open Target Exchange

Server.

n On the toolbar, click the Open Target Exchange Server icon .

2. Follow the instructions in the "Data Wizard: Target Selection" topic "To specify a Microsoft
Exchange Server as the target for a single mailbox (on-premise or Office 365)" on page 46.
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To open a Microsoft Exchange Server as the target for restored data for all mailboxes

1. Do one of the following to display the Connect To Exchange Serverwindow:
n On the File menu, click Open\Create Target, and then click Open Target Exchange

Server.

n On the toolbar, click the Open Target Exchange Server icon .

2. Follow the instructions in the "Data Wizard: Target Selection" topic "To specify a Microsoft
Exchange Server as the target for all mailboxes" on page 48.

To open a Microsoft Exchange Server as the target for restored data for Specific Mailboxes with
multi-tenancy support

1. Do one of the following to display the Connect To Exchange Serverwindow:
n On the File menu, click Open\Create Target, and then click Open Target Exchange

Server.

n On the toolbar, click the Open Target Exchange Server icon .

2. Follow the instructions in the "Data Wizard: Target Selection" topic "To specify a Microsoft
Exchange Server as the target for specific mailboxes with multi-tenancy support" on page
49.

Opening Multiple Sources and Targets
You can display multiple sources in the Source pane and multiple targets in the Target pane.
Sources include EDB, PST, and CAS files. Targets include PSTs, CAS, and Microsoft Exchange
Servers. See the instructions for using the Data Wizard or the main window to open one source or
one target at a time.
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Multiple sources Multiple targets

Figure 2-18: Multiple sources and targets can be displayed

Closing Sources and Targets
You can close sources and targets from the Single Mailbox Recovery main window.

Avoid maintaining a connection to a LUN in a Snapshot copy during a period when the storage
system volume in which that LUN is contained is scheduled for updating Snapshot copies.

Caution: If a LUN in a Snapshot copy is mounted, and while it is mounted one or more Snapshot
copies are taken of the storage system volume in which it is contained, a "busy Snapshot copy"
will result, and you will not be able to unmount or delete that LUN until all the more recent
Snapshot copies are deleted. The chances of this situation are increased in configurations
where a single secondary storage volume is used to coalesce Snapshot copies from numerous
primary storage trees.

To close a source

1. In the Source pane, select a source EDB, PST, or CAS file.
2. Do one of the following:

n On the File menu, click Close Store.
n Right-click the selection, and on the context menu click Close Store.

3. If the source is an EDB file in a SnapManager-based backup copy, unmount the LUN as
soon as your Single Mailbox Recovery restoration completes.
If the source is an EDB file in a SnapCenter-based backup Snapshot copy, it will
automatically unmount when the source is closed.

To close all sources

1. In the Source pane, right-click the sources root node.
2. On the context menu, click Close All Stores.
3. If the source is an EDB file in a SnapManager-based backup copy, unmount the LUN as

soon as your Single Mailbox Recovery restoration completes.
If the source is an EDB file in a SnapCenter-based backup Snapshot copy, it will
automatically unmount when the source is closed.

To close a target

1. In the Target pane, select a PST file, Microsoft Exchange Server database, or CAS file.
2. Do one of the following:

l On the File menu, click Close Store.
l Right-click the selection, and on the context menu click Close Store.
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Deleting Items in the Target Pane
Using the Delete key to remove an item (for example, folder, message) from the Single Mailbox
Recovery Target pane permanently deletes the item, similar to using Shift+Delete in Microsoft
Office Outlook.

Note:Messages within a content analysis store profile folder cannot be deleted.

Creating New Mailboxes
You can create new mailboxes by either using the Mailbox Creation wizard or the Copy and
Paste functions. Possible uses for this function are migrating user accounts from an older version
of Microsoft Exchange Server or archiving legacy data.

Note: To use MailboxCreationWizard on your computer, youmust have the Exchange Server
Management Tools for the version of Microsoft Exchange Server where you will be creating
mailboxes. Ensure the Exchange Server Management Tools andMicrosoft Exchange Server
version, service pack, and roll up level are the same version. For supported operating system
and prerequisite requirements for the Exchange Server Management Tools, please refer to the
Exchange Server Management Tools documentation for your specific version.

User Permission
In order to create mailboxes, the following are required:

n You must have the necessary Active Directory permissions to create a mailbox on the
selected Microsoft Exchange Server.

n Both the user account logons and the Name field must be unique to create a new user
account and mailbox. If you are creating a mailbox for an existing user, the Name field
must match the full name of the existing user.

Tip: It is recommended that anyone creating mailbox-enabled users have fundamental
knowledge of Microsoft Exchange Server administration and Active Directory.

Preference Settings
The Target Options tab of the Preferences dialog box contains a Mailbox Creation group with
the following option:

n Allow mailbox creation during copy

When selected, a copy operation can create new mailboxes, so a copy operation can create
a target mailbox for a source mailbox to allow it to be copied.
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When cleared, new mailboxes are not created and only mailboxes that match an existing
mailbox can be copied. Any mailboxes that do not match a target mailbox are skipped.

The Security tab of the Preferences dialog box contains the following option regarding
mailboxes:

n List inaccessible mailboxes

When selected, mailboxes always appear in the Target pane and mailboxes will indicate if they
are accessible. Otherwise, inaccessible mailboxes are not displayed.

For more information, see "Setting Preferences" on page 21.

Creating Mailboxes
You can create mailboxes with the Mailbox Creation wizard or by copying a single mailbox. You
can also copy the root of a source EDB to the root of a target Microsoft Exchange Server.

If the mailbox already exists and is accessible, it is added to the target directory and shown as
accessible. If the source mailbox did not exist in the target directory, a new mailbox is created
on either a new user account or an existing user account. If the mailbox you create is not
accessible, it appears in the target directory and shown as inaccessible.

Note:Mailbox creation on disabled user accounts is not supported.

Note: The target Microsoft Exchange Server must be in the same domain as the Single Mailbox
Recovery computer.

Note: In aMicrosoft Exchange Server 2010 environment installed using the /hosting switch,
mailboxes can only be created in the domain, not an Exchange HostedOrganization.

Note: In aMicrosoft Exchange Server 2010 or 2013 environment that has deployed Address Book
Policies, an Address Book Policy cannot be assignedwhen creating amailbox.

Creating Mailboxes Using the Mailbox Creation Wizard
You can manually create a single mailbox on a target Microsoft Exchange Server by using the
Mailbox Creation wizard to specify user account and mailbox information.

To create a Microsoft Exchange Server 2007mailbox using the wizard

1. Open a target Microsoft Exchange Server in Single Mailbox Recovery.
2. Do one of the following to open the Mailbox Creation wizard :

n Right-click the target Microsoft Exchange Server root directory and click New
Mailbox.

n On the Edit menu, click New Mailbox.
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Figure 2-19: User Information page for Microsoft Exchange Server 2007

3. On the User Information page, enter the following:
n Organizational unit: This field is pre-populated. You can change it by clicking

Browse.
n First name: (Optional) Enter the first name of the user. If a user account already

exists, but there is no mailbox based on this Name, the mailbox is created on the
existing user account.

n Initials: (Optional) Enter the initials of the user.
n Last name: (Optional) Enter the last name of the user. If a user account already

exists, but there is no mailbox based on this Name, the mailbox is created on the
existing user account.

n Name: This field auto-populates as the First name, Initials, and Last name are
entered. This field can also be modified.

n User logon name (User Principal Name): Create a user logon name for the new
account. If this name matches the same field of an existing user account, an error
appears at the end of the process indicating that it is a duplicate.

n UPN suffix: This field adds the Organizational Unit selected as the second half of the
logon name email address.

n User logon name (pre-Windows 2000): A user logon name for older versions of
Windows.

n Password and Confirm Password: The password must meet the domain's minimum
password requirements or the user/mailbox creation will fail.
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n Save as default password: Select to designate the entered password as the
default.

4. Click Next.

Figure 2-20: Mailbox Settings page for Microsoft Exchange Server 2007

5. On the Mailbox Settings page, do the following:
n Alias: Enter the alias for the mailbox user.
n Server: Auto-populated with the Storage group andMailbox database. Ensure

these settings are correct.
n Mailbox database: The mailbox database is automatically selected by the

Microsoft Exchange Server if not specified. To specify the mailbox database, select
the check box which enables the drop-down list of all available mailbox databases.

n Managed foldermailbox policy: (Microsoft Exchange Server 2007 only) To apply a
managed folder policy to your mailbox, select the check box which enables the
drop-down list of all available managed folder mailbox policies in the organization.

n Exchange ActiveSync mailbox policy: (Microsoft Exchange Server 2007 only) To
apply an ActiveSync mailbox policy to your mailbox, select the check box which
enables the drop-down list of all available ActiveSync mailbox policies in the
organization.

6. Click Finish. The mailbox information is validated and the mailbox is created.
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Note: If the Managed folder mailbox policy check box is selected, a warning appears
stating: "When assigning amanaged folder mailbox policy with managed custom folders
to amailbox, Microsoft Office Outlook clients older thanMicrosoft Office Outlook 2007 do
not have all available client features and clients older thanMicrosoft Office Outlook 2003
SP2 are not supported. Are you sure you want to assign amanaged folder mailbox policy
to this mailbox?"

To create a Microsoft Exchange Server 2010 (and later) mailbox using the wizard

1. Open a target Microsoft Exchange Server in Single Mailbox Recovery.
2. Do one of the following to open the Mailbox Creation wizard :

n Right-click the target Microsoft Exchange Server root and click New Mailbox
n On the Edit menu, click New Mailbox.

Figure 2-21: User Information page for Microsoft Exchange Server 2010 and later

3. On the User Information page, enter the following:
n Organizational unit:The Organizational Unit is automatically selected by the

Microsoft Exchange Server if not specified. You can change it by selecting the
Specify the Organizational unit rather than using a default one check box. Select
this check box to enable the Browse button where you can select a different
Organizational unit.
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n First name: (Optional) Enter the first name of the user. If a user account already
exists, but there is no mailbox based on this Name, the mailbox is created on the
existing user account.

n Initials: (Optional) Enter the initials of the user.
n Last name: (Optional) Enter the last name of the user. If a user account already

exists, but there is no mailbox based on this Name, the mailbox is created on the
existing user account.

n Name: This field auto-populates as the First name, Initials, and Last name are
entered. This field can also be modified.

n User logon name (User Principal Name): Create a user logon name for the new
account. If this name matches the same field of an existing user account, an error
appears at the end of the process indicating that it is a duplicate.

n UPN suffix: This field adds the Organizational Unit selected as the second half of the
logon name email address.

n User logon name (pre-Windows 2000): A user logon name for older versions of
Windows.

n Password andConfirm Password: The password must meet the domain's minimum
password requirements or the user/mailbox creation will fail.

n Save as default password: Select this check box to designate the entered
password as the default.

4. Click Next.

Figure 2-22: Mailbox Settings page for Microsoft Exchange Server 2010 and later
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5. Enter the following Mailbox Settings:
n Alias: Enter the Alias for the mailbox user.
n Mailbox database: The mailbox database is automatically selected by the

Microsoft Exchange Server if not specified. To specify the mailbox database, select
the check box which enables the drop-down list of all available mailbox databases.

n Managed foldermailbox policy: (Microsoft Exchange Server 2010 only) To apply a
managed folder policy to your mailbox, select the check box which enables the
drop-down list of all available managed folder mailbox policies in the organization.

n Exchange ActiveSync mailbox policy: To apply an ActiveSync mailbox policy to
your mailbox, select the check box which enables the drop-down list of all
available ActiveSync mailbox policies in the organization.

Note: If the Managed folder mailbox policy check box is selected, a warning
appears stating: "When assigning amanaged folder mailbox policy with managed
custom folders to amailbox, Microsoft Office Outlook clients older thanMicrosoft
Office Outlook 2007 do not have all available client features and clients older than
Microsoft Office Outlook 2003 SP2 are not supported. Are you sure you want to
assign amanaged folder mailbox policy to this mailbox?"

6. Click Next. The mailbox information is validated.
7. If you are creating aMicrosoft Exchange Server 2010 (or later) mailbox, and the Archive

Settings page appears. Select the Create an archive mailbox for this account to
associate an online archive mailbox with the user account. To specify the mailbox
database, select the check box which enables the drop-down list of all available mailbox
databases.
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Figure 2-23: Archive Settings for Microsoft Exchange Server 2010 and later

Note: If using Microsoft Exchange Server 2010 SP1 and later or Microsoft Exchange Server
2013, the mailbox database can be selected.

8. Click Finish. The mailbox is created.

Creating Mailboxes Using Copy and Paste
You can create new mailboxes by using the Copy and Paste functions. Mailbox creation
through copying can be made available or unavailable by selecting or clearing an option in
the Mailbox Creation group on the Target Options page of the Preferences dialog box.

Note: Source archive mailboxes are treated like regular mailboxes for the purposes of copy and
creation. When copying an archive mailbox to a target Microsoft Exchange Server root, the
application will attempt to identify an existing target user mailbox. If one cannot be found, a
newmailbox is created and copied to. Target archive mailboxes will not be the destination of a
single or multiple mailbox copy operation.

To create a single mailbox using copy and paste

1. Verify that Allow mailbox creation during copy option in Preferences is selected. For more
information, see "Target Options Tab" on page 22.

2. Right-click the single mailbox in the Source pane and click Copy.
3. Highlight the target Microsoft Exchange Server and click Paste.

Note: If Paste is not available, you do not have access rights to the source mailbox.

Single Mailbox Recovery queries the Active Directory for an existing mailbox-enabled user
account based on the source mailbox's GUID and name information. If the search finds
both (a full match), Single Mailbox Recovery copies the mailbox to that full matching
user's mailbox. If the search finds only a name match, it is considered a partial match. The
name match includes checks for both the source mailbox name and alias (if it is
available) in the target environment. When a partial match is found, the target mailbox
may not be for the same user as the source mailbox. You are then prompted on how to
proceed (either by skipping, copying to the matching mailbox, or creating a new
mailbox and copying into that – see below for further details).

Note: Alias is not present in Microsoft Exchange Server 2013 and later sources, so only a
match on the mailboxGUID is considered a full match for Microsoft Exchange Server 2013
and later source mailboxes. If no full matching user account exists, the MailboxCreation
wizard opens.

4. If a full matching mailbox is not found in the target, the MailboxCopy wizard opens the
Mailbox Copy Options page.

5. If no match is found on the target, do one of the following inNo Match group:
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n Select Skip Mailbox to skip this mailbox and not copy it. (The Mailbox Creation
wizard closes and the process ends.)

n Select Create and copy to new mailbox to proceed with the Mailbox Creation
wizard and create a new target mailbox for this copy.

Figure 2-24: MailboxCopyOptions page - No Match

6. If a partial match is found on the target, do one of the following in Partial Match group:
n Select Skip Mailbox to skip this mailbox and not copy it. (The Mailbox Creation

wizard closes and the process ends.)
n Select Copy to existing mailbox to copy the mailbox. (The Mailbox Creation wizard

closes and the copy begins.)
n Select Create and copy to new mailbox to proceed with the Mailbox Creation

wizard and create a new target mailbox for this copy.
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Figure 2-25: MailboxCopyOptions page - Partial Match

7. Click Next.
8. If you selected the Create and copy to new mailbox option: Confirm the content of the

User Information page is correct or make any changes and click Next.
9. Confirm the content of the Mailbox Settings is correct or make any changes and click

Finish (or Next, if using Microsoft Exchange Server 2010 or later). The mailbox information is
validated.

Note: If the source mailbox does not have an alias (as is the case with Microsoft Exchange
Server 2013), the UPN, user logon name (pre-Windows 2000), and Alias are auto-generated
based on the source mailbox name.

10. If you are using Microsoft Exchange Server 2010 or later, the Archive Settings page
appears. Select the Create an archive mailbox for this account to associate an online
archive mailbox with the user account. To specify the mailbox database, select the
check box which enables the drop-down list of all available mailbox databases.
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Figure 2-26: Archive Settings for Microsoft Exchange Server 2010 and later

Note: If using Microsoft Exchange Server 2010 SP1 and later or Microsoft Exchange Server
2013, the mailbox database can be selected.

11. Click Finish. The mailbox is created and the copy proceeds. Progress information appears
in a Report dialog box.

12. Click Print to print the report, Save to save the report to your hard drive, or Close to close
the Copy Progress window. The mailbox from the source EDB you copied is now a new
mailbox in the Target pane.

To create multiple Microsoft Exchange Servermailboxes using copy and paste

1. Verify that Allow mailbox creation during copy option in Preferences is selected. For more
information, see "Target Options Tab" on page 22.

2. Do one of the following:
n Right-click the EDB file root node in the source tree and click Copy. Then highlight

the target Microsoft Exchange Server and click Paste.
Note: If Paste is not available, you do not have access rights to the source mailbox.

n Select the EDB file root node in the source tree and drag it to the Microsoft
Exchange Server node in the target tree.
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The New Mailboxwizard opens the Mailbox Copy Options page, which allows you to
customize the behavior when copying all the mailboxes in the source EDB. Here you
configure the wizard to process the possible scenarios of no match, partial match, and
public folder mailboxes during the copy. While the likelihood of each scenario during the
copy is unknown, the Mailbox Copy Option page allows you to instruct the wizard how to
process each one if it occurs during the copy.

3. If no match is found on the target for one the source mailboxes, choose one of the
following inNo Match group:

n Select Skip Mailbox to skip the mailbox and not copy it. Mailboxes with no match
found during the copy are skipped.

n Select Create and copy to new mailbox to create a target mailbox and copy to it.
Mailboxes with no match found during the copy have a new target mailbox
created and copied to that new target mailbox.

4. If a partial match is found on the target for of the source mailboxes, choose one of the
following in Partial Match group:

n Select Skip Mailbox to skip the mailbox and not copy it. Mailboxes with a partial
match found during the copy are skipped.

n Select Copy to existing mailbox to copy the mailbox to the existing mailbox (no
new mailbox is created). Mailboxes with a partial match found during the copy are
copied to the partial matching mailbox.

n Select Create and copy to new mailbox to create a new target mailbox and copy
to the mailbox to that target. Mailboxes with a partial match found during the copy
have a new target mailbox created and copied to that new target mailbox.
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Figure 2-27: MailboxCopyOptions page

5. If the source EDB originates from aMicrosoft Exchange Server 2013 and later and the
target is connected to All Public Folders, choose one of the following in the Public Folder
Mailboxes group:

n Select Skip Mailbox to not copy the public folders contained in Public Folder
mailboxes found during the copy.

n Select Copy to public folders to copy the public folders in Public Folder mailboxes
found during to copy to the target's All Public Folders.
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Figure 2-28: MailboxCopyOptions - Public Folder Mailboxes

6. Click Next.
If you selectedCreate and copy to a new mailbox in No Match or Partial Match, the
Mailbox Creation wizard proceeds. Otherwise, the copy begins.

7. Confirm the content of the User Information page is correct or make any changes and
click Next.
Note: Not all fields can be changed.

8. Confirm the content of the Mailbox Settings is correct or make any changes and click
Next.
Note:When copying multiple mailboxes, the UPN, user logon name (pre-Windows 2000),
and Alias for newmailboxes are auto-generated based on the source mailbox. If the
source mailbox contains an alias (Microsoft Exchange Server 2010 and earlier) this is used.
If the source mailbox does not contain an alias (as is the case with Microsoft Exchange
Server 2013), the source mailbox name is used (after removing any illegal characters).
Alternatively, a different type value can be used. By selecting the 'Alias base' check box,
these fields are set to an auto-generated value that is a number appended to the Alias
base (or just a number if the Alias base is empty). If you choose, you can change the field
values on the NewMailbox Summary page for anymailbox being created as part of the
copy.
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Figure 2-29: Mailbox Settings (Microsoft Exchange Server 2010 and later) - Multiple copy

Figure 2-30: Mailbox Settings (Microsoft Exchange Server 2007 and earlier) - Multiple copy
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Note: IfManaged foldermailbox policy is selected, a warning appears stating: "When
assigning amanaged folder mailbox policy with managed custom folders to amailbox,
Microsoft Office Outlook clients older thanMicrosoft Office Outlook 2007 do not have all
available client features and clients older thanMicrosoft Office Outlook 2003 SP2 are not
supported. Are you sure you want to assign amanaged folder mailbox policy to this
mailbox?"

9. If you are using Microsoft Exchange Server 2010 or later, the Archive Settings page
appears. Select the Create an archive mailbox for this account to associate an online
archive mailbox with the user account. To specify the mailbox database, select the
check box which enables the drop-down list of all available mailbox databases.

Figure 2-31: Archive Settings for Microsoft Exchange Server 2010 and later

Note: If using Microsoft Exchange Server 2010 SP1 and later or Microsoft Exchange Server
2013, the mailbox database can be selected.

10. Click Next. Single Mailbox Recovery analyzes the source and target selections to
determine the new mailboxes that will be created on the target. While performing this
analysis, the Identifying New Mailboxes page appears and displays progress information.

Note: If the 'Alias base' check box on the Mailbox Settings page is selected, the UPN, user
logon name, and Alias are auto-generated using the Alias base field value. Otherwise,
the values are set based on the source mailbox. This initial auto-generated value can be
modified on the NewMailbox Summary page using the Edit Mailbox Item dialog box.

11. When Single Mailbox Recovery finishes analyzing, the progress information clears and the
Mailbox Creation wizard displays the New Mailbox Summary page.
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12. On the New Mailbox Summary page, review the list of mailboxes to be created.

Figure 2-32: NewMailboxes Summary page

13. If you want to edit amailbox, do the following:
n Select the mailbox and click Edit Item or double-click the mailbox.
n Use the Edit Mailbox Item dialog box to make changes to any target information

and click OK to validate the new content.
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Figure 2-33: Edit Mailbox Item dialog box

n If the information you supply is not valid, an error message appears. Correct the
issue on the Edit Mailbox Item dialog box and click OK.

14. On the New Mailbox Summary page, clear the check box for any mailboxes you want to
skip entirely (do not create and copy). You can select or clear the entire list by clicking
Check All or Uncheck All.

15. Select Report file if you want to generate a CSV file listing the Source Mailbox Name,
Target User Name, User Principal Name, and Alias for each mailbox created during the
copy.

16. Click Finish and the copy proceeds with progress information appearing in the Report
dialog box.

17. Click Print to send the report to a printer, Save to save the report to a hard drive, or Close
to close the Copy Progress window. Each mailbox from the source EDB you copied that
did not previously exist is now listed as a new mailbox in the Target pane.

Licensing Information
License information for the Microsoft Exchange Server database currently in use can be
obtained by right-clicking on the source root in the Source pane and selecting Save Licensing
Information.

The file saves into a text format and automatically names it "ServerProperties.txt."
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Auditing Failure
If your Administrator is running the Single Mailbox Recovery Administrative Server auditing
service, any failure of the audit log warns you with a message, giving you the option to retry, re-
connect, or abort Single Mailbox Recovery or Single Mailbox Recovery ExtractWizard. Once the
audit log is confirmed to have failed, Single Mailbox Recovery or Single Mailbox Recovery
ExtractWizard starts the process of shutting down.

Contact your Administrator if restarting the applications is not successful.
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Chapter 3: Finding Messages
Overview
The Find in Source window lets you search a source EDB, PST, or CAS file for message items that
are defined by such criteria as keywords, message senders and recipients, and message
creation dates. In addition, this window lets you define the scope of your search: an EDB, PST, or
CAS file, one or more mailboxes or folders (for example, Inbox), dates, or even previous search
results.

The Find in Exchange Server Target window adds the ability to search a live Microsoft Exchange
Server target and perform actions on the search results.

Guidelines for Using the Find Window
n The Find Now button only becomes available if at least one of the following conditions is

met:
l At least one Search in check box is selected.
l The Sent from or Sent to box contains at least one character.
l The Created Dated after or Created Dated before check box is selected.

n Each Search in check box that you select is run as a separate query, and the results of the
query are combined (i.e., OR'd together). For example, if you enter "solution" in the Search
for words box, and then select the Message Subject andMessage Body check boxes,
Single Mailbox Recovery will return message items that contain "solution" in either the
message subject or message body.

n If you select one or more Search in check boxes, but specify no additional search criteria,
Single Mailbox Recovery will return all of the message items in the folder(s) undergoing the
search.

n Single Mailbox Recovery can search multiple information stores at the same time. In the
Find in Source window, click Browse and you will see a tree view of all of the open source
data stores. You can then select multiple mailboxes or folders to include in your search.

n Single Mailbox Recovery does not return duplicates of a message item during a search as
long as the "Check for duplicate messages during search" preference is selected. For
example, if the same message item exists in two or more data stores, only the first message
item found is listed in the search results.

n The contents of an inaccessible EDB mailbox cannot be searched.
n Messages in the Microsoft Exchange Server 2010 or later Recoverable Items folder are

included in search results only if the Show Recoverable Items preference is enabled. For
more information about setting preferences, see "Security Tab" on page 24 .

n If you use the "Mailbox Criteria (optional)" box on the Select Source Files dialog box or the
Source Selection page of the Data Wizard, only EDB mailboxes containing your entry (or
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entries) are displayed on the Source pane. Any mailboxes that do not match the entered
string(s) do not appear in the Source pane and are not be included in any subsequent
tasks (such as searching, copying, and exporting of the entire database). For more
information, see "MailboxCriteria" on page 30.

n If you use the "Multi-Tenancy Criteria" box on the Select Source Files dialog box, the
Source Selection page of the Data Wizard, the Connect to Exchange Server dialog box,
or the Target Selection page of the Data Wizard, only mailboxes contained in the
selected Address Book Policy or Organization appear in the Source or Target panes. Only
these mailboxes are included in any subsequent tasks (such as searching, copying, and
exporting of the entire database). For more information, see "Multi-Tenancy Support" on
page 31.

Searching Sources
The Find in source window provides the ability to search single or multiple mailboxes and
perform actions on the search results.

Tip: CAS and PST files are searchable in the Source pane but not in the Target pane.

The actions allowed to perform on search results are copying or exporting message items,
performing Integrity Checks, and viewing message items using the Message Views options. You
can have several Find in Source windows open at a time.

To search for message items in sources

1. In the Source pane, select the folder (for example, EDB or PST file, mailbox, Inbox) you
want to search. The folder(s) you select defines the scope of your search.

2. Do one of the following:

l Click Find in the toolbar to display the Find in Source window. The name of the
folder you selected appears next to the Search in folder box.

l Right-click the file and click Find.
l On the Tools menu, click Find.
l Press F3

Note: The first time you search for amessage item, the Search in folder option is
automatically selected. For information on using the Search in results option, see
"Searching Within Results" on page 85.

3. To search multiple mailboxes or folders, click Browse. In the Select Folder(s) window,
select the items you want to search. In the illustration below, two folders have been
selected.
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Figure 3-1: You can select multiple folders or mailboxes to search.

Note: If you select the Search Subfolders check box, Single Mailbox Recovery includes
subfolders in the search.

4. Click OK to return to the Find in Source window.
5. In the Search for words box, enter one or more words or phrases if you want to execute a

keyword search. Keep in mind the following points:
l Put a space between words or phrases to perform an AND operation (i.e., all words

must be matched in order to include a message item with the search results).
l Put a comma between words or phrases to perform an OR operation (i.e., only one of

the words must be matched in order to include a message item with the search
results).

l Put quotation marks around word phrases (i.e., the exact phrase must be matched in
order to include a message item with the search results).

Example: Search for words: dog cat mouse, rat

Search results: Message items that contain ["dog" AND "cat" AND "mouse"] OR
["rat"] are included in the search results.

6. In the Exclude words box, enter words or phrases if you want to perform a NOT operation.
If matched, these words or phrases will exclude a message item from the search results.
The rules for using spaces, commas, and quotation marks apply when excluding words
from a search.

Example: Search for words: dog cat mouse, rat

Exclude words: bird
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Search results: Message items that contain ["dog" AND "cat" AND "mouse"] OR
["rat"] BUT NOT ["bird"] are included in the search results.

7. For Search in, select one or more of the following check boxes: Message Subject,
Message Body, Attachment File Name(s), or Attachment Text. Each Search in check box
that you select is run as a separate query, and the results of the query are combined (i.e.,
OR'd together).

Note: Single Mailbox Recovery has the ability to searchmultiple levels of embedded
message items. Select Attachment Text in the Select in check box. See "Searching
Embedded Message Items" on page 85 for more information.

Note about searching within attachments: Single Mailbox Recovery does not search
within archive file types (such as .zip or .rar files). For more information, see "Searching
Within Attachments" on page 90.

8. In the Sent from and Sent to boxes, enter the appropriate names, if desired. Using the Sent
to box is particularly useful if you are trying to find a message item sent to multiple people.
The rules for using spaces, commas, and quotation marks apply when using the Sent from
and Sent to boxes.

9. For Date, select an action performed on the document (such as Received, Sent, or Due)
as a search criteria, if desired. This searches for documents based on when that action
occurred.

10. For After and Before, select the appropriate check box, if desired. You may select both
check boxes. Then type or select the part of the date you want to change.
l After: Searches for documents created on or after the selected date.
l Before: Searches for documents created on or before the selected date.

11. When you have finished specifying search criteria, click Find Now. The results of your
search appear in the message item list. In Search Results column, the Date displays the
time of the action selected in the Time search criteria.

12. To preview the message items returned by the search, click the Preview check box.
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Figure 3-2: Find windowwith results andmessage pane

Searching Embedded Message Items
You can search multiple levels of embedded message items in Single Mailbox Recovery.

Note: Searching attachments (email and non-email) is available only when the Agent for
Advanced Searching for Microsoft Exchange Server is enabled.

To search embedded message items

1. Perform steps 1 through 6 in "Searching Sources" on page 82.
2. For Search in, click Attachment Text.
3. Continue with step 8 in the "Searching Sources" on page 82process.

Searching Within Results
The Search in results option lets you refine the search process using the previous search results.

To search within results

1. To make the Search in results option available, you must perform at least one search.
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2. Modify the search criteria as desired. For information on specifying search criteria, see
"Searching Sources" on page 82.

3. Select the Search in results option at the top left of the Find in Source window.
4. Click Find Now. The results of your new search appear in the message item list.
5. To preview the message items returned by the search, click the Preview check box.

Figure 3-3: Checking the Preview option adds amessage Preview pane

Viewing Previous Search Results
You can click the Previous button multiple times to return to any previous search criteria and
search results. This button becomes unavailable when there are no more previous results.
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To view previous search results

1. Perform at least two searches so the Previous button becomes available.
2. Click Previous. The results of the previous search appear in the in the message item list.
3. You can now view the previous search, or you can modify the search criteria and

conduct a new search. For information on specifying search criteria, see "Searching
Sources" on page 82.

Clearing Fields and Results
If you click the Clear Fields button, all of the search criteria that you entered in the Find in Source
window are returned to the default settings. If you click the Clear Results button, all current and
past search results are cleared.

Searching Microsoft Exchange Server Target
You can search a live Microsoft Exchange Server target and delete, move, copy, or export the
search results. This means you can search and delete, or move specific message items from a
Microsoft Exchange Server target. You can have only one search session Find in Exchange
Target window open at one time.

Note:Only accessible mailboxes and public folders of the Microsoft Exchange Server can be
searched.

Tip: CAS and PST files are not searchable in the Target pane but are searchable in the source
pane.

To search a Microsoft Exchange Server target

1. Do one of the following to display the Find in Exchange Target window:
l Right-click the valid object in the Target pane and click Find.
l On the Tools menu, click Find.

l On the toolbar, click the Find icon .

l Press F3.
2. Conduct search as described in "Searching Sources" on page 82.

Tip: Microsoft Exchange Server target search results can have an Integrity Check performed
either by right-clicking the message or clicking Integrity Check in the Tools menu.

Managing Message Items
Once you have performed a target search, several functions are available on the search results
including cut, move, export, copy, and delete.
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Moving Message Items
Moving message items from the search results to another folder within the target directory
removes the message items from the original location. You can move message items by using
the Move To Folder function, or by dragging to the destination folder.

Move to Folder

Single Mailbox Recovery presents you with a Move To Folder option and a corresponding Move
Items destination selection window.

Note:Message items cannot be moved to a Content Analysis Store (CAS).

To move to folder using Move To Folder

1. Do one of the following to display the Move Items window:
l Right-click the message item(s) in the search results and click Move To Folder.
l On the Edit menu, click Move To Folder.

2. Select a folder as the destination and click OK. The Copy Progress window appears.
3. Select Print to print the progress report, Save to save the progress report to your hard drive,

or Close to close the window.

Dragging a Message

Dragging a Find in Target search result list has a "Move" option. This option behaves in the same
manner as the Move to Folder function or cut and paste.

To drag to a folder

1. Right-click the message item in the search results and drag to a mailbox in the Target
pane.

2. At the destination mailbox, a shortcut menu appears with the options of Paste, Move,
Paste Special, or Cancel. Select one and the Copy Progress window appears.

3. Click Print to print the progress report, Save to save the progress report to your hard drive,
or Close to close the window.

Copying Message Items
You can copy message items to Microsoft Exchange Server and PST file targets. Only valid
targets are displayed in the Copy Items window.

Copy to Folder

Single Mailbox Recovery presents you with a Copy To Folder option which copies the item and
keeps it in its original location to be pasted in a designated location.

To copy to folder

1. On the Edit menu, click Copy To Folder. The Copy Items window appears.
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2. Select a folder as the destination and click OK. The message item is now copied and
pasted to the designated location.

3. In the Copy Progress window, click Print to print the progress report, Save to save the
progress report to your hard drive, or Close to close the window.

Cutting and Deleting Message Items
The target search results has two new actions, cutting message items and deleting message
items, which are only available in the target search results window.

Cutting Message Items

Cutting a message item moves the item from the original location to a given target.

Deleting Message Items

Deleting a message item in the search results works in a similar manner as deleting message
items from the main target list. When you delete message items from the search results list, they
are also deleted from the main target list if the same message item is currently displayed.

Note: You cannot delete message items from the main target list if the Find in Exchange Target
dialog is open.

Saving and Using Search Profiles
Single Mailbox Recovery allows you to save search criteria to a text file for the purpose of using
the search criteria in future searches. There are two menu commands that allow you to perform
these functions: "Save Criteria" and "Use Previous Criteria." In addition, if you want to modify the
search criteria in a search profile, you can edit the text file with a text editor.

When creating a search profile, you can save the following search criteria. The "Search For,"
"Exclude Words," "Sent from," and "Sent to" fields have a maximum of 4,095 characters.

n Search for words
n Exclude words
n Search in
n Sent from
n Sent to
n Created Dated after
n Created Dated before

Note: The saved criteria of a content analysis store profile folder can be used for a search.
Conversely, the saved criteria for a search can be used to create a content analysis store profile
folder. For more information on content analysis stores, see "Content Analysis Store" on page
155.
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To create a search profile

1. Open the Find in Source window, and enter search criteria.
2. On the File menu in the Find in Source window, click Save Criteria.
3. In the Save As window, specify a name and location for the search profile text file.
4. Click Save.

To edit a search profile

1. Locate and open the search profile that you want to edit.
2. Modify the search criteria as desired and save the text file.

To use a search profile when performing a search

1. Open the Find in Source window.
2. On the File menu in the Find in Source window, click Use Previous Criteria.
3. In the Open window, locate and open the search profile that you want to use for your

search.
4. Click Open. The Find in Source window is populated with the search criteria specified in

the search profile.

Using Multiple Search Windows
Single Mailbox Recovery allows you to open multiple instances of the Find in Source window to
search any combination of information stores at the same time. There is no limit other than
system resources for the number of concurrent searches you can initiate.

When searching on a live Microsoft Exchange Server target, you are able to have only one
instance of a search session Find in Exchange target window at one time.

Note: If you are using multiple instances of the Find in Source window to search within the same
mailbox, youmay notice a slowdown in performance.

Searching Within Attachments
In both the Find in Source and Find in Exchange Target windows, you can search the text of
email attachments. The Searching within Attachments feature supports Unicode text and is
available for EDB, PST, CAS sources, and Microsoft Exchange Server targets. Single Mailbox
Recovery supports Microsoft Office documents and many other popular file types.

Note about the licensing agent: The "Agent for Advanced Searching" must be enabled in order
to search attachments. For more information, see "Task III: View and Enable Agents" in the
Release Notes file.
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Figure 3-4: Select the Attachment Text option to include in your search

To search within attachments

1. In the Find in Source or Find in Exchange Target window, select the Attachment Text
check box.

2. Specify other desired search criteria. For more information, see "Searching Sources" on
page 82.

3. Click Find Now. If Single Mailbox Recovery matches a keyword or phrase in the text of the
attachment, it will return a "Hit" just as it would if it found a keyword or phrase in the body
or subject of a message item.

Exceptions When Searching Within Attachments
Single Mailbox Recovery does not search for the following items:

n Archive files (for example, .zip, .rar)
n Binary files (for example, .dll, .exe, .jpg)
n Metadata associated with files (for example, author and company information in an .xls

file)

Other Single Mailbox Recovery Features
Available Through the Find Window
In addition to the search features described in the previous sections, there are several Single
Mailbox Recovery features available through the Find window.
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Opening and Saving Attachments in the Find Window
For instructions on opening and saving attachments, see "Opening Attachments" on page 15
and "Saving Attachments" on page 16.

Keep in mind that you must have an application on your computer that can open the
attachment's file type. If no associated program is available for the attachment file type, Single
Mailbox Recovery will present a message dialog box saying the attachment cannot be viewed.

Exporting Message Items from the Find Window
The Export feature allows you to copy individual message items from the Find window to a local
or network drive destination. You can choose to save exported message items as plain text files
(.txt), Microsoft Office Outlook files (.msg), or Outlook Data files (.pst). For more information, see
"Exporting Messages" on page 95.

To export message items from the Find window

1. In the Find in Source or Find in Exchange Target window, perform a search.
2. In the Results area, select the message items you want to export.
3. On the Tools menu in the Find in Source or Find in Exchange Target window, click Export.
4. In the Export window, specify options and click Export. For more information on the export

options, see "Exporting Messages" on page 95.

Restoring Message Items from the Find Window
The results of conducting a search appear in the message item list in the Find window. You can
restore the message items in this list by dragging them or copying and pasting them into the
target folder. If you want to maintain the directory structure of restored individual message
items, use the Paste Special command.

You can also restore message items by browsing in the main window and dragging or copying
and pasting from the main window to the target. You do not need to search to restore message
items. For more information, see "Restoring Microsoft Exchange Server Data" on page 114.

Performing an Integrity Check on Message Items in the Find
in Source Window
The Find in Source window allows you to perform an integrity check on one or more message
items in the Results area. During the integrity check, Single Mailbox Recovery verifies that it can
read all of the properties of the message items.

Note:Only accessible mailboxes can have an Integrity Check performed.
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To perform an integrity check onmessage items in the Find in Source window

1. In the Find in Source window, perform a search.
2. In the Results area, select the message items for which you want to perform an integrity

check.
3. On the Tools menu in the Find in Source window, click Integrity Check. The Integrity

Check window appears.

Search Results Report
You can save a text-based report of the search results to your local drive without having to copy
or export any of the search results. The search results report is saved into a file that includes the
search criteria, date/time the search was started, and a report of message items that matches
the criteria.

Save Report
You can save the search results report once a search has been performed and either
completed or stopped.

The Save Report button creates two text-based reports. One report contains a search session
summary (Summary Report) and the other report contains search session message item results
(Message Report).

Summary Report
The information included in the Summary report is the search session details and the user-
defined search criteria for the search.

Message Report
The information included in the Message report is based on the column headings in the search
results, message type, attachments, From and To, etc.

To save the report

1. After conducting the search, click Save Report. The Browse For Folderwindow appears.
2. Select the destination for the report and click OK. The search results reports creates both

a Message Report and a Summary Report, and are saved on your hard drive in a .txt
format.
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Figure 3-5: Summary andMessages Reports

The files are named using the date of the search and a suffix indicating the type of report.
For example, if you run a search on 5/8/2007, the report names are:
SearchResults_20070508_Summary.txt for the summary report, or
SearchResults_20070508_Messages.txt for the message report.

For cases where you choose to create more than one set of reports on the same date,
files are named using an incremental numbering convention starting with "1." If you run a
second search on 5/8/2007, the report names are:
SearchResults_20070508(1)_Summary.txt for the summary report, or
SearchResults_20070508(1)_Messages.txt for the message report.

3. Clicking Cancel during the report generation progress terminates the process and any
reports created for this Save Report action are deleted from the report destination.

Using the Report
The text summary or message report is tab delimited and can be imported into a spreadsheet if
desired. Simply drag the .txt file from its location into a blank spreadsheet. The source # in the
search results is replaced with the full path to its location in the report.
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Chapter 4: Exporting Messages
Overview
You can export mail from an EDB, PST, or CAS source file or live target Microsoft Exchange Server
to a local or network drive destination. Exported messages can be saved as Microsoft Office
Outlook files (.msg), saved as plain text files (.txt), or become contents of a PST file. This can assist
you in copying old email backups into an alternate or non-email system. You can export at all
levels (mailbox, folder, and individual messages) for the corresponding file type.

You can export at all levels: an EDB file, a PST file, a CAS file, a CAS profile folder, a mailbox, a
folder, and individual messages.

You can also export forms from an organizational forms library in a public folder EDB or source
public folder mailbox. These exported files can be saved as Microsoft Office Outlook forms (.oft).

General Information about Exporting Messages
n When saving exported message items as plain text files (.txt) or Microsoft Office Outlook

files (.msg), the file name for an exported message is its subject. The file name for an
exported organizational form is the form's name. When saving exported message items to
Outlook Data files (.pst), the file name is either based on the name of the mailbox or set by
the user depending on the level of the source being exported. A duplicate file name will
create a file with the same name but with an (x) appended to the filename: x = 1 for the
first duplicate, x = 2 for the next duplicate, and so on. If the subject or form name contains
illegal file name characters, each offending character will be replaced with an
underscore.

n Associated messages and folder properties will not be exported.
n When exporting individual messages, you have the option to keep the folder/mailbox

hierarchy, similar to the paste special feature. When exporting a mailbox or folder, you
have the option to also export the subfolders.

n Messages in the Microsoft Exchange Server 2010 and later Recoverable Items folders can
be exported if the Show Recoverable Items preference is enabled.

n When exporting the Recoverable Items folder, it is renamed to distinguish the copied
version from the actual version. The folder is renamed using the localized short date in
parenthesis and appended to the folder name. Example: "Recoverable Items (1/22/2009)"

n If you use the "Mailbox Criteria (optional)" box on the Source Selection page of the Data
Wizard, only EDB mailboxes containing your entry (or entries) are displayed on the Source
pane. Any mailboxes that do not match the entered string(s) do not appear in the Source
pane and are not be included in any subsequent tasks (such as searching, copying, and
exporting of the entire database). For more information, see "MailboxCriteria" on page 30.
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n If you use the "Multi-Tenancy Criteria" box on the Source Selection page of the Data
Wizard, the Connect to Exchange Server dialog box, or the Target Selection page of the
Data Wizard, only mailboxes contained in the selected Address Book Policy or
Organization appear in the Source or Target panes. Only these mailboxes are included in
any subsequent tasks (such as searching, copying, and exporting of the entire database).
For more information, see "Multi-Tenancy Support" on page 31.

About Message (.msg), Text (.txt), and PST
Export
The file type for an exported message can be either Microsoft Office Outlook (.msg) or plain text
(.txt) or PST.

Message (.msg) export

A .msg file (OLE compound document) can be imported directly into Microsoft Office Outlook.
This file type encapsulates the entire message including attachments.

Text (.txt) export

A .txt file is created with the following information. Note that neither message attachments nor
message properties are exported.

PST export

The Export to PST option allows you to generate PST files at all levels of the following:

n Off-line private store EDB files
n Off-line public store EDB files (Microsoft Exchange Server 2010 and earlier)
n CAS files
n PST files

You can also export to PST files from a target and source Find window. For more information, see
"Exporting to PST" on page 103.

Exporting Messages
You can export an EDB file, a source PST file, a source CAS file, a source CAS profile folder,
mailboxes, folders, messages, and a live Microsoft Exchange Server target.

Note:Only accessible mailbox items can be exported. If you are exporting a CAS file, only
accessible mailboxes are included in the export.

The section explains how to perform the following export tasks from the Single Mailbox Recovery
main window:
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n "To export an entire source private EDB file, mailbox, or PST file" on page 97
n "To export a source PST folder, a folder, a CAS file, a profile CAS folder, or a public EDB file"

on page 98
n "To export a mailbox or a folder from a Microsoft Exchange Server target" on page 99
n "To export individual source or target messages" on page 101
n "To export individual messages from the Find window to a TXT or MSG file" on page 102

To export an entire source private EDB file, mailbox, or PST file

1. In the Source pane, select the root of the EDB file, mailbox, or PST file.
2. Do one of the following:

n On the Tools menu, click Export.

n On the toolbar, click the Export icon .

n Right-click the EDB file, and on the shortcut menu, click Export. The Export EDB , or
Export Mailboxwindow appears.

Figure 4-1: PST, MSG, or TXT format can be selected for export

3. If you want to export multiple objects (mailboxes, PST files), click Browse and in the
Selected Mailboxes dialog box, select the mailbox or PST file you want to export, then
click Ok. (You can select more than one).

4. In the Format box, select PST, MSG, or TXT. If you selected PST, Export results to multiple PSTs
is selected by default.

5. If you want to limit the documents exported by when an action was performed (such as
Received, Sent, or Due), select Filter By and do the following:

n In the Date box, select an action performed on the document.
n For After and Before, select the appropriate check box, if desired. You may select

both check boxes. Then type or select the part of the date you want to change.
After searches for documents created on or after the selected date. Before
searches for documents created on or before the selected date.
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6. In the Export to Folder or Export to File box, specify the location of the exported EDB file.
7. Click Export.
8. In the Export Progress window, verify the EDB file was successfully exported, and click

Close.

To export a source PST folder, a folder, a CAS file, a profile CAS folder, or a public EDB file

1. In the Source pane, select a PST folder, a folder, a CAS file, a profile CAS folder, or a
public EDB file root.

2. Do one of the following:
n On the Tools menu, click Export.

n On the toolbar, click the Export icon .

n Right-click a PST folder, a folder, a CAS file, a profile CAS folder, or a public EDB
root, and on the shortcut menu, click Export. The Export EDB, Export Folder, or Export
CAS window appears.

Figure 4-2: Export Folders window

3. In the Format box, select PST, MSG, or TXT.
4. In the Export to File or Export to Folder box, do one of the following:

n If you selected the PST format, enter the name of the resulting PST file. If you are
exporting a mailbox, the name of the PST file defaults to the name of mailbox
(which can be modified).
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n If you selected the MSG or TXT format, enter the location of the exported mailbox,
folder, or public EDB file.

5. Select the Export Subfolders check box if you want to export all of the subfolders for the
selected mailbox or folder.

Note: This option is selected automatically when exporting the EDB public root.

6. If you want to limit the documents exported by when an action was performed (such as
Received, Sent, or Due), select Filter By and do the following:

n In the Date box, select an action performed on the document.
n For After and Before, select the appropriate check box, if desired. You may select

both check boxes. Then type or select the part of the date you want to change.
After searches for documents created on or after the selected date. Before
searches for documents created on or before the selected date.

7. Click Export.
8. In the Export Progress window, verify the mailbox or folder was successfully exported, and

click Close. The mailbox or folder appears in the specified location. For PSTs, the exported
mailbox or folder is included in the PST file.

To export a mailbox or a folder from a Microsoft Exchange Server target

1. In the Target pane, select a PST file, a mailbox or a profile CAS folder, or the public EDB file
root.

2. Do one of the following:
n On the Tools menu, click Export.

n On the toolbar, click the Export icon .

n Right-click the mailbox, folder, or public EDB root, and on the shortcut menu, click
Export. The Export Mailboxor Export Folderwindow appears.
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Figure 4-3: Export Mailboxes window

3. In the Format box, select PST, MSG, or TXT.
4. In the Export to File or Export to Folder box, do one of the following:

n If you selected the PST format, enter the name of the resulting PST file. If you are
exporting a mailbox, the name of the PST file defaults to the name of mailbox
(which can be modified).

n If you selected the MSG or TXT format, enter the location of the exported mailbox,
folder, or public EDB file.

5. Select the Export Subfolders check box if you want to export all of the subfolders for the
selected mailbox or folder.

Note: This option is selected automatically when exporting the EDB public root.

6. If you want to limit the documents exported by when an action was performed (such as
Received, Sent, or Due), select Filter By and do the following:

n In the Date box, select an action performed on the document.
n For After and Before, select the appropriate check box, if desired. You may select

both check boxes. Then type or select the part of the date you want to change.
After searches for documents created on or after the selected date. Before
searches for documents created on or before the selected date.

7. Click Export.
8. In the Export Progress window, verify the mailbox or folder was successfully exported, and

click Close. The mailbox or folder appears in the specified location. For PSTs, the exported
mailbox or folder is included in the PST file.
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To export individual source or target messages

1. In the Source or Target pane, select one or more messages from the message list.
2. Do one of the following:

n On the Tools menu, click Export.

n On the toolbar, click the Export icon .

n Right-click the selection, and on the shortcut menu, click Export. The Export
Messages dialog box appears.

Figure 4-4: PST, MSG, or TXT format can be exported

3. In the Format box, select PST, MSG or TXT.
4. Select the Maintain Message Path option if you want to maintain the directory structure of

the exported messages.
5. If you are exporting message from the Source pane to PST, you can also select Skip

mailbox folder to merge the exported message into the resulting PST without maintaining
the mailbox folder.

6. If you want to limit the documents exported by when an action was performed (such as
Received, Sent, or Due), select Filter By and do the following:

n In the Date box, select an action performed on the document.
n For After and Before, select the appropriate check box, if desired. You may select

both check boxes. Then type or select the part of the date you want to change.
After searches for documents created on or after the selected date. Before
searches for documents created on or before the selected date.

7. In the Export to File or Export to Folder box, do one of the following:

101



n If you selected the PST format, enter the name of the resulting PST file.
n If you selected the MSG or TXT format, enter the location of the exported mailbox,

folder, or public EDB file.
8. Click Export.
9. In the Export Progress window, verify the mailbox or folder was successfully exported, and

click Close. The messages appear in the specified location. For PSTs, the exported
mailbox or folder is included in the PST file.

To export individual messages from the Find window to a TXT or MSG file

1. In the Find in Source or Find in Exchange Target window, select one or more messages
from the message list.

2. Right-click the selection, and on the shortcut menu, click Export.
3. In the Format box, select MSG or TXT.

Figure 4-5: Exporting the MSG or TXT format

4. If you want to maintain the directory structure of the exportedmessages, select the
Maintain Message Path option.

5. If you want to limit the documents exported by when an action was performed (such as
Received, Sent, or Due), select Filter By and do the following:

n In the Date box, select an action performed on the document.
n For After and Before, select the appropriate check box, if desired. You may select

both check boxes. Then type or select the part of the date you want to change.
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After searches for documents created on or after the selected date. Before
searches for documents created on or before the selected date.

6. In the Export To Folder box, specify the location for the exported messages.
7. Click Export.
8. In the Export Progress window, verify your messages were successfully exported, and click

Close. The messages appear in the specified location.

Exporting to PST
You can export to a PST file from the Source and Target panes, the Source and Target Message
lists, and the Source and Target Find windows.

Exporting to PST from the Source Pane
When exporting to PST from the Source Pane, follow the instructions To export individual source
or target messages in "Exporting Messages" on page 96.

In the Export to File or Export to Folder box, enter the name of the resulting PST file. The exported
mailbox or folder is included in the PST file.

Figure 4-6: Exporting to PST from the Source Pane

Exporting to PST from the Target Pane
When exporting to PST from the Target Pane, follow the instructions To export a mailbox or a
folder from a Microsoft Exchange Server target in "Exporting Messages" on page 96.

If you want to export all of the subfolders for the selected mailbox or folder, select the Export
Subfolders check box

Note: You can only export a single mailbox on the target, not multiple mailboxes.
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In the Export to File or Export to Folder box, enter the name of the resulting PST file. The exported
mailbox or folder is included in the PST file.

Figure 4-7: Exporting to PST from the Target Pane

Exporting to PST from the Message List
When exporting messages from the Message List view, you can use the Skip Mailbox Folder
option on the Export dialog box to merge the exported message into the resulting PST without
maintaining the mailbox folder.

Figure 4-8: Exporting to PST from the Message List
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Exporting to PST from the Find Window
The following two options are available when exporting to PST from the Find window.

n Export results to multiple PSTs: If selected, search results are exported based on which
mailbox or CAS profile folder they were originally stored in. One PST will be created for
every mailbox and CAS profile folder. IfMaintain Message Path is also selected, the
directory structure of the exported messages inside PST is maintained. In such cases, PST
files receive the name of the respective mailbox or CAS profile folder in which the
messages were found. Exported public EDB files are named "All Public Folders.pst."

n Export results to single PST: If selected, search results are exported to a single PST. If
Maintain Message Path is also selected, the directory structure of the exported messages
inside PST is maintained. IfMerge Mailboxes is selected, results are exported to a single PST
file with all the standard PST folders. With Export results to a single PST, you can choose a
name for a PST file.

To export individual messages from the Find window to a PST file

1. In the Find in Source or Find in Exchange Target window, select one or more messages
from the message list.

2. Right-click the selection, and on the shortcut menu, click Export.
3. In the Format box, select PST.

Figure 4-9: Exporting the PST format

4. In the Export to File box, specify the location for the exported messages.
5. Do one of the following:
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n To export all of the selected messages to one PST, choose Export results to single
PST.

n To export messages from different mailboxes, CAS profiles, or public folders in
respectively named separate PST files, choose Export results to multiple PSTs.

6. If you want to maintain the directory structure of the exportedmessages, select the
Maintain Message Path option.

7. If you selected Export results to single PST you can choose Merge Mailboxes. This option
removes the mailbox level from the directory structure of the exported messages. For
more information, see the Scenarios section that follows.

8. If you want to limit the documents exported by when an action was performed (such as
Received, Sent, or Due), select Filter By and do the following:

n In the Date box, select an action performed on the document.
n For After and Before, select the appropriate check box, if desired. You may select

both check boxes. Then type or select the part of the date you want to change.
After searches for documents created on or after the selected date. Before
searches for documents created on or before the selected date.

9. Click Export.
10. In the Export Progress window, verify your messages were successfully exported, and click

Close.

When exporting message from the Source pane, you can also use the Skip Mailbox Folder
option on the Export dialog box. This option merges the exported message into the resulting PST
without maintaining the mailbox folder.

Note: Before exporting to PST, ensure that you have sufficient disk space available at the
destination of the PST export.

Scenarios
Scenarios for exporting multiple mailboxes from the Find Window to a single PST
Scenario 1
A folder with the mailbox name for every mailbox in which messages are found is created in the
new PST. The message path is maintained, even if the higher level folder does not contain
messages. The PST name is created by the user.
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Figure 4-10: Scenario 1

Scenario 2
Folders in which messages are found are created in the resulting PST. The message path is
maintained from the root level (even if the higher level folder does not include messages).
Mailbox names are removed. If the folder already exists, the messages found in a different folder
with the same name and at the same hierarchy level are placed in the existing folder in the
resulting PST. The PST name is created by the user.

Figure 4-11: Scenario 2
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Scenario 3
All messages found are exported to the PST at the root level. The PST name is created by the
user.

Figure 4-12: Scenario 3

Scenario 4
A folder with the mailbox name for every mailbox in which messages are found is created in a
new PST. Messages found in these mailboxes reside in these new mailbox folders, without the
folder structure in which they were located originally. PST name is created by the user.

Figure 4-13: Scenario 4
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Scenarios for exporting multiple mailboxes from the Find Window to multiple PSTs
Scenario 5
All the folders with messages found are created, starting from the first PST level folder and not
the mailbox name. PST is named after the corresponding EDB mailbox name.

Figure 4-14: Scenario 5

Scenario 6
All the messages are located in the root of the PST. PST is named after the corresponding EDB
mailbox name.

Figure 4-15: Scenario 6

Using an Exported PST
To use an exported PST

1. Navigate to where the PST was created.
2. Drag the PST into Single Mailbox Recovery in either the source or the Target pane. The

Select Source Files window appears.
3. In the Select Source Files window, click OK.

The PST now appears in the target or source directory.
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Appending Messages to Existing PST Files
You can configure Single Mailbox Recovery to append messages to existing PST files. Selecting
the Append to existing PST files during export option on the Preferences dialog box updates
previously exported PST files with new messages from the export process.

If this option is cleared, Single Mailbox Recovery does not append messages to an existing PST
file, but creates a new PST file with a number in parenthesis added to the name of the exported
PST file. For example, if John Doe.pst already exists, a new PST files is created and named John
Doe(1).pst. If John Doe(1).pst also exists, then the most recently exported PST would be named
John Doe(2).pst.

Note: You can only appendmessages to existing PST files which are not password protected.

To append messages to existing PST files

1. On the Edit menu, click Preferences, then click General.
2. On the General tab of the Preferences dialog box, select Append to existing PST files

during export and click OK.
3. Perform the export to PST. For more information, see To export to PST in "Exporting

Messages" on page 96
4. Do one of the following:

n If you selected Export results to single PST, choose the existing PST file to which you
want to append the new messages.

n If you selected Export results to multiple PSTs, choose a folder with PSTs you exported
previously,

5. In the Export Progress window, verify new messages were successfully added to existing
PST, then click Close.

Note: There is a 2GB limit for Microsoft Office Outlook 97-2002 style PSTs. For more information,
see "Limits for PST and Folder Targets" on page 116

Setting a Global Limit for PST Files
When exporting PST files, you can define the maximum size of single Unicode PST file using the
Target Options tab of the Preference dialog box or the Command Line.

Target Options tab
When Limit maximum PST file size is selected, Single Mailbox Recovery automatically creates a
new PST file when the size in the MB field is reached during export. Single Mailbox Recovery saves
the processed PST file with its orginal name and creates the next file with the same name and a
_001.pst suffix, with the folders structure similar to the original file. Single Mailbox Recovery then
continues exporting messages to the newly created _001.pst file, saves it at the maximum size,
and continues the process, increasing the numbered suffix (_001.pst, _002.pst, _003.pst ...) until
the entire orginal PST file is exported.
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Single Mailbox Recovery appends files to existing ones also enforces the global size limit so it tries
to add files into existing pst file and if it reaches size limit it overflows to another file.

If files are present from a previous PST file export in which where size limit was reached (For
example, OriginalFileName.pst, OriginalFileName001.pst, and OriginalFileName002.pst)Single
Mailbox Recovery exports files to OriginalFileName002.pst until the limit is reached and
continues, creating OriginalFileName003.pst.

Note:Microsoft supports PST files up to 47.5GB with an absolute limit of 50GB, so the MB field
should not exceed 48640.

Exporting Organizational Forms
Microsoft Exchange Organizational Forms libraries are stored in public folder databases or public
folder mailboxes. When a public folder EDB or public folder mailbox containing one or more
Organizational Forms folders is loaded as a source in Single Mailbox Recovery, you can export
the forms from the Organizational Forms library folder(s).

To export organizational forms

1. In the source tree, select the root of the public folder EDB or public folder mailbox.
2. Do one of the following to open the Export Organizational Forms dialog box:

n On the Tools menu, click Export Organizational Forms.
n PressCtrl+G.
n Right-click the selection, and on the shortcut menu, click Export Organizational

Forms.

Figure 4-16: Export Organizational Forms dialog box
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3. In the Look In drop list, select the organizational forms folder containing the forms you
want to export.

Note:Organizational Forms Library folders can be stored in different public folder
databases or public folder mailboxes. All public folder databases andmailboxes list all
public folders andOrganizational Forms Library folders, not just those they store content
for. Only the Organizational Forms Library folders stored within the selected public folder
database or mailboxwill contain items.

4. In the table, select the form(s) you want to export.
5. Click Export. The Export Forms dialog box appears with OFT selected in the Format list box.

Figure 4-17: Export Forms dialog box

6. In the Export To box, enter the folder path to where you want the forms exported.
Note: You can use the browse button to open the Browse For Folder dialog box to select
the path.

7. Click Export.
8. Use the Export Progress dialog box to verify your forms were successfully exported, and

click Close.
9. On the Export Organizational Forms dialog box, click Close.

About the Export Progress Window
Each time you attempt to export messages, the Export Progress window appears. This window
displays the following information:

n Source and target
n Export start time
n Number of folders to export
n Number of messages to export
n Warnings or errors encountered during the export process. If an error occurs on a

message, the message subject and source path along with an error message will be
displayed. If the message does not have a subject, the date (created) and message
sender will be displayed instead.

n Total folders and messages successfully exported
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Figure 4-18: The export progress is shown

Note:

n If an error occurs that Single Mailbox Recovery can recover from, such as a corruption
that prevents it from getting amessage property, Single Mailbox Recovery will log an
error, stop processing that message, and continue.

n If an error occurs from which Single Mailbox Recovery cannot recover, such as amajor
corruption error, Single Mailbox Recovery will log an error to the Export Progress window
and stop exporting.

Saving and Printing the Report
The contents of the export report can be saved by clicking Save. This opens a Save File dialog
box allowing you to select the location and name of the file. The default name of the report is
"ExportProgress.txt."

The export report can also be printed by clicking Print.
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Chapter 5: Restoring Microsoft
Exchange Server Data
Overview
This chapter describes how to restore Microsoft Exchange Server data (an EDB file, a PST file, a
mailbox, or a folder) to a Microsoft Exchange Server. The following topics are covered:

Quick look at restoring your Exchange data. The first part of this chapter provides you with a
quick look at restoring your Exchange database, so you can begin to use Single Mailbox
Recovery immediately.

Examples of restoring your Exchange data. The second part of this chapter provides examples of
restoring messages, folders, mailboxes, and even an entire EDB file to the desired destination.

Note: The concepts in this chapter apply to EDB, PST, andCAS files (unless otherwise noted),
even though all of the examples of sources are EDB files.

Note: If you use the "MailboxCriteria (optional)" box on the Select Source Files dialog box or the
Source Selection page of the DataWizard, only EDB mailboxes containing your entry (or entries)
are displayed on the Source pane. Anymailboxes that do not match the entered string(s) do not
appear in the Source pane and are not be included in any subsequent tasks (such as searching,
copying, and exporting of the entire database). For more information, see "MailboxCriteria" on
page 30.

Note: If you use the "Multi-Tenancy Criteria" box on the Select Source Files dialog box, the Source
Selection page of the DataWizard, the Connect to Exchange Server dialog box, or the Target
Selection page of the DataWizard, only mailboxes contained in the selected Address Book
Policy or Organization appear in the Source or Target panes. Only these mailboxes are included
in any subsequent tasks (such as searching, copying, and exporting of the entire database). For
more information, see "Multi-Tenancy Support" on page 31.

Quick Look at Restoring Your Microsoft
Exchange Server Data
Restoring data from a source EDB, PST, or CAS file to a target destination is a simple process. Just
drag or use the Copy and Paste/Paste Special commands.

n "Restoring Your Microsoft Exchange Server Data in Three Easy Steps" on page 115
n "Limits for PST and Folder Targets" on page 116
n "About Restoring Messages to a Microsoft Exchange Server" on page 116
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n "About the Copy Progress Window " on page 117
n "Creating, Renaming, and Deleting Folders in the Target Pane" on page 117
n "Copying and Pasting or Dragging" on page 118

Restoring Your Microsoft Exchange Server Data in Three
Easy Steps
If you copy an EDB file, a PST file, a mailbox, or a folder from the Source pane and paste it to any
target destination, Single Mailbox Recovery will preserve the directory structure of all restored
messages. When restoring individual messages, you must use the Paste Special command to
preserve their directory structure.

To restore individual messages with copy-paste

1. In the Source pane or Find in Source window, copy messages from the message list.
2. In the Target pane, paste the messages into a folder.
3. In the Copy Progress window, verify that your messages were successfully copied, and

click Close.

To restore individual messages with copy-paste special

1. In the Source pane or Find in Source window, copy messages from the message list.
2. In the Target pane, use Paste Special to paste the messages into a folder, mailbox, PST

root, or Microsoft Exchange Server root.
3. In the Copy Progress window, verify that your messages were successfully copied, and

click Close.

Tip: Use the Paste Special command to retain the directory structure of messages copied
from the Find in Source or Find in Exchange Target window, because messages in this
window often come from several source locations.

To restore a folder, a mailbox, an EDB file, a CAS file, or a PST file

1. In the Source pane, copy a folder, a mailbox, an EDB file, a CAS file, or a PST file.
2. In the Target pane, paste the copied item into a folder, mailbox, PST root, or Microsoft

Exchange Server root.
3. In the Copy Progress window, verify that your messages were successfully copied, and

click Close.
Note: You cannot open the same PST as a source and target. In addition, you cannot
restore messages from a PST file to aMicrosoft Exchange Server root node.

To restore data even faster by dragging

n Example: To restore an entire EDB file, drag it to the target Microsoft Exchange Server
root.

115



Limits for PST and Folder Targets
When restoring Microsoft Exchange Server Data to a target PST or folder, Microsoft Office
Outlook 97-2002 style PSTs have the following limits:

Global Limits for PST Limit

The global limit can be set for any PST file. For more information, see "Setting a Global Limit for
PST Files" on page 110.

16,383Messages Per Folder (for example, Inbox) Limit

When a target folder (for example, Inbox) reaches 16,383 messages, Single Mailbox Recovery
creates a new PST folder for the additional messages. The new folder has the same name as the
original target folder plus an appended number in parentheses: Inbox (1), Inbox (2), and so on.
Single Mailbox Recovery creates the folder path in the new folder and continues to restore
Microsoft Exchange Server data where it left off.

Note: If you have upgraded the PST file to a large table format, the PST can hold 64,000
messages per folder. However, when a target folder (for example, Inbox) reaches 16,383
messages, Single Mailbox Recovery still creates a new PST folder for the additional messages.

To turn off the preference setting for the PST messages per folder limit
If you do not want Single Mailbox Recovery to create new folders when the number of messages
reaches 16,383, do the following:

1. On the Edit menu, click Preferences.
2. In the Preferences window, click the Target Options tab, and then clear the Create new

PST folders when PST message/folder limits are reached check box.

Note: If you turn off the preference, all messages above the messages per folder limit will fail to
copy correctly, and the PST file may become corrupt.

About Restoring Messages to a Microsoft Exchange Server
You must have sufficient access rights to all of the Microsoft Exchange Server mailboxes you are
trying to restore messages to.

Restoring Messages to Microsoft Exchange Server 2007 and later

In Microsoft Exchange Server 2007 and later, the permission that controls whether or not any
mailbox can be copied to is Full Mailbox Access. You must have Full Mailbox Access set to
"Allow" in order to copy to a mailbox other than the one you logged in under.
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About the Copy Progress Window
Each time you attempt to restore messages to the Target pane, the Copy Progress window
appears. This window displays the following information about the copy operation:

n Time of copy operation
n Number of messages, associated messages, and folders
n Errors, if any
n Mailboxes that Single Mailbox Recovery connected to or failed to connect to when

copying to a Microsoft Exchange Server
n Copy results

Viewing the copy results in Copy Progress window is especially important when attempting to
restore multiple items to a Microsoft Exchange Server root node. That is because Single Mailbox
Recovery restores one mailbox at a time; therefore, the only way you will know if all of the
mailboxes were successfully copied to the Microsoft Exchange Server will be to look at the copy
results listed in this window.

If you do not have full access rights to the mailboxes you are trying to restore messages to, Single
Mailbox Recovery will be unable to connect to the mailboxes. For more information, see "About
Restoring Messages to a Microsoft Exchange Server" on page 116.

Creating, Renaming, and Deleting Folders in the Target Pane
The Target pane has folders in which you can place your restored messages. However, you may
want to create new folders for your messages. You can also rename or delete any folder in the
Target pane.

To create a new folder in the Target pane

1. In the Target pane, select a folder, a PST root node, or a Microsoft Exchange Server
mailbox.

2. Do one of the following:
l On the Edit menu, click New Folder.
l Right-click and on the shortcut menu, click New Folder.
l PressCtrl+N.

3. In the Create New Mail Folderwindow, name the folder and click OK. A subfolder is
created in the target folder.

To rename a folder in the Target pane

1. In the Target pane, select a folder.
2. Do one of the following:

l On the Edit menu, click Rename.
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l Right-click and on the shortcut menu, click Rename.
l PressCtrl+R.

3. Type a new name for the folder.

Note: You can also rename a PST root.

To delete a folder in the Target pane

1. In the Target pane, select a folder.
2. Do one of the following:

l On the Edit menu, click Delete.
l Press the Delete key.

Copying and Pasting or Dragging
In Single Mailbox Recovery, you can restore data to the Target pane by using Copy-Paste,
Copy-Paste Special, or dragging.

Note: If you copy the Recoverable Items folder, it is renamed to distinguish the copied version
from the actual version. The folder is renamed using the localized short date in parenthesis and
appended to the folder name. Example: "Recoverable Items (10/22/2009)"

To copy an item in the Source pane or Find window

1. In the Source pane or Find in Source window, select messages, a folder, a mailbox, or the
entire EDB file.

Note: In the Find in Source window, you can only select messages.

2. Do one of the following:
l On the Edit menu, click Copy.
l Right-click the selected item(s), and on the shortcut menu, click Copy.

l Click the Copy Mail Item icon on the toolbar.

l PressCtrl+C.

To paste an item in the Target pane

1. In the Target pane, select a folder, a mailbox, the PST root node, or the Microsoft
Exchange Server root node.

2. Do one of the following:
l On the Edit menu, click Paste.
l Right-click the selected item, and on the shortcut menu, click Paste or Paste Special.

For more information on using the Paste Special command, see "Restoring Messages
with Copy-Paste" on page 119.
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l Click the Paste icon on the toolbar.

l PressCtrl+V (Paste) or Ctrl+Y (Paste Special).

To drag an item to the Target pane

n Drag an item from the Source pane into a folder in the Target pane. Dragging achieves
the same results as copying and pasting.

To use drag when right-clicking a source item

1. In the Source pane, select one or more messages.
2. Right-click the selected messages and drag them to a folder in the Target pane.
3. When you let go of the mouse, a shortcut menu appears. On the shortcut menu, click

Paste or Paste Special. For more information on using the Paste Special command, see
"Restoring Messages with Paste Special" on page 120.

Examples of Restoring Your Microsoft Exchange
Server Data
This section provides examples of restoring messages, folders, mailboxes, and even an entire EDB
file to the desired destination. In each case, it provides guidelines for restoring messages.

Note: The concepts in this chapter apply to both EDB and PST files (unless otherwise noted),
even though all of the following examples are EDB files.

Restoring Messages with Copy-Paste
The following instructions show you how to restore individual messages to a folder in a target PST
file or Microsoft Exchange Server by using Copy-Paste. Keep in mind that dragging achieves the
same results.

Guidelines for Restoring Messages

n You can copy messages from the message list in the Source pane or the Find in Source
window.

n You can drag or copy and paste to restore individual messages to a folder in the Target
pane.

n You cannot drag or copy and paste to restore individual messages to a PST root node, a
Microsoft Exchange Server root node, or a Microsoft Exchange Server mailbox. However,
you can use Paste Special to restore individual messages to these locations.
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n Dragging or copying and pasting to restore individual messages does not preserve the
directory structure of the restored messages. If you want to preserve the directory
structure of restored individual messages, use Paste Special.

n You cannot copy-paste inaccessible mailboxes.

Tip: For information on Paste Special, see "Restoring Messages with Paste Special" on
page 120.

To restore messages with copy-paste

1. In the Source pane or Find in Source window, copy messages from the message list.
2. In the Target pane, paste the messages into a folder (for example, Inbox) in the target PST

file or Microsoft Exchange Server.
3. In the Copy Progress window, verify that your messages were successfully copied. You

can also print or save the copy report by doing one of the following.

l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

4. In the Copy Progress window, click Close to return to the main window.

Results of Restoring Messages with Copy-Paste

All unduplicated messages appear in the target folder.

Restoring Messages with Paste Special
You can use the Paste Special command to preserve the directory structure of restored
individual messages. The Paste Special command is especially useful when restoring messages
from the message list in the Find window, since these messages often come from several source
locations.

Guidelines for Restoring Messages with Paste Special

n You can use the Paste Special command to restore individual messages to any target
destination. Using the Paste Special command preserves the directory structure of the
restored messages.

n You can use the Paste Special command to restore individual messages only. You cannot
use the Paste Special command to restore an entire EDB file, a mailbox, or a folder.

n You cannot use Paste Special to restore messages to a public folder.
n If the target is a PST root node or folder, Single Mailbox Recovery creates a folder to

represent each mailbox. Each mailbox is a subfolder of the folder the user selected for the
Paste Special operation.
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n If the target is a Microsoft Exchange Servermailbox or folder, Single Mailbox Recovery
copies all messages to the target. Each mailbox is a subfolder of the folder the user
selected for the Paste Special operation.

n If the target is a Microsoft Exchange Server root node, the Paste Special code attempts to
connect to each mailbox one at a time and copies each message to its corresponding
mailbox and folder. If the folder does not exist, it will be created. If the mailbox does not
exist, Single Mailbox Recovery logs an error in the copy results, skips the entire mailbox,
and continues the Paste Special operation.

Note: You cannot restore messages from a PST file to aMicrosoft Exchange Server root
node.

To restore messages to a PST root or folder with Paste Special
If the target is a PST root node or folder, Single Mailbox Recovery creates a folder to represent
each mailbox. Each mailbox is a subfolder of the folder you selected for the Paste Special
operation.

1. In the Source pane or Find in Source window, copy messages from the message list.
2. In the Target pane, use Paste Special to paste the messages into a PST root node or folder.
3. In the Copy Progress window, verify that your messages were successfully copied. You

can also print or save the copy report by doing one of the following.
l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

4. In the Copy Progress window, click Close to return to the main window.

Results of Restoring Messages to a PST Root Node or Folder with Paste Special

All unduplicated messages appear in the target destination, and their directory structure will be
preserved.

To restore messages to a Microsoft Exchange Servermailbox or folder with Paste Special
If the target is a Microsoft Exchange Server mailbox or folder, Single Mailbox Recovery copies all
messages to the target. Each mailbox is a subfolder of the folder you selected for the Paste
Special operation.

1. In the Source pane or Find in Source window, copy messages from the message list.
2. In the Target pane, use Paste Special to paste the messages into a Microsoft Exchange

Server mailbox or folder.
3. In the Copy Progress window, review your results to make sure all the messages were

copied to the target destination. You can also print or save the copy report by doing one
of the following.
l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

4. In the Copy Progress window, click Close to return to the main window.
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Results of Restoring Messages to a Microsoft Exchange Server Mailbox or Folder with Paste
Special

Each mailbox is a subfolder of the target destination, and all unduplicated messages are
restored. In addition, their directory structure is preserved.

Figure 5-1: Results of using Paste Special on a target Microsoft Exchange Server mailbox

To restore messages to a Microsoft Exchange Server root node with Paste Special
If the target is a Microsoft Exchange Server root node, Single Mailbox Recovery attempts to
connect to each mailbox one at a time and copies each message to its corresponding mailbox
and folder. If the folder does not exist, it is created. If the mailbox does not exist, Single Mailbox
Recovery logs an error in the Copy Progress window, skips the entire mailbox, and continues the
Paste Special operation.

Important: The source mailbox must exist on the target Microsoft Exchange Server, and you must
have full mailbox access rights to all of the Microsoft Exchange Server mailboxes to which you
are trying to restore messages. For more information on access rights, see "About Restoring
Messages to a Microsoft Exchange Server" on page 116.

1. Select one or more messages from the message list in the Find in Source window or the
Source pane.

2. In the Source pane or Find in Source window, copy messages from the message list.
3. In the Target panes use Paste Special to paste the messages into a Microsoft Exchange

Server root node.
4. In the Copy Progress window, verify your results to make sure that your messages from all

mailboxes were copied to the target destination. You can also print or save the copy
report by doing one of the following:

l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

5. In the Copy Progress window, click Close to return to the Single Mailbox Recovery main
window.

Results of Restoring Messages to a Microsoft Exchange Server Root Node with Paste Special
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All unduplicated messages are restored in each mailbox that Single Mailbox Recovery can
connect to, and the directory structure of the messages is preserved.

When attempting to restore multiple mailboxes to a Microsoft Exchange Server root node, you
must look at the Copy Progress window to verify that your messages from all mailboxes were
successfully copied to the Microsoft Exchange Server. That is because Single Mailbox Recovery
displays only one mailbox at a time in the Target pane.

Restoring a Folder
The following instructions show you how to restore a folder to any target destination by using
Copy-Paste. Keep in mind that dragging achieves the same results.

Guidelines for Restoring a Folder

n You can drag or copy and paste to restore a folder to a target PST root node or folder, or
to a Microsoft Exchange Server mailbox or folder. If the folder does not exist in the target
destination, it is created.

n You cannot restore a folder to a Microsoft Exchange Server root node.
n You cannot restore a private folder to a public folder. But you can restore messages from

a private folder to a public folder.
n You cannot use the Paste Special command to restore a folder. You can use the Paste

Special command to restore individual messages only.
n If you copy the Recoverable Items folder, it is renamed to distinguish the copied version

from the actual version. The folder is renamed using the localized short date in parenthesis
and appended to the folder name. Example: "Recoverable Items (10/22/2009)"

To restore a folder

1. In the Source pane, copy a folder (for example, Inbox).
2. In the Target pane, paste the folder into a folder, mailbox, or PST root node.
3. In the Copy Progress window, verify your results to make sure that your messages from all

mailboxes were copied to the target destination. You can also print or save the copy
report by doing one of the following.
l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

4. In the Copy Progress window, click Close to return to the Single Mailbox Recoverymain
window.

Results of Restoring a Folder

All unduplicated messages in the folder are restored and their directory structure is preserved. If
the folder does not exist in the target destination, it is created.

Note: No folder is created because the copied folder (Inbox) already exists in the target
Microsoft Exchange Server mailbox.
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Restoring a Mailbox
The following instructions show you how to restore a mailbox to any target destination by using
Copy-Paste. Keep in mind that dragging achieves the same results.

Guidelines for Restoring a Mailbox

n You can drag or copy and paste to restore a mailbox to a target PST root node or folder,
or to a Microsoft Exchange Server root node, mailbox, or folder.

n If you restore a mailbox to a target PST root node: Messages from folders in the source PST
are restored to corresponding folders in the target PST (for example, messages from the
source Inbox are restored to the target Inbox). If a corresponding folder does not exist in
the target destination, it is created.

n If you restore a mailbox to a target PST folder, or to a Microsoft Exchange Server, mailbox,
or folder: If the mailbox does not exist in the target destination, a folder with its name is
created.

Important: If you want to restore a mailbox to a target Microsoft Exchange Server root
node, the source mailbox must exist on the target Microsoft Exchange Server, and you
must have full mailbox access rights to all of the Microsoft Exchange Server mailboxes
you are trying to restore messages to. For more information on access rights, see "About
Restoring Messages to a Microsoft Exchange Server" on page 116.

n You cannot restore a mailbox to a public folder. But you can restore messages from a
mailbox to a public folder.

n You cannot use the Paste Special command to restore a mailbox. You can use the Paste
Special command to restore individual messages only.

To restore a mailbox

1. In the Source pane, copy a mailbox (for example, User 1).
2. In the Target pane, paste the mailbox into a folder, mailbox, PST root node, or Microsoft

Exchange Server root node.
3. In the Copy Progress window, verify your results to make sure that your messages from all

mailboxes were copied to the target destination. You can also print or save the copy
report by doing one of the following.
l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

4. In the Copy Progress window, click Close to return to the Single Mailbox Recovery main
window.

Results of restoring a mailbox

All unduplicated messages in a mailbox are restored and their directory structure is preserved.
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If the mailbox does not exist in the target destination, a folder with its name is created. However,
if you restore a mailbox to a target PST root node, a mailbox is not created. Instead, messages
from folders in the source PST are restored to corresponding folders in the target PST.

Restoring an EDB File
The following instructions show you how to restore an entire EDB file to any target destination
with Copy-Paste. Keep in mind that dragging achieves the same results.

Guidelines for Restoring an EDB File

n It is recommended that you restore an EDB file to a target Microsoft Exchange Server root
node.

n You can drag or copy and paste to restore an entire EDB file. You cannot use the Paste
Special command to restore an EDB file. You can use the Paste Special command to
restore individual messages only.

Important: If you restore an EDB file to a target Microsoft Exchange Server root node, the
source mailbox must exist on the target Microsoft Exchange Server, and you must have
full mailbox access rights to all of the Microsoft Exchange Server mailboxes to which you
are trying to restore messages. For more information on access rights, see "About
Restoring Messages to a Microsoft Exchange Server" on page 116.

To restore an EDB file

1. In the Source pane, select the EDB file.
2. On the Edit menu, click Copy.
3. In the Target pane, select the Microsoft Exchange Server root node.
4. On the Edit menu, click Paste.
5. In the Copy Progress window, review your results to make sure all the messages were

copied to the target destination. You can also print or save the copy report by doing one
of the following.
l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

6. In the Copy Progress window, click Close to return to the Single Mailbox Recovery main
window.

Results of restoring an EDB file

Single Mailbox Recovery attempts to connect to each mailbox in the Target pane one at a
time and copies each message to its corresponding mailbox and folder. If the folder does not
exist, it will be created. If the mailbox does not exist, Single Mailbox Recovery displays an error in
the Copy Progress window, skips the entire mailbox, and continues the operation.
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Restoring to Public Folders
The following instructions show you how to restore messages or public folders to a public folder
target. An option to open public folders is available upon connection to a Microsoft Exchange
Server.

Important: Single Mailbox Recovery opens public folders and your mailbox when you connect
to a Microsoft Exchange Server target. You will see those folders that you have permission to
see.

Guidelines for Restoring to Public Folders

n You can restore folders from a pub.edb database or Public Folder mailbox to a public
folder target. All public folder permissions are transferred to the target folders. However,
folder permissions may not transfer if the version of the source Microsoft Exchange Server is
different than the version of the target Microsoft Exchange Server.

Note: Public folder permissions cannot be transferred to Microsoft Exchange Server 2013
or later targets.

n You can restore messages from any database source or search results to a public folder
target.

n You cannot restore a folder or non-Public Folder mailbox from a mailbox database to a
public folder target. But you can restore messages in a folder or non-Public Folder mailbox
to a public folder.

n You cannot use Paste Special when restoring messages to a public folder target.

Note: The ability to restore to public folders is also available at the command line.

To restore messages to a target Public Folders

1. In the Source pane or Find in Source window, copy messages from the message list.
2. In the Target pane, paste the messages into the target root public folder or a folder in the

public folder.
3. In the Copy Progress window, verify that your messages were successfully copied. You

can also print or save the copy report by doing one of the following.
l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

4. In the Copy Progress window, click Close to return to the Single Mailbox Recovery main
window.

To restore a folder from a public database or Public Foldermailbox to a target Public Folders

1. In the Source pane copy a folder from a public database, or Public Folder mailbox in a
Microsoft Exchange Server 2013 or later mailbox database.
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2. In the Target pane, paste the folder into the target root public folder or a folder in the
public folder.

3. In the Copy Progress window, verify that your messages were successfully copied. You
can also print or save the copy report by doing one of the following.
l Click Print to print the copy report.
l Click Save to save the copy report as a text file.

4. In the Copy Progress window, click Close to return to the Single Mailbox Recovery main
window.

Note: Public folders can be stored in different public folder databases or public folder
mailboxes. All source public folder databases andmailboxes list all public folders, not just those
they store content for. Only the public folders stored within the selected public folder database
or mailboxwill contain items in the Source pane.

Results of Restoring to Public Folders

When you restore folders from a pub.edb database or Public Folder mailbox to a public folder
target, the following occurs:

n All public folder permissions are transferred to the target folders. However, folder
permissions may not transfer if the version of the source Microsoft Exchange Server is
different than the version of the target Microsoft Exchange Server.

Note: Public folder permissions cannot be transferred to Microsoft Exchange Server 2013
or later targets.

n The Microsoft Exchange Server user doing the restore will be added to all public folder
permissions with owner rights.

n If you have IFS (also known as "M:drive") enabled on your Microsoft Exchange Server,
permissions for child folders may be merged with permissions for parent folders.
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Chapter 6: Using the Command Line
Overview
The command line feature allows you to easily batch repetitive processes such as multiple copy
and export tasks without initiating the Single Mailbox Recovery user interface. This feature is
extremely beneficial in Single Mailbox Recovery production environment implementations.

Note:Onlymessage containers (such asmailboxes, folders, entire EDB) can be selected for
copy/export. All messages contained are copied/exported. Individual messages cannot be
selected from the command line.

Command Line Syntax
The syntax is as follows:

<< >> Required for all operations

< > Required for copy/export operations

[ ] Optional

Command Line Syntax

smbr <<Operation>> [Program Options] [Operation options] <<Source Store>> [Source options]
<Source Folder Path> <Target Store>[Target options] <Target Folder Path>

<<Operation>>

-copy

Copy source selection to the data store specified by the Target details.

-export

Export source selection, creating a new item type specified by the –f option, in the
specified Target Folder Path.

-list

List top level folders or mailboxes for source selection.

-integ

Perform integrity check of source selection.

-h

Open the Command Line options help.

[Program Options]
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-Server[=Address]

This program option provides control of the choice of Single Mailbox Recovery Administrative
Server. Without an address the switch forces the display of the Single Mailbox Recovery
Administrative Server Connection Point Manager dialog box. This dialog box allows you to use a
server different from the server advertised in the Active Directory. Without an address this option
is only valid when running in GUI mode.

Address

(address=<address>);(port=<port>)

Force a connection attempt at the specified address and port. For example: "-
server=(address=192.168.0.2);(port=49152)" forces a connection to a
server running on IP address 192.168.0.2 on port 49152.

[Operation options]

-f: <format option>

The format option will be the data type created during an –export command.

msg

Export message as .msg (.msg is the default).

txt

Export message as .txt.

pst

Export message to a PST.

-p: <format option>

97

Create a 97-2002 style PST (ANSI) during export.

2003

Create a 2003 style PST (Unicode) during export.

Note: See "Exporting Messages" on page 95 for further detail.

-r

Include all subfolders of source selection in the export/copy function .

-d:<date criteria>

received

sent

129



due

expires

created

modified

starts

ends

completed

-da <mm/dd/yyyy>

Process messages dated on or after this date

-db <mm/dd/yyyy >

Process messages dated on or before this date.

-o <path ending with output filename>

Generate a process log.

-v

Write verbose data to the output file (-o c:\output.txt).

Note: If the file exists, Single Mailbox Recovery will append to the output progress file. If the
file does not exist, Single Mailbox Recovery will create it.

<Source Store>

Full path of EDB file, CAS file, or PST file

[Source options]

-l <log file path>

-t <temp file path>

-m <mailbox criteria>

Filter available mailboxes by text string. Use ; to separate multiple strings.

Note: For more information, see "MailboxCriteria" on page 30.

-a

Automatically open the specified EDB source and view it in the source tree
without using the Data Wizard.

< Source Folder Path >
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The internal path to the desired data; the mailbox to the source folder, profile folder, or
$ROOT for all folders.

If specifying amailbox, the mailbox name can be its display name.

If specifying a source mailbox that is in the current environment, the mailbox name can
be its display name or the UPN (for example, mailbox@domain.local).

If specifying multiple folders or mailboxes, separate their names with a pipe “|” symbol
(for example, folder1|folder2|folder3).

Note: If the "Enforce ABP or HostedOrganization for current user" security preference is selected
on the Security tab of the Preferences dialog box, only matching mailboxes can be accessed.
For more information, see "Multi-Tenancy Support" on page 31.

<Target Store>

The ServerName;mailbox , path to folder, or Full path and name of PST.

Note: The ServerName can be omitted if Autodiscover is being used.

Note: The Target Store is not needed for export. Default path for output will be the current path
of the command line.

[Target options]

-pub

Connects to target's Public Folders

-partialmatch:<copy|skip>

copy

Allow copy of partial match mailboxes into target.

skip

Skip all partial match mailboxes during copy.

-autodiscover:<on|off>

on

Use Autodiscover to connect to the target mailbox.

off

Do not use Autodiscover to connect to the target mailbox.

-outlookanywhere:<on|off>

on
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Use Outlook Anywhere to connect to the target mailbox.

off

Do not use Outlook Anywhere to connect to the target mailbox.

<Outlook Anywhere Required Options> (Not needed and ignored if –autodiscover:on is
specified)

-proxy <proxy server>

Name of Exchange proxy server for Outlook Anywhere.

-authentication:<authentication mode>

basic

Use basic authentication.

ntlm

Use NTLM authentication.

negotiate

Use Negotiate authentication.

[Outlook Anywhere Options] (ignored if –autodiscover:on is specified)

-ssl

Use SSL for Outlook Anywhere connection, required if using basic authentication.

-principal <certificate principal name>

Principal name to look for when validating proxy server certificate.

-httpfirstonfast

On fast networks, use HTTP to connect first, then use TCP/IP.

-httpfirstonslow

On slow networks, use HTTP to connect first, then use TCP/IP.

<Target Folder Path>

Target destination: the full path, including mailbox to the target folder to be copied/exported
to, $ROOT for root datastore folder, or $PUBLIC_ROOT for root of "All Public Folders".

$ROOT
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Command Line Parameters
Parameter Description

<Operation> — required for all
operations

Pre-populate the EDB file, log and temp path fields of the
open source dialog

-Copy

-Export

-List Report information about the database

-Integ Database integrity check

-h Help

[Operation
options]

-f :msg Messages will be exported as .msg (the default)

-f :txt Messages will be exported as .txt

-r Export/copy subfolders

-o <filename> Name of file to output progress information to default is CON

Note: If the file exists, Single Mailbox Recovery appends to the output progress
file. If the file does not exist, Single Mailbox Recovery creates it.

-da
<dd/mm/yyyy>

Process messages dated on or after this date

-db
<dd/mm/yyyy>

Process messages dated on or before this date

-v Verbose

<Source Store>— required for all operations
Full path of EDB file or PST file

[Source options]
-l <Log file path>

-t <Temp file path>

<Source Folder Path>— required for copy and export operations
full path, including mailbox to the source, folder to be copied/exported or $ROOT for root
datastore folder
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<Target Store>
ServerName;mailbox or Full path
of PST

Examples. Pcpdc;jJones, Pcpdc;hJohnson, C:\archive.pst

Note: The ServerName can be omitted if Autodiscover is
being used.

Note: The Target Store is not needed for export.

[Target Options]
-pub Connect to target's Public Folders

-partialmatch:copy Allow copy of partial match mailboxes into target

-partialmatch:skip Skip all partial match mailboxes during copy

-autodiscover:on Use Autodiscover to connect to the target mailbox

-autodiscover:off Do not use Autodiscover to connect to the target mailbox

-outlookanywhere:on Use Outlook Anywhere to connect to the target mailbox

-outlookanywhere:off Do not use Outlook Anywhere to connect to the target
mailbox

<Outlook Anywhere Required
Options>

Note: Not needed and ignored if -autodiscover:on is specified

-proxy <proxy server> Name of Exchange proxy server for Outlook Anywhere

-authentication:basic Use basic authentication

-authentication:ntlm Use NTLM authentication

-authentication:negotiate Use Negotiate authentication

[Outlook Anywhere Options] Note: Ignored if -autodiscover:on is specified

-ssl Use SSL for Outlook Anywhere connection, required if using
basic authentication

-principal <certificate
principal name>

Principal name to look for when validating proxy server
certificate

-httpfirstonfast On fast networks, use HTTP to connect first, then use TCP/IP

-httpfirstonslow On slow networks, use HTTP to connect first, then use TCP/IP

<Target Folder Path>— required
for copy and export operations
Full path, including mailbox, to
the target folder to be
copied/exported to or $ROOT
for root datastore folder or
$PUBLIC_ROOT for root of "All
Public Folders"

Note:Onlymessage containers (i.e., mailboxes, folders,
entire EDB) can be selected for copy/export. All messages
containedwill be copied/exported. Individual messages
cannot be selected from the command line. $PUBLIC_ROOT
should be usedwhen copying public folder mailboxes.
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Examples of Using the Command Line
The following examples are for pre-populate EDB file, copy, export, integrity check, and list
(such as report information about the database).

Example 1: Pre-populate the EDB file, log and temp path fields of the Open Source dialog.

smbr c:\ExchangeDb.edb -l c:\Log_Dir -t c:\Temp_Dir

<Operation> Explanation
Pre-populate the EDB file, log and temp path fields of the open source
dialog

<Source Store> Explanation

c:\ExchangeDb.edb Path to the EDB file

-l c:\Log_Dir Log file path

-t c:\Temp_Dir Temporary file path

Example 2: Open an EDB file from the command line without using the Data Wizard.

smbr c:\ExchangeDb.edb -l c:\Log_Dir -t c:\Temp_Dir -a

<Operation> Explanation
c:\ExchangeDb.edb Path to the EDB file

-l c:\Log_Dir Log file path

-t c:\Temp_Dir Temporary file path

-a Automatically open the source without using the Data Wizard

Example 3: Copy mbxUser 's Inbox and all subfolders from c:\ExchangeDb.edb to the Inbox in
c:\Target.pst. c:\OutputReport.txt will contain the copy report.

smbr –copy –r –o c:\OutputReport.txt c:\ExchangeDb.edb -l c:\LogDir -t
c:\TempDir mbxUser\inbox c:\Target.pst $ROOT

<Operation> Explanation
-copy Perform a copy operation

[Operation options] Explanation

-r Copy subfolders

-o c:\OutputReport.txt Output report file name

<Source Store> Explanation

c:\ExchangeDb.edb Path to the database file name

[Source options] Explanation
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<Operation> Explanation
-l c:\LogDir Log file path

-t c:\TempDir Temporary file path

<Source Folder Path> Explanation

mbxUser\inbox Source folder to copy

<Target Store> Explanation

c:\target.pst Target data store

<Target Folder Path> Explanation

$ROOT Copy to the root folder of the data store

Example 4: Copy mbxUser 's Inbox and all subfolders from c:\ExchangeDb.edb to mbxUser 's
Inbox on an active Microsoft Exchange Server ExchangeTarget. c:\OutputReport.txt will contain
the copy report.

smbr –copy –r –o c:\OutputReport.txt c:\ExchangeDb.edb -l c:\LogDir -t
c:\TempDir mbxUser\inbox ExchangeTarget;mbxUser inbox

<Operation> Explanation
-copy Perform a copy operation

[Operation options] Explanation

-r Copy subfolders

-o c:\OutputReport.txt Output report file name

<Source Store> Explanation

c:\ExchangeDb.edb Path to the database file name

[Source options] Explanation

-l c:\LogDir Log file path

-t c:\TempDir Temporary file path

<Source Folder Path> Explanation

mbxUser\inbox Source folder to copy

<Target Store> Explanation

ExchangeTarget;mbxUser Target data store (Microsoft Exchange Server name and logon ID)

<Target Folder Path> Explanation

inbox Copy to the inbox

Example 5: Export mbxUser 's mailbox and all subfolders from ExchangeDb.edb as text to
c:\ExportDir.
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smbr –export –r -f:txt –o c:\OutputReport.txt c:\ExchangeDb.edb -l c:\LogDir
-t c:\TempDir mbxUser c:\ExportDir

<Operation> Explanation
-export Perform an export operation

[Operation options] Explanation

-r Export subfolders

-f:txt Messages will be exported as .txt

–o c:\OutputReport.txt Export report file name

<Source Store> Explanation

c:\p cdata.edb Path to the database file name

[Source options] Explanation

-l c:\LogDir Log file path

-t c:\TempDir Temporary file path

<Source Folder Path> Explanation

mbxUser Source folder to copy

<Target Store> Explanation

c:\ExportDir Target data store

Example 6: Provides information on the databases including a list of mailboxes.

smbr -list -o c:\mblist.txt c:\ExchangeDb.edb -l c:\LogDir -t c:\TempDir

-list Perform a list operation

[Operation options] Explanation

-o c:\mblist.txt Output report file name

<Source Store> Explanation

c:\ExchangeDb.edb Path to the database file name

[Source options] Explanation

-l c:\LogDir Log file path

-t c:\TempDir Temporary file path

Example 7: Provides information on the databases including a list of mailboxes filtered by
mailbox criteria.

smbr -list -o c:\mbxlist.txt c:\ExchangeDb.edb -l c:\LogDir -t c:\TempDir –m
mbxUser1;mbxUser2
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<Operation> Explanation
-list Perform a list operation

<Operation> Explanation

-o c:\mblist.txt Output report file name

<Source Store> Explanation

c:\ExchangeDb.edb Path to the database file name

[Source options] Log file path

-l c:\LogDir Temporary file path

-t c:\TempDir Only open pcuser1 and pcuser2 mailboxes

Example 8: Perform an integrity check on an entire EDB.

smbr -integ -r –o c:\OutputReport.txt c:\ExchangeDb.edb -l c:\LogDir -t
c:\TempDir $ROOT

<Operation> Explanation
-integ Perform an integrity check on a database

[Operation options] Explanation

–o c:\OutputReport.txt Output report file name

<Source Store> Explanation

c:\ExchangeDb.edb Path to the database file name

[Source options] Explanation

-l c:\LogDir Log file path

-t c:\TempDir Temporary file path

<Source Folder Path> Explanation

$ROOT Root of the EDB (entire EDB)

Example 9: Copy a folder from a pub EDB to public folders (only copy messages dated after
01/01/2000).

smbr –copy –r –o c:\OutputReport.txt -da 01/01/2000 c:\ExchangePUB.edb -l
c:\LogDir -t c:\TempDir newsgroups ExchangeTarget;mbxUser –pub $PUBLIC_ROOT

<Operation> Explanation
-copy Perform a copy operation

[Operation options] Explanation

-r Copy subfolders

–o c:\OutputReport.txt Output report file name

-da 01/01/2000 Only copy messages that were created after this date

<Source Store> Explanation
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<Operation> Explanation
c:\ExchangeDb.edb Path to the database file name

[Source options] Explanation

-l c:\LogDir Log file path

-t c:\TempDir Temporary file path

<Source Folder Path> Explanation

newsgroups Source folder to copy

<Target Store> Explanation

ExchangeTarget;mbxUser Target data store (Microsoft Exchange Server name and
logon ID)

<Target Options> Explanation

-pub Copy to public folders

<Target Folder Path> Explanation

$PUBLIC_ROOT Public folders root

Example 10: Perform an integrity check on an entire Content Analysis Store.

smbr -integ -r –o c:\OutputReport.txt c:\source.cas $ROOT

<Operation> Explanation
-integ Perform an integrity check on a database

[Operation options] Explanation

-r Check subfolders

–o c:\OutputReport.txt output report file name

<Source Store> Explanation

c:\source.cas Path to the Content Analysis Store file name

<Source Folder Path> Explanation

$ROOT Root of the CAS (entire CAS)

Example 11: Copy Profile1 from c:\source.cas to the root in c:\target.pst.

smbr -copy -r –o c:\OutputReport.txt c:\source.cas Profile1 c:\Target.pst
$ROOT

<Operation> Explanation
-copy Perform a copy operation

[Operation options] Explanation

-r Copy subfolders
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<Operation> Explanation
–o c:\OutputReport.txt output report file name

<Source Store> Explanation

c:\source.cas Path to the Content Analysis Store file name

<Source Folder Path> Explanation

Profile1 Source folder to copy

<Target Store> Explanation

c:\target.pst Target data store

<Target Folder Path> Explanation

$ROOT Copy to the root folder of the data store

Example 12: Export Profile2 from source.cas as text to c:\export.

smbr -export -r -f:txt –o c:\OutputReport.txt c:\source.cas Profile2
c:\ExportDir

<Operation> Explanation
-export Perform an export operation

[Operation options] Explanation

-r Export subfolders

-f:txt Messages will be exported as .txt

–o c:\OutputReport.txt Export report file name

<Source Store> Explanation

c:\source.cas Path to the Content Analysis Store file name

<Source Folder Path> Explanation

Profile2 Source folder to copy

<Target Store> Explanation

c:\ExportDir Target data store

Example 13: Copy all subfolders and messages from the mbxUser mailbox in
c:\ExchangeDb.edb to the mailbox at mail@exchserver.local. Use Autodiscover to connect,
but do not use Outlook Anywhere to connect.

smbr -copy -r -o c:\OutputReport.txt c:\ExchangeDb.edb -l c:\LogDir -t
c:\TempDir mbxUser mailbox1@exchserver1.local -autodiscover:on -
outlookanywhere:off $ROOT

<Operation> Explanation
-copy Perform a copy operation

[Operation options]
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<Operation> Explanation
-r Copy subfolders

-o c:\OutputReport.txt Output report file name

<Source Store> Explanation

C:\ExchangeDb.edb Path to the database file

[Source options] Explanation

-l c:\LogDir Log file path

-t c:\TempDir Temporary file path

<Source Path> Explanation

mbxUser Source folder to copy

<Target Store> Explanation

;mailbox@exchserver1.local Target mailbox (autodiscovery provides the Exchange
environment)

[Target options] Explanation

-autodiscover:on Use Autodiscover to connect. Autodiscover will detect the
Exchange server

-outlookanywhere:off Do not use Outlook Anywhere to connect

<Target Path> Explanation

$ROOT Copy to the root of the mailbox

Example 14: Copy all subfolders and messages from the mbxUser mailbox in
c:\ExchangeDb.edb to the mailbox at mbxUser@exchserver1.local. Do not use Autodiscover to
connect. Use the Outlook Anywhere with settings as follows: proxy server is
exchservervas.exchserver.local,connecting using SSL, use basic authentication.

-copy-r –o c:\OutputReport.txt c:\ExchangeDb.edb -l c:\LogDir -t c:\TempDir
mbxUser ExchangeTarget;mbxUser@ExchangeTarget.local -autodiscover:off -
outlookanywhere:on -proxy ExchangeCAS.ExchangeTarget.local -
authentication:basic -SSL $ROOT

<Operation> Explanation
-copy Perform a copy operation

[Operation options]

-r Copy subfolders

–o c:\OutputReport.txt Output report file name

<Source Store> Explanation

c:\ExchangeDb.edb Path to the database file

[Source options] Explanation
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<Operation> Explanation
-l c:\LogDir Log file path

-t c:\TempDir Temporary file path

<Source Path> Explanation

mbxUser Source folder to copy

<Target Store> Explanation

ExchangeTarget;mbxUser@ExchangeTarget.local Target Exchange server and mailbox.
Server must be specified because
Autodiscover is not being used

<Target options> Explanation
-autodiscover:off Do not use Auto Discover to connect to

target mailbox.

-outlookanywhere:on Use Outlook Anywhere to connect to the
target mailbox.

<Outlook Anywhere Required Options> Explanation

-proxy ExchangeCAS.ExchangeTarget.local Name of Exchange proxy server for
Outlook Anywhere.

-authentication:basic Use basic authentication

<Outlook Anywhere Options> Explanation

-SSL Use SSL for Outlook Anywhere connection,
required if using basic authentication

<Target Folder Path> Explanation

$ROOT $ROOT for the root of the mailbox
"mbxUser"
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Chapter 7: Reporting
Overview
This section shows you how to create reports, view the statistics in the generated reports, and
save the reports as either tab-delimited or comma-delimited text files. Any data store opened as
a source can be the source of a report.

Note: If you use the "MailboxCriteria (optional)" box on the Select Source Files dialog box or the
Source Selection page of the DataWizard, only EDB mailboxes containing your entry (or entries)
are displayed on the Source pane. Anymailboxes that do not match the entered string(s) do not
appear in the Source pane and are not be included in any subsequent tasks (such as searching,
copying, and exporting of the entire database). For more information, see "MailboxCriteria" on
page 30.

Note: If you use the "Multi-Tenancy Criteria" box on the Select Source Files dialog box, the Source
Selection page of the DataWizard, the Connect to Exchange Server dialog box, or the Target
Selection page of the DataWizard, only mailboxes contained in the selected Address Book
Policy or Organization appear in the Source or Target panes. Only these mailboxes are included
in any subsequent tasks (such as searching, copying, and exporting of the entire database). For
more information, see "Multi-Tenancy Support" on page 31.

Creating Reports
You can generate reports on an EDB, PST, or CAS source data store in Single Mailbox Recovery.
The reports contain statistics about the data store such as sizes and counts for attachments and
messages, and may be generated per attachment type, domain, mailbox, database, and
date. The Mailbox and Date reports are available for Priv EDB data sources only.

Note:Only accessible mailboxes can generate a report.

To create one ormore reports

1. In the Source pane, select an EDB, PST, or CAS data source.
2. On the Tools menu, click Create Reports. The Create Reports window appears.

l If you selected a Priv EDB as the source for the report, the list pane displays all
mailboxes in the EDB.

l If you selected a PST or Pub EDB as the source, the list pane displays all folders
immediately under the root of the PST or Pub EDB.
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Figure 7-1: The Create Reports dialog box
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Figure 7-2: The Create Reports window for a CAS

3. Do one of the following:
l For Priv EDB: Under Mailboxes, select the mailboxes to be included in the report(s). All

mailboxes are selected by default.
l For Pub EDB or PST: Under Folders, select the folders to be included in the report(s). All

folders are selected by default.
l For CAS: Under Profile Folders, select the folders to be included in the report(s). All

folders are selected by default.
4. Under Reports, select one or more reports that you would like to create:

l Attachment Statistics
l Domain Statistics
l Messages by Database
l Messages by Profile Folder: This report is available for CAS data sources only.
l Messages by Mailbox: This report is available for Priv EDB data sources only.
l Messages by Date: If you select this report, then specify the appropriate options for

received date range and date unit (for example, hour, day, week, month). This report
is available for Priv EDB and CAS data sources only.

5. Under Message Options, select the appropriate deleted item retention option(s). Both
options are selected by default. For PST sources, the first option is cleared. You cannot
modify the default options for PST sources.
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l Include messages in deleted item retention: Select this option to include messages in
deleted item retention.

Note for Microsoft Exchange Server 2010 and 2013 sources:When the Show
Recoverable Items preference is enabled (for more information, see "Security
Tab" on page 24), the messages in the Recoverable Items folder are included in
the reports for Microsoft Exchange Server 2010 and 2013 sources only if the Include
messages in deleted item retention check box is selected. If the preference
setting is cleared, then the Include messages in deleted item retention check box
is unchecked and disabled for Microsoft Exchange Server 2010 and 2013 reports.

l Include messages not in deleted item retention: Select this option to include
messages that are not in deleted item retention. In most cases, this option represents
most of the messages in the source data store.

6. Click Generate Reports. The Reports window appears. For more information the contents
of the reports, see "Viewing Reports" on page 146.

Viewing Reports
The Reports window shows the progress of the report generation and also shows the reports
themselves. This window consists of a tabbed view of the reports, with each tab containing a
single report.

Figure 7-3: The Reports progress window
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Single Instance Storage (SIS) vs. Cumulative Counts
The Attachment Statistics and Messages by Database reports use the terms "SIS" (Single Instance
Storage) and "Cumulative" when referring to the number and size of attachments in the data
store. The term "SIS" counts attachments only once and does not include their duplicates. The
term "cumulative" refers to all of the attachments or messages, including their duplicates.

Example: An attachment of type .doc of size 100 KB is being shared by three messages. As the
table shows, the SIS size more closely estimates how much of the EDB size is attributed to the
attachment.

The cumulative size more closely estimates how much of the EDB size is attributed to
attachments if the data store did not have SIS.

Method of Counting Attach-
ments/Messages

Total # of .doc Attach-
ments

Total Size of .doc
Files

SIS Count 1 100 KB

Cumulative Count 3 300 KB

Attachment Statistics Report
The Attachment Statistics report provides statistics on all of the attachments contained in
messages in the selected source. The attachments are categorized by extension, which
appears in upper case letters (for example, .doc, .xls). Attachments without extensions are put
into a separate row called "No Extension."

Column Heading Description

Attachment Extension Attachment type by extension (for example, .doc, .ppt, .pdf).

Cumulative Number of
Attachments Found in
Messages

Cumulative number of attachments of each type found in the
processed messages.

Cumulative Size of
Attachments

Cumulative size of attachments of each type found in
messages.

Average Attachment Size Cumulative size of attachments of each type divided by the
cumulative number of attachments found in messages.
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Column Heading Description

Percent of Total by Number Number of attachments of each type divided by total
attachments of all types.

Percent of Total by Size Total size of attachments of each type divided by the total
size of attachments of all types.

SIS Number of Attachments SIS number of attachments of each type. NA for PST sources.

SIS Size of Attachments SIS size of attachments of each type. NA for PST sources.

SIS Percent of Total by Size SIS size of attachments of each type divided by SIS size of
attachments of all types in attachment table. NA for PST
sources.

Domain Statistics Report
The Domain Statistics report provides statistics on messages grouped by the domain from which
the messages were sent.

The domain is determined using the PR_SENDER_ADDRTYPE in combination with the PR_SENDER_
EMAIL_ADDRESS as follows:

l If PR_SENDER_ADDRTYPE is "EX" or "SYSTEM," then it is a Microsoft Exchange Server
message and the domain is "internal."

l If PR_SENDER_ADDRTYPE is "SMTP", then the domain is whatever follows the @ in the PR_
SENDER_EMAIL_ADDRESS property.

l If PR_SENDER_ADDRTYPE is something else, then the domain is "unknown."

Column
Heading

Description

Domain The name of the domain (for example, http://www.netapp.com) from
which the message was sent. All messages whose domain cannot be
determined are placed into an "unknown" domain. All Microsoft
Exchange Server messages are placed into an "internal" domain.

Number
of
Messages

Total count of messages that were received from each domain.
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Column
Heading

Description

Total Size
of
Messages

Total size of all messages that were received from each domain.

Percent
of Total
by
Number

Number of messages from each domain divided by the total number of
messages from all domains.

Percent
of Total
by Size

Total size of messages from each domain divided by the total size of
messages from all domains.

Messages by Database Report
The Messages by Database report provides statistics on the database that contains the
processed messages. In the current version of Single Mailbox Recovery, reports are limited to a
single EDB or PST, which means the database report has only one row of information. For
example, the database report for Priv1.edb has one row of information listing all message
statistics for Priv1.edb and its mailboxes.

Column Heading Description

Database (EDB,
PST, or CAS)

The database name (for example, Priv1.edb, Pub1.edb, Microsoft
Office Outlook.pst, User1.cas).

Cumulative
Number of
Messages

Cumulative number of messages.

Cumulative Size of
Messages

Cumulative size of all messages processed.

Average Size of
Messages

Cumulative size of messages divided by cumulative number of
messages.

Cumulative Size of
Attachments

Cumulative size of attachments in all messages processed.

149



Column Heading Description

SIS Size of
Attachments

SIS total size of attachments. This column applies only to EDB sources.
For PST and CAS data stores, this column is NA.

Important: The statistics in the Database report refer only to the mailboxes (for a Priv EDB) or the
folders (for a PST, Pub EDB, or CAS profile folders) you selected in the Create Reports window.
The statistics also depend on the options you specified in the Message Options area. In other
words, unless all mailboxes/folders are selected, the Database report does not provide statistics
for the entire database.

Figure 7-4:  The Create Reports dialog box for a Priv EDB source

Messages by Mailbox Report
The Messages by Mailbox report provides message statistics for all selected mailboxes in a Priv
EDB data store.

Note: This report is available only for a Priv EDB.
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Column
Heading

Description

Mailbox Name of the mailbox: Display name (alias)

Number of
Messages

Total number of messages in the mailbox.

Total Size of
Messages

Total size of all messages in the mailbox.

Average
Size of
Messages

Total size of messages divided by number of messages.

Total
Attachment
Size

Total size of attachments in all messages in this mailbox. Attachments in
messages in this mailbox that are also in messages in another mailbox are
counted in both mailboxes.

Shared
Attachment
Size

Size of attachments that are found more than once, either multiple times in
this mailbox or in this mailbox and other mailboxes. Calculated as total size of
attachments minus the non-shared attachment size.

Non-shared
Attachment
Size

Size of attachments that are not shared with other messages.

Internal
Received
Messages

Received messages of type "EX" or "SYSTEM."

SMTP
Received
Messages

Received messages of type "SMTP."

Other
Received
Messages

Received messages not of type "EX," "SMTP," or "SYSTEM."

Note: For a definition of "receivedmessage," see the "Glossary" on page 188.

Messages by Date Report
The Messages by Date report provides statistics for messages in a date range, such as 1/1/2004 to
1/1/2005, and a unit of hours, days, weeks, or months. The report is keyed off of the received
date of the message.
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Note: This report is available only for a Priv EDB andCAS files.

Column Heading Description

Hour/Day/Week/Month The date unit that was selected in the Create Reports window.
Examples are: Hour: "12/25/2004 - 9 PM" Day: "12/25/2004" Week:
"12/26/2004 - 1/1/2005" (Weeks start on Sunday and end on
Saturday.) Month: "12/2004"

Internal Received
Messages

Received messages of type "EX" or "SYSTEM."

Total Size of Internal
Received Messages

The sum of the internal received message sizes.

SMTP Received
Messages

Received messages of type "SMTP."

Total Size of SMTP
Received Messages

The sum of the SMTP received message sizes.

Other Received
Messages

Received messages not of type "EX," "SMTP," or "SYSTEM."

Total Size of Other
Received Messages

The sum of the other received message sizes.

Note: For a definition of "receivedmessage," see the "Glossary" on page 188.

Messages by Profile Folder
The Messages by Profile Folder report provides statistics for messages in a profile folder, the
number of messages, total size of messages, average size of messages, total attachment size,
shared attachment size, non-shared attachment size, internal received messages, SMTP
received messages, and other received messages. The report is keyed off of the profile folder.

Note: The Messages by Profile Folder report only includes information gathered from accessible
mailboxes.

Note: This report is available only for a CAS.

Column Head-
ing

Description

Profile Folder Title of the profile folder.
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Column Head-
ing

Description

Number of
Messages

Total number of messages in the profile folder.

Total Size of
Messages

Total size of all messages in the profile folder.

Average Size
of Messages

Total size of messages in the profile folder divided by number of messages.

Total
Attachment
Size

Total size of attachments in all messages in the profile folder.

Shared
Attachment
Size

Size of attachments that are found more than once, either multiple times
in this profile folder or in this profile folder and other profile folders.

Non-shared
Attachment
Size

Size of attachments that are not shared with other messages.

Internal
Received
Messages

Received messages of type "EX" or "SYSTEM."

SMTP
Received
Messages

Received message of type "SMTP."

Other
Received
Messages

Received messages not of type "EX," "SMTP," or "SYSTEM."

Note: For a definition of "receivedmessage," see the "Glossary" on page 188.

Sorting Reports
The Attachment Statistics and Messages by Database reports use the terms "SIS" (Single Instance
Storage) and "Cumulative" when referring to the number and size of attachments in the data
store. The term "SIS" counts attachments only once and does not include their duplicates. The
term "cumulative" refers to all of the attachments or messages, including their duplicates.
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Example: An attachment of type .doc of size 100 KB is being shared by three messages. As the
table shows, the SIS size more closely estimates how much of the EDB size is attributed to the
attachment. The cumulative size more closely estimates how much of the EDB size is attributed
to attachments if the data store did not have SIS.

Method of Counting Attach-
ments/Messages

Total # of .doc Attach-
ments

Total Size of .doc
Files

SIS Count 1 100 KB

Cumulative Count 3 300 KB

To sort the statistics in a report

1. Click a column heading to sort the statistics based on that heading. An arrow appears
indicating the sort direction. An up arrow indicates the statistics appear in ascending (A-Z)
order. A down arrow indicates that the statistics appear in descending (Z-A) order.

2. To reverse the order of the statistics based on that column heading, click the column
heading again. The arrow reverses directions.

An Example of Sorting

The Attachment Statistics report is originally sorted based on the ascending order of
attachment extensions (for example, .doc precedes .txt). If you click the Attachment Extension
heading, the down arrow appears and statistics are sorted in descending order (for example,
.txt precedes .doc).

If you click the "Number of Attachments Found in Messages" column heading, the up arrow
appears and statistics are sorted based on ascending order. This means that the attachment
extension occurring least frequently in the data source appears first in the report.

Saving Reports
You may save the currently active report as either a tab-separated or comma-separated text
file. The report name defaults to the name shown on the report tab, without the spaces and with
a .txt extension (for example, MailboxReport.txt). The file type defaults to a tab-separated text
file.

To save a report

1. In the Reports window, make the desired report active by clicking its tab (for example,
Attachment Report, Database Report).

2. Click Save.
3. In the Save Report window, specify the name, location, and file type for the report. You

may save the report as either a tab-separated or comma-separated text file.
4. Click Save to return to the Reports window.
5. Repeat steps 1-4 for each report you want to save.
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Chapter 8: Content Analysis Store
Overview
The content analysis store (CAS) enables you to automate and save search results by selecting
sources. Sources include entire EDB files, individual mailboxes from an EDB, or folders from an
EDB. Any number of sources is allowed, including multiple EDBs.

After selecting specific sources, you can create profile folders as subfolders to the content
analysis store. Each profile folder has the same criteria as the search criteria, such as, "From," "To,"
"Subject," etc. Only messages matching the criteria are contained in the profile. Multiple profile
folders are possible. Every profile folder processes simultaneously. This allows you to make many
separate searches (profiles) for the same set of sources.

After the processing is complete, you can open the content analysis store as a source. This allows
you to use the CAS for searching, copying, exporting, and integrity checks. It allows you to copy
the data out of the CAS into PSTs or to a Microsoft Exchange Server. It allows you to repeatedly
use a specific set of profile results without having to rerun the profile processing. The results of the
profile can be saved between sessions using the CAS. You can also save the CAS on one
computer and reopen it on a different computer to share the results of a profile.

Content analysis stores provide a method for an email administrator to perform content analysis
offline from their production server. This feature:

n Minimizes the time it takes to detect/filter out emails that include specific content.
n Minimizes the time it takes to detect/filter out a specific type of email file that is being sent

or received (for example, specific extension, subject, date).
n Analyzes the number of emails being sent/received that contain what could be legally

damaging content (for example, admission of guilt).
n Analyzes the number of emails being sent/received that contain politically incorrect

content (for example, tasteless jokes, pornography).
n Analyzes the number of emails with confidential content that go out unprotected -

unencrypted.
n Minimizes the time it takes to determine if someone is using the system for unauthorized

activity (for example, spamming, inappropriate downloads, starting a business).

Creating a Content Analysis Store
A new content analysis store can be created from the File menu, from the toolbar, or from the
Data Wizard. After the CAS file is created, a new content analysis store shows in the Target pane.
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To create a content analysis store using the toolbar

1. On the toolbar, click the Create/Open Target Content Analysis Store icon located on
the toolbar. The Opening a Content Analysis File window appears.

2. Enter a File name and in the Look in box, select a destination.
3. Click Open. The name of the store defaults to the file name you entered in step 2. It can

be renamed as any other target folder.

To open or create a target Content Analysis Store using the menu

1. To display the Opening a Content Analysis File window, on the File menu, point to Open
Target Content Analysis Store and click Open Existing or Create New.

2. If creating a new target CAS, enter a File name and click Open.
3. If opening an existing target CAS, select the CAS from the list and click Open.

To open or create a target Content Analysis Store using the Data Wizard

1. On the File menu, click Use Wizard.
2. On the Source Selection page, click Content Analysis Store (.cas) in Select Source list.

Figure 8-1: Selecting a CAS on the Source Selection page

3. On the Content Analysis Store (.cas) box, click Browse to open the Create Content
Analysis File window and locate the source CAS.

4. Click Next.
5. On the Target Selection page, click Content Analysis Store (.cas) in Select Target list.
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Figure 8-2: Selecting Content Analysis Store on the Target Selection page

6. Do one of the following:
n If you know the target CAS file path, type it in the Content Analysis Store Path box.
n Click Browse to open the Create Content Analysis Store window, and navigate to

the desired location. Then create a new CAS file by typing a name in the File name
box, or select an existing CAS file. Then click Open. The path of the target CAS file
appears in the Content Analysis Store Path box.

7. Click Next.

Important: For more details, see "Pointing Single Mailbox Recovery to a NetApp Device".

Creating a Content Analysis Store with Microsoft Exchange
Server 2010 and 2013 Data
Any source or target content analysis store (CAS) created with Microsoft Exchange Server 2010
and 2013 data is subject to different handling based on the Recoverable Items preference
settings. For more information, see "Security Tab" on page 24.
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When a CAS is created, whatever the Recoverable Items preference setting is at that time will
be stored with that CAS. If you attempt to open a CAS as a source or target, the preference
stored in the CAS is checked against the current preference setting. If they do not match, the
following message displays: "The current `Show Recoverable Items' preference setting does not
match the setting for the Content Analysis Store. The Content Analysis Store cannot be opened
unless its setting is changed. To change the setting the Content Analysis Store, click `OK.' The
Content Analysis Store will be opened as a target and all profiles will be reprocessed. Click
`Cancel' to cancel opening the Content Analysis Store."

Note: If a Microsoft Exchange Server 2010 or 2013 source EDB file hasmulti-tenancy criteria
applied, it cannot be added to a target CAS file.

Creating and Processing Content Analysis Store Profile
Folders
A content analysis store profile folder is created as a subfolder of the content analysis store to
filter EDB messages (only) based on the profile criteria.

When the profile folder is created, a folder appears under the content analysis store and Single
Mailbox Recovery searches all the sources in the content analysis store for messages that match
the criteria for the profile folder.

During processing (searching), the profile folder is green and its status will indicate that
processing is taking place. The status bar at the lower left also indicates the status. The message
pane on the right populates with the results when the profile folder is selected or when the
screen is refreshed.

Deduplication can be performed on a per profile basis and if selected does not return
duplicates of a message during a search. For example, if the same message exists in two or
more data stores, only the first message found is listed in the search results. Selecting this option
may result in slower search performance.

Note:Only accessible mailboxes in the EDB source can populate the CAS target profile with
messages.

Note: If a source EDB is openedwithmulti-tenancy restrictions, it cannot be used as a source for
a target CAS.

To create and process a content analysis store profile folder

1. Select a target content analysis store root.
2. In the Profile menu on the menu bar, click Create Profile. The Create Profile window opens

with "Profile1" as the default Profile Name. Once created, the content analysis store
profile folder can be renamed just as any folder would be.

3. Enter the criteria for the content analysis. This window offers similar search options as the
Find window. For more information, see "Finding Messages" on page 81.

Note: The profile criteria can be saved and imported.
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Figure 8-3: The Create Profile Folder window is used to enter profile criteria

4. Click OK. Single Mailbox Recovery indicates that a profile is processing when the color of
the profile folder is green and its status states "Processing." When the profile is selected,
the status shown in the status bar at the lower left of the main window indicates that the
profile is processing. For more information, see "Profile Processing Statuses " on page 160.

5. When the processing for a profile is complete, the color of the profile icon changes from
green to blue and its status states "Completed." All messages from the content analysis
store EDBs that match the criteria are contained in the profile folder.

Note: A content analysis store cannot be opened as a source until all profile processing
has completed.

Figure 8-4: Messages displayed after profile folder created

Note: If the same source is added to the content analysis store twice for processing,
Single Mailbox Recovery ignores the second copy. The source is not listed twice nor is an
error message displayed.
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DB # Column
The content analysis store profile folder message views include a column to display a database
number to enable you to trace back to the actual database in the content analysis store. This
number does not correlate to the profile folder number or source #, i.e., "Profile1" or "Source 1"
does not necessarily correlate with DB #1. The correlation is between the profile folder message
and the source database.

Example:

Figure 8-5: The Database numbers are tied to the actual database.

Note: Database (DB) numbers are tied to the actual database, not the folder so each folder
from the same EDB will have the same DB number. DB numbers increment from 1 for each
different database added to the content analysis store, not for each folder.

Profile Processing Statuses
When the profile is processing, there are four possible statuses that are displayed: Processing,
Suspended, Completed, andCompleted with errors.

Figure 8-6: Profile Processing Status folders are indicated by different colors
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Processing

After entering the profile criteria, the profile is created and is represented by a folder under the
content analysis store. During processing (searching), the profile folder is green and its status
states "Processing." Selecting the profile folder or pressing F5 populates the message pane with
messages when the processing is complete.

Processing occurs when a new profile is created, when removing a source, when adding a
source, when editing a profile, when copying a source profile folder to a target content analysis
store, or when resuming a suspended profile.

Note: If unrecoverable errors are encountered during processing then the profile is not fully
processed and is blue in color with a red ! indicating the error.

Suspended

Processing can be suspended on any profile folder during processing. Suspended profile folders
are red in color. The status also indicates that the profile is suspended. For more information, see
"Suspending and Resuming Content Analysis Store Profile Folders" on page 162.

Completed

Once the processing is complete, the profile folder turns blue and its status states "Completed."

Completed with errors

If Single Mailbox Recovery detects corruption or some other issues while processing, the profile
folder status states "Completed with errors." To obtain details on the error, view the Properties on
the profile folder by right-clicking on the profile folder and selecting Properties.

Figure 8-7: An error message displays when processing cannot be completed

Saving and Importing Profile Criteria
Profile criteria can be saved and later imported into a new profile in the Create Profile window
to save time.
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To save a profile criteria

1. On the File menu, click Save Criteria.
2. In the Save As window, enter a File name and click Save. Be sure to note where the

criteria file is being saved in the Look in: box.

Note: The profile folder name is not saved.

To import saved profile criteria

1. On the File menu, click Use Previous Criteria.
2. In the Open window, select the previously saved profile criteria .txt file.
3. Click Open. All previously saved profile criteria, except for the Profile Name, reads from

the file and is placed into the Create Profile fields.
4. Enter a new Profile Name.

Note: Search criteria from previous and current versions of Single Mailbox Recovery can
be imported into Single Mailbox Recovery for find and profile criteria.

Suspending and Resuming Content Analysis Store Profile
Folders
You can pause the processing of one or more profile criteria folders and then resume processing
at a later time. Suspended profile folders are red in color and then turn to green when
processing is resumed. The folder then turns to blue when processing is complete. For more
information, see "Profile Processing Statuses " on page 160.

Important: Processing of all profiles is suspended automatically if you exit Single Mailbox
Recovery or if you close the content analysis store before processing is complete.

To suspend the processing on profiles

n Do one of the following:

l Select the profile folder, click the Profile menu and click Suspend Processing.
l Right-click the profile folder and click Suspend Processing.

To suspend processing on all profiles

n Do one of the following:

l Select the content analysis store root, click the Profile menu and click Suspend
Processing.

l Right-click the content analysis store root and click Suspend Processing.

Note: Suspended profiles are red in color. The status also indicates that the profile is suspended.
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To resume processing on profiles

n Do one of the following:

l Select a profile folder, click the Profile menu and click Resume Processing.
l Right-click the profile folder and click Resume Processing.

To resume processing of all profiles

n Do one of the following:

l Select the content analysis store root, click the Profile menu and click Resume
Processing.

l Right-click the profile folder and click Resume Processing.

Adding Sources to Content Analysis Stores
Only EDB store objects, EDB mailboxes, or EDB folders can be dragged or copied and pasted
from the source into the new content analysis store root to prepare for analysis.

If you open a source with a set of mailbox criteria, create a CAS using that source, then close
and re-open the source with different mailbox criteria, no additional folders or mailboxes can be
added from that source. Re-open the source with the matching mailbox criteria or remove all
references to the original source before re-adding.

Note:Messages or folders cannot be copied directly to a profile folder (results folder).

To add a folder, a mailbox, or an EDB file with copy-paste

1. In the Source pane, select a folder, a mailbox, or an EDB file.
2. Do one of the following:

l On the Edit menu, click Copy.
l Right-click the selected item(s), and on the shortcut menu, click Copy.

l Click the Copy Mail Item icon on the toolbar.

l PressCtrl+C (Copy).

3. In the Target pane, click the content analysis store root and do one of the following:

l On the Edit menu, click Paste.
l Right-click the selected item, and on the shortcut menu, click Paste.

l Click the Paste icon on the toolbar.

l PressCtrl+V (Paste).
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4. In the Copy Progress window, verify that your messages were successfully copied, and
click Close.

To add data even faster, use dragging

n To move entire EDB store objects, EDB mailboxes, or EDB folders, drag to the target
content analysis store root. Dragging achieves the same results as copying and pasting.

To drag when right-clicking a source item

1. In the Source pane, select one or more messages.
2. Right-click the selected message containers and drag them to a content analysis store in

the Target pane.
3. Release the mouse and on the shortcut menu, click Paste.

Important: If a new source (Inbox, Deleted items, Outbox, etc.) is dragged to the
content analysis store or the user removes a source store from the content analysis store,
all profiles automatically process the new source.

Editing and Deleting Profiles
Deleting a profile stops any processing on that profile and removes that profile and all data
associated with it from the content analysis store. Deleting a profile does not modify the EDB
sources.

To edit a profile

1. To edit a profile, right-click the profile folder and click Edit Profile or on the Profile menu,
select Edit Profile.

2. On the Edit Profile Folderwindow, edit any or all of the criteria. When new criteria is
entered, all messages in the profile are deleted, the icon changes to its processing color
(green), the profile status will update, and the process begins.

To delete a profile

n Do one of the following:
l Right-click the profile folder and click Delete.
l Click profile folder, and on the Edit menu, click Delete.
l Select the profile folder and press the Delete key on the keyboard.

Closing a Content Analysis Store
Closing a content analysis store root closes the root as well as all of the profile folders created
under that root.
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To close a content analysis store (CAS)

n Do one of the following:
l Right-click the CAS and click Close Store.
l Click the CAS and on the File menu, click Close Store.

Opening a Content Analysis Store as Source
When all profile processing has completed, you can open the content analysis store as a
source, for which the following source operations can be performed: Copy/Paste, Paste
Special, Export, Find, Integrity Check, Properties, and Create Reports. Use copy/paste to copy
source profile search criteria to a target content analysis store.

Note:Opening aContent Analysis Store with Microsoft Exchange Server 2016 or later data is not
supported. When aCAS open as a source containing Microsoft Exchange Server 2016 or later
data, you have the option to open the CAS as a target and remove all Microsoft Exchange
Server 2016 or later data.

If a content analysis store is opened as a source and it has not completed processing all profiles,
a window indicates that the content analysis store has not completed its processing. There is
then an option to open the CAS as a target. If that option is selected, Single Mailbox Recovery
opens it as a target and resumes processing on all remaining profiles.

To open a content analysis store as source

1. One the File menu, click Open Source.
2. On the Select Source Files dialog box, click Browse to the right of Source File (*.edb, *.pst,

*.cas).
3. In the Open dialog box, select a .cas file and click Open.
4. In the Select Source Files dialog box, click OK. A source content analysis store appears in

the left pane of source.

Figure 8-8: A source content analysis store root and profile folders
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Viewing Properties of a Content Analysis Store
To view the properties of a content analysis store

n To display the CAS File Properties window, right-click the CAS in either the Source or Target
pane and click Properties.

Figure 8-9: The Properties of the selected CAS file

To view the properties of a content analysis store profile folder

n Right-click the profile folder and click Properties.

Figure 8-10: The Properties of the CAS profile folder

Creating Reports in Content Analysis Store
You can create reports of the source content analysis store by right-clicking the source content
analysis store root. The reports are:
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n Attachment statistics
n Domain statistics
n Messages by Database
n Messages by Profile Folder
n Messages by Date

For instructions on creating reports, see "Reporting " on page 143.

Viewing Profiles in Content Analysis Store
The Viewing Profiles option allows you to view what profile criteria has been used for a specific
content analysis. All fields are read only.

To view a profile

1. Do one of the following to display the Profile Folder Properties page:
l Right-click the profile folder in either the Source pane or Target pane and point to
View Profile Folder.

l Click the profile in either the Source pane or Target pane, click the Profile menu and
click View Profile Folder.
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Figure 8-11: Profile Folder Properties

2. Click OK to exit.

Missing Database Files
If an EDB or log file that belongs to a content analysis store is moved and then the content
analysis store is opened, there is a prompt to find or remove the missing database files. If the EDB
is located but the STM is missing, Single Mailbox Recovery displays an error indicating that the
STM needs to be located in the same directory as the EDB.

Missing EDB
When there is a wrong EDB, you are prompted to locate the file.
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To locate the missing EDB

1. On the Missing Database File error message, click Browse. The Open window appears.
2. Navigate to the EDB files and double-click the appropriate file.
3. Click OK. The Source pane now populate with files.
4. If you are unable to locate the EDB file, click Remove on the Missing Database File error

message.
5. When asked to confirm, click OK.

Important: When an EDB is removed, the complete source EDB is removed from the CAS
as well as any source folders or mailboxes that also reference that EDB.

Missing Log Files
When there are missing log files, you are prompted to locate the log directory. The Browse
button opens a Browse for Folder dialog and defaults to the last known location of the logs.

To locate missing log files

1. On the Missing Database File error message, click Browse. The Open window appears.
2. Navigate to the directory containing the logs and click OK. The Source pane now

populates with files.

Important: When logs are removed, the complete source EDB is removed from the CAS
as well as any source folders or mailboxes that also reference that EDB and logs.

Missing STM Files
When there are missing .stm files, you are prompted to remove the files.

To remove missing .stm files

1. On the Missing Database File error message, click Remove.
2. When asked to confirm, click OK.

Important: When the .stm file is removed, the complete source EDB is removed from the
CAS as well as any source folders or mailboxes that also reference that EDB and .stm.

Missing Temp Files Directory Location
When there are missing temp file directory locations, you are prompted to locate the temp file
directory location. The Browse button opens a Browse for Folder window and defaults to the
current temporary path set by Single Mailbox Recovery.

To locate missing temp file directory location

1. On the Missing Database File error message, click Browse. The Open window appears.
2. Navigate to the directory containing the temp files.
3. Click OK. The Source pane now populates with files.
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Note: If just the temp files are missing but the directory exists, it recreates the temp files.

Wrong Database Files
When Single Mailbox Recovery finishes opening the EDB, it checks the database for the correct
file in the content analysis store. If it does not locate the correct file, it determines that there is a
different EDB at the original location than when the CAS was originally created. An error
appears and prompts you to remove the file from the CAS.

To remove wrong files

1. On the Wrong Database File error message, click Remove.
2. A message appears asking if you are sure you want to remove the source and all related

messages from the content analysis store. Click OK.
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Chapter 9: Message Views
Overview
You can view all instances of a given message or attachment in the EDB source(s) within the
same database as well as messages related by conversation in the Message Views option. This
option is particularly useful in assisting with administrative tasks such as database cleanup
activities, determining the history or dissemination of a message, or grouping messages by
conversation thereby allowing you to view them together in context without missing a reply or
forward.

Message views are available for messages in the Source pane, find results pane, and also from
another message view. Message views are available only on single messages. If multiple
messages are selected in the message pane, the message view menu items and toolbar buttons
are unavailable.

You can view a message in various ways, depending on the message view option selected.
Upon option selection, you are presented the following:

n Message Table View - All the messages that are referenced by the same message table
row as the selected message.

n Attachment Table View - All the messages that have an attachment that are referenced
by the same attachment table row as the selected attachment.

n Conversation View - Messages that are related by conversation, with the sorting order of
the email thread based on who replied to whom within the thread. Messages are
indented to show the thread timeline of when replies occurred.

Note: If you use the "MailboxCriteria (optional)" box on the Select Source Files dialog box or the
Source Selection page of the DataWizard, only EDB mailboxes containing your entry (or entries)
are displayed on the Source pane. Anymailboxes that do not match the entered string(s) do not
appear in the Source pane and are not be included in any subsequent tasks (such as searching,
copying, and exporting of the entire database). For more information, see "MailboxCriteria" on
page 30.

Note: If you use the "Multi-Tenancy Criteria" box on the Select Source Files dialog box, the Source
Selection page of the DataWizard, the Connect to Exchange Server dialog box, or the Target
Selection page of the DataWizard, only mailboxes contained in the selected Address Book
Policy or Organization appear in the Source or Target panes. Only these mailboxes are included
in any subsequent tasks (such as searching, copying, and exporting of the entire database). For
more information, see "Multi-Tenancy Support" on page 31.
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Message Views Menus and Toolbars
The message views are accessible via the Tools menu, toolbar buttons, and a sub-menu on the
shortcut menu in the message panes.

Message Views Menus
The Tools menu contains a sub-menu with menu items for each message view.

Figure 9-1: The Tools menu leads to the Message Views options

Message Views Toolbar Icons
A toolbar button exists for each message view: Message Table View, Attachment Table View,
and Conversation View.

Figure 9-2: The toolbar provides another option for accessing the Message Views

Message View Shortcut Menu
The Source pane shortcut menu has a Message Views sub-menu with menu items for each
message view. As with the main menu, the new Message Views menu items provides status bar
text when they are highlighted.
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Figure 9-3: The Message View options can be reached by right-clicking an EDB message in the
upper message pane.

Figure 9-4: The Status Bar

Message View Pane
The Message View Pane is the area that hosts the various message views. The pane provides you
the ability to view the related messages and perform various actions (for example, viewing
messages in alternate views, exporting messages to your directory, checking the integrity).

Other Options Available in the Message View
Other actions can be performed within a Message View, such as Exporting messages, Integrity
Check, copying messages, and viewing a message in another Message View.

Figure 9-5: Other options available in the Tools menu are Copy, Export, and Integrity Check

These options are available in any Message View:
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n Copying Messages-Messages within a Message View can be copied and pasted into
folders in the Target pane via the Edit menu or shortcut menu. For more information about
copying messages, see "Restoring Microsoft Exchange Server Data" on page 114.

n Exporting Messages-Messages within a Message View can be exported as any message
can via the Tools menu or shortcut menu. For more information, see "Exporting Messages"
on page 95.

n Integrity Check -Messages within a Message View can have an integrity check performed
on them via the Tools menu or shortcut menu. For more information, see "Looking at the
Interface" on page 6.

n Message Views -Messages within a Message View can be viewed in any of the three
Message View options, Message Table View, Attachment Table View, or Conversation
View. The message view options are only available if a single message is selected.

Message View Options
You have the option of viewing all instances of a given message or attachment in the EDB
source(s) in three different ways-Message Table, Attachment Table View, and Conversation
View.

Message Table View
Choosing the Message Table View option displays all the messages from the same EDB that
reference the same message table row (Single Instance Storage).

Example:

Amessage is sent to User1, User2, and User3. The message is stored in the message table once. If
a user opens up the database and right-clicks the message in User1's Inbox and chooses
Message Table View, a table opens with three messages in it: One in User1's Inbox (or deleted
items), one in User2's Inbox, and one in User3's Inbox as long as they are all in the same Microsoft
Exchange Server database (EDB). If User 1, 2, or 3 are in a different EDB, those messages will not
appear in this view.

Sample

Figure 9-6: The Message Table View displays messages that have been deleted.
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The message pane displays the related messages in a report format showing the Message Type,
Attachment, From, To, Subject, Folder, Date, and Status (indicating if message has been
deleted).

Note:Onlymessages within the same EDB can be viewed in the Message Table View.

To open and view messages in the Message Table View

1. In the message pane, select an EDB message.
2. Do one of the following to display the Message Table View:

l Click the Message Table View icon on the toolbar.

l Right-click a message and point to Message Views, then click Message Table View.
l Click the Tools menu, point to Message Views, then click Message Table View.

Note: The first time opening a view on this EDB, amessage appears stating that a
Message View file needs to generate.

Attachment Table View
Choosing the Attachment Table View option displays all of the messages in the same EDB that
have an attachment referencing the same attachment table row as the selected attachment
(Single Instance Storage). If the message contains multiple attachments, a sub-menu listing
each individual attachment allows the selection of an individual attachment.

Note: The Attachment Table View does not support Microsoft Exchange Server 2007 or later
sources, as Microsoft stopped supporting single instance storage with Microsoft Exchange Server
2007.

Example:

Amessage with an attachment is sent from User1 to User2 and User3. User3 forwards the email to
User4. The attachment is stored in the attachment table only once (single instance storage). A
user opens up the Microsoft Exchange Server database (EDB) containing these messages and
creates an Attachment Table View on the message in User's "Sent Items" folder. The Attachment
Table View contains five messages: one in User1's Sent Items, one in User2's Inbox, one is User's
Inbox, one in User3's Sent Items and one in User4's Inbox as long as they are all in the same EDB.

As in the Message Table View, the Attachment Table View shows the related messages in a
report format with Message Type, Attachment, From, To, Subject, Folder, Date, and Status
(including indicating if message has been deleted).

Note:

n Only messages with attachments can be viewed in the Attachment Table View.
n Only attachments within the same EDB can be viewed in the Attachment Table View.
n Attachments within inaccessible mailboxes cannot be viewed in the Attachment Table

View.
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To open the Attachment Table View

1. In the message pane, select a message.
2. Do one of the following to display the Attachment Table View:

l Click the Attachment Table View icon on the toolbar.

l Right-click a message and point to Message Views, then click Attachment Table
View.

l Click the Tools menu, point to Message Views, then click Attachment Table View.
Note: The first time opening a view in this EDB, amessage appears stating that aMessage
View file needs to generate.

Figure 9-7: The Attachment Table View displays messages with attachments

3. To view a message within the Attachment Table View, right-click a message, point to
Message Views and select one of the following options:
l Message Table View
l Attachment Table View
l Conversation View

4. Any message in the Attachment Table View can be opened by double-clicking the
message in the table.
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Conversation View
Choosing the Conversation View option displays the messages that are related by conversation
showing the Message Type, Attachment, From, To, Subject, Folder, Date, and Status (including
indicating if message has been deleted). Messages are indented to show the chain of replies
and forwards.

Example:

If a user composes and sends Email 1 to another user, and that user sends Email 2, a reply to
Email 1, then Email 1 has no indention and Email 2 is indented one level. If the first user then
replies to Email 2 with Email 3, then Email 3 is indented two levels.

Note:

n Only conversation threads within the same EDB can be viewed in the Conversation View.
n Messages within inaccessible mailboxes cannot be viewed in the Conversation View.

To open a Conversation View

1. In the message pane, select a message.
2. Do one of the following to display the Conversation View:

l Click the Conversation View icon on the toolbar.

l Right-click a message and point to Message Views, then click Conversation View.
l Click the Tools menu, point to Message Views, then click Conversation View.
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Figure 9-8: The Conversation View displays the conversation threads which are indicated
by indentations.

Note:

l The first time opening a view on this EDB, amessage appears stating that aMessage
View file needs to generated.

l If the first message is missing, the next message in the thread is still indented indicating
that it is not the original message.

3. To view a message within the Conversation View, right-click a message, point to Message
Views and select one of the following options:
l Message Table View
l Attachment Table View
l Conversation View

4. Any message in the Conversation View can be opened by double-clicking the message
in the table.

Opening a View for the First Time
The first time you create any Message Table View, Attachment Table View, or Conversation
View, Single Mailbox Recovery creates a Message View file. If no file exists, you are prompted to
create the file.
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To create a Message View for the first time

1. When the No Message View File dialog box appears, click Yes to create the file.

Figure 9-9: This message informs the user that an initial message view file does not exist

A progress window appears displaying the stage, progress text, estimated time, elapsed
time, and a grow bar.

For Microsoft Exchange Server 2007 and earlier, there are 5 stages: Initializing file,
Processing attachments, Processing messages, Processing rows, and Saving file.

For Microsoft Exchange Server 2010 and later, there are 3 stages: Creating the file,
processing the conversation messages, and saving the file.

After the message view file has been created, if creating a Message Table View, the
Creating Message View File progress window is replaced by another progress dialog that
tracks the progress of view preparation. A Preparing Message Table View progress
window appears.

If you click Cancel during this process, the Message Table View is not shown.

3. To view a message within the Message Table View, Attachment Table View, or
Conversation View, right-click a message, point to Message Views and select one of the
following options:
l Message Table View
l Attachment Table View
l Conversation View

4. To open a message in the Message Table View, Attachment Table View, or Conversation
View, double-click the message in the table.

Find in Source Window in Message Views
You can open a message view from the Find in Source window by using the Message Views sub-
menu on the Find Window's top-level Tools menu. The messages in the Find in Source window's
results pane also have the Message Views shortcut menu by right-clicking on a message and
pointing to Message Views.

To openmessages in Find in Source window result pane in different views

1. Click the Find icon
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on the toolbar.

2. In the Find in Source window, enter search criteria in the appropriate fields.
3. Click Find Now. The Results pane appears with the search results.

Figure 9-10: The Find results can be displayed in each of the Message Views

4. Do one of the following:
l Click the Tools menu, point to Message Views, then click the desired view in the sub-

menu.
l Right-click the message, point to Message Views, then click the desired view in the

sub-menu.
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Appendix A: Before You Open an EDB
File as a Source
Overview
This section describes information you need to know and tasks you need to perform to restore
Exchange mail items from an EDB file:

n "About the Microsoft Exchange Server Database" on page 181
n "Organizing Files Extracted from Other Backup Applications" on page 182
n "Verifying Hard Drive Space for .idx and .dat Files" on page 183

About the Microsoft Exchange Server Database
Note: The information in this section is taken from Microsoft Training andCertification:
Implementing andManaging Microsoft Exchange 2000. Workbook. Redmond, WA: Microsoft
Press, 2001.

The Microsoft Exchange Server database consists of the following files:

File(s) Description
.edb file This is a rich text database file that contains data placed in the store through MAPI, as

well as all the database tables that define mailboxes, messages, folders, and
attachments.

.stm file This is a streaming database file that contains common Internet formatted content,
such as Multipurpose Internet Mail Extensions (MIME) content, that protocols other
than the MAPI protocol place in the store.

Note: The .stm file is new to Microsoft Exchange Server 2000. Microsoft Exchange
Server 5.5 does not contain .stm files.

.log files These are transaction logs, or history files that record server activity. These files are
useful in restoring and backing up Microsoft Exchange Server data. All Microsoft
Exchange Server 2000 transaction logs are 5 MB in size. Each storage group uses its
own set of transaction log files. For example, if a storage group contains five stores,
all transactions for all five stores are recorded in a single series of transaction log files.
You can determine where to locate the transaction log files for each storage group.

181



File(s) Description
.chk files These are checkpoint files used for recovering (playing back) data from transaction

logs into EDB files. The checkpoint is the place marker in the EDB.CHK file that
indicates which transactions have been committed. Whenever data is written to an
EDB file from the transaction log, the EDB.CHK file is updated with information
specifying that the transaction was successfully committed to the respective EDB
file. Separate Exx.chk files are maintained for each storage group using ESE
(Extensible Storage Engine).

.pat files These are patch files that are used to record information on page splits in Microsoft
Exchange Server 5.5 through Microsoft Exchange Server 2000 (SP1). In Microsoft
Exchange Server 2000 (SP2) and later, the functionality provided by .pat files is
incorporated into Exchange log files.

The information in this section is taken from Microsoft Training and Certification: Implementing
and Managing Microsoft Exchange 2000. Workbook. Redmond, WA: Microsoft Press, 2001.

Organizing Files Extracted from Other Backup
Applications
If the source EDB is in an offline backup or in an online incremental or differential backup (as
opposed to a full online backup) created by an application other than SnapManager or
SnapCenter, then-after you have extracted the files to a location accessible from the Single
Mailbox Recovery server-use the following guidelines for organizing the files according to the
backup type.

If the source EDB is contained in an online incremental or differential backup: For best results, do
the following:

n Put the .edb and .stm files in one directory.
n Put the associated log files (e.g., .log, .pat, .chk) in one directory.

The two directories can be different.

Single Mailbox Recovery does not require .stm or .log files, but you should include them to
ensure that all email data is recovered. You may get corruption errors if these files are not
present. In other words, the quality of the recovery is better if you include the .stm and log files.

If the source EDB is contained in an offline backup: You need to use the .edb and .stm files. To
ensure that all email data is recovered, you should also include all .log files, as well as .pat and
.chk files if they exist. Single Mailbox Recovery performs its own verification process and will
include the .log and .pat files to determine if it needs them to recover the data.

Note:Microsoft Exchange Server 5.5 and later do not use .stm files.

182



Verifying Hard Drive Space for .idx and .dat Files
Single Mailbox Recovery never modifies an .edb file or its associated files (.log, .stm, .pat, or .chk
files). However, it does create .idxand .dat files the first time you open an .edb file from a
directory that contains log files; the interface prompts you to accept the default location for
.idx and .dat files or specify a new location if the files require more hard drive space. Be sure you
have a sufficient amount of hard drive space for .dat and .idx files. These files may require hard
drive space equal to the size of the .log files. Therefore, you may need to change the default file
path for .idx and .dat files if you need more space.

Each time you reopen the .edb file, Single Mailbox Recovery uses the information in the .idx and
.dat files so it can open the .edb file quicker.
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Appendix B: Granular Recovery of
Mailbox using Single Mailbox Recovery
with ONTAP System Manager or NetApp
PowerShell cmdlets
Overview
In the current version of Single Mailbox Recovery 8.x for SnapCenter, Single Mailbox Recovery
queries the localhost having the active Microsoft Exchange database and enumerates the
available snapshot. Based on the selected snapshot, the user mailbox is recovered. This method
requires Single Mailbox Recovery to be installed on active Microsoft Exchange database, along
with the Microsoft Outlook client. The process to recover mailbox is explained in Chapter 2: Using
Single Mailbox Recovery.

You can alternatively recover mailbox by mounting a clone copy of the LUN with the active
Microsoft Exchange database and passing the folder path containing exchange database
(edb/log files).

Note: Below steps are valid if the Microsoft Exchange databases are on iSCSI disk.

To recovermailbox by mounting a clone copy of the LUN

1. Login to the ONTAP System Manager.
2. On the left pane, click Storage> Volume.
3. Select the appropriate volume containing the Microsoft Exchange database files
4. Right-click the selected volume and click Clone > Create > Volume.
5. On the Create FlexClone Volume dialog box, enter the Name of the FlexClone volume.
6. In the FlexClone parent Snapshot copy section, select Use an existing Snapshot copy and

select the appropriate Snapshot copy.
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7. Click Clone.
A clone copy of the LUNs associated with the volume is created in Storage > LUNs.

8. Individually select each LUNs hosting the Microsoft Exchange data file and log file and
map the LUNs to initiator group

Note: Ensure the initiator group for the separate server where the LUNs are to be mapped
is already created in the OnCommand System Manager).

Once the LUNs are mapped to server, disk will be available to server in offline.

9. Click Server Manager >Tools > Computer Management, bring the disk online, and assign
drive letters to both the data and log disk.

10. View the EDB/log files on each of the newly created disk and copy the paths of the files.
11. Click Cancel to exit SnapCenter authentication windows.
12. Open Single Mailbox Recovery.
13. Click File > Open Source….
14. On the Data Wizard Source Selection page, in the Select Source list, click EDB file (*.edb).
15. Select the EDB Path and the Log File Path.
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16. Click Finish to load all the emails from the databases.
17. Open the desired user mailbox and browse through Inbox to recover mail
18. After the mail has been recovered, exit Single Mailbox Recovery.
19. Dismount the disk from OnCommand system manager by doing the following:

n Click Storage > Volumes > Clone Volume.
n Right-click the clone volume and click Change status to > Offline.
n Select the volume and delete it.

Steps from 1-8 above can also be performed using NetApp PowerShell cmdlets.

To create and mount a clone copy of volume using NetApp PowerShell cmdlets

1. Install the latest NetApp PowerShell Toolkit from NetApp community site on Windows
server.

Note: The SVM, vservername, volume name, Snapshot name are case sensitive.

2. PS C:\Import-module DataONTAP

(If DataONTAP dll is installed on different location, then provide complete path of dll while
importing module.)

3. PS C:\Connect-NAController <<clustername/ipaddress>> -HTTPS (provide the
filer username and password).

4. Note the name of the snapshot from SnapCenter > Resources > Microsoft Exchange
Server > Database Name > Snapshot name.

5. Note the onetime svmname and parent volume name (case sensitive).
6. PS C:\New-NcVolclone -clonevolume <<new clonename>> -parentsnapshot

<<snapshot name>> -vservercontext "<<svmname>>" -parentvolume
<<volumename>>
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7. PS C:\get-nclun -volume <<new clonename>> | add-nclunmap -initiatorgroup
<<initiator group name >>

8. Activate the disk and assign drive letters from computer management tool
9. Repeat the steps 9-18 from To recovermailbox by mounting a clone copy of the LUN.

10. Drop the volume from PowerShell cmdlets by doing the following:

n Set the volume to offline:
PS C:\set-ncvol <<new clonename>> -offline -vservercontext "<<svmname>>"

n Delete the clone volume:
PS C:\remove-ncvol <<new clonename>> -vservercontext "<<svmname>>"
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Glossary
Term Description

ABP Address Book Policies. With this feature, you can restrict the users and
mailboxes they can view when sending emails in an environment using
Microsoft Exchange Server 2010 SP2 and later. Users can be assigned ABPs.
ABPs include a Global Address List (GAL) that defines the mailboxes a user
assigned an ABP can view.

Attachment
Table View

A table that displays all the messages that have an attachment referenced
by the same attachment table row as the selected message.

CAS See Content Analysis Store

CHK Checkpoint files (.chk files) are used for recovering (playing) data from
transaction logs into EDB files. The checkpoint is the place marker in the
EDB.CHK file that indicates which transactions have been committed.
Whenever data is written to an EDB file from the transaction log, the
EDB.CHK file is updated with information specifying that the transaction was
successfully committed to the respective EDB file. Separate Exx.chk files are
maintained for each storage group using ESE (Extensible Store Engine).

Content
Analysis Store
(CAS)

A data store type where each message in the root level container identifies
a source container. A source container can either be an EDB, an EDB
mailbox, or an EDB folder. The CAS is used to analyze messages based on
profile criteria entered before processing.

Conversation
View

A table that displays all messages in the database that are related by
conversation. The conversation thread is indented to indicate replies.

Data Store A unified collection of folders and messages contained in a single storage
medium. A PST file is a data store. A Microsoft Exchange Server Information
Store is also a data store. In a basic case, Microsoft Exchange Server has two
live data stores, one for the private mailboxes and one for the public folders.

Data Wizard The first time you start Single Mailbox Recovery, the Data Wizard starts. The
Data Wizard guides you through the loading of Microsoft Exchange Server
Database (EDB), PST files, or content analysis store (CAS) files into Single
Mailbox Recovery, and shows you how to specify the target PST file or
Microsoft Exchange Server.
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Term Description

Deduplication Deduplication is performed on a per profile basis and if selected does not
return duplicates of a message during a search. For example, if the same
message exists in two or more data stores, only the first message found is
listed in the search results.

EDB See Microsoft Exchange Server Database.

EIS See Microsoft Exchange Server Information Store.

Exchange
Hosted
Organization
(or Hosted
Organization)

An organizational unit created in an environment that has deployed
Microsoft Exchange Server 2010 SP1 or SP2 using the /hosting switch (Hosting
Mode). Users and associated mailboxes created in a hosted organization
can only see other users and mailboxes created in the same hosted
organization.

Log Files Transaction log files (.log files) are history files recording server activity. These
files are useful in restoring and backing up Microsoft Exchange Server data.
Transaction logs for Microsoft Exchange Server 5.5, 2000, and 2003 are 5 MB in
size. Transaction logs for Microsoft Exchange Server 2007 and later are 1 MB in
size.

Messages Messages are found in the folders of a Microsoft Exchange Server Information
Store. Messages can mean "email," but Microsoft Office Outlook Contacts
are also messages, as are Appointments, Journal Entries, Sticky Notes, and
Tasks.

Message
Table View

A table that displays all messages that are referenced by the same message
table row as the selected message. For example: A message that is sent to
three different users appears three times, one in each user's Inbox.

Microsoft
Exchange
Server
Database

This file, which usually has an EDB extension, contains the mailbox, folders,
and messages you see when connecting to a Microsoft Exchange Server.
The Microsoft Exchange Server reads and writes to this file in response to
incoming email and events from the clients. On Microsoft Exchange Server
2000, this is one of the two files that make up the Microsoft Exchange Server
Information Store, the other being the STM file.
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Term Description

Microsoft
Exchange
Server
Information
Store

This is the set of files that compose the data store for private mailboxes and
public folders on a Microsoft Exchange Server. On Microsoft Exchange Server
5.5, this is the single Microsoft Exchange Server Database file usually named
priv1.edb and pub1.edb. On Microsoft Exchange Server 2000 and 2003, the
private mailbox data store consists of the files priv1.edb and priv1.stm and
the public folder data store consists of pub1.edb and pub1.stm. On Microsoft
Exchange Server 2007 and 2010, a private mailbox data and public folder
store consist of the EDB file without a STM file. On Microsoft Exchange Server
2013 or later, a mailbox data store consists of the EDB file without a STM file.

Multi-
Tenancy
Support

Support included in Single Mailbox Recovery and Single Mailbox Recovery
Administrative Server for multi-tenant deployments of Microsoft Exchange
Server 2010 and later. Specifically support is provided for environments that
are utilizing the Microsoft Exchange Server 2010 SP1, SP2 Hosting Mode or
Microsoft Exchange Server 2010 SP2 and later Address Book Policy feature.
Support includes the ability to limit the source and target mailboxes a user
can access based on Exchange Hosted Organizations or Address Book
Policies.

For information regarding Hosting Mode using the "/hosting" switch, see

http://technet.microsoft.com/en-us/library/ff923272.aspx

and

http://social.technet.microsoft.com/wiki/contents/articles/1110.
exchange-2010-sp1-information-for-hosted-service-providers.aspx.

For information regarding Address Book Policies, see

http://technet.microsoft.com/en-us/library/hh529948.aspx

and

http://technet.microsoft.com/en-us/library/hh529916.aspx.

PAT Patch files (.pat files) are used to record information on page splits in
Microsoft Exchange Server 5.5 through Microsoft Exchange Server 2000 (SP1).
In Microsoft Exchange Server 2000 (SP2) and later, the functionality provided
by .pat files is incorporated into Microsoft Exchange Server log files.

Profile Folder A subfolder of the content analysis store containing the results of profile
criteria entered for processing.

PST Personal Storage file. This file, used by Microsoft Office Outlook, contains
folders and messages that have been retrieved from a user's Microsoft
Exchange Server mailbox and copied locally.
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Term Description

Received
Messages

Messages that have been sent through a Microsoft Exchange Server to
another mailbox. Messages in the "Sent Items" folder are copies of messages
sent through a Microsoft Exchange Server and are not considered to be
"received messages." Because messages in the "Drafts" folder, "Notes" folder,
and other similar items are not sent through a Microsoft Exchange Server,
they too are not considered to be "received."
Note: Because recovery software such as Single Mailbox Recovery restores
messages from a source to aMicrosoft Exchange Server mailboxwithout
sending them, the messages that Single Mailbox Recovery restores are not
considered to be "receivedmessages."

Shortcut
Menu

This menu is accessed by right-clicking on an item.

Source Data
Store

This is the data store from which folders and messages are copied. The
source is read-only, so items cannot be copied into, deleted from, or
changed in the source.

STM For Microsoft Exchange Server 2000 and 2003, this is one of the two files that
make up the Microsoft Exchange Server Information Store, the other being
the EDB file. The STM file stores certain data for emails that come into the
Microsoft Exchange Server through the POP or SMTP port. This email data
may eventually get moved into the EDB file over time.

Target Data
Store

This is the data store to which folders and messages are copied. The target is
read-write allowing items to be added, deleted, and changed. The target
data store can be a Microsoft Exchange Server or PST file.
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