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Generate custom reports

Unified Manager reporting

Active IQ Unified Manager (formerly OnCommand Unified Manager) provides the ability
to view, customize, download, and schedule reports for your ONTAP storage systems.
The reports can provide details about the storage system capacity, health, performance,
security, and protection relationships.

The new Unified Manager reporting and scheduling functionality introduced in Active IQ Unified Manager 9.6
replaces the previous reporting engine that was retired in Unified Manager version 9.5.

Reporting provides different views of your network, offering actionable intelligence on capacity, health,
performance, security, and protection data. You can customize your views by showing, hiding, and rearranging
columns, filtering data, sorting data, and searching the results. You can save custom views for reuse, download
them as reports, and schedule them as recurring reports to distribute through email.

You can download views in Microsoft® Excel format and customize them. You can use advanced Excel
features, such as complex sorts, layered filters, pivot tables, and charts. When satisfied with the resulting Excel
report, you can upload the Excel file for use each time the report is scheduled and shared.

In addition to generating reports from the user interface, you can extract health, security, and performance data
from Unified Manager using these additional methods:

• Using Open Database Connectivity (ODBC) and ODBC tools to directly access the database for cluster
information

• Executing Unified Manager REST APIs to return the information you are interested in reviewing

From this release of Active IQ Unified manager, following enhancements are made to the reports:

• Email is sent for a report as per the configured schedule. Even when you generate an on-demand report,
you will receive an email.

• The file name of the report and metadata of the report includes the hostname from where the report was
generated. Even if any one changes the filename, still you can identify the hostname from where the report
was generated due to this enhancement.

Access points for generating reports

You can gather information in Unified Manager about your clusters to create reports from
the UI, MySQL database queries, and REST APIs.

These sections cover Unified Manager reporting and scheduling through the UI.

There are three ways you can access the reporting capabilities provided by Unified Manager:

• Extracting data directly from the inventory pages in the UI.

• Using Open Database Connectivity (ODBC) and ODBC tools to access all the available objects.

• Executing Unified Manager REST APIs to return the information that you want to review.

These sections cover Unified Manager reporting and scheduling through the UI.
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Unified Manager databases accessible for custom reporting

Unified Manager uses a MySQL database to store data from the clusters that it is
monitoring. Data is persisted into various schemas in the MySQL database.

All table data from the following databases are available:

Database Description

netapp_model Data about the objects on ONTAP controllers.

netapp_model_view Data about the objects on ONTAP controllers, suitable
for report tool consumption.

netapp_performance Cluster specific performance counters.

ocum Unified Manager application data and information to
support UI filtering, sorting, and the calculation of
some derived fields.

ocum_report Data for inventory configuration and capacity-related
information.

ocum_report_birt Views for inventory configuration and capacity-related
data, suitable for report tool consumption.

opm Performance configuration settings and threshold
information.

scalemonitor Data about the Unified Manager application health
and performance issues.

vmware_model VMware object data for datastores hosted on NetApp
storage.

vmware_model_view Views for VMware object data for datastores hosted
on NetApp storage, suitable for report tool
consumption.

vmware_performance VMware performance counter data for datastores
hosted on NetApp storage.

A reporting user — a Database user with the Report Schema role — is able to access the data in these tables.
This user has read-only access to reporting and other database views directly from the Unified Manager
database. Note that this user does not have permission to access any tables that contain user data or cluster
credential information.
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Unified Manager REST APIs that can be used for reporting

You can use REST APIs to help manage your clusters by viewing the health, capacity,
performance, and security information captured by Unified Manager.

REST APIs are exposed through the Swagger web page. You can access the Swagger web page to display
the Unified Manager REST API documentation, as well as to manually issue an API call. From the Unified
Manager web UI, in the Menu Bar, click the Help button and then select API Documentation. For information
about Unified Manager REST APIs, see the Getting started with Active IQ Unified Manager REST APIs.

You must have the Operator, Storage Administrator, or Application Administrator role to access the REST APIs.

Understanding reports

Reports display detailed information about storage, network, quality of service, and
protection relationships, helping you to identify and solve potential problems before they
occur.

When you customize a view, you can save it with a unique name for future use. You can schedule a report
based on that view to run on a regular basis and share it with others. You can also download the view in Excel
to customize it using advanced Excel features, then upload that file back into Unified Manager . If you schedule
a report using that view, it will use the Excel file you uploaded to create robust reports you can share.

You can manage all reports that have been scheduled from the Report Schedules page.

You must have the Application Administrator or Storage Administrator role to manage reports.

You can download reports as comma-separated values (CSV), Excel, or PDF files.

Understanding the view and report relationship

Views and inventory pages become reports when you download or schedule them.

You can customize and save views and inventory pages for reuse. Almost everything you can view in Unified
Manager can be saved, reused, customized, scheduled, and shared as a report.

In the view drop down, items with the delete icon are existing custom views that you or another user have
created. Items without an icon are default views provided with Unified Manager. Default views cannot be
modified or deleted.

• If you delete a custom view from the list, it also deletes any Excel files or scheduled reports
that use that view.

• If you change a custom view, reports that use that view will reflect the change the next time
the report is generated and sent by email according to the report schedule. When changing
views, make sure your changes work with any associated Excel customizations used for the
reports. If needed, you can update the Excel file by downloading it, making the required
changes, and uploading it as a new Excel customization for the view.
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Only users with the Application Administrator or Storage Administrator role can see the delete icon, change or
delete a view, or change or delete a scheduled report.

Types of reports

This table provides a comprehensive list of the views and inventory pages that are
available as reports that you can customize, download, and schedule.

Active IQ Unified Manager reports

Type Storage or network object

Capacity Clusters

Aggregates

Volumes

Qtrees

Health Clusters

Nodes

Aggregates

Storage VMs

Volumes

SMB/CIFS shares

NFS shares
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Type Storage or network object

Performance Clusters

Nodes

Aggregates

Storage VMs

Volumes

LUNs

NVMe namespaces

Network Interfaces (LIFs)

Ports

Quality of Service Traditional QoS policy groups

Adaptive QoS policy groups

Performance Service Level policy groups

Volume protection relationships (available from the
Volumes page)

All relationships

Last 1 month transfer status

Last 1 month transfer rate

Security Storage VMs

Clusters

Reporting limitations

There are some limitations with the new Active IQ Unified Manager reporting functionality
of which you should be aware.

Existing reports from previous versions of Unified Manager

You can only edit the schedule and recipients for existing reports that were created and imported (as .rptdesign
files) in Unified Manager 9.5 and earlier releases. If you customized any of the standard reports that were
provided with Unified Manager 9.5 or earlier, these custom reports are not imported into the new reporting tool.

If you need to edit existing reports imported from .rptdesign files, do one of the following and remove the
imported report:

• create a new view and schedule a report from that view (preferred)

• hover over the report, copy the SQL, and pull the data using an external tool
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The default views can be generated as reports without the need for any customization. You can use the new
reporting solution to recreate any custom reports.

Schedule and report relationship

You can create many different schedules with any combination of recipients for each saved report. However,
you cannot reuse the schedule for multiple reports.

Report protection

Any user with the appropriate permissions can edit or delete reports. There is no way to prevent other users
from removing or making changes to saved views or schedules.

Event reports

Although you can customize the event view and download the resulting report in CSV format, you cannot
schedule recurring event reports for generation and distribution.

Report attachments

Reports cannot be sent in the body of an email. Instead, reports are only sent as PDF, Excel, or CSV
attachments.

Working with reports

Learn how to find and customize inventory page views into shareable scheduled reports.

Report workflow

Decision tree that describes the report workflow.
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Reporting quick start

Create a sample custom report to experience exploring views and scheduling reports.
This quick start report finds a list of volumes that you might want to move to the cloud tier
because there is a fair amount of inactive (cold) data. You will open the Performance: All
Volumes view, customize the view using filters and columns, save the custom view as a
report, and schedule the report to share once a week.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

• You must have configured FabricPool aggregates and have volumes on those aggregates.

Follow the steps below to:

• Open the default view

• Customize the columns by filtering and sorting the data
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• Save the view

• Schedule a report to be generated for the custom view

Steps

1. In the left navigation pane, click Storage > Volumes.

2. In the View menu, select Performance > All Volumes.

3. Click Show/Hide to make sure the “Disk Types” column appears in the view.

Add or remove other columns to create a view that contains the fields that are important for your report.

4. Drag the “Disk Types” column next to the “Cloud Recommendation” column.

5. Click the filter icon to add the following three filters, and then click Apply Filter:

◦ Disk Types contains FabricPool

◦ Cloud Recommendation contains tier

◦ Cold Data greater than 10 GB

Note that each filter is joined with a logical AND so that all volumes returned must meet all the criteria. You
can add a maximum of five filters.

6. Click the top of the Cold Data column to sort the results so that the volumes with the most cold data appear
at the top of the view.
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7. When the view is customized, the view name is Unsaved View. Name the view to reflect what the view is
showing, for example “Vols change tiering policy”. When done, click the check mark or press Enter to save
the view with the new name.

8. Download the report as a CSV, Excel, or PDF file to see the output before you schedule or share it.

Open the file with an installed application, such as Microsoft Excel (CSV or Excel) or Adobe Acrobat (PDF),
or save the file.

You can further customize your report using complex filters, sorts, pivot tables, or charts by
downloading the view as an Excel file. After you open the file in Excel, use the advanced
features to customize your report. When satisfied, upload the Excel file. This file, with its
customizations, is applied to the view when the report is run.

For more information on customizing reports using Excel, see Sample Microsoft Excel reports.

9. Click the Scheduled Reports button on the inventory page. All scheduled reports relating to the object, in
this case volumes, appear in the list.

10. Click Add Schedule to add a new row to the Report Schedules page so you can define the schedule
characteristics for the new report.

11. Enter a name for the report and complete the other report fields, then click the check mark ( ) at the end
of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

The following sample report is in CSV format:
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The following sample report is in PDF format:

Based on the results shown in the report, you might want to use ONTAP System Manager or the ONTAP CLI to
change the tiering policy to “auto” or “all” for certain volumes to offload more cold data to the cloud tier.

Searching for a scheduled report

You can search for scheduled reports by name, view name, object type, or recipients.

1. In the left navigation pane, click Storage Management > Report Schedules.

2. Use the Search Scheduled Reports text field.

To find reports by … Try …

Schedule name Type part of the report schedule name.

View name Type part of the report view name. Default views
and custom views appear in the view list.

Recipient Type part of the email address.

File type Type "PDF", "CSV", or "XLSX".

3. You can click a column heading to sort reports in ascending or descending order by that column, such as
schedule name or format.

Customizing reports

There are many ways you can customize views so that you can create a report that
contains all the information you need to manage your ONTAP clusters.

Start with a default inventory page or a custom view, then customize it by adding or removing columns,
changing the column order, filtering the data, or sorting on a specific column in ascending or descending order.

Starting in Unified Manager 9.8, you can also download the view in Excel to customize it using advanced
features. When done, upload the customized Excel file. If you schedule a report using that view, it uses the
customized Excel file to create robust reports you can share.

For more information on customizing reports using Excel, see Sample Microsoft Excel reports.
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You must have the Application Administrator or Storage Administrator role to manage reports.

Customizing columns

Use Show/Hide to choose the columns you want to use in your report. Drag the columns
on the inventory page to rearrange them.

Steps

1. Click Show/Hide to add or remove columns.

2. On the inventory page, drag columns to rearrange them in the order you want in your report.

3. Name the unsaved view to save your changes.

Filtering data

Filter the data to make sure the results match your report requirements. Filtering enables
you to display only the data in which you are interested.

Steps

1. Click the filter icon to add filters to focus the results you want to view, and then click Apply Filter.

2. Name the unsaved view to save your changes.
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Sorting data

To sort the results, click a column and indicate ascending or descending order. Sorting
data prioritizes the information you need for the report.

Steps

1. Click the top of a column to sort the results so that the most important information appears at the top of the
view.

2. Name the unsaved view to save your changes.

Using search to refine your view

After you have the view you want, you can further refine the results using the Search field
to focus on the results that you want to include in the report.

Steps

1. Open the custom or default view that you want to use as the basis of your report.

2. Type in the Search field to refine the data listed in the view. You can enter partial data in any of the
displayed columns. For example, if you want to search for nodes that include "US_East" in the name, you
can refine the full list of nodes.

The results of your search are saved in the custom view and used in the resulting scheduled report.

3. Name the unsaved view to save your changes.

Using Excel to customize your report

After you have saved the view, you can download it in Excel Workbook format (.xlsx).
When you open the Excel file, you can use advanced Excel features to customize your
report.

What you’ll need

You can only upload an Excel Workbook file with the .xlsx extension.

For example, some advanced Excel features you can use in your report include:

• Multi-column sort

• Complex filtering

• Pivot tables

• Charts

12



• The downloaded Excel file uses the default file name for the view, not your saved name.

◦ The format is <View Area>-<Day>-<Month>-<Year>-<Hour>-<Minute>-

<Second>.xlsx.

◦ For example, a custom saved view named Volumes-not online has a file name of

health-volumes-05-May-2020-19-18-00.xlsx if saved at that day and time.

• You can add sheets to the Excel file, but do not change existing sheets.

◦ Do not change the existing sheets, data and info. Instead, copy the data to a new page
that you create.

◦ One exception to the above rule is that you can create formulas on the “data” page. Use
the data page formulas to create charts on new pages.

◦ Do not name a new sheet data or info.

• If a customized Excel file exists, there is a check mark beside the Reports > Upload Excel

menu item. When you download the Excel file, the version with the customizations is

used.

Steps

1. Open the default, custom, or saved view that you want to use as the basis of your report.

2. Select Reports > Download Excel.

3. Save the file. The file is saved to your downloads folder.

4. Open the saved file in Excel. Do not move the file to a new location, or if you do your work in another
location, save the file back to the original location using the original file name before uploading the file.

5. Customize the file using Excel features, such as complex sorts, layered filters, pivot tables, or charts. For
more information, see the Microsoft® Excel documentation.

6. Select Reports > Upload Excel and select the file that you modified. The most recently downloaded file is
uploaded from the same file location.

7. Send yourself a test report using the Scheduled Reports feature.

Downloading reports

You can download reports and save the data to a local or network drive as a comma-
separated values (CSV) file, a Microsoft Excel (.XLSX) file, or a PDF file. You can open
CSV and XLSX files with spreadsheet applications, such as Microsoft Excel, and PDF
files with readers such as Adobe Acrobat.

Steps

13



1. Click the Reports button to download the report as one of the following:

Choose To…

Download CSV Save the report as a comma-separated values
(CSV) file.

Download PDF Save the report as a .pdf file.

Download Excel Save the report as a Microsoft Excel (XLSX) file.

Scheduling reports

After you have a view you want to reuse and share as a report, you can schedule it using
Active IQ Unified Manager. You can manage scheduled reports, changing the recipients
and distribution frequency for each report schedule.

You can schedule most views or inventory pages in Unified Manager. Exceptions are events, which are reports
you can download as CSV files, but you cannot schedule events for regeneration and sharing. You also cannot
download or schedule the dashboards, favorites, or configuration pages.

Starting in Active IQ Unified Manager 9.8, you can download views in Microsoft® Excel format and customize
them. You can use advanced Excel features such as complex sorts, layered filters, pivot tables, and charts.
When satisfied with the resulting Excel report, you can upload the Excel file for use each time the report is
scheduled and shared.

You can schedule the built in views or views you customize. You can choose which file type to send, either
CSV, PDF, or XSLX. When you schedule a report for the first time, you can download it and assign yourself as
the only recipient to see the report as your recipients will see it.

Scheduling a report

After you have a view or Excel file that you want to schedule for regular generation and
distribution, you can schedule the report.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

• You must have configured the SMTP server settings in the General > Notifications page so that the
reporting engine can send reports as email attachments to the list of recipients from the Unified Manager
server.

• The email server must be configured to allow attachments to be sent with the generated emails.

Use the following steps to test and schedule a report to be generated for a view. Select or customize the view
you want to use. The following procedure uses a network view that shows the performance of your network
interfaces, but you can use any view you want.

Steps

1. Open your view. This example uses the default network view that shows LIF performance. In the left
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navigation pane, clickNetwork > Network Interfaces.

2. Customize the view as needed using the built-in Unified Manager features.

3. After you customized the view, you can provide a unique name in the View field and click the check mark
to save it.

4. You can use the advanced features of Microsoft® Excel to customize your report. For details, see Using
Excel to customize your report.

5. To see the output before you schedule or share it:

Option Description

If you used Excel to customize the report View the existing downloaded Excel file.

If you did not use Excel to customize the report Download the report as a CSV, PDF or XLSX file.

Open the file with an installed application, such as Microsoft Excel (CSV/XSLX) or Adobe Acrobat (PDF).

6. If you are satisfied with the report, click Scheduled Reports.

7. In the Report Schedules page, click Add Schedule.

8. Accept the default name, which is a combination of the view name and the frequency, or customize the
schedule name.

9. To test the scheduled report the first time, only add yourself as the recipient. When satisfied, add the email
addresses for all report recipients.

10. Specify how frequently the report will be generated and sent to the recipients. You can choose Daily,
Weekly, or Monthly.

11. Select the format, either PDF, CSV, or XSLX.

For reports where you used Excel to customize the content, always select XSLX.

12. Click the checkmark ( ) to save the report schedule.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the scheduled frequency.
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Scheduling imported .rptdesign reports

You can schedule existing reports that were created and imported in an earlier release of
Unified Manager.

Scheduling imported reports requires the following:

• imported BIRT designed .rptdesign file reports in an earlier Unified Manager release

• applicable when upgrading to Unified Manager 9.6 GA or later

After upgrading to Unified Manager 9.6 GA or later, the Report Schedules page lists the imported reports. You
can edit the schedule for these reports to specify the recipient email addresses, frequency, and format (PDF or
CSV). Otherwise these reports cannot be edited or viewed in the Unified Manager UI.

Steps

1. Open the Report Schedules page. If you have imported reports, a message appears.

2. Click the View name to display the SQL query that is being used to generate the report.

3.
Click the more icon , click Edit, define the report schedule details, and save the report.

You can also delete any unwanted reports from the more icon .
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Managing report schedules

You can manage your report schedules from the Report Schedules page. You can view,
modify, or delete existing schedules.

What you’ll need

You cannot schedule new reports from the Report Schedules page. You can only add scheduled
reports from the object inventory pages.

• You must have the Application Administrator or Storage Administrator role.

Steps

1. In the left navigation pane, click Storage Management > Report Schedules.

2. On the Report Schedules page:

If you want to… Then…

View an existing schedule Scroll through the list of existing reports using the
scroll bars and page controls.

Edit an existing schedule a.
Click the more icon  for the schedule you
want to use.

b. Click Edit.

c. Make the necessary changes.

d. Click the check mark to save your changes.

Delete an existing schedule a.
Click the more icon  for the schedule you
want to use.

b. Click Delete.

c. Confirm your decision.

Editing scheduled reports

After reports are scheduled, you can edit them on the Report Schedules page.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Steps

1. In the left navigation pane, click Storage Management > Report Schedules.
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If you have the appropriate permissions you can alter any report and its schedule in the
system.

2.
Click the more icon  for the schedule you want to change.

3. Click Edit.

4. You can change the Schedule Name, Recipient list, Frequency, and Format for the report schedule.

5. When done, click the check mark to save your changes.

Deleting scheduled reports

After reports are scheduled, you can delete them from the Report Schedules page.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Steps

1. In the left navigation pane, click Storage Management > Report Schedules.

If you have the appropriate permissions you can remove any report and its schedule in the
system.

2.
Click the more icon  for the schedule you want to remove.

3. Click Delete.
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4. Confirm your decision.

The scheduled report is removed from the list and will no longer be generated and distributed on the set
schedule.

If you delete a custom view from the inventory page, any custom Excel files or scheduled
reports that use that view are also deleted.

Sample custom reports

These sample custom reports are commonly used to help you identify potential problems
and respond to potential issues before problems occur.

The list of reports in this section is not exhaustive and will grow over time. You can suggest custom reports to
add to this section by providing documentation feedback.

You must have the Application Administrator or Storage Administrator role to manage reports.

Customizing cluster storage reports

The sample cluster storage reports in this section are just samples to help you
understand how to create reports about cluster capacity to help you monitor you storage
system resources.

Creating a report to view capacity by cluster model

You can create a report to analyze storage capacity and utilization of clusters based on
storage system model.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view that displays capacity by cluster model, and then schedule a
report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Clusters.

2. In the View menu, select Capacity > All Clusters.

3. Select Show/Hide to remove any columns, such as “Cluster FQDN” and “OS Version”, that you do not
want in the report.

4. Drag the “Total Raw Capacity”, the “Model/Family”, and the three aggregate columns near the “Cluster”
column.

5. Click the top of the “Model/Family” column to sort the results by cluster type.

6. Save the view with a specific name that reflects what the view is showing, for example, “Capacity by
Cluster Model”.

7. Click the Scheduled Reports button on the inventory page.
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8. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

9. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to add more capacity to certain clusters, or upgrade
older cluster models.

Creating a report to identify clusters with the most unallocated LUN capacity

You can create a report to find the clusters with the most unallocated LUN capacity,
greater than .5 TB, to help identify where you can add additional workloads.

What you’ll need * You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view that displays clusters with the most unallocated LUN capacity,
and then schedule a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Clusters.

2. In the View menu, select Capacity > All Clusters.

3. Select Show/Hide to remove any columns you do not want in the report.

4. Drag the “Unallocated LUN Capacity” column near the “HA Pair” column.

5. Click the filter icon, add the following filter, and then click Apply Filter:

◦ Unallocated LUN capacity greater than 0.5 TB

6. Click the top of the “Unallocated LUN Capacity” column to sort the results by the greatest amount of
unallocated LUN capacity.

7. Save the view with a specific name that reflects what the view is showing, for example “Most unallocated
LUN capacity” and click the check mark ( ).

8. Click the Scheduled Reports button on the inventory page.

9. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

10. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to use the unallocated LUN capacity of the cluster.

Creating a report to view HA pairs with the most available capacity

You can create a report to find the high availability (HA) pairs with the most capacity to
provision new volumes and LUNs.
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What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view that displays HA pairs sorted by the most available capacity to
provision new volumes and LUNs, and then schedule a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Clusters.

2. In the View menu, select Capacity > All Clusters.

3. Select Show/Hide to remove any columns you do not want in the report.

4. Drag the “Aggregate Unused Capacity” column near the “HA Pair” column.

5. Click the filter icon, add the following filter, and then click Apply Filter:

◦ Aggregate Unused Capacity greater than 0.5 TB

6. Click the top of the “Aggregate Unused Capacity” column to sort the results by the greatest amount of
unused aggregate capacity.

7. Save the view with a specific name that reflects what the view is showing, for example, “Least used
aggregate capacity”, and click the check mark ( ).

8. Click the Scheduled Reports button on the inventory page.

9. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

10. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to balance HA pairs based on aggregate capacity.

Creating a report to view nodes running older versions of ONTAP

You can create a report to display the version of ONTAP software that is installed on all
cluster nodes so that you can see which nodes you should upgrade.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view that displays nodes running older versions of ONTAP, and then
schedule a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Nodes.

2. Select Show/Hide to remove any columns that you do not want in the report.

3. Drag the “OS Version” column near the “Node” column.

4. Click the top of the “OS Version” column to sort the results by oldest version of ONTAP.

5. Save the view with a specific name that reflects what the view is showing, for example, “Nodes by ONTAP
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version”.

6. Click the Scheduled Reports button on the inventory page.

7. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

8. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to upgrade nodes running older versions of ONTAP.

Customizing aggregate capacity reports

These sample custom reports are used to help you identify and respond to potential
problems related to aggregate storage capacity.

The reports in this section are just samples to help you understand how to create reports about aggregate
capacity to help you monitor you storage system resources.

Creating a report to view aggregates reaching full capacity

You can create a report to find the aggregates that are reaching full capacity so that you
can add more capacity or move workloads to other aggregates.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view that displays aggregates reaching full capacity, then schedule
a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Aggregates.

2. In the View menu, select Capacity > All Aggregates.

3. Select Show/Hide to remove any columns you do not want in the report.

4. Click the filter icon, add the following filter, and then click Apply Filter:

◦ Days to Full less than 45 Days

5. Click the top of the “Days to Full” column to sort the results by the least number of days remaining to reach
full capacity.

6. Save the view with a specific name that reflects what the view is showing, for example, “Days to full
aggregate capacity”, and click the check mark ( ).

7. Click the Scheduled Reports button on the inventory page.

8. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

9. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.
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The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to increase storage on aggregates reaching full
capacity. Additionally, you might want to increase the Days Until Full capacity threshold to more than the
default 7 days so that you receive events that provide more time to react to space getting low on aggregates.

Creating a report to view aggregates that are 80% or more full

You can create a report to highlight the aggregates that are 80% or more full.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view that displays aggregates that are 80% or more full, then
schedule a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Aggregates.

2. In the View menu, select Capacity > All Aggregates.

3. Select Show/Hide to remove any columns you do not want in the report.

4. Drag the “Available Data %” and the “Used Data %” columns near the “Aggregate” column.

5. Click the filter icon, add the following filters, and then click Apply Filter:

◦ Used Data % is greater than 80%

6. Click the top of the “Used Data %” column to sort the results by capacity percent.

7. Save the view with a specific name that reflects what the view is showing, for example, “Aggregates
nearing full”, and click the check mark ( ) .

8. Click the Scheduled Reports button on the inventory page.

9. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

10. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to move some data from certain aggregates.

Creating a report to view aggregates that are overcommitted

You can create a report to analyze storage capacity and use of aggregates, and to view
aggregates that are overcommitted.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view that displays aggregates that are exceeding the
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overcommitted threshold, then schedule a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Aggregates.

2. In the View menu, select Capacity > All Aggregates.

3. Select Show/Hide to remove any columns that you do not want in the report.

4. Drag the “Overcommitted Capacity %” column near the “Aggregate” column.

5. Click the filter icon, add the following filters, and then click Apply Filter:

◦ Overcommitted Capacity % is greater than 100%

6. Click the top of the “Overcommitted Capacity %” column to sort the results by capacity percent.

7. Save the view with a specific name that reflects what the view is showing, for example, “Aggregates
overcommitted”, and click the check mark ( ).

8. Click the Scheduled Reports button on the inventory page.

9. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

10. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to add some more capacity to aggregates, or move
some data from certain aggregates.

Customizing volume capacity reports

These sample custom reports are used to help you identify and respond to potential
problems related to volume capacity and performance.

Creating a report to identify volumes nearing full capacity that have Snapshot Autodelete turned off

You can create a report that contains the list of volumes that are approaching full capacity
with the Snapshot Autodelete feature disabled. The results can help identify volumes
where you might want to configure Snapshot Autodelete.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Follow the steps below to create a custom view that displays the required columns in the correct order, and
then schedule a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Volumes.

2. In the View menu, select Capacity > All Volumes.

3. Select Show/Hide to remove any columns you do not want in the report.
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4. Drag and drop the “Snapshot Autodelete” and “Days To Full” columns near the “Available Data Capacity”
column.

5. Click the filter icon, add the following two filters, and then click Apply Filter:

◦ Days To Full less than 30 days

◦ Snapshot Autodelete is Disabled

6. Click the top of the Days To Full column so that the volumes with the fewest remaining days appear at the
top of the list.

7. Save the view with a specific name that reflects what the view is showing, for example “Vols near capacity”.

8. Click the Scheduled Reports button on the inventory page.

9. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to enable Snapshot Autodelete on the volumes or
find a way to increase the available space.

Creating a report to identify space used by volumes with thin provisioning disabled

When a volume is not thin provisioned it takes up the full amount of space on the disk as
defined when the volume was created. Identifying volumes that have thin provisioning
disabled helps you decide whether you want to enable thin-provisioning on certain
volumes.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Follow the steps below to create a custom view that displays the required columns in the correct order, and
then schedule a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Volumes.

2. In the View menu, select Capacity > All Volumes.

3. Select Show/Hide to remove any columns you do not want in the report.

4. Drag and drop the “Used Data %” and the “Thin Provisioned” columns near the “Available Data Capacity”
column.

5. Click the filter icon, add the following filter, Thin provisioned is No, and then click Apply Filter.

6. Click the top of the “Used Data %” column to sort the results so that the volumes with the highest
percentage appear at the top of the list.

7. Save the view with a name to reflect what the view is showing, for example “Vols no thin provisioning”.

8. Click the Scheduled Reports button on the inventory page.

9. Click Add Schedule to add a new row to the Report Schedules page so you can define the schedule
characteristics for the new report.
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10. Enter a name for the report schedule and complete the other report fields, then click the checkmark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to enable thin provisioning on certain volumes.

Creating a report to identify volumes on FabricPool aggregates that should move data to the cloud tier

You can create a report that contains the list of volumes that currently reside on
FabricPool aggregates, that have a cloud recommendation of Tier, and that have a large
amount of cold data. This report can help you decide if you should change the tiering
policy for certain volumes to “auto” or “all” to offload more cold (inactive) data to the cloud
tier.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

• You must have configured FabricPool aggregates and have volumes on those aggregates.

Follow the steps below to create a custom view that displays the required columns in the correct order, and
then schedule a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Volumes.

2. In the View menu, select Performance > All Volumes.

3. In the column chooser, make sure that the “Disk Type” column appears in the view.

Add or remove other columns to create a view that is important for your report.

4. Drag and drop the “Disk Type” column near the “Cloud Recommendation” column.

5. Click the filter icon, add the following three filters, and then click Apply Filter:

◦ Disk Type contains fabricpool

◦ Cloud Recommendation contains tier

◦ Cold Data greater than 10 GB
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6. Click the top of the Cold Data column so that the volumes with the most cold data appear at the top of the
view.

7. Save the view with a name to reflect what the view is showing, for example “Vols change tiering
policy”.

8. Click the Scheduled Reports button on the inventory page.

9. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

10. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to use System Manager or the ONTAP CLI to change
the tiering policy to “auto” or “all” for certain volumes to offload more cold data to the cloud tier.

Customizing Qtree capacity reports

These sample custom reports are used to help you identify and respond to potential
problems related to Qtree capacity.
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Creating a report to view qtrees that are nearly full

You can create a report to analyze storage capacity and utilization of qtrees, and to view
qtrees that are nearly full.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view that displays qtrees that are nearly full, and then schedule a
report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Qtrees.

2. Select Show/Hide to remove any columns you do not want in the report.

3. Drag the “Disk Used %” column near the “Qtrees” column.

4. Click the filter icon, add the following filters, and then click Apply Filter:

◦ Disk Used % is greater than 75%

5. Click the top of the “Disk Used %” column to sort the results by capacity percent.

6. Save the view with a specific name that reflects what the view is showing, for example, “Qtrees nearing
full”, and click the check mark ( ).

7. Click the Scheduled Reports button on the inventory page.

8. Click Add Schedule to add a new row to the Report Schedules page so you can define the schedule
characteristics for the new report.

9. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to adjust the disk hard and soft limits (if set), or
balance data across the qtrees.

Customizing NFS share reports

You can customize NFS share reports to analyze information about NFS export policies
and rules for volumes on your storage systems. For example, you can customize reports
to display volumes with inaccessible mount paths and volumes with the default export
policy.

Creating a report to view volumes that have an inaccessible mount path

You can create a report to find volumes that have an inaccessible mount path.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.
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Use the following steps to create a custom view for volumes that have an inaccessible mount path, and then
schedule a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > NFS Shares.

2. Select Show/Hide to remove any columns that you do not want in the report.

3. Click the filter icon, add the following filter, and then click Apply Filter:

◦ Mount Path Active is No

4. Save the view with a specific name that reflects what the view is showing, for example “Volumes with an
inaccessible mount path” and click the check mark ( ).

5. Click the Scheduled Reports button on the inventory page.

6. Click Add Schedule to add a new row to the Report Schedules page so you can define the schedule
characteristics for the new report.

7. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to correct the inaccessible mount paths.

Creating a report to view volumes that are using the default export policy

You can create a report to find volumes that are using the default export policy.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view for volumes that are using the default export policy, and then
schedule a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > NFS Shares.

2. Select Show/Hide to remove any columns that you do not want in the report.

3. Drag the “Export Policy” column near the “Volume” column.

4. Click the filter icon, add the following filter, and then click Apply Filter:

◦ Export Policy contains default

5. Save the view with a specific name that reflects what the view is showing, for example “Volumes with a
default export policy” and click the check mark ( ).

6. Click the Scheduled Reports button on the inventory page.

7. Click Add Schedule to add a new row to the Report Schedules page so you can define the schedule
characteristics for the new report.

8. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
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recipients listed using the specified frequency.

Based on the results shown in the report, you might want to configure a custom export policy.

Customizing storage VM reports

You can create storage VM reports to analyze volume information and to view overall
health and storage availability. For example, you can create reports to display SVMs
reaching the maximum volume count and to analyze stopped SVMs.

Creating a report to view storage VMs reaching the maximum volume limit

You can create a report to find SVMs that are reaching the maximum volume limit.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view that displays storage VMs that are reaching the maximum
volume limit, and then schedule a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Storage VMs.

2. Select Show/Hide to remove any columns you do not want in the report.

3. Drag the “Volume Count” and “Maximum Allowed Volumes” columns near the “Storage VM” column.

4. Click the top of the “Maximum Allowed Volumes” column to sort the results by the highest number of
volumes.

5. Save the view with a specific name that reflects what the view is showing, for example “SVMs reaching
max volumes” and click the check mark ( ).

6. Click the Scheduled Reports button on the inventory page.

7. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

8. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to balance the volumes assigned to storage VMs or,
if possible, use ONTAP System Manager to change the maximum allowed volumes.

Creating a report to view stopped storage VMs

You can create a report to display a list of all stopped SVMs.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.
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Use the following the steps to create a custom view that displays stopped storage VMs, and then schedule a
report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Storage VMs.

2. In the View menu, select Health > All Storage VMs.

3. Select Show/Hide to remove any columns that you do not want in the report.

4. Drag the “State” column near the “Storage VM” column.

5. Click the filter icon, add the following filter, and then click Apply Filter:

◦ State is Stopped

6. Save the view with a specific name that reflects what the view is showing, for example “Stopped SVMs”
and click the check mark ( ).

7. Click the Scheduled Reports button on the inventory page.

8. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

9. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to investigate why the SVM is stopped to see if you
should restart the stopped SVMs.

Customizing volume relationship reports

The Volume Relationships Inventory report enables you to analyze the storage inventory
details in a cluster, understand the degree of protection that is required for volumes, and
filter the volume details based on source of failure, pattern, and schedules.

Creating a report to group volume relationships by source of failure

You can create a report that groups volumes by the reason the relationship is in an
unhealthy state.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view that groups volumes by source of failure, and then schedule a
report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Volumes.

2. In the View menu, select Relationship > All Relationships.

3. Select Show/Hide to make sure the “Relationship Health” and “Unhealthy Reason” columns appear in the
view.
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Add or remove other columns to create a view that is important for your report.

4. Drag the “Relationship Health” and “Unhealthy Reason” columns near the “State” column.

5. Click the filter icon, add the following filter, and then click Apply Filter:

◦ Relationship health is bad

6. Click the top of the “Unhealthy Reason” column to group the volume relationships by source of failure.

7. Save the view with a specific name that reflects what the view is showing, for example, “Vol relationships
by failure”.

8. Click the Scheduled Reports button on the inventory page.

9. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you can investigate the source and impact of each type of failure.

Creating a report to group volume relationships by issue

You can create a report that groups volume relationships by issue.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view that groups volume relationships by issue, and then schedule
a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Volumes.

2. In the View menu, select Relationship > All Relationships.

3. Select Show/Hide to remove any columns you do not want in the report.

4. Drag the “Unhealthy Reason” column near the “State” column.

5. Click the top of the “Unhealthy Reason” column to group the volumes by issue.

6. Save the view with a specific name that reflects what the view is showing, for example, “Vol relationships
by issue”.

7. Click the Scheduled Reports button on the inventory page.

8. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you can investigate the source and impact of each type of issue.
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Creating a report to view volume transfer trends at specific time intervals

You can create a report that displays volume transfer trends at specific time intervals.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view for volumes at specific time intervals, and then schedule a
report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Volumes.

2. In the View menu, select Relationship > Last 1 month Transfer Status.

3. Select Show/Hide to remove any columns you do not want in the report.

4. Drag the Transfer Duration column near the “Operational Result” column.

5. Click the filter icon, add the following filter, and then click Apply Filter:

◦ Transfer End Time in the last 7 Days

6. Click the top of the “Transfer Duration” column to sort the volumes by time interval.

7. Save the view with a specific name that reflects what the view is showing, for example “Volumes by
duration”.

8. Click the Scheduled Reports button on the inventory page.

9. Enter a name for the report schedule, set the frequency as Weekly, and complete the other report fields,
then click the check mark ( ) at the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you can investigate the transfer time intervals.

Creating a report to view failed or successful volume transfer

You can create a report that displays the status of volume transfers. You can view both
failed and successful volume transfers in this report.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view to show which transfers failed and which were successful, and
then schedule a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Volumes.

2. In the View menu, select Relationship > Last 1 month Transfer Status.

3. Select Show/Hide to remove any columns that you do not want in the report.

4. Drag the “Operation Result” column near the “State” column.
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5. Click the top of the “Opeateration Result” column to sort the volumes by the status.

6. Save the view with a specific name that reflects what the view is showing, for example “Volumes by
transfer status”.

7. Click the Scheduled Reports button on the inventory page.

8. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you can investigate the transfer status.

Creating a report to view volume transfers based on transfer size

You can create a report to view volume transfers based on transfer size.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view for volume transfers based on transfer size, and then schedule
a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Volumes.

2. In the View menu, select Relationship > Last 1 month Transfer Rate.

3. Click the top of the “Total Transfer Size” column to sort the volume transfers by size.

4. Save the view with a specific name that reflects what the view is showing, for example “Volumes by
transfer size”.

5. Click the Scheduled Reports button on the inventory page.

6. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you can investigate the volume relationships by transfer size.

Creating a report to view volume transfers grouped by day

You can create a report to view volume transfers grouped by day.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view for volume transfers grouped by day, and then schedule a
report to be generated for that view.

Steps
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1. In the left navigation pane, click Storage > Volumes.

2. In the View menu, select Relationship > Last 1 month Transfer Rate.

3. Click the top of the “Day” column to sort the volume transfers by day.

4. Save the view with a specific name that reflects what the view is showing, for example “Volume transfers
by day”.

5. Click the Scheduled Reports button on the inventory page.

6. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you can investigate the volume transfers by day.

Customizing volume performance reports

These sample custom reports are used to help you identify and respond to potential
problems related to volume performance.

Creating a report to view volumes with a high amount of cold data on an aggregate that is not
FabricPool-enabled

You can create a report to display volumes with a high amount of cold data on a non-
FabricPool aggregate. This can help you identify volumes that should be moved to a
FabricPool aggregate.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to create a custom view for volumes with a high amount of cold data on a non-
FabricPool-enabled aggregate, and then schedule a report to be generated for that view.

Steps

1. In the left navigation pane, click Storage > Volumes.

2. In the View menu, select Performance > All Volumes.

3. Select Show/Hide to make sure the “Disk Type” column appears in the view.

Add or remove other columns to create a view that is important for your report.

4. Drag the “Disk Type” column near the “Cold Data” column.

5. Click the filter icon, add the following filter, and then click Apply Filter:

◦ Cold Data greater than 100 GB

◦ Disk Type contains SSD

6. Click the top of the “Disk Type” column to sort the volumes by disk type so that the disk type SSD
(FabricPool) is at the bottom.

7. Save the view with a specific name that reflects what the view is showing, for example “Cold data vols not
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FabricPool”.

8. Click the Scheduled Reports button on the inventory page.

9. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you can find volumes that are good candidates to be moved to
FabricPool aggregates.

Sample Microsoft Excel reports

These sample Microsoft Excel reports are intended to introduce reporting options
available using Excel advanced features.

The advanced functionality of Excel can create a wide array of reports specific to your needs. For full
information on how to use Excel, see the product documentation.

You must have the Application Administrator or Storage Administrator role to manage reports.

Creating a report to show an aggregate capacity table and chart

You can create a report to analyze capacity in an Excel file by using summed totals and
the clustered column chart format.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to open a Health: All Aggregates view, download the view in Excel, create an available
capacity chart, upload the customized Excel file, and schedule the final report.

Steps

1. In the left navigation pane, click Storage > Aggregates.

2. Select Reports > Download Excel.
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Depending on your browser, you might need to click OK to save the file.

3. If needed, click Enable Editing.

4. In Excel, open the downloaded file.

5. Create a new sheet ( ) after the data sheet and name it Total Data Capacity.

6. Add the following columns on the new Total Data Capacity sheet:

a. Total Data Capacity (GB)

b. Committed Capacity (GB)

c. Used Data Capacity (GB)

d. Available Data Capacity (GB)

7. In the first row of each column, enter the following formula, making sure that it references the data sheet
(data!), and references the correct column and row specifiers for the data captured (Total Data Capacity
pulls data from column E, rows 2 through 20).

a. =SUM(data!E$2:data!E$20)

b. =SUM(data!F$2:data!F$50)

c. =SUM(data!G$2:data!G$50)

d. =SUM(data!H$2:data!H$50)

The formula totals each column based on the current data.

1. On the data sheet, select the Total Data Capacity (GB) and Committed Capacity (GB) columns.

2. Select Recommended Charts from the Insert menu and select the Clustered Column chart.

3. Right-click the chart and select Move chart to move the chart to the Total Data Capacity sheet.

4. Using the Design and Format menus, which are available when the chart is selected, you can customize
how the chart looks.

5. When satisfied, save the file with your changes. Do not change the file name or location.
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6. In Unified Manager, select Reports > Upload Excel.

Make sure you are in the same view where you downloaded the Excel file.

7. Select the Excel file you have modified.

8. Click Open.

9. Click Submit.

A check mark appears beside the Reports > Upload Excel menu item.

10. Click Scheduled Reports.

11. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

Select the XLSX format for the report.

12. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.
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Based on the results shown in the report, you might want to investigate how to best use the available capacity
across your network.

Creating a report to show aggregate total versus available capacity charts

You can create a report to analyze storage total and committed capacity in an Excel chart
format.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to open a Health: All Aggregates view, download the view in Excel, create a total and
committed capacity chart, upload the customized Excel file, and schedule the final report.

Steps

1. In the left navigation pane, click Storage > Aggregates.

2. Select Reports > Download Excel.

Depending on your browser, you might need to click OK to save the file.

3. In Excel, open the downloaded file.

4. If needed, click Enable Editing.

5. On the data sheet, right-click the Type column and select Sort > Sort A to Z.
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This will arrange your data by storage type, such as:

◦ HDD

◦ Hybrid

◦ SSD

◦ SSD (FabricPool)

6. Select the Type, Total Data Capacity, and Available Data Capacity columns.

7. On the Insert menu, select a 3-D column chart.

The chart appears on the data sheet.
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8. Right-click the chart and select Move Chart.

9. Select New sheet and name the sheet Total Storage Charts.

Make sure the new sheet appears after the info and data sheets.

10. Name the chart title Total versus Available Capacity.

11. Using the Design and Format menus, available when the chart is selected, you can customize how the
chart looks.

12. When satisfied, save the file with your changes. Do not change the file name or location.

13. In Unified Manager, select Reports > Upload Excel.
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Make sure you are in the same view where you downloaded the Excel file.

14. Select the Excel file you have modified.

15. Click Open.

16. Click Submit.

A check mark appears beside the Reports > Upload Excel menu item.

17. Click Scheduled Reports.

18. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

Select the XLSX format for the report.

19. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to balance the load on your aggregates.

Creating a report to view available volume capacity charts

You can create a report to analyze available volume capacity in an Excel chart.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to open a Health: All Volumes view, download the view in Excel, create an available
capacity chart, upload the customized Excel file, and schedule the final report.

Steps

1. In the left navigation pane, click Storage > Volumes.

2. Select Reports > Download Excel.
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Depending on your browser, you might need to click OK to save the file.

3. If needed, click Enable Editing.

4. In Excel, open the downloaded file.

5. On the data sheet, select the data that you want to use in the Volume and Available Data % columns.

6. On the Insert menu, select a 3-D piechart.

The chart shows which volumes have the largest available space. The chart appears on the data sheet.

Depending on your network configuration, selecting the entire columns or too many data
rows might make your pie chart unreadable. This sample uses the 3-D pie chart, but you can
use any chart type. Use the chart that best displays the data you want to capture.

7. Name the chart title Available Capacity.

8. Right-click the chart and select Move Chart.

9. Select New sheet and name the sheet Storage Volume Charts.

Make sure the new sheet appears after the info and data sheets.
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10. Using the Design and Format menus, available when the chart is selected, you can customize how the
chart looks.

11. When satisfied, save the file with your changes.

12. In Unified Manager, select Reports > Upload Excel.

Make sure you are in the same view where you downloaded the Excel file.

13. Select the Excel file you have modified.

14. Click Open.

15. Click Submit.

A check mark appears beside the Reports > Upload Excel menu item.

16. Click Scheduled Reports.

17. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

18. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

Select the XLSX format for the report.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to balance the load on your volumes.

Creating a report to view aggregates that have the most available IOPS

This report shows which aggregates have the most available IOPS per aggregate type on
which you can provision new workloads.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to open a Health: All Volumes view, download the view in Excel, create an available
capacity chart, upload the customized Excel file, and schedule the final report.
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Steps

1. In the left navigation pane, click Storage > Aggregates.

2. Select Performance: All Aggregates from the View drop-down.

3. Select Show/Hide to show the Available IOPS column and hide the Cluster FQDN, Inactive

Data Reporting, and Threshold Policy columns.

4. Drag and drop the Available IOPS and Free Capacity columns next to the Type column.

5. Name and save the custom view Available IOPS Per Aggr.

6. Select Reports > Download Excel.

Depending on your browser, you might need to click OK to save the file.

7. If needed, click Enable Editing.

8. In Excel, open the downloaded file.

9. On the data sheet, click the little triangle at the top-left of the sheet to select the entire sheet.

10. On the Data ribbon, select Sort from the Sort & Filter area.

11. Set the following sort levels:

a. Specify the Sort by as Available IOPS (IOPS), the Sort On as Cell Values, and the Order as

Largest to Smallest.

b. Click Add Level.

c. Specify the Sort by as Type, the Sort On as Cell Values, and the Order as Z to A.

d. Click Add Level.

e. Specify the Sort by as Free Capacity (GB), the Sort On as Cell Values, and the Order as

Largest to Smallest.

f. Click OK.

12. Save and close the Excel file.

13. In Unified Manager, select Reports > Upload Excel.

Make sure you are in the same view where you downloaded the Excel file.

14. Select the Excel file you have modified, in this case performance-aggregates-<date>.xlsx.
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15. Click Open.

16. Click Submit.

A check mark appears beside the Reports > Upload Excel menu item.

17. Click Scheduled Reports.

18. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

19. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

Select the XLSX format for the report.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to provision new workloads on the aggregates that
have the greatest available IOPS.
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