
Sample Microsoft Excel reports
Active IQ Unified Manager 9.14
NetApp
March 05, 2024

This PDF was generated from https://docs.netapp.com/us-en/active-iq-unified-
manager/reporting/task_create_report_to_view_capacity.html on March 05, 2024. Always check
docs.netapp.com for the latest.



Table of Contents

Sample Microsoft Excel reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1

Creating a report to show an aggregate capacity table and chart . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1

Creating a report to show aggregate total versus available capacity charts . . . . . . . . . . . . . . . . . . . . . . . . . .  3

Creating a report to view available volume capacity charts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  7

Creating a report to view aggregates that have the most available IOPS . . . . . . . . . . . . . . . . . . . . . . . . . . . .  9



Sample Microsoft Excel reports

These sample Microsoft Excel reports are intended to introduce reporting options
available using Excel advanced features.

The advanced functionality of Excel can create a wide array of reports specific to your needs. For full
information on how to use Excel, see the product documentation.

You must have the Application Administrator or Storage Administrator role to manage reports.

Creating a report to show an aggregate capacity table and
chart

You can create a report to analyze capacity in an Excel file by using summed totals and
the clustered column chart format.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to open a Health: All Aggregates view, download the view in Excel, create an available
capacity chart, upload the customized Excel file, and schedule the final report.

Steps

1. In the left navigation pane, click Storage > Aggregates.

2. Select Reports > Download Excel.

Depending on your browser, you might need to click OK to save the file.

3. If needed, click Enable Editing.

4. In Excel, open the downloaded file.

5. Create a new sheet ( ) after the data sheet and name it Total Data Capacity.

6. Add the following columns on the new Total Data Capacity sheet:

a. Total Data Capacity (GB)
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b. Committed Capacity (GB)

c. Used Data Capacity (GB)

d. Available Data Capacity (GB)

7. In the first row of each column, enter the following formula, making sure that it references the data sheet
(data!), and references the correct column and row specifiers for the data captured (Total Data Capacity
pulls data from column E, rows 2 through 20).

a. =SUM(data!E$2:data!E$20)

b. =SUM(data!F$2:data!F$50)

c. =SUM(data!G$2:data!G$50)

d. =SUM(data!H$2:data!H$50)

The formula totals each column based on the current data.

1. On the data sheet, select the Total Data Capacity (GB) and Committed Capacity (GB) columns.

2. Select Recommended Charts from the Insert menu and select the Clustered Column chart.

3. Right-click the chart and select Move chart to move the chart to the Total Data Capacity sheet.

4. Using the Design and Format menus, which are available when the chart is selected, you can customize
how the chart looks.

5. When satisfied, save the file with your changes. Do not change the file name or location.

6. In Unified Manager, select Reports > Upload Excel.

Make sure you are in the same view where you downloaded the Excel file.

7. Select the Excel file you have modified.

8. Click Open.
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9. Click Submit.

A check mark appears beside the Reports > Upload Excel menu item.

10. Click Scheduled Reports.

11. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

Select the XLSX format for the report.

12. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to investigate how to best use the available capacity
across your network.

Creating a report to show aggregate total versus available
capacity charts

You can create a report to analyze storage total and committed capacity in an Excel chart
format.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to open a Health: All Aggregates view, download the view in Excel, create a total and
committed capacity chart, upload the customized Excel file, and schedule the final report.

Steps

1. In the left navigation pane, click Storage > Aggregates.

2. Select Reports > Download Excel.
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Depending on your browser, you might need to click OK to save the file.

3. In Excel, open the downloaded file.

4. If needed, click Enable Editing.

5. On the data sheet, right-click the Type column and select Sort > Sort A to Z.

This will arrange your data by storage type, such as:

◦ HDD

◦ Hybrid

◦ SSD

◦ SSD (FabricPool)

6. Select the Type, Total Data Capacity, and Available Data Capacity columns.
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7. On the Insert menu, select a 3-D column chart.

The chart appears on the data sheet.

8. Right-click the chart and select Move Chart.

9. Select New sheet and name the sheet Total Storage Charts.

Make sure the new sheet appears after the info and data sheets.

10. Name the chart title Total versus Available Capacity.

11. Using the Design and Format menus, available when the chart is selected, you can customize how the
chart looks.

12. When satisfied, save the file with your changes. Do not change the file name or location.
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13. In Unified Manager, select Reports > Upload Excel.

Make sure you are in the same view where you downloaded the Excel file.

14. Select the Excel file you have modified.

15. Click Open.

16. Click Submit.

A check mark appears beside the Reports > Upload Excel menu item.

17. Click Scheduled Reports.

18. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

Select the XLSX format for the report.

19. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.
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The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to balance the load on your aggregates.

Creating a report to view available volume capacity charts

You can create a report to analyze available volume capacity in an Excel chart.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to open a Health: All Volumes view, download the view in Excel, create an available
capacity chart, upload the customized Excel file, and schedule the final report.

Steps

1. In the left navigation pane, click Storage > Volumes.

2. Select Reports > Download Excel.

Depending on your browser, you might need to click OK to save the file.

3. If needed, click Enable Editing.

4. In Excel, open the downloaded file.

5. On the data sheet, select the data that you want to use in the Volume and Available Data % columns.

6. On the Insert menu, select a 3-D piechart.

The chart shows which volumes have the largest available space. The chart appears on the data sheet.

Depending on your network configuration, selecting the entire columns or too many data
rows might make your pie chart unreadable. This sample uses the 3-D pie chart, but you can
use any chart type. Use the chart that best displays the data you want to capture.

7. Name the chart title Available Capacity.

8. Right-click the chart and select Move Chart.
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9. Select New sheet and name the sheet Storage Volume Charts.

Make sure the new sheet appears after the info and data sheets.

10. Using the Design and Format menus, available when the chart is selected, you can customize how the
chart looks.

11. When satisfied, save the file with your changes.

12. In Unified Manager, select Reports > Upload Excel.

Make sure you are in the same view where you downloaded the Excel file.

13. Select the Excel file you have modified.

14. Click Open.

15. Click Submit.

A check mark appears beside the Reports > Upload Excel menu item.

16. Click Scheduled Reports.

17. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

18. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
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the end of the row.

Select the XLSX format for the report.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.

Based on the results shown in the report, you might want to balance the load on your volumes.

Creating a report to view aggregates that have the most
available IOPS

This report shows which aggregates have the most available IOPS per aggregate type on
which you can provision new workloads.

What you’ll need

• You must have the Application Administrator or Storage Administrator role.

Use the following steps to open a Health: All Volumes view, download the view in Excel, create an available
capacity chart, upload the customized Excel file, and schedule the final report.

Steps

1. In the left navigation pane, click Storage > Aggregates.

2. Select Performance: All Aggregates from the View drop-down.

3. Select Show/Hide to show the Available IOPS column and hide the Cluster FQDN, Inactive

Data Reporting, and Threshold Policy columns.

4. Drag and drop the Available IOPS and Free Capacity columns next to the Type column.

5. Name and save the custom view Available IOPS Per Aggr.

6. Select Reports > Download Excel.

Depending on your browser, you might need to click OK to save the file.

7. If needed, click Enable Editing.
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8. In Excel, open the downloaded file.

9. On the data sheet, click the little triangle at the top-left of the sheet to select the entire sheet.

10. On the Data ribbon, select Sort from the Sort & Filter area.

11. Set the following sort levels:

a. Specify the Sort by as Available IOPS (IOPS), the Sort On as Cell Values, and the Order as

Largest to Smallest.

b. Click Add Level.

c. Specify the Sort by as Type, the Sort On as Cell Values, and the Order as Z to A.

d. Click Add Level.

e. Specify the Sort by as Free Capacity (GB), the Sort On as Cell Values, and the Order as

Largest to Smallest.

f. Click OK.

12. Save and close the Excel file.

13. In Unified Manager, select Reports > Upload Excel.

Make sure you are in the same view where you downloaded the Excel file.

14. Select the Excel file you have modified, in this case performance-aggregates-<date>.xlsx.

15. Click Open.

16. Click Submit.

A check mark appears beside the Reports > Upload Excel menu item.

17. Click Scheduled Reports.

18. Click Add Schedule to add a new row to the Report Schedules page so that you can define the schedule
characteristics for the new report.

19. Enter a name for the report schedule and complete the other report fields, then click the check mark ( ) at
the end of the row.

Select the XLSX format for the report.

The report is sent immediately as a test. After that, the report generates and is sent by email to the
recipients listed using the specified frequency.
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Based on the results shown in the report, you might want to provision new workloads on the aggregates that
have the greatest available IOPS.
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