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Release notes

What’s new

Learn what’s new with BlueXP cloud ops.

7 December 2020

Navigation between Cloud Manager and Spot

It’s now easier to navigate between Cloud Manager and Spot.

A new Storage Operations section in Spot enables you to navigate directly to Cloud Manager. After you’re

done, you can get back to Spot from the Compute tab in Cloud Manager.

18 October 2020

Introducing the Compute service

By leveraging Spot’s Cloud Analyzer, Cloud Manager can now provide a high-level cost analysis of your cloud

compute spending and identify potential savings. This information is available from the Compute service in

Cloud Manager.

Learn more about the Compute service.
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Get started

Learn about BlueXP cloud ops

By leveraging Spot’s Cloud Analyzer service, BlueXP can provide a high-level cost

analysis of your cloud compute spending and identify potential savings.

Cloud Analyzer is a cloud infrastructure management solution that uses advanced analytics to provide visibility

and insights into your cloud costs. It shows you where you can optimize those costs and lets you implement

that optimization using Spot’s portfolio of continuous optimization products in just a few clicks.

Features

• A cost analysis that shows current cost for the month, projected monthly costs, and missed savings

• A view of spend efficiency by account, including the estimated additional savings

• A link to Spot’s Cloud Analyzer for more in-depth details about the spending for all accounts

Supported cloud providers

This service is supported with AWS.

Cost

There’s no cost to use this service through BlueXP.

How Cloud Analyzer works with BlueXP

At a high-level, Cloud Analyzer integration with BlueXP works like this:

1. You click Extensions > Cloud ops and connect your AWS management account.

2. NetApp configures your environment as follows:

a. Creates an organization in the Spot platform.

b. Sends an email welcoming you to Spot.

You can log in to the Spot service using the same single-sign on credentials that you use with BlueXP.

c. Cloud Analyzer starts processing your AWS account data.

3. In BlueXP, the cloud ops page refreshes and you use the information to gain insights on past, current, and

future cloud costs.

4. You click Get Full Analysis at any time to go to Spot’s Cloud Analyzer, which provides a full analysis of

your cloud spend and savings opportunities.

Data security

Cloud Analyzer data is encrypted at rest and no credentials are stored for any account.
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Connect your AWS account

Connect Cloud Analyzer to your AWS payer account so that you can start optimizing your

cloud compute costs.

Steps

1. From the navigation menu, select Extensions > Cloud ops.

2. Click Add AWS Credentials to Start.

3. Follow the steps on the page to connect your AWS account:

a. Log in to your AWS management account.

b. Set up cost and usage reports on the AWS account.

c. Run the CloudFormation template.

d. Paste the Spot RoleARN.

View more details about these steps.

Result

Cloud Analyzer starts processing your AWS account data. If you have multiple accounts, Cloud Analyzer starts

with read-only capabilities for all linked accounts under the management account. If you want to get more

details about the potential savings for those accounts, then you’ll need to connect them, as well. You can find
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more details about connecting accounts when you analyze your compute costs.
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Analyze your compute costs

After you connect your account, you can view a cost analysis directly from BlueXP and

then click a link to get a full analysis from Cloud Analyzer.

View a cost analysis

View an analysis of your cloud compute costs to get insights into past, current, and future cloud costs.

Steps

1. Click Extensions > Cloud ops.

2. View the cost analysis to gain insights into your compute costs.

Month to date cost

The total cost of your workloads from the beginning of the current month to present.

Projected Costs

The forecasted cost at the end of the month based on analysis of your usage pattern.

Last Week Missed Savings

Savings that could have been achieved in the previous seven days using optimization of spot instances and

reservations.

Top AWS Account Spend Efficiency

The top 10 accounts according to the greatest amount of estimated additional savings.

Each account is assigned an efficiency score based on current and additional potential savings. The
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estimated additional savings indicates how much can be further saved by leveraging the use of spot and

reserved instances.

You can take the following actions to further optimize your accounts:

• View details: View your cost optimization opportunities by going to Spot’s Cloud Analyzer.

• Connect: Connect an account that is not yet managed. You will be directed to the wizard that connects

the account.

Top AWS Accounts

This is a bar graph showing your top ten accounts by cost. The graph is based on the last 30 days of spend

activity.

Learn more about the Cost Analysis page that’s available in Spot’s Cloud Analyzer.

Get a full analysis

Go to Cloud Analyzer for more analysis and recommendations.

Click Get Full Analysis at any time to access more charts and analysis, in-depth recommendations, a use

case optimization breakdown (containers, ElasticApps, and reservations), and more.

Here’s an example of what you’ll see in Cloud Analyzer:

• View the product page for Cloud Analyzer to learn more about its capabilities

• View the documentation for Spot to get help using Cloud Analyzer
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Knowledge and support

Register for support

Support registration is required to receive technical support specific to BlueXP and its

storage solutions and services. Support registration is also required to enable key

workflows for Cloud Volumes ONTAP systems.

Registering for support does not enable NetApp support for a cloud provider file service. For technical support

related to a cloud provider file service, its infrastructure, or any solution using the service, refer to "Getting

help" in the BlueXP documentation for that product.

• Amazon FSx for ONTAP

• Azure NetApp Files

• Cloud Volumes Service for Google Cloud

Support registration overview

There are two forms of registration to activate support entitlement:

• Registering your BlueXP account ID support subscription (your 20 digit 960xxxxxxxxx serial number

located on the Support Resources page in BlueXP).

This serves as your single support subscription ID for any service within BlueXP. Each BlueXP account-

level support subscription must be registered.

• Registering the Cloud Volumes ONTAP serial numbers associated with a subscription in your cloud

provider’s marketplace (these are 20 digit 909201xxxxxxxx serial numbers).

These serial numbers are commonly referred to as PAYGO serial numbers and get generated by BlueXP at

the time of Cloud Volumes ONTAP deployment.

Registering both types of serial numbers enables capabilities like opening support tickets and automatic case

generation. Registration is completed by adding NetApp Support Site (NSS) accounts to BlueXP as described

below.

Register your BlueXP account for NetApp support

To register for support and activate support entitlement, one user in your BlueXP account must associate a

NetApp Support Site account with their BlueXP login. How you register for NetApp support depends on

whether you already have a NetApp Support Site (NSS) account.

Existing customer with an NSS account

If you’re a NetApp customer with an NSS account, you simply need to register for support through BlueXP.

Steps

1. In the upper right of the BlueXP console, select the Settings icon, and select Credentials.

2. Select User Credentials.
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3. Select Add NSS credentials and follow the NetApp Support Site (NSS) Authentication prompt.

4. To confirm that the registration process was successful, select the Help icon, and select Support.

The Resources page should show that your account is registered for support.

Note that other BlueXP users will not see this same support registration status if they have not associated

a NetApp Support Site account with their BlueXP login. However, that doesn’t mean that your BlueXP

account is not registered for support. As long as one user in the account has followed these steps, then

your account has been registered.

Existing customer but no NSS account

If you’re an existing NetApp customer with existing licenses and serial numbers but no NSS account, you need

to create an NSS account and associate it with your BlueXP login.

Steps

1. Create a NetApp Support Site account by completing the NetApp Support Site User Registration form

a. Be sure to select the appropriate User Level, which is typically NetApp Customer/End User.

b. Be sure to copy the BlueXP account serial number (960xxxx) used above for the serial number field.

This will speed up the account processing.

2. Associate your new NSS account with your BlueXP login by completing the steps under Existing customer

with an NSS account.

Brand new to NetApp

If you are brand new to NetApp and you don’t have an NSS account, follow each step below.

Steps

1. In the upper right of the BlueXP console, select the Help icon, and select Support.
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2. Locate your account ID serial number from the Support Registration page.

3. Navigate to NetApp’s support registration site and select I am not a registered NetApp Customer.

4. Fill out the mandatory fields (those with red asterisks).

5. In the Product Line field, select Cloud Manager and then select your applicable billing provider.

6. Copy your account serial number from step 2 above, complete the security check, and then confirm that

you read NetApp’s Global Data Privacy Policy.

An email is immediately sent to the mailbox provided to finalize this secure transaction. Be sure to check

your spam folders if the validation email doesn’t arrive in few minutes.

7. Confirm the action from within the email.

Confirming submits your request to NetApp and recommends that you create a NetApp Support Site

account.

8. Create a NetApp Support Site account by completing the NetApp Support Site User Registration form

a. Be sure to select the appropriate User Level, which is typically NetApp Customer/End User.

b. Be sure to copy the account serial number (960xxxx) used above for the serial number field. This will

speed up the account processing.

After you finish

NetApp should reach out to you during this process. This is a one-time onboarding exercise for new users.

Once you have your NetApp Support Site account, associate the account with your BlueXP login by completing

the steps under Existing customer with an NSS account.

Associate NSS credentials for Cloud Volumes ONTAP support

Associating NetApp Support Site credentials with your BlueXP account is required to enable the following key

workflows for Cloud Volumes ONTAP:

• Registering pay-as-you-go Cloud Volumes ONTAP systems for support

Providing your NSS account is required to activate support for your system and to gain access to NetApp

technical support resources.

• Deploying Cloud Volumes ONTAP when you bring your own license (BYOL)

Providing your NSS account is required so that BlueXP can upload your license key and to enable the

subscription for the term that you purchased. This includes automatic updates for term renewals.

• Upgrading Cloud Volumes ONTAP software to the latest release

Associating NSS credentials with your BlueXP account is different than the NSS account that is associated

with a BlueXP user login.
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These NSS credentials are associated with your specific BlueXP account ID. Users who belong to the BlueXP

account can access these credentials from Support > NSS Management.

• If you have a customer-level account, you can add one or more NSS accounts.

• If you have a partner or reseller account, you can add one or more NSS accounts, but they can’t be added

alongside customer-level accounts.

Steps

1. In the upper right of the BlueXP console, select the Help icon, and select Support.

2. Select NSS Management > Add NSS Account.

3. When you’re prompted, select Continue to be redirected to a Microsoft login page.

NetApp uses Microsoft Entra ID as the identity provider for authentication services specific to support and

licensing.

4. At the login page, provide your NetApp Support Site registered email address and password to perform the

authentication process.

These actions enable BlueXP to use your NSS account for things like license downloads, software upgrade

verification, and future support registrations.

Note the following:

◦ The NSS account must be a customer-level account (not a guest or temp account). You can have

multiple customer-level NSS accounts.

◦ There can be only one NSS account if that account is a partner-level account. If you try to add

customer-level NSS accounts and a partner-level account exists, you’ll get the following error message:

"The NSS customer type is not allowed for this account as there are already NSS Users of different

type."

The same is true if you have pre-existing customer-level NSS accounts and try to add a partner-level

account.

◦ Upon successful login, NetApp will store the NSS user name.
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This is a system-generated ID that maps to your email. On the NSS Management page, you can

display your email from the  menu.

◦ If you ever need to refresh your login credential tokens, there is also an Update Credentials option in

the  menu.

Using this option prompts you to log in again. Note that the token for these accounts expire after 90

days. A notification will be posted to alert you of this.

Get help

NetApp provides support for BlueXP and its cloud services in a variety of ways. Extensive

free self-support options are available 24x7, such as knowledgebase (KB) articles and a

community forum. Your support registration includes remote technical support via web

ticketing.

Get support for a cloud provider file service

For technical support related to a cloud provider file service, its infrastructure, or any solution using the service,

refer to "Getting help" in the BlueXP documentation for that product.

• Amazon FSx for ONTAP

• Azure NetApp Files

• Cloud Volumes Service for Google Cloud

To receive technical support specific to BlueXP and its storage solutions and services, use the support options

described below.

Use self-support options

These options are available for free, 24 hours a day, 7 days a week:

• Documentation

The BlueXP documentation that you’re currently viewing.

• Knowledge base

Search through the BlueXP knowledge base to find helpful articles to troubleshoot issues.

• Communities

Join the BlueXP community to follow ongoing discussions or create new ones.

Create a case with NetApp support

In addition to the self-support options above, you can work with a NetApp Support specialist to resolve any

issues after you activate support.

Before you get started
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• To use the Create a Case capability, you must first associate your NetApp Support Site credentials with

your BlueXP login. Learn how to manage credentials associated with your BlueXP login.

• If you’re opening a case for an ONTAP system that has a serial number, then your NSS account must be

associated with the serial number for that system.

Steps

1. In BlueXP, select Help > Support.

2. On the Resources page, choose one of the available options under Technical Support:

a. Select Call Us if you’d like to speak with someone on the phone. You’ll be directed to a page on

netapp.com that lists the phone numbers that you can call.

b. Select Create a Case to open a ticket with a NetApp Support specialist:

▪ Service: Select the service that the issue is associated with. For example, BlueXP when specific to

a technical support issue with workflows or functionality within the service.

▪ Working Environment: If applicable to storage, select Cloud Volumes ONTAP or On-Prem and

then the associated working environment.

The list of working environments are within scope of the BlueXP account, workspace, and

Connector you have selected in the top banner of the service.

▪ Case Priority: Choose the priority for the case, which can be Low, Medium, High, or Critical.

To learn more details about these priorities, hover your mouse over the information icon next to the

field name.

▪ Issue Description: Provide a detailed description of your problem, including any applicable error

messages or troubleshooting steps that you performed.

▪ Additional Email Addresses: Enter additional email addresses if you’d like to make someone else

aware of this issue.

▪ Attachment (Optional): Upload up to five attachments, one at a time.

Attachments are limited to 25 MB per file. The following file extensions are supported: txt, log, pdf,

jpg/jpeg, rtf, doc/docx, xls/xlsx, and csv.
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After you finish

A pop-up will appear with your support case number. A NetApp Support specialist will review your case and get

back to you soon.

For a history of your support cases, you can select Settings > Timeline and look for actions named "create

support case." A button to the far right lets you expand the action to see details.

It’s possible that you might encounter the following error message when trying to create a case:

"You are not authorized to Create a Case against the selected service"

This error could mean that the NSS account and the company of record it’s associated with is not the same

company of record for the BlueXP account serial number (ie. 960xxxx) or the working environment serial

number. You can seek assistance using one of the following options:

• Use the in-product chat

• Submit a non-technical case at https://mysupport.netapp.com/site/help
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Manage your support cases (Preview)

You can view and manage active and resolved support cases directly from BlueXP. You can manage the cases

associated with your NSS account and with your company.

Case management is available as a Preview. We plan to refine this experience and add enhancements in

upcoming releases. Please send us feedback by using the in-product chat.

Note the following:

• The case management dashboard at the top of the page offers two views:

◦ The view on the left shows the total cases opened in the past 3 months by the user NSS account you

provided.

◦ The view on the right shows the total cases opened in the past 3 months at your company level based

on your user NSS account.

The results in the table reflect the cases related to the view that you selected.

• You can add or remove columns of interest and you can filter the contents of columns like Priority and

Status. Other columns provide just sorting capabilities.

View the steps below for more details.

• At a per-case level, we offer the ability to update case notes or close a case that is not already in Closed or

Pending Closed status.

Steps

1. In BlueXP, select Help > Support.

2. Select Case Management and if you’re prompted, add your NSS account to BlueXP.

The Case management page shows open cases related to the NSS account that is associated with your

BlueXP user account. This is the same NSS account that appears at the top of the NSS management

page.

3. Optionally modify the information that displays in the table:

◦ Under Organization’s cases, select View to view all cases associated with your company.

◦ Modify the date range by choosing an exact date range or by choosing a different time frame.
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◦ Filter the contents of the columns.

◦
Change the columns that appear in the table by selecting  and then choosing the columns that

you’d like to display.
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4. Manage an existing case by selecting  and selecting one of the available options:

◦ View case: View full details about a specific case.

◦ Update case notes: Provide additional details about your problem or select Upload files to attach up

to a maximum of five files.

Attachments are limited to 25 MB per file. The following file extensions are supported: txt, log, pdf,

jpg/jpeg, rtf, doc/docx, xls/xlsx, and csv.

◦ Close case: Provide details about why you’re closing the case and select Close case.
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Legal notices

Legal notices provide access to copyright statements, trademarks, patents, and more.

Copyright

https://www.netapp.com/company/legal/copyright/

Trademarks

NETAPP, the NETAPP logo, and the marks listed on the NetApp Trademarks page are trademarks of NetApp,

Inc. Other company and product names may be trademarks of their respective owners.

https://www.netapp.com/company/legal/trademarks/

Patents

A current list of NetApp owned patents can be found at:

https://www.netapp.com/pdf.html?item=/media/11887-patentspage.pdf

Privacy policy

https://www.netapp.com/company/legal/privacy-policy/

Open source

Notice files provide information about third-party copyright and licenses used in NetApp software.

Notice for BlueXP
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Copyright information

Copyright © 2024 NetApp, Inc. All Rights Reserved. Printed in the U.S. No part of this document covered by

copyright may be reproduced in any form or by any means—graphic, electronic, or mechanical, including

photocopying, recording, taping, or storage in an electronic retrieval system—without prior written permission

of the copyright owner.

Software derived from copyrighted NetApp material is subject to the following license and disclaimer:

THIS SOFTWARE IS PROVIDED BY NETAPP “AS IS” AND WITHOUT ANY EXPRESS OR IMPLIED

WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY

AND FITNESS FOR A PARTICULAR PURPOSE, WHICH ARE HEREBY DISCLAIMED. IN NO EVENT SHALL

NETAPP BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR

CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE

GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER

CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT

(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS

SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

NetApp reserves the right to change any products described herein at any time, and without notice. NetApp

assumes no responsibility or liability arising from the use of products described herein, except as expressly

agreed to in writing by NetApp. The use or purchase of this product does not convey a license under any

patent rights, trademark rights, or any other intellectual property rights of NetApp.

The product described in this manual may be protected by one or more U.S. patents, foreign patents, or

pending applications.

LIMITED RIGHTS LEGEND: Use, duplication, or disclosure by the government is subject to restrictions as set

forth in subparagraph (b)(3) of the Rights in Technical Data -Noncommercial Items at DFARS 252.227-7013

(FEB 2014) and FAR 52.227-19 (DEC 2007).

Data contained herein pertains to a commercial product and/or commercial service (as defined in FAR 2.101)

and is proprietary to NetApp, Inc. All NetApp technical data and computer software provided under this

Agreement is commercial in nature and developed solely at private expense. The U.S. Government has a non-

exclusive, non-transferrable, nonsublicensable, worldwide, limited irrevocable license to use the Data only in

connection with and in support of the U.S. Government contract under which the Data was delivered. Except

as provided herein, the Data may not be used, disclosed, reproduced, modified, performed, or displayed

without the prior written approval of NetApp, Inc. United States Government license rights for the Department

of Defense are limited to those rights identified in DFARS clause 252.227-7015(b) (FEB 2014).

Trademark information

NETAPP, the NETAPP logo, and the marks listed at http://www.netapp.com/TM are trademarks of NetApp, Inc.

Other company and product names may be trademarks of their respective owners.
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