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Release notes

What’s new with NetApp Workload Factory for Builders

Learn what’s new with the Builders capability of Workload Factory.

5 October 2025

BlueXP workload factory now NetApp Workload Factory

BlueXP has been renamed and redesigned to better reflect the role it has in managing your data infrastructure.

As a result, BlueXP workload factory has been renamed to NetApp Workload Factory.

16 June 2025

Clone support

You can now clone a project in BlueXP Workload Factory for Builders. When you clone a project, Builders

creates a new project from a snapshot, with the same configuration as the original. Cloning is useful for quickly

creating similar projects or for testing purposes. You can mount the new project clone by following the

instructions in Builders.

Manage versions of BlueXP Workload Factory for Builders projects

4 May 2025

Updated permissions terminology

The Workload Factory user interface and documentation now use "read-only" to refer to read permissions and

"read/write" to refer to automate permissions.

1 December 2024

Builders workload initial release

BlueXP Workload Factory for Builders simplifies software version consumption and access, eliminating the

need for custom tools or scripts. It enables you to consume software versions as instant clones integrated with

Perforce Helix Core as a convenient workspace for your development processes, saving time and resources.

The initial release includes the capability to manage projects and workspaces, and automate actions with

Codebox. You can also integrate Builders with Perforce Helix Core, so that you can manage different versions

of each project and switch between them quickly.

Known limitations of NetApp Workload Factory for Builders

Known limitations identify platforms, devices, or functions that are not supported by this

release of the product, or that do not interoperate correctly with it. Review these

limitations carefully.
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Operator permissions required

NetApp Workload Factory for Builders requires Operator permissions to function correctly.
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Get started

Learn about NetApp Workload Factory for Builders

NetApp Workload Factory for Builders is a rapid build environment creation tool for

software builders. It enables fast setup of personal development environments, saving

time and enabling self-service for developers while empowering DevOps teams to retain

control of the infrastructure. Using Builders, software developers can quickly create

workspaces without needing specialized data storage or understanding of the

development infrastructure.

What is NetApp Workload Factory for Builders?

NetApp Workload Factory for Builders is designed to streamline the way developers manage and interact with

different versions of their software. Builders integrates seamlessly with Perforce Helix Core to provide instant

clones of software versions, creating ready-to-use workspaces for development, QA, and CI/CD processes.

With Builders, you can easily create a project and assign a volume that represents your software environment

and its artifacts. As you update your software, you can take snapshots of the volume, capturing the state of

your software at that moment. This means you can access any version of your software instantly without the

need to resync with the version control system, saving valuable time and resources.

By leveraging ONTAP’s snapshot and clone capabilities, Builders enhances your development workflow,

allowing for rapid access to multiple versions of your software, accelerating development cycles, and helping to

reduce time to market.

For more information about Workload Factory, refer to the Workload Factory overview.

NetApp Workload Factory for Builders features

NetApp Workload Factory for Builders offers the following features:

• Create, edit, and remove projects

• Create snapshots of defined software versions

• Create, and delete workspaces (based on clones)

• Create access policies to control access to a project

• Analyze the capacity usage of each project

• Control clone size limits and clone retention for each project

• Integrate with version control systems such as Perforce

Projects and workspaces in Builders

When you use Builders, you create a project and assign a volume that represents your software environment

and its artifacts. Each time that you create a new version of the software, you need resync the volume data

and create a project snapshot to mark the volume state as a known version. The project source volume might

get rolling updates and have multiple snapshots to mark multiple versions. You can use each snapshot

immediately as an instant clone, a dedicated or shared editable repository available to developers, QA or build

processes. A clone in the context of a specific software version is a workspace.

4
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Operational modes in Workload Factory

Three different operational modes - basic, read-only and read/write - offer flexible options for deployment inside

and outside of Workload Factory. Gain immediate value at zero-trust in basic mode with code snippets for use

outside Workload Factory. Get incremental value with incremental trust in read-only and read/write modes.

Learn more about operational modes in Workload Factory.

Automation with Workload Factory Codebox

Workload factory introduces built-in automation with the Codebox. The Codebox offers the following

automation benefits:

• Code snippet generation: Infrastructure-as-Code (IaC) snippets are generated during resource creation,

enabling seamless integration with existing orchestration workflows.

• Infrastructure-as-code co-pilot: the Codebox is an Infrastructure-as-code (IaC) co-pilot that helps

developers and DevOps generate code to execute any operation supported by Workload Factory.

• Code viewer and automation catalog: the Codebox provides a code viewer for quick analysis of

automation and an automation catalog for quick future re-use.

Cost

There is no cost for using the Builders capability of Workload Factory.

Licensing

No special licenses are needed from NetApp to use the Builders capabilities of Workload Factory.

Regions

Builders is supported in all commercial regions where FSx for ONTAP is supported. View supported Amazon

regions.

The following AWS regions aren’t supported:

• China regions

• GovCloud (US) regions

• Secret Cloud

• Top Secret Cloud

Getting help

Amazon FSx for NetApp ONTAP is an AWS first-party solution. For questions or technical support issues

associated with your FSx for ONTAP file system, infrastructure, or any solution using this service, use the

Support Center in your AWS Management Console to open a support case with AWS. Select the “FSx for

ONTAP” service and appropriate category. Provide the remaining information required to create your AWS

support case.

For general questions about Workload Factory or Workload Factory applications and services, refer to Get help

for Builders for Workload Factory.
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Quick start for Builders

Get started creating a Builders project. Administrators and team leads can use Builders to

administer projects and workspaces for teams of developers.

 Log in to Workload Factory

You’ll need to set up an account with Workload Factory and log in using one of the console experiences.

 Add AWS credentials and permissions to your account

You can use Workload Factory in Basic mode without adding credentials to access your AWS account. Adding

AWS credentials to Workload Factory in either read-only or read/write mode gives your Workload Factory

account the permissions needed to create and manage FSx for ONTAP file systems, and to deploy and

manage Builders projects.

Learn how to add credentials and permissions.

 Set up your environment to meet Builders requirements

You’ll need a deployed and discovered FSx for ONTAP file system that contains at least one volume that has

been configured as an NFS share.

Learn more about Builders requirements.

 Integrate with other services

Integrate Builders with other services such as a service portal or Perforce Helix Core using the workload

Factory REST API.

Learn how to integrate Builders with Perforce.

What’s next

You can now create a project to provide fast and efficient management of code and artifacts to teams of

developers.

Builders requirements

Ensure that Workload Factory and AWS are set up properly before you begin using

NetApp Workload Factory for Builders. This includes having your AWS log in credentials,

a deployed FSx for ONTAP file system, and more.

Workload factory login and account

You’ll need to set up an account with Workload Factory and log in using one of the console experiences.

AWS credentials and permissions

You need to add AWS credentials to Workload Factory with read/write permissions, which means you’ll be

using Workload Factory in read/write mode for Builders.
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Basic mode and read-only mode permissions are not supported at this time.

Learn how to add AWS credentials to Workload Factory

FSx for ONTAP file system

You need a minimum of one FSx for ONTAP file system:

• The file system will be used by Builders to store the projects and workspaces that you create.

This FSx for ONTAP file system must use FlexVol volumes. FlexGroup volumes are not supported.

• You’ll need to know the AWS region, VPC, and subnet where the AWS FSx for ONTAP file system

resides.

• You’ll need at least one volume in the filesystem with the following configuration:

◦ The volume must be configured as an NFS share.

◦ The filesystem must be configured with a link. Learn more about links.

• You’ll need to consider the tag key/value pairs that you want to apply to the AWS resources that are part

of this deployment (optional).

Learn how to deploy and manage FSx for ONTAP file systems

Integrate Builders with Perforce

Integrate Builders with the Perforce Helix Visual Client (P4V) so that developers can

manage your workspaces using the Perforce CLI. This enables developers to quickly

switch between projects and workspaces, saving time during development.

Steps

1. Download the P4V integration file.

2. Open P4V and go to Tools > Manage Tools > HTML tabs.

3. Select Import HTML tabs.

4. Select the P4V integration XML file and select Import.

5. Go to View > Workload Factory.

Result

The NetApp Workload Factory for Builders web UI appears as an HTML tab within the P4V client.

What’s next?

Create an Amazon EC2 deployment plan using the migration advisor.
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Use Builders workloads

Manage Builders projects

You can manage Builders projects to control how your code and artifacts are managed for

each project in NetApp Workload Factory for Builders.

Create a project

You can create a new Builders project so that you can leverage the data protection features of your Amazon

FSX for NetApp ONTAP filesystem for your code and artifacts.

Steps

1. Log in to Workload Factory using one of the console experiences.

2. In the Builders tile, select Create project.

3. On the Create project page, provide the following:

a. Project name: Enter a name for the project.

b. Description: Enter a description for the project.

c. Filesystem: Provide the following:

i. Credentials: Select the Amazon AWS credentials to use. Builders uses these credentials to

discover FSx for ONTAP filesystems that you can use with this project and to create clones and

snapshots of projects.

ii. Region: Select the region that this FSx for ONTAP filesystem resides in.

iii. FSx for ONTAP filesystem: Select an FSx for ONTAP filesystem to use with this project.

You can only select filesystems that are configured with a link. Learn more about links.

iv. Choose a volume: Select a volume on which to store the project; Builders uses this volume as a

software repository.

You can only select volumes that are configured as an NFS share.

d. Operation policies: Provide limits for project clones:

i. Maximum retention in days: Enter the maximum number of days that a clone should be retained.

After this number of days, Workload Factory removes the clone.

ii. Maximum number of clones per user or group: Enter the maximum number of clones that can

be provisioned for a user or group.

iii. Maximum clone size in GiB: Enter the maximum size in GiB of a project clone.

e. Access policies: Explicitly grant project access to specific users or groups:

i. Policy enforcement scope: Enter single IP addresses or IP address ranges to limit project access

to only those IP addresses or ranges.

For example: 172.16.0.0/24

ii. User or group identifiers: Enter user or group identifiers to limit project access to only those users

or groups.
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For example: User1234

4. Select Create.

Result

The project is created, and appears in the list of projects on the Projects page.

View existing projects

You can view existing projects created in NetApp Workload Factory for Builders by following these steps.

Steps

1. Log in to Workload Factory using one of the console experiences.

2. In the Builders tile, select Go to Projects page.

3. View the existing projects listed on the Projects page.

Edit a project

You can edit the settings of a project at any time.

Steps

1. Log in to Workload Factory using one of the console experiences.

2. In the Builders tile, select Go to Projects page.

3. On the Projects page, select  for the project you want to edit.

4. Make any needed changes to the project configuration.

5. Select Save.

View a project’s workspaces

A clone or snapshot of a project is known as a workspace. When you create a workspace, it is retained for as

long as the project’s operation policy allows. You can view existing workspaces for a project by following these

steps.

Steps

1. Log in to Workload Factory using one of the console experiences.

2. In the Builders tile, select Go to Projects page.

3. On the Projects page, choose a project and select View.

4. View the status and details of all workspaces for this project.

5. If you see alerts or warnings for a workspace, hover over the alert or warning icon to see the reason.

Delete a project

You can delete a project when it is no longer needed by following these steps.

Steps

1. Log in to Workload Factory using one of the console experiences.

2. In the Builders tile, select Go to Projects page.
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3. On the Projects page, select  for the project you want to delete.

4. Select Delete.

5. In the confirmation dialog, select Delete.

Result

The project is deleted, and any code or artifacts associated with the project are deleted from the volume.

Snapshots and clones of the project are retained.

Manage versions of NetApp Workload Factory for Builders
projects

Work with different versions of your Builders projects by creating on-demand snapshots

and clones directly from Workload Factory. Snapshots and clones of a project are stored

in the filesystem that was associated with the project when it was created. You can also

manage snapshots and clones using the Workload Factory REST API.

Create a snapshot of a project

You can create a snapshot of a project by following these steps.

Steps

1. Log in to Workload Factory using one of the console experiences.

2. In the Builders tile, select Go to Projects page.

3. On the Projects page, select  for the project you want to snapshot.

4. In the resulting menu, select Create a snapshot.

5. In the Create snapshot dialog, choose a name for the snapshot and select Create.

Create a clone of a project

Clone a Builders project from a snapshot by following these steps. When you create a clone, a new editable

volume is created to contain the clone.

Steps

1. Log in to Workload Factory using one of the console experiences.

2. In the Builders tile, select Go to Projects page.

3. On the Projects page, select  for the project you want to clone.

4. In the resulting menu, select Create a clone.

5. In the Create clone dialog, do the following:

a. Enter a name for the clone.

The default name for the clone is the project name with a suffix of the current date and time.

b. Select a snapshot to use as the base for the clone.

c. Select Create.

Result
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Workload factory creates a new clone of the project, and the clone appears as a new project on the Projects

page.

Create a Builders workspace

A workspace in NetApp Workload Factory for Builders is a Perforce representation of a

project at a specific moment in time. Workspaces are created using a project snapshot as

a basis. You can create new workspaces within a Builders project. You can create

workspaces from the Perforce UI.

Before you begin

Ensure you have integrated Builders with the Perforce Helix Visual Client. See Integrate Builders with Perforce

for more information.

Steps

1. Log in to Perforce.

2. In the Perforce menu, select View > WF.

The Workload Factory login screen appears within the Perforce UI.

3. Log in to Workload Factory using one of the console experiences.

4. In the Builders workloads tile, select Create project.

5. Select Create workspace.

6. On the Create a workspace project page, provide the following:

a. Select a snapshot to use as a basis for the workspace.

b. Enter a name for the workspace.

c. Optionally, enter a user identifier to claim the workspace. This identifier should match the Perforce user

ID of the developer that will use this workspace.

7. Select Create.

Result

The workspace is created, and appears in the list of workspaces on the Workspaces page.

Automate Builders tasks with Codebox

You can automate project creation and data protection operations with Codebox.

Codebox is an infrastructure as code (IaC) co-pilot that helps you generate code to

execute any operations supported by Workload Factory.

Learn more about Codebox automation and how to use it.
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Knowledge and support

Register for support for NetApp Workload Factory for
Builders

Before you can open a support case with NetApp technical support, you need to add a

NetApp Support Site account to Workload Factory and then register for support.

Support registration is required to receive technical support specific to NetApp Workload Factory and its

storage solutions and services. You must register for support from the NetApp Console, which is a separate

web-based console from Workload Factory.

Registering for support does not enable NetApp support for a cloud provider file service. For technical support

related to a cloud provider file service, its infrastructure, or any solution using the service, refer to "Getting

help" in the Workload Factory documentation for that product.

Amazon FSx for ONTAP

Support registration overview

Registering your account ID support subscription (your 20 digit 960xxxxxxxxx serial number located on the

Support Resources page in the NetApp Console) serves as your single support subscription ID. Each NetApp

account-level support subscription must be registered.

Registering enables capabilities like opening support tickets and automatic case generation. Registration is

completed by adding NetApp Support Site (NSS) accounts to the NetApp Console as described below.

Register your account for NetApp support

To register for support and activate support entitlement, one user in your account must associate a NetApp

Support Site account with their NetApp Console login. How you register for NetApp support depends on

whether you already have a NetApp Support Site (NSS) account.

Existing customer with an NSS account

If you’re a NetApp customer with an NSS account, you simply need to register for support through the NetApp

Console.

Steps

1. In the upper right of the Workload Factory console, select Help > Support.

Selecting this option opens the NetApp Console in a new browser tab and loads the Support dashboard.

2. From the NetApp Console menu, select Administration, and then select Credentials.

3. Select User Credentials.

4. Select Add NSS credentials and follow the NetApp Support Site (NSS) Authentication prompt.

5. To confirm that the registration process was successful, select the Help icon, and select Support.

The Resources page should show that your account is registered for support.
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Note that other NetApp Console users will not see this same support registration status if they have not

associated a NetApp Support Site account with their NetApp Console login. However, that doesn’t mean

that your NetApp account is not registered for support. As long as one user in the account has followed

these steps, then your account has been registered.

Existing customer but no NSS account

If you’re an existing NetApp customer with existing licenses and serial numbers but no NSS account, you need

to create an NSS account and associate it with your NetApp Console login.

Steps

1. Create a NetApp Support Site account by completing the NetApp Support Site User Registration form

a. Be sure to select the appropriate User Level, which is typically NetApp Customer/End User.

b. Be sure to copy the NetApp account serial number (960xxxx) used above for the serial number field.

This will speed up the account processing.

2. Associate your new NSS account with your NetApp Console login by completing the steps under Existing

customer with an NSS account.

Brand new to NetApp

If you are brand new to NetApp and you don’t have an NSS account, follow each step below.

Steps

1. In the upper right of the Workload Factory console, select Help > Support.

Selecting this option opens the NetApp Console in a new browser tab and loads the Support dashboard.

2. Locate your account ID serial number from the Support Resources page.

3. Navigate to NetApp’s support registration site and select I am not a registered NetApp Customer.

4. Fill out the mandatory fields (those with red asterisks).

5. In the Product Line field, select Cloud Manager and then select your applicable billing provider.

6. Copy your account serial number from step 2 above, complete the security check, and then confirm that

you read NetApp’s Global Data Privacy Policy.

An email is immediately sent to the mailbox provided to finalize this secure transaction. Be sure to check

your spam folders if the validation email doesn’t arrive in few minutes.

7. Confirm the action from within the email.
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Confirming submits your request to NetApp and recommends that you create a NetApp Support Site

account.

8. Create a NetApp Support Site account by completing the NetApp Support Site User Registration form

a. Be sure to select the appropriate User Level, which is typically NetApp Customer/End User.

b. Be sure to copy the account serial number (960xxxx) used above for the serial number field. This will

speed up the account processing.

After you finish

NetApp should reach out to you during this process. This is a one-time onboarding exercise for new users.

Once you have your NetApp Support Site account, associate the account with your NetApp Console login by

completing the steps under Existing customer with an NSS account.

Get help with Builders

NetApp provides support for Workload Factory and its cloud services in a variety of ways.

Extensive free self-support options are available 24x7, such as knowledgebase (KB)

articles and a community forum. Your support registration includes remote technical

support via web ticketing.

Get support for FSx for ONTAP

For technical support related to FSx for ONTAP, its infrastructure, or any solution using the service, refer to

"Getting help" in the Workload Factory documentation for that product.

Amazon FSx for ONTAP

To receive technical support specific to Workload Factory and its storage solutions and services, use the

support options described below.

Use self-support options

These options are available for free, 24 hours a day, 7 days a week:

• Documentation

The Workload Factory documentation that you’re currently viewing.

• Knowledge base

Search through the Workload Factory knowledge base to find helpful articles to troubleshoot issues.

• Communities

Join the Workload Factory community to follow ongoing discussions or create new ones.

Create a case with NetApp support

In addition to the self-support options above, you can work with a NetApp Support specialist to resolve any

issues after you activate support.
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Before you get started

To use the Create a Case capability, you must first register for support. associate your NetApp Support Site

credentials with your Workload Factory login. Learn how to register for support.

Steps

1. In the upper right of the Workload Factory console, select Help > Support.

Selecting this option opens the NetApp Console in a new browser tab and loads the Support dashboard.

2. On the Resources page, choose one of the available options under Technical Support:

a. Select Call Us if you’d like to speak with someone on the phone. You’ll be directed to a page on

netapp.com that lists the phone numbers that you can call.

b. Select Create a Case to open a ticket with a NetApp Support specialist:

▪ Service: Select Workload Factory.

▪ Case Priority: Choose the priority for the case, which can be Low, Medium, High, or Critical.

To learn more details about these priorities, hover your mouse over the information icon next to the

field name.

▪ Issue Description: Provide a detailed description of your problem, including any applicable error

messages or troubleshooting steps that you performed.

▪ Additional Email Addresses: Enter additional email addresses if you’d like to make someone else

aware of this issue.

▪ Attachment (Optional): Upload up to five attachments, one at a time.

Attachments are limited to 25 MB per file. The following file extensions are supported: txt, log, pdf,

jpg/jpeg, rtf, doc/docx, xls/xlsx, and csv.
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After you finish

A pop-up will appear with your support case number. A NetApp Support specialist will review your case and get

back to you soon.

For a history of your support cases, you can select Settings > Timeline and look for actions named "create

support case." A button to the far right lets you expand the action to see details.

It’s possible that you might encounter the following error message when trying to create a case:

"You are not authorized to Create a Case against the selected service"

This error could mean that the NSS account and the company of record it’s associated with is not the same

company of record for the NetApp Console account serial number (ie. 960xxxx) or the system serial number.

You can seek assistance using one of the following options:

• Use the in-product chat

• Submit a non-technical case at https://mysupport.netapp.com/site/help
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Manage your support cases (Preview)

You can view and manage active and resolved support cases directly from the NetApp Console. You can

manage the cases associated with your NSS account and with your company.

Case management is available as a Preview. We plan to refine this experience and add enhancements in

upcoming releases. Please send us feedback by using the in-product chat.

Note the following:

• The case management dashboard at the top of the page offers two views:

◦ The view on the left shows the total cases opened in the past 3 months by the user NSS account you

provided.

◦ The view on the right shows the total cases opened in the past 3 months at your company level based

on your user NSS account.

The results in the table reflect the cases related to the view that you selected.

• You can add or remove columns of interest and you can filter the contents of columns like Priority and

Status. Other columns provide just sorting capabilities.

View the steps below for more details.

• At a per-case level, we offer the ability to update case notes or close a case that is not already in Closed or

Pending Closed status.

Steps

1. In the upper right of the Workload Factory console, select Help > Support.

Selecting this option opens the NetApp Console a new browser tab and loads the Support dashboard.

2. Select Case Management and if you’re prompted, add your NSS account to the NetApp Console.

The Case management page shows open cases related to the NSS account that is associated with your

NetApp Console user account. This is the same NSS account that appears at the top of the NSS

management page.

3. Optionally modify the information that displays in the table:

◦ Under Organization’s cases, select View to view all cases associated with your company.

◦ Modify the date range by choosing an exact date range or by choosing a different time frame.
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◦ Filter the contents of the columns.

◦ Change the columns that appear in the table by selecting [The plus icon that appears in the table] and

then choosing the columns that you’d like to display.

4. Manage an existing case by selecting [An icon with three dots that appears in the last column of the table]
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and selecting one of the available options:

◦ View case: View full details about a specific case.

◦ Update case notes: Provide additional details about your problem or select Upload files to attach up

to a maximum of five files.

Attachments are limited to 25 MB per file. The following file extensions are supported: txt, log, pdf,

jpg/jpeg, rtf, doc/docx, xls/xlsx, and csv.

◦ Close case: Provide details about why you’re closing the case and select Close case.
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Legal notices for NetApp Workload Factory for
Builders

Legal notices provide access to copyright statements, trademarks, patents, and more.

Copyright

https://www.netapp.com/company/legal/copyright/

Trademarks

NETAPP, the NETAPP logo, and the marks listed on the NetApp Trademarks page are trademarks of NetApp,

Inc. Other company and product names may be trademarks of their respective owners.

https://www.netapp.com/company/legal/trademarks/

Patents

A current list of NetApp owned patents can be found at:

https://www.netapp.com/pdf.html?item=/media/11887-patentspage.pdf

Privacy policy

https://www.netapp.com/company/legal/privacy-policy/

Open source

Notice files provide information about third-party copyright and licenses used in NetApp software.

NetApp Workload Factory
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Copyright information

Copyright © 2025 NetApp, Inc. All Rights Reserved. Printed in the U.S. No part of this document covered by

copyright may be reproduced in any form or by any means—graphic, electronic, or mechanical, including

photocopying, recording, taping, or storage in an electronic retrieval system—without prior written permission

of the copyright owner.

Software derived from copyrighted NetApp material is subject to the following license and disclaimer:

THIS SOFTWARE IS PROVIDED BY NETAPP “AS IS” AND WITHOUT ANY EXPRESS OR IMPLIED

WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY

AND FITNESS FOR A PARTICULAR PURPOSE, WHICH ARE HEREBY DISCLAIMED. IN NO EVENT SHALL

NETAPP BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR

CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE

GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER

CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT

(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS

SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

NetApp reserves the right to change any products described herein at any time, and without notice. NetApp

assumes no responsibility or liability arising from the use of products described herein, except as expressly

agreed to in writing by NetApp. The use or purchase of this product does not convey a license under any

patent rights, trademark rights, or any other intellectual property rights of NetApp.

The product described in this manual may be protected by one or more U.S. patents, foreign patents, or

pending applications.

LIMITED RIGHTS LEGEND: Use, duplication, or disclosure by the government is subject to restrictions as set

forth in subparagraph (b)(3) of the Rights in Technical Data -Noncommercial Items at DFARS 252.227-7013

(FEB 2014) and FAR 52.227-19 (DEC 2007).

Data contained herein pertains to a commercial product and/or commercial service (as defined in FAR 2.101)

and is proprietary to NetApp, Inc. All NetApp technical data and computer software provided under this

Agreement is commercial in nature and developed solely at private expense. The U.S. Government has a non-

exclusive, non-transferrable, nonsublicensable, worldwide, limited irrevocable license to use the Data only in

connection with and in support of the U.S. Government contract under which the Data was delivered. Except

as provided herein, the Data may not be used, disclosed, reproduced, modified, performed, or displayed

without the prior written approval of NetApp, Inc. United States Government license rights for the Department

of Defense are limited to those rights identified in DFARS clause 252.227-7015(b) (FEB 2014).

Trademark information

NETAPP, the NETAPP logo, and the marks listed at http://www.netapp.com/TM are trademarks of NetApp, Inc.

Other company and product names may be trademarks of their respective owners.
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