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Use Perforce integration

Learn about Perforce integration in NetApp Workload
Factory for EDA

Integrating Perforce with CI/CD pipelines enhances the development process by

automating builds, tests, and deployments, leading to faster and more reliable software

delivery.

Continuous Integration and Continuous Deployment (CI/CD) in EDA is a rapid build environment creation tool

for software builders. It enables fast setup of personal development environments, saving time and enabling

self-service for developers while empowering DevOps teams to retain control of the infrastructure. Using

CI/CD, software developers can quickly create workspaces without needing specialized data storage or

understanding of the development infrastructure.

What is CI/CD?

By using CI/CD, you can streamline the way developers manage and interact with different versions of their

software. It works with Perforce Helix Core to instantly clone software versions and create workspaces for

development, QA, and CI/CD.

You can easily create a project and assign a volume that represents your software environment and its

artifacts. As you update your software, you can take snapshots of the volume, capturing the state of your

software at that moment. You can access any software version instantly without resyncing, saving time and

resources.

Using the snapshot and clone capabilities of NetApp ONTAP, you can quickly access different versions of your

software, so you can develop and release updates faster. For more information about Workload Factory, refer

to the Workload Factory overview.

CI/CD features

• Create, edit, and remove projects. See Manage projects.

• Create snapshots of defined software versions. See Manage project versions.

• Create, and delete workspaces (based on clones). See Create a workspace.

• Create access policies to control access to a project.

• Analyze the capacity usage of each project.

• Control clone size limits and clone retention for each project.

• Integrate with version control systems such as Perforce. See Integrate with Perforce.

Projects and workspaces in EDA

You can create a project and assign a volume that represents your software environment and its artifacts. Each

time that you create a new version of the software, you need resync the volume data and create a project

snapshot to mark the volume state as a known version. The project source volume might get rolling updates

and have multiple snapshots to mark multiple versions. You can use each snapshot immediately as an instant

clone, a dedicated or shared editable repository available to developers, QA or build processes. A clone in the

context of a specific software version is a workspace.
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Automation with Workload Factory Codebox

Workload factory introduces built-in automation with the Codebox. The Codebox offers the following

automation benefits:

• Code snippet generation: Infrastructure-as-Code (IaC) snippets are generated during resource creation,

enabling seamless integration with existing orchestration workflows.

• Infrastructure-as-code co-pilot: the Codebox is an Infrastructure-as-code (IaC) co-pilot that helps

developers and DevOps generate code to execute any operation supported by Workload Factory.

• Code viewer and automation catalog: the Codebox provides a code viewer for quick analysis of

automation and an automation catalog for quick future re-use.

Cost

There is no cost for using the CI/CD capability of Workload Factory.

Licensing

No special licenses are needed from NetApp to use the CI/CD capabilities of Workload Factory.

Regions

EDA is supported in all commercial regions where FSx for ONTAP is supported. View supported Amazon

regions.

The following AWS regions aren’t supported:

• China regions

• GovCloud (US) regions

• Secret Cloud

• Top Secret Cloud

Getting help

Amazon FSx for NetApp ONTAP is an AWS first-party solution. For support, use the Support Center in your

AWS Management Console to open a case. Select "FSx for ONTAP" and the category, then provide the

required information.

For general questions about Workload Factory or Workload Factory applications and services, refer to Get help

for EDA for Workload Factory.

EDA requirements

Ensure that Workload Factory and AWS are set up properly before you use NetApp

Workload Factory for EDA. This includes having your AWS log in credentials, a deployed

FSx for ONTAP file system, and more.

Workload factory login and account

You’ll need to set up an account with Workload Factory and log in using one of the console experiences.
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AWS credentials and permissions

You need to add AWS credentials to Workload Factory with read/write permissions, which means you’ll be

using Workload Factory in read/write mode for EDA.

Basic mode and read-only mode permissions are not supported at this time.

AWS credentials are also required to use the latency monitoring feature, which collects

CloudWatch metrics for volume performance analysis. Learn about latency monitoring.

Learn how to add AWS credentials to Workload Factory

FSx for ONTAP file system

You need a minimum of one FSx for ONTAP file system:

• The file system will be used by EDA to store the projects and workspaces that you create.

This FSx for ONTAP file system must use FlexVol volumes. FlexGroup volumes are not supported.

• You’ll need to know the AWS region, VPC, and subnet where the AWS FSx for ONTAP file system

resides.

• You’ll need at least one volume in the filesystem with the following configuration:

◦ The volume must be configured as an NFS share.

◦ The filesystem must be configured with a link. Learn more about links.

• You’ll need to consider the tag key/value pairs that you want to apply to the AWS resources that are part

of this deployment (optional).

Learn how to deploy and manage FSx for ONTAP file systems

Manage EDA projects

You can manage EDA projects to control how your code and artifacts are managed for

each project in NetApp Workload Factory for EDA.

Create a project

You can create a new EDA project so that you can leverage the data protection features of your Amazon FSX

for NetApp ONTAP filesystem for your code and artifacts. .Steps

1. Log in using one of the console experiences.

2. Select the menu  and then select EDA.

3. Select CI/CD.

4. Select Create project.

5. On the Create project page, provide the following:

a. Project name: Enter a name for the project.

b. Description: Enter a description for the project.

c. Filesystem: Provide the following:
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i. Credentials: Select the Amazon AWS credentials to use. EDA uses these credentials to discover

FSx for ONTAP filesystems that you can use with this project and to create clones and snapshots

of projects.

ii. Region: Select the region that this FSx for ONTAP filesystem resides in.

iii. FSx for ONTAP filesystem: Select an FSx for ONTAP filesystem to use with this project.

You can only select filesystems that are configured with a link. Learn more about links.

iv. Choose a volume: Select a volume on which to store the project; EDA uses this volume as a

software repository.

You can only select volumes that are configured as an NFS share.

d. Operation policies: Provide limits for project clones:

i. Maximum retention in days: Enter the maximum number of days that a clone should be retained.

After this number of days, Workload Factory removes the clone.

ii. Maximum number of clones per user or group: Enter the maximum number of clones that can

be provisioned for a user or group.

iii. Maximum clone size in GiB: Enter the maximum size in GiB of a project clone.

e. Access policies: Explicitly grant project access to specific users or groups:

i. Policy enforcement scope: Enter single IP addresses or IP address ranges to limit project access

to only those IP addresses or ranges.

For example: 172.16.0.0/24

ii. User or group identifiers: Enter user or group identifiers to limit project access to only those users

or groups.

For example: User1234

6. Select Create.

Result

The project is created, and appears in the list of projects on the Projects page.

View existing projects

You can view existing projects created in NetApp Workload Factory for EDA by following these steps.

Steps

1. Log in using one of the console experiences.

2. Select the menu  and then select EDA.

3. Select CI/CD.

4. Select Go to Projects page.

5. View the existing projects listed on the Projects page.
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Edit a project

You can edit the settings of a project at any time.

Steps

1. Log in using one of the console experiences.

2. Select the menu  and then select EDA.

3. Select CI/CD.

4. Select Go to Projects page.

5. On the Projects page, select  for the project you want to edit.

6. Make any needed changes to the project configuration.

7. Select Save.

View a project’s workspaces

A clone or snapshot of a project is known as a workspace. When you create a workspace, it is retained for as

long as the project’s operation policy allows. You can view existing workspaces for a project by following these

steps.

Steps

1. Log in using one of the console experiences.

2. Select the menu  and then select EDA.

3. Select CI/CD.

4. Select Go to Projects page.

5. On the Projects page, choose a project and select View.

6. View the status and details of all workspaces for this project.

7. If you see alerts or warnings for a workspace, hover over the alert or warning icon to see the reason.

Delete a project

You can delete a project when it is no longer needed by following these steps.

Steps

1. Log in using one of the console experiences.

2. Select the menu  and then select EDA.

3. Select CI/CD.

4. Select Go to Projects page.

5. On the Projects page, select  for the project you want to delete.

6. Select Delete.

7. In the confirmation dialog, select Delete.

Result

The project is deleted, and any code or artifacts associated with the project are deleted from the volume.

Snapshots and clones of the project are retained.
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Manage versions of NetApp Workload Factory for EDA
projects

Work with different versions of your EDA projects by creating on-demand snapshots and

clones directly from Workload Factory. Snapshots and clones of a project are stored in

the filesystem that was associated with the project when it was created. You can also

manage snapshots and clones using the Workload Factory REST API.

Create a snapshot of a project

You can create a snapshot of a project by following these steps.

Steps

1. Log in using one of the console experiences.

2. Select the menu  and then select EDA.

3. Select CI/CD.

4. Select Go to Projects page.

5. On the Projects page, select  for the project you want to snapshot.

6. In the resulting menu, select Create a snapshot.

7. In the Create snapshot dialog, choose a name for the snapshot and select Create.

Create a clone of a project

Clone an EDA project from a snapshot by following these steps. When you create a clone, a new editable

volume is created to contain the clone.

Steps

1. Log in using one of the console experiences.

2. Select the menu  and then select EDA.

3. Select CI/CD.

4. Select Go to Projects page.

5. On the Projects page, select  for the project you want to clone.

6. In the resulting menu, select Create a clone.

7. In the Create clone dialog, do the following:

a. Enter a name for the clone.

The default name for the clone is the project name with a suffix of the current date and time.

b. Select a snapshot to use as the base for the clone.

c. Select Create.

Result

Workload factory creates a new clone of the project, and the clone appears as a new project on the Projects

page.
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Create an EDA workspace

A workspace in NetApp Workload Factory for EDA is a Perforce representation of a

project at a specific moment in time. Workspaces are created using a project snapshot as

a basis. You can create new workspaces within an EDA project. You can create

workspaces from the Perforce UI.

Before you begin

Ensure you have integrated EDA with the Perforce Helix Visual Client. See Integrate EDA with Perforce for

more information.

Steps

1. Log in to Perforce.

2. In the Perforce menu, select View > WF.

The Workload Factory login screen appears within the Perforce UI.

3. Log in using one of the console experiences.

4. Select the menu  and then select EDA.

5. Select CI/CD.

6. Select Create project and then select Create workspace.

7. On the Create a workspace project page, provide the following:

a. Select a snapshot to use as a basis for the workspace.

b. Enter a name for the workspace.

c. Optionally, enter a user identifier to claim the workspace. This identifier should match the Perforce user

ID of the developer that will use this workspace.

8. Select Create.

Result

The workspace is created, and appears in the list of workspaces on the Workspaces page.

Automate EDA workload tasks with Codebox

You can automate project creation and data protection operations with Codebox.

Codebox is an infrastructure as code (IaC) co-pilot that helps you generate code to

execute any operations supported by Workload Factory.

Learn more about Codebox automation and how to use it.

Integrate EDA with Perforce

Integrate EDA with the Perforce Helix Visual Client (P4V) so that developers can manage

your workspaces using the Perforce CLI. This enables developers to quickly switch

between projects and workspaces, saving time during development.

Steps
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1. Download the P4V integration file.

2. Open P4V and go to Tools > Manage Tools > HTML tabs.

3. Select Import HTML tabs.

4. Select the P4V integration XML file and select Import.

5. Go to View > Workload Factory.

Result

The NetApp Workload Factory for EDA web UI appears as an HTML tab within the P4V client.

What’s next?

Create an Amazon EC2 deployment plan using the migration advisor.
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