問題
VSC、VASA Provider、SRA仮想アプライアンスのIPアドレスを変更したあと、VSCインターフェイスを使用して特定の操作を実行するとエラーが表示されます。たとえば、データストアを削除しようとしたときやESXiホストのVASA Providerサーバにアクセスしようとしたときです。
原因
vCenter Serverが、更新されたIPアドレスではなく、古いIPアドレスを使用してVASA Providerを呼び出しています。
対処方法
VSC、VASA Provider、SRA仮想アプライアンスのIPアドレスを変更する場合は、次の手順に従ってください。
- vCenter ServerからVSCの登録を解除します。
- https://<vcenter_ip>/mobにアクセスします。
- をクリックします。
- puttyを使用して、rootとしてvCenter Serverにログインします。
- 次のコマンドを使用して、vsphere-client-serenityディレクトリに移動します。cd /etc/vmware/vsphere-client/vc-packages/vsphere-client-serenity
- 次のコマンドを使用して、vSphere Clientサービスを停止します。 vsphere-client stop
- 次のコマンドを入力して、UI拡張機能が含まれているディレクトリを削除します。rm -rf com.netapp*
- 次のコマンドを使用して、vSphere Clientサービスを起動します。vsphere-client start
vSphere Clientが再起動して正常に初期化されるまで数分かかることがあります。
- 次のコマンドを使用して、vsphere-ui serenityディレクトリに移動します。 /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/
- 次のコマンドを使用して、vSphere UIサービスを停止します。vsphere-ui stop
- 次のコマンドを入力して、UI拡張機能が含まれているディレクトリを削除します。rm -rf com.netapp*
- 次のコマンドを使用して、vSphere UIを起動します。service-control --start vsphere-ui