适用于现有用户的 VSC、VASA Provider 和 SRA 部署工作流

Virtual Storage Console (VSC)、VASA Provider 和 Storage Replication Adapter (SRA) 虚拟设备 9.x 版支持原位升级到最新版本。

早期版本的应用程序(例如 VSC、VASA Provider 和 SRA)分别使用不同的升级过程。如果您的设置中安装了 VSC、VASA Provider 或 SRA,则应执行以下操作:
  1. 部署最新版的 VSC、VASA Provider 和 SRA 虚拟设备。
  2. 迁移任何现有配置数据。

    此配置数据包括存储系统凭据以及 kaminoprefs.xmlvscPreferences.xml 文件中的首选项。

配置 VSC 首选项文件

在许多情况下,您可能不需要迁移配置数据。但是,如果您先前自定义了首选项文件,则可能需要查看它们并对新部署的虚拟设备进行类似的更改。可以执行以下操作之一:

如果您要从 VASA Provider 6.X 升级,则应在升级之前取消注册 VASA Provider。有关更多详细信息,请参见当前版本的文档。

如果您还需要从 SRA 4.0 或更早版本升级:

对于任何 SRA 升级,应从 Site Recovery Manager 服务器中删除 SRA 软件(Site Recovery Manager 服务器上使用 .msi 文件安装的适配器)。您可以使用 Windows 系统控制面板卸载此软件,然后在 SRA 服务器上使用 .msi 文件安装最新的 SRA 软件。

如果您已部署 VASA Provider,则在从现有设置升级后,必须使用编辑设置选项将虚拟设备的内存大小配置为 12 GB。此外,还必须修改预留的虚拟内存大小。要修改此内存大小,必须关闭虚拟机

如果 VSC、VASA Provider 和 SRA 您在设置中安装了虚拟设备 7.2 或 7.2.1 版,则无法直接升级到虚拟设备 9.7.1 版。您必须先将现有设置升级到虚拟设备 9.7 版 VSC、VASA Provider 和 SRA ,然后再升级到 9.7.1 版。

如果要部署最新版本的虚拟设备,必须参见VSC、VASA Provider 和 SRA 虚拟设备的部署要求主题。有关执行原位升级的信息、请参见升级到 VSC、VASA Provider 和 SRA 虚拟设备 9.6 版主题。