仮想マシンのプロビジョニングが不明なエラーで失敗する

vVolデータストアでの仮想マシンのプロビジョニング処理(作成、クローニング、電源オン、電源オフ、一時停止、移行、サスペンド、VMストレージ プロファイルの更新など)が失敗し、タスク マネージャに一般的なエラー メッセージが表示されるだけでVASA ProviderとVMwareのどちらの問題かが示されないことがあります。

問題

タスク マネージャに「No suitable volume was found amongst the candidate volumes for the specified requirements.」などのエラー メッセージが表示されます。

原因

VMware、VASA Provider、またはONTAPストレージの問題が原因でエラーが発生することがあります。エラー メッセージにはエラーの具体的な原因が表示されない場合があります。多数のStorage Virtual Machine(SVM)、ボリューム、LUNを含む大規模なストレージ システムが原因の場合もあります。このようなストレージ システムではバックグラウンドでの定期的な検出処理に時間がかかり、仮想マシンのプロビジョニング処理が同時に実行された場合にプロビジョニング処理がタイムアウトする可能性があります。

対処方法

  1. ログ ファイル/opt/netapp/vpserver/logs/error.logvvolvp.log、およびzapi_error.logを調べて、問題がVASA ProviderとONTAPストレージのどちらに関係しているかを確認します。
    • NaException com.netapp.offtap3.ontap.ApiFailedException: No suitable volume was found amongst the candidate volumes for the specified requirements. Details: Vvol Placement: Type: place Candidate Volumes: Vvol_nfs_pb2, Vvol_nfs_pb1 Performance: Greatest IOPS Size: 4GB Space Guaranteed: false Volumes with insufficient unpromised IOPS: Vvol_nfs_pb1, Vvol_nfs_pb2 Result: success (errno=13001)」などのエラーが報告された場合は、ストレージ管理者と協力してストレージのIOPSを増やすなどの対処策を実行する必要があります。
    • プロビジョニング処理は、バックグラウンドで検出処理が実行されていないときにのみ実行する必要があります。

    VASA Providerのログ ファイルに報告されているエラーが具体的でない場合は、テクニカル サポートに連絡して問題を解決する必要があります。

  2. VASA Providerのログ ファイルに該当するエラーが報告されていない場合は、sps.logログ ファイルを調べて、問題がVMwareに関連するかどうかを確認し、報告されているエラーを基に適切な対処策を実行します。

    sps.logログ ファイルに報告されているエラーが具体的でない場合は、VMware管理者に連絡して問題を解決する必要があります。