部署 ONTAP 工具的注意事项和要求

在部署适用于 VMware vSphere 的 ONTAP 工具之前,最好先对此部署进行规划,并确定希望如何在环境中配置 ONTAP 工具。

下表简要介绍了在部署 ONTAP 工具之前应考虑的事项。

注意事项 说明
首次部署 ONTAP 工具 部署 ONTAP 工具会自动安装 VSC 功能。

部署或升级适用于 VMware vSphere 的 ONTAP® 工具

适用于 VMware vSphere 的 ONTAP 工具的新用户部署工作流

从现有 VSC 部署升级 从现有 VSC 部署升级到 ONTAP 工具的过程取决于 VSC 的版本以及是否已部署 ONTAP 工具。有关详细信息,请参见部署工作流和升级部分。

适用于现有用户的 ONTAP 工具部署工作流

升级前最佳实践:

  • 您应记录有关所使用的存储系统及其凭据的信息。

    升级完成后,您应确认已自动发现所有存储系统,并且这些存储系统具有正确的凭据。

  • 如果您先前修改了任何标准 VSC 角色,则应复制这些角色以保存所做的更改。

    每次重新启动 VSC 服务时,VSC 都会使用当前默认值覆盖这些标准角色。

重新为 VSC 生成 SSL 证书 部署 ONTAP 工具时,系统会自动生成 SSL 证书。要创建站点专用的证书,您可能需要重新生成 SSL 证书。

为 Virtual Storage Console 重新生成 SSL 证书

设置 ESXi 服务器值 虽然默认情况下,大多数 ESXi 服务器值都已设置,但最好检查一下这些值。这些值基于内部测试得出。您可能需要根据具体环境更改某些值以提高性能。
子操作系统超时值 子操作系统(子 OS)超时脚本用于为受支持的 Linux、Solaris 和 Windows 子操作系统设置 SCSI I/O 超时值,以确保可以正确地进行故障转移。

下表简要介绍了配置 ONTAP 工具的要求。

注意事项 说明
基于角色的访问控制 (RBAC) 的要求 VSC 既支持 vCenter Server RBAC,又支持 ONTAP RBAC。

用于向 vCenter Server 注册 VSC(使用 https://<appliance_ip>:8143/Register.html)的帐户必须是 vCenter Server 管理员(已分配给 vCenter Server 管理员或管理员角色)。如果您计划以管理员身份运行 VSC,则必须具有执行所有任务所需的所有权限和特权。

如果公司要求您限制对 vSphere 对象的访问,您可以为用户创建并分配标准 VSC 角色,以满足 vCenter Server 的要求。

您可以使用随 ONTAP 工具提供的 JSON 文件通过 ONTAP System Manager 创建建议的 ONTAP 角色。

如果用户尝试在没有适当特权和权限的情况下执行某项任务,任务选项会变为灰色。

ONTAP 版本 存储系统必须运行 ONTAP 9.3、9.5、9.6、9.7、9.8P1 或更高版本。
存储功能配置文件 要使用存储功能配置文件或设置警报,您必须启用适用于 ONTAP 的 VASA Provider。启用 VASA Provider 后,您可以配置 VMware 虚拟卷 (Virtual Volume, vVol) 数据存储库,并且可以创建和管理存储功能配置文件以及警报。

当卷或聚合容量接近全满或数据存储库不再符合关联存储功能配置文件时,警报功能将向您发出警告。