English

1. Configure Management Switches: NetApp HCI with Anthos

Contributors netapp-dorianh Download PDF of this topic

Cisco Nexus 3048 switches are used in this deployment procedure to provide 1Gbps connectivity for in and out-of-band management of the compute and storage nodes. These steps begin after the switches have been racked, powered, and put through the initial setup process. To configure the switches to provide management connectivity to the infrastructure, complete the following steps:

Enable Advanced Features for Cisco Nexus

Run the following commands on each Cisco Nexus 3048 switch to configure advanced features:

  1. Enter configuration mode.

    Switch-01# configure terminal
  2. Enable VLAN functionality.

    Switch-01(config)# feature interface-vlan
  3. Enable LACP.

    Switch-01(config)# feature lacp
  4. Enable virtual port channels (vPCs).

    Switch-01(config)# feature vpc
  5. Set the global port-channel load-balancing configuration.

    Switch-01(config)# port-channel load-balance src-dst ip-l4port
  6. Perform the global spanning-tree configuration.

    Switch-01(config)# spanning-tree port type network default
    Switch-01(config)# spanning-tree port type edge bpduguard default

Configure Ports on the Switch for In-Band Management

  1. Run the following commands to create VLANs for management purposes.

    Switch-01(config)# vlan 2
    Switch-01(config-vlan)# Name Native_VLAN
    Switch-01(config-vlan)# vlan 16
    Switch-01(config-vlan)# Name OOB_Network
    Switch-01(config-vlan)# vlan 3480
    Switch-01(config-vlan)# Name MGMT_Network
    Switch-01(config-vlan)# exit
  2. Configure the ports ETH1/29-32 as VLAN trunk ports that connect to management interfaces on each HCI storage node.

    Switch-01(config)# int eth 1/29
    Switch-01(config-if)# description HCI-STG-01 PortA
    Switch-01(config-if)# switchport mode trunk
    Switch-01(config-if)# switchport trunk native vlan 2
    Switch-01(config-if)# switchport trunk allowed vlan 3480
    Switch-01(config-if)# spanning tree port type edge trunk
    Switch-01(config-if)# int eth 1/30
    Switch-01(config-if)# description HCI-STG-02 PortA
    Switch-01(config-if)# switchport mode trunk
    Switch-01(config-if)# switchport trunk native vlan 2
    Switch-01(config-if)# switchport trunk allowed vlan 3480
    Switch-01(config-if)# spanning tree port type edge trunk
    Switch-01(config-if)# int eth 1/31
    Switch-01(config-if)# description HCI-STG-03 PortA
    Switch-01(config-if)# switchport mode trunk
    Switch-01(config-if)# switchport trunk native vlan 2
    Switch-01(config-if)# switchport trunk allowed vlan 3480
    Switch-01(config-if)# spanning tree port type edge trunk
    Switch-01(config-if)# int eth 1/32
    Switch-01(config-if)# description HCI-STG-04 PortA
    Switch-01(config-if)# switchport mode trunk
    Switch-01(config-if)# switchport trunk native vlan 2
    Switch-01(config-if)# switchport trunk allowed vlan 3480
    Switch-01(config-if)# spanning tree port type edge trunk
    Switch-01(config-if)# exit

Configure Ports on the Switch for Out-of-Band Management

  1. Run the following commands to configure the ports for cabling the IPMI interfaces on each HCI node.

    Switch-01(config)# int eth 1/13
    Switch-01(config-if)# description HCI-CMP-01 IPMI
    Switch-01(config-if)# switchport mode access
    Switch-01(config-if)# switchport access vlan 16
    Switch-01(config-if)# spanning-tree port type edge
    Switch-01(config-if)# int eth 1/14
    Switch-01(config-if)# description HCI-STG-01 IPMI
    Switch-01(config-if)# switchport mode access
    Switch-01(config-if)# switchport access vlan 16
    Switch-01(config-if)# spanning-tree port type edge
    Switch-01(config-if)# int eth 1/15
    Switch-01(config-if)# description HCI-STG-03 IPMI
    Switch-01(config-if)# switchport mode access
    Switch-01(config-if)# switchport access vlan 16
    Switch-01(config-if)# spanning-tree port type edge
    Switch-01(config-if)# exit
In the validated configuration, we cabled odd-node IPMI interfaces to Switch-01, and even-node IPMI interfaces to Switch-02.

Create a vPC Domain to Ensure Fault Tolerance

  1. Activate the ports used for the vPC peer-link between the two switches.

    Switch-01(config)# int eth 1/1
    Switch-01(config-if)# description vPC peer-link Switch-02 1/1
    Switch-01(config-if)# int eth 1/2
    Switch-01(config-if)# description vPC peer-link Switch-02 1/2
    Switch-01(config-if)# exit
  2. Perform the vPC global configuration.

    Switch-01(config)# vpc domain 1
    Switch-01(config-vpc-domain)# role priority 10
    Switch-01(config-vpc-domain)# peer-keepalive destination <switch-02_mgmt_address> source <switch-01_mgmt_address> vrf managment
    Switch-01(config-vpc-domain)# peer-gateway
    Switch-01(config-vpc-domain)# auto recovery
    Switch-01(config-vpc-domain)# ip arp synchronize
    Switch-01(config-vpc-domain)# int eth 1/1-2
    Switch-01(config-vpc-domain)# channel-group 10 mode active
    Switch-01(config-vpc-domain)# int Po10
    Switch-01(config-if)# description vPC peer-link
    Switch-01(config-if)# switchport mode trunk
    Switch-01(config-if)# switchport trunk native vlan 2
    Switch-01(config-if)# switchport trunk allowed vlan 16,3480
    Switch-01(config-if)# spanning-tree port type network
    Switch-01(config-if)# vpc peer-link
    Switch-01(config-if)# exit