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VSC, VASA Provider, and SRA 9.7

Error deleting a datastore after network settings are changed

Contributors netapp-asubhas

Issue

After changing the IP address of the virtual appliance for VSC, VASA Provider, and SRA, an error is displayed while using the VSC interface to perform certain operations. For example, deleting a datastore or trying to access VASA Provider server on ESXi host.

Cause

The vCenter Server does not use the updated IP address and continues to use the old IP address to make calls to VASA Provider.

Corrective action

When IP address of the virtual appliance for VSC, VASA Provider, and SRA changes, you should perform the following:

  1. Unregister VSC from vCenter Server.

  2. Access https://<vcenter_ip>/mob.

  3. Click Content  Extension Manager  Unregister Extension  Unregister all com.netapp.extensions.

  4. Log in to the vCenter Server as root using putty.

  5. Change to the vsphere-client-serenity directory using: cd /etc/vmware/vsphere-client/vc-packages/vsphere-client-serenity.

  6. Stop the vSphere Client: service using vsphere-client stop.

  7. Remove the directories containing the UI extensions: rm -rf com.netapp*

  8. Start the vSphere Client: service using vsphere-client start.

    This operation can take several minutes for the vSphere Client to restart and initialize correctly.

  9. Change to the vsphere-ui serenity directory using: /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/.

  10. Stop the vSphere UI: service using vsphere-ui stop.

  11. Remove the directories containing the UI extensions: rm -rf com.netapp*

  12. Start the vSphere UI using: service-control --start vsphere-ui.