본 한국어 번역은 사용자 편의를 위해 제공되는 기계 번역입니다. 영어 버전과 한국어 버전이 서로 어긋나는 경우에는 언제나 영어 버전이 우선합니다.

Cisco FC 스위치를 수동으로 구성합니다

기여자

MetroCluster 구성의 각 Cisco 스위치는 ISL 및 스토리지 연결에 맞게 적절히 구성해야 합니다.

Cisco FC 스위치에는 다음 요구사항이 적용됩니다.

  • 동일한 모델의 지원되는 Cisco 스위치 4개를 동일한 NX-OS 버전 및 라이센스로 사용해야 합니다.

  • MetroCluster 구성에는 4개의 스위치가 필요합니다.

    4개의 스위치는 각각 2개의 스위치로 구성된 2개의 Fabric에 연결되어야 하며 각 Fabric은 두 사이트를 포괄해야 합니다.

  • 스위치는 ATTO FiberBridge 모델에 대한 연결을 지원해야 합니다.

  • Cisco FC 스토리지 패브릭에서는 암호화 또는 압축을 사용할 수 없습니다. MetroCluster 구성에서는 지원되지 않습니다.

에 있습니다 "NetApp 상호 운용성 매트릭스 툴(IMT)"에서 스토리지 솔루션 필드를 사용하여 MetroCluster 솔루션을 선택할 수 있습니다. 부품 탐색기 * 를 사용하여 부품 및 ONTAP 버전을 선택하여 검색을 구체화합니다. 결과 표시 * 를 클릭하여 조건에 맞는 지원되는 설정 목록을 표시할 수 있습니다.

ISL(Inter-Switch Link) 연결에는 다음 요구 사항이 적용됩니다.

  • 모든 ISL은 하나의 Fabric에서 길이와 속도가 동일해야 합니다.

    다양한 Fabric에서 서로 다른 길이의 ISL을 사용할 수 있습니다. 모든 패브릭에서 동일한 속도를 사용해야 합니다.

스토리지 접속에는 다음 요구 사항이 적용됩니다.

  • 각 스토리지 컨트롤러에는 스위치 패브릭에 연결할 수 있는 4개의 이니시에이터 포트가 있어야 합니다.

    각 스토리지 컨트롤러에서 각 패브릭에 두 개의 이니시에이터 포트를 연결해야 합니다.

    참고

    다음 조건이 모두 충족될 경우 컨트롤러당 2개의 이니시에이터 포트(각 패브릭에 단일 이니시에이터 포트)를 사용하여 FAS8020, AFF8020, FAS8200, AFF A300 시스템을 구성할 수 있습니다.

    • 디스크 스토리지를 연결하는 데 사용할 수 있는 FC 이니시에이터 포트가 4개 이하이며 추가 포트를 FC 이니시에이터로 구성할 수 없습니다.

    • 모든 슬롯이 사용 가능하며 FC 이니시에이터 카드를 추가할 수 없습니다.

Cisco 스위치 라이센스 요구 사항

패브릭 연결 MetroCluster 구성의 Cisco 스위치에는 특정 기능 기반 라이센스가 필요할 수 있습니다. 이 라이센스를 사용하면 스위치에서 QoS 또는 장거리 모드 크레딧과 같은 기능을 사용할 수 있습니다. MetroCluster 구성의 4개 스위치 모두에 필요한 기능 기반 라이센스를 설치해야 합니다.

MetroCluster 구성에는 다음과 같은 기능 기반 라이센스가 필요할 수 있습니다.

  • Enterprise_PKG

    이 라이센스를 통해 Cisco 스위치에서 QoS 기능을 사용할 수 있습니다.

  • PORT_ACTIVATION_PKG

    Cisco 9148 스위치에 대해 이 라이센스를 사용할 수 있습니다. 이 라이센스를 사용하면 지정된 시간에 16개의 포트만 활성 상태인 경우 스위치에서 포트를 활성화하거나 비활성화할 수 있습니다. 기본적으로 16개의 포트가 Cisco MDS 9148 스위치에서 활성화됩니다.

  • fm_server_PKG

    이 라이센스를 통해 패브릭을 동시에 관리하고 웹 브라우저를 통해 스위치를 관리할 수 있습니다.

    FM_SERVER_PKG 라이선스는 성능 임계값과 임계값 모니터링 등의 성능 관리 기능도 지원합니다. 이 라이센스에 대한 자세한 내용은 Cisco Fabric Manager Server Package 를 참조하십시오.

show license usage 명령을 사용하여 라이센스가 설치되었는지 확인할 수 있습니다. 이러한 라이센스가 없는 경우 설치를 진행하기 전에 영업 담당자에게 문의하십시오.

참고 Cisco MDS 9250i 스위치에는 고정 1/10 GbE IP 스토리지 서비스 포트 2개가 있습니다. 이러한 포트에는 추가 라이센스가 필요하지 않습니다. Cisco SAN Extension over IP 애플리케이션 패키지는 FCIP 및 압축과 같은 기능을 활성화하는 이러한 스위치에 대한 표준 라이센스입니다.

Cisco FC 스위치를 공장 출하 시 기본값으로 설정

성공적인 구성을 위해서는 스위치를 공장 출하 시 기본값으로 설정해야 합니다. 이렇게 하면 스위치가 클린 구성에서 시작됩니다.

이 작업은 MetroCluster 구성의 모든 스위치에 대해 수행해야 합니다.

단계
  1. 콘솔을 연결하고 동일한 Fabric의 두 스위치에 로그인합니다.

  2. 스위치를 기본 설정으로 다시 설정합니다.

    쓰기 지우기

    명령을 확인하라는 메시지가 나타나면 ""y""를 응답할 수 있습니다. 그러면 스위치에 있는 모든 라이센스 및 구성 정보가 지워집니다.

  3. 스위치를 재부팅합니다.

    다시 로드

    명령을 확인하라는 메시지가 나타나면 ""y""를 응답할 수 있습니다.

  4. 다른 스위치에 대해 쓰기 지우기 및 다시 로드 명령을 반복합니다.

    'reload' 명령을 실행한 후 스위치가 재부팅된 다음 설정 질문을 표시합니다. 이 시점에서 다음 섹션으로 이동하십시오.

다음 예에서는 FC_SWITCH_A_1 및 FC_SWITCH_B_1로 구성된 패브릭의 프로세스를 보여 줍니다.

FC_Switch_A_1# write erase
    Warning: This command will erase the startup-configuration.
    Do you wish to proceed anyway? (y/n)  [n] y
    FC_Switch_A_1# reload
    This command will reboot the system. (y/n)?  [n] y

FC_Switch_B_1# write erase
    Warning: This command will erase the startup-configuration.
    Do you wish to proceed anyway? (y/n)  [n] y
    FC_Switch_B_1# reload
    This command will reboot the system. (y/n)?  [n] y

Cisco FC 스위치 기본 설정 및 커뮤니티 문자열을 구성합니다

'셋업' 명령이나 'reload' 명령어를 실행한 후 기본 설정을 지정해야 한다.

단계
  1. 스위치에 설정 질문이 표시되지 않으면 기본 스위치 설정을 구성합니다.

    셋업

  2. SNMP 커뮤니티 문자열을 입력하라는 메시지가 표시될 때까지 설정 질문에 대한 기본 응답을 수락합니다.

  3. ONTAP 상태 모니터에서 액세스할 수 있도록 커뮤니티 문자열을 ""public"(모두 소문자)로 설정합니다.

    커뮤니티 문자열을 ""public"" 이외의 값으로 설정할 수 있지만 지정한 커뮤니티 문자열을 사용하여 ONTAP 상태 모니터를 구성해야 합니다.

    다음 예에서는 FC_SWITCH_A_1의 명령을 보여 줍니다.

    FC_switch_A_1# setup
        Configure read-only SNMP community string (yes/no) [n]: y
        SNMP community string : public
        Note:  Please set the SNMP community string to "Public" or another value of your choosing.
        Configure default switchport interface state (shut/noshut) [shut]: noshut
        Configure default switchport port mode F (yes/no) [n]: n
        Configure default zone policy (permit/deny) [deny]: deny
        Enable full zoneset distribution? (yes/no) [n]: yes

    다음 예에서는 FC_SWITCH_B_1의 명령을 보여 줍니다.

    FC_switch_B_1# setup
        Configure read-only SNMP community string (yes/no) [n]: y
        SNMP community string : public
        Note:  Please set the SNMP community string to "Public" or another value of your choosing.
        Configure default switchport interface state (shut/noshut) [shut]: noshut
        Configure default switchport port mode F (yes/no) [n]: n
        Configure default zone policy (permit/deny) [deny]: deny
        Enable full zoneset distribution? (yes/no) [n]: yes

포트에 대한 라이센스를 획득하는 중입니다

연속 포트 범위에서 Cisco 스위치 라이센스를 사용할 필요가 없습니다. 대신 사용되는 특정 포트에 대한 라이센스를 취득하고 사용하지 않는 포트에서 라이센스를 제거할 수 있습니다.

스위치 구성에서 라이센스가 부여된 포트 수를 확인하고 필요한 경우 필요에 따라 라이센스를 한 포트에서 다른 포트로 이동해야 합니다.

단계
  1. 스위치 패브릭의 라이센스 사용량을 표시합니다.

    '포트-리소스 모듈 1

    라이센스가 필요한 포트를 확인합니다. 이러한 포트 중 일부는 라이센스가 부여되지 않은 경우 라이센스가 부여된 포트가 추가로 있는지 확인하고 해당 포트에서 라이센스를 제거하는 것이 좋습니다.

  2. 구성 모드 시작:

    구성

  3. 선택한 포트에서 라이센스를 제거합니다.

    1. 라이센스가 없는 포트를 선택합니다.

      interface_interface-name _

    2. 포트에서 라이센스를 제거합니다.

      항만 면허증 취득 안 함

    3. 포트 구성 인터페이스를 종료합니다.

      종료

  4. 선택한 포트에 대한 라이센스를 취득합니다.

    1. 라이센스가 없는 포트를 선택합니다.

      interface_interface-name _

    2. 포트를 라이센스를 획득할 수 있는 자격을 부여합니다.

      항만 사용권

    3. 포트에서 라이센스를 취득합니다.

      항만 사용권 취득

    4. 포트 구성 인터페이스를 종료합니다.

      종료

  5. 추가 포트에 대해서도 이 과정을 반복합니다.

  6. 구성 모드 종료:

    종료

포트에서 라이센스 제거 및 취득

이 예에서는 포트 FC1/2, 포트 FC1/1에서 라이센스가 제거되고 포트 FC1/1에서 라이센스가 획득되는 것을 보여 줍니다.

Switch_A_1# conf t
    Switch_A_1(config)# interface fc1/2
    Switch_A_1(config)# shut
    Switch_A_1(config-if)# no port-license acquire
    Switch_A_1(config-if)# exit
    Switch_A_1(config)# interface fc1/1
    Switch_A_1(config-if)# port-license
    Switch_A_1(config-if)# port-license acquire
    Switch_A_1(config-if)# no shut
    Switch_A_1(config-if)# end
    Switch_A_1# copy running-config startup-config

    Switch_B_1# conf t
    Switch_B_1(config)# interface fc1/2
    Switch_B_1(config)# shut
    Switch_B_1(config-if)# no port-license acquire
    Switch_B_1(config-if)# exit
    Switch_B_1(config)# interface fc1/1
    Switch_B_1(config-if)# port-license
    Switch_B_1(config-if)# port-license acquire
    Switch_B_1(config-if)# no shut
    Switch_B_1(config-if)# end
    Switch_B_1# copy running-config startup-config

다음 예에서는 포트 라이센스 사용이 확인되는 것을 보여 줍니다.

Switch_A_1# show port-resources module 1
    Switch_B_1# show port-resources module 1

Cisco MDS 9148 또는 9148S 스위치에서 포트 활성화

Cisco MDS 9148 또는 9148S 스위치의 경우 MetroCluster 구성에 필요한 포트를 수동으로 활성화해야 합니다.

이 작업에 대해
  • Cisco MDS 9148 또는 9148S 스위치에서 16개의 포트를 수동으로 활성화할 수 있습니다.

  • Cisco 스위치를 사용하면 포드 라이센스를 순서대로 적용하는 것이 아니라 임의의 포트에 적용할 수 있습니다.

  • 12개 이상의 포트가 필요하지 않은 경우 Cisco 스위치는 각 포트 그룹의 포트 하나를 사용해야 합니다.

단계
  1. Cisco 스위치에서 사용 가능한 포트 그룹을 봅니다.

    'How port-resources module_blade_number_'

  2. 포트 그룹에서 필요한 포트를 라이센스 및 취득합니다.

    구성

    'interface_port_number_'

    '산후트'

    항만 사용권 취득

    "닥쳐.

    예를 들어, 다음 명령 시퀀스 라이센스를 사용하여 포트 fc 1/45를 획득합니다.

    switch# config t
    switch(config)#
    switch(config)# interface fc 1/45
    switch(config-if)#
    switch(config-if)# shut
    switch(config-if)# port-license acquire
    switch(config-if)# no shut
    switch(config-if)# end
  3. 구성을 저장합니다.

    'copy running-config startup-config’를 선택합니다

Cisco FC 스위치에서 F 포트 구성

FC 스위치에서 F 포트를 구성해야 합니다.

MetroCluster 구성에서 F 포트는 스위치를 HBA 이니시에이터, FC-VI 상호 연결 및 FC-SAS 브리지에 연결하는 포트입니다.

각 포트는 개별적으로 구성해야 합니다.

다음 섹션을 참조하여 구성의 F-포트(스위치-노드)를 식별하십시오.

이 작업은 MetroCluster 구성의 각 스위치에 대해 수행해야 합니다.

단계
  1. 구성 모드 시작:

    구성

  2. 포트에 대한 인터페이스 구성 모드로 들어갑니다.

    'interface_port-ID_'

  3. 포트를 종료합니다.

    '허틀다운'

  4. 포트를 F 모드로 설정합니다.

    스치포트 모드 F

  5. 포트를 고정 속도로 설정합니다.

    'switchport speed_speed-value_'

    speed-value_ 는 8000이나 16000입니다

  6. 스위치 포트의 속도 모드를 Dedicated로 설정합니다.

    '위츠포트 속도 모드 전용’입니다

  7. 포트를 다시 시작합니다.

    "종료 안 함"

  8. 구성 모드 종료:

    "끝"

다음 예에서는 두 스위치의 명령을 보여 줍니다.

Switch_A_1# config  t
FC_switch_A_1(config)# interface fc 1/1
FC_switch_A_1(config-if)# shutdown
FC_switch_A_1(config-if)# switchport mode F
FC_switch_A_1(config-if)# switchport speed 8000
FC_switch_A_1(config-if)# switchport rate-mode dedicated
FC_switch_A_1(config-if)# no shutdown
FC_switch_A_1(config-if)# end
FC_switch_A_1# copy running-config startup-config

FC_switch_B_1# config  t
FC_switch_B_1(config)# interface fc 1/1
FC_switch_B_1(config-if)# switchport mode F
FC_switch_B_1(config-if)# switchport speed 8000
FC_switch_B_1(config-if)# switchport rate-mode dedicated
FC_switch_B_1(config-if)# no shutdown
FC_switch_B_1(config-if)# end
FC_switch_B_1# copy running-config startup-config

ISL과 동일한 포트 그룹의 F 포트에 버퍼 대 버퍼 크레딧을 할당합니다

ISL과 동일한 포트 그룹에 있는 경우 F 포트에 버퍼 대 버퍼 크레딧을 할당해야 합니다. 포트에 필요한 버퍼 대 버퍼 크레딧이 없으면 ISL이 작동하지 않을 수 있습니다.

F-포트가 ISL 포트와 동일한 포트 그룹에 있지 않은 경우에는 이 작업이 필요하지 않습니다.

F-포트가 ISL이 포함된 포트 그룹에 있는 경우 MetroCluster 구성의 각 FC 스위치에서 이 작업을 수행해야 합니다.

단계
  1. 구성 모드 시작:

    구성

  2. 포트의 인터페이스 구성 모드를 설정합니다.

    'interface_port-ID_'

  3. 포트를 비활성화합니다.

    '산후트'

  4. 포트가 F 모드에 있지 않은 경우 포트를 F 모드로 설정합니다.

    스치포트 모드 F

  5. 비 E 포트의 버퍼 대 버퍼 크레딧을 1로 설정합니다.

    스비츠포트 fcrxbcredit 1

  6. 포트를 다시 활성화합니다.

    "닥쳐.

  7. 구성 모드 종료:

    종료

  8. 업데이트된 구성을 시작 구성으로 복사합니다.

    'copy running-config startup-config’를 선택합니다

  9. 포트에 할당된 버퍼 대 버퍼 크레딧을 확인합니다.

    '포트-리소스 모듈 1

  10. 구성 모드 종료:

    종료

  11. 패브릭의 다른 스위치에서도 이 단계를 반복합니다.

  12. 설정을 확인합니다.

    '포트 자원 모듈 1

이 예에서 포트 FC1/40은 ISL입니다. 포트 FC1/37, FC1/38 및 FC1/39는 동일한 포트 그룹에 있으며 구성해야 합니다.

다음 명령은 FC1/37~FC1/39에 대해 구성 중인 포트 범위를 보여줍니다.

FC_switch_A_1# conf t
FC_switch_A_1(config)# interface fc1/37-39
FC_switch_A_1(config-if)# shut
FC_switch_A_1(config-if)# switchport mode F
FC_switch_A_1(config-if)# switchport fcrxbbcredit 1
FC_switch_A_1(config-if)# no shut
FC_switch_A_1(config-if)# exit
FC_switch_A_1# copy running-config startup-config

FC_switch_B_1# conf t
FC_switch_B_1(config)# interface fc1/37-39
FC_switch_B_1(config-if)# shut
FC_switch_B_1(config-if)# switchport mode F
FC_switch_B_1(config-if)# switchport fcrxbbcredit 1
FC_switch_A_1(config-if)# no shut
FC_switch_A_1(config-if)# exit
FC_switch_B_1# copy running-config startup-config

다음 명령 및 시스템 출력은 설정이 올바르게 적용되었는지 보여줍니다.

FC_switch_A_1# show port-resource module 1
...
Port-Group 11
 Available dedicated buffers are 93

--------------------------------------------------------------------
Interfaces in the Port-Group       B2B Credit  Bandwidth  Rate Mode
                                      Buffers     (Gbps)

--------------------------------------------------------------------
fc1/37                                     32        8.0  dedicated
fc1/38                                      1        8.0  dedicated
fc1/39                                      1        8.0  dedicated
...

FC_switch_B_1# port-resource module
...
Port-Group 11
 Available dedicated buffers are 93

--------------------------------------------------------------------
Interfaces in the Port-Group       B2B Credit  Bandwidth  Rate Mode
                                     Buffers     (Gbps)

--------------------------------------------------------------------
fc1/37                                     32        8.0  dedicated
fc1/38                                      1        8.0  dedicated
fc1/39                                      1        8.0 dedicated
...

Cisco FC 스위치에서 VSAN 생성 및 구성

MetroCluster 구성에서 각 FC 스위치의 스토리지 포트에 대해 FC-VI 포트에 대한 VSAN과 VSAN을 생성해야 합니다.

VSAN은 고유한 번호와 이름을 가져야 합니다. 순서대로 프레임을 전달하는 두 ISL을 사용하는 경우 추가 구성을 수행해야 합니다.

이 작업의 예에는 다음과 같은 명명 규칙이 사용됩니다.

스위치 패브릭

vSAN 이름입니다

ID 번호입니다

1

FCVI_1_10

10

스토리지_1_20

20

2

FCVI_2_30

30

스토리지_2_20

이 작업은 각 FC 스위치 패브릭에서 수행해야 합니다.

단계
  1. FC-VI VSAN 구성:

    1. 아직 구성 모드를 입력하지 않은 경우 다음과 같이 하십시오.

      구성

    2. VSAN 데이터베이스 편집:

      VSAN 데이터베이스

    3. VSAN ID 설정:

      "vSAN_VSAN-ID _"

    4. VSAN 이름 설정:

      'vSAN_VSAN-ID_NAME_VSAN_NAME_'

  2. FC-VI VSAN에 포트 추가:

    1. VSAN의 각 포트에 대한 인터페이스를 추가합니다.

      'vSAN_VSAN-ID_INTERFACE_INTERFACE_NAME_'

      FC-VI VSAN의 경우 로컬 FC-VI 포트를 연결하는 포트가 추가됩니다.

    2. 구성 모드 종료:

      "끝"

    3. running-config를 startup-config에 복사합니다.

      'copy running-config startup-config’를 선택합니다

      다음 예에서는 포트가 FC1/1 및 FC1/13입니다.

    FC_switch_A_1# conf t
    FC_switch_A_1(config)# vsan database
    FC_switch_A_1(config)# vsan 10 interface fc1/1
    FC_switch_A_1(config)# vsan 10 interface fc1/13
    FC_switch_A_1(config)# end
    FC_switch_A_1# copy running-config startup-config
    FC_switch_B_1# conf t
    FC_switch_B_1(config)# vsan database
    FC_switch_B_1(config)# vsan 10 interface fc1/1
    FC_switch_B_1(config)# vsan 10 interface fc1/13
    FC_switch_B_1(config)# end
    FC_switch_B_1# copy running-config startup-config
  3. VSAN의 포트 구성원 자격 확인:

    'How VSAN member’입니다

    FC_switch_A_1# show vsan member
    FC_switch_B_1# show vsan member
  4. 프레임의 주문 전달 또는 순서가 없는 전송을 보장하기 위해 VSAN을 구성합니다.

    참고 표준 IOD 설정을 권장합니다. 필요한 경우에만 유목(Good)을 구성해야 합니다.
    • 다음 단계를 수행하여 프레임을 순서대로 제공해야 합니다.

      1. 구성 모드 시작:

        "구성"

      2. VSAN에 대한 교환 주문 보장 활성화:

        'in-order-s런티 VSAN_vsan-ID _'

        중요 FC-VI VSAN(FCVI_1_10 및 FCVI_2_30)의 경우 VSAN 10에서만 프레임 및 교환을 순서대로 보장해야 합니다.
      3. VSAN에 대한 로드 밸런싱 설정:

        'vSAN_VSAN-ID_loadbalancing src-dst-id'

      4. 구성 모드 종료:

        "끝"

      5. running-config를 startup-config에 복사합니다.

        'copy running-config startup-config’를 선택합니다

        FC_SWITCH_A_1에서 프레임의 주문 전송을 구성하는 명령:

        FC_switch_A_1# config t
        FC_switch_A_1(config)# in-order-guarantee vsan 10
        FC_switch_A_1(config)# vsan database
        FC_switch_A_1(config-vsan-db)# vsan 10 loadbalancing src-dst-id
        FC_switch_A_1(config-vsan-db)# end
        FC_switch_A_1# copy running-config startup-config

        FC_SWITCH_B_1에서 프레임의 주문 전송을 구성하는 명령:

      FC_switch_B_1# config t
      FC_switch_B_1(config)# in-order-guarantee vsan 10
      FC_switch_B_1(config)# vsan database
      FC_switch_B_1(config-vsan-db)# vsan 10 loadbalancing src-dst-id
      FC_switch_B_1(config-vsan-db)# end
      FC_switch_B_1# copy running-config startup-config
    • 다음 단계를 수행하여 프레임이 오더할 수 있도록 구성해야 합니다.

      1. 구성 모드 시작:

        "구성"

      2. VSAN에 대한 교환 주문 보장 비활성화:

        'no in-order-s런티 VSAN_vsan-ID _'

      3. VSAN에 대한 로드 밸런싱 설정:

        'vSAN_VSAN-ID_loadbalancing src-dst-id'

      4. 구성 모드 종료:

        "끝"

      5. running-config를 startup-config에 복사합니다.

        'copy running-config startup-config’를 선택합니다

        FC_SWITCH_A_1에서 프레임의 주문 후 전달을 구성하는 명령:

        FC_switch_A_1# config t
        FC_switch_A_1(config)# no in-order-guarantee vsan 10
        FC_switch_A_1(config)# vsan database
        FC_switch_A_1(config-vsan-db)# vsan 10 loadbalancing src-dst-id
        FC_switch_A_1(config-vsan-db)# end
        FC_switch_A_1# copy running-config startup-config

        FC_SWITCH_B_1에서 프레임의 주문 후 전달을 구성하는 명령:

      FC_switch_B_1# config t
      FC_switch_B_1(config)# no in-order-guarantee vsan 10
      FC_switch_B_1(config)# vsan database
      FC_switch_B_1(config-vsan-db)# vsan 10 loadbalancing src-dst-id
      FC_switch_B_1(config-vsan-db)# end
      FC_switch_B_1# copy running-config startup-config

      +

      참고 컨트롤러 모듈에서 ONTAP를 구성할 때는 MetroCluster 구성의 각 컨트롤러 모듈에서 유드로 명시적으로 구성해야 합니다.
  5. FC-VI VSAN에 대한 QoS 정책 설정:

    1. 구성 모드 시작:

      "구성"

    2. QoS를 활성화하고 다음 명령을 순서대로 입력하여 클래스 맵을 생성합니다.

      'QoS 활성화'

      'QoS class-map_class_name_match-any

    3. 이전 단계에서 생성한 클래스 맵을 정책 맵에 추가합니다.

      'CLASS_CLASS_NAME_'

    4. 우선 순위 설정:

      우선 순위 높음

    5. 이 절차에서 이전에 생성한 정책 맵에 VSAN을 추가합니다.

      'QoS service policy_policy_name_vsan_vsan-id_'

    6. 업데이트된 구성을 시작 구성으로 복사합니다.

      'copy running-config startup-config’를 선택합니다

    FC_SWITCH_A_1에서 QoS 정책을 설정하는 명령:

    FC_switch_A_1# conf t
    FC_switch_A_1(config)# qos enable
    FC_switch_A_1(config)# qos class-map FCVI_1_10_Class match-any
    FC_switch_A_1(config)# qos policy-map FCVI_1_10_Policy
    FC_switch_A_1(config-pmap)# class FCVI_1_10_Class
    FC_switch_A_1(config-pmap-c)# priority high
    FC_switch_A_1(config-pmap-c)# exit
    FC_switch_A_1(config)# exit
    FC_switch_A_1(config)# qos service policy FCVI_1_10_Policy vsan 10
    FC_switch_A_1(config)# end
    FC_switch_A_1# copy running-config startup-config

    FC_SWITCH_B_1에서 QoS 정책을 설정하는 명령:

    FC_switch_B_1# conf t
    FC_switch_B_1(config)# qos enable
    FC_switch_B_1(config)# qos class-map FCVI_1_10_Class match-any
    FC_switch_B_1(config)# qos policy-map FCVI_1_10_Policy
    FC_switch_B_1(config-pmap)# class FCVI_1_10_Class
    FC_switch_B_1(config-pmap-c)# priority high
    FC_switch_B_1(config-pmap-c)# exit
    FC_switch_B_1(config)# exit
    FC_switch_B_1(config)# qos service policy FCVI_1_10_Policy vsan 10
    FC_switch_B_1(config)# end
    FC_switch_B_1# copy running-config startup-config
  6. 스토리지 VSAN 구성:

    1. VSAN ID 설정:

      "vSAN_VSAN-ID _"

    2. VSAN 이름 설정:

      'vSAN_VSAN-ID_NAME_VSAN_NAME_'

    FC_SWITCH_A_1에서 스토리지 VSAN을 구성하는 명령:

    FC_switch_A_1# conf t
    FC_switch_A_1(config)# vsan database
    FC_switch_A_1(config-vsan-db)# vsan 20
    FC_switch_A_1(config-vsan-db)# vsan 20 name STOR_1_20
    FC_switch_A_1(config-vsan-db)# end
    FC_switch_A_1# copy running-config startup-config

    FC_SWITCH_B_1에서 스토리지 VSAN을 구성하는 명령:

    FC_switch_B_1# conf t
    FC_switch_B_1(config)# vsan database
    FC_switch_B_1(config-vsan-db)# vsan 20
    FC_switch_B_1(config-vsan-db)# vsan 20 name STOR_1_20
    FC_switch_B_1(config-vsan-db)# end
    FC_switch_B_1# copy running-config startup-config
  7. 스토리지 VSAN에 포트를 추가합니다.

    스토리지 VSAN의 경우 HBA 또는 FC-to-SAS 브리지를 연결하는 모든 포트를 추가해야 합니다. 이 예에서는 FC1/5, FC1/9, FC1/17, FC1/21입니다. FC1/25, FC1/29, FC1/33 및 FC1/37이 추가되고 있습니다.

    FC_SWITCH_A_1의 스토리지 VSAN에 포트를 추가하는 명령:

    FC_switch_A_1# conf t
    FC_switch_A_1(config)# vsan database
    FC_switch_A_1(config)# vsan 20 interface fc1/5
    FC_switch_A_1(config)# vsan 20 interface fc1/9
    FC_switch_A_1(config)# vsan 20 interface fc1/17
    FC_switch_A_1(config)# vsan 20 interface fc1/21
    FC_switch_A_1(config)# vsan 20 interface fc1/25
    FC_switch_A_1(config)# vsan 20 interface fc1/29
    FC_switch_A_1(config)# vsan 20 interface fc1/33
    FC_switch_A_1(config)# vsan 20 interface fc1/37
    FC_switch_A_1(config)# end
    FC_switch_A_1# copy running-config startup-config

    FC_SWITCH_B_1의 스토리지 VSAN에 포트를 추가하는 명령:

    FC_switch_B_1# conf t
    FC_switch_B_1(config)# vsan database
    FC_switch_B_1(config)# vsan 20 interface fc1/5
    FC_switch_B_1(config)# vsan 20 interface fc1/9
    FC_switch_B_1(config)# vsan 20 interface fc1/17
    FC_switch_B_1(config)# vsan 20 interface fc1/21
    FC_switch_B_1(config)# vsan 20 interface fc1/25
    FC_switch_B_1(config)# vsan 20 interface fc1/29
    FC_switch_B_1(config)# vsan 20 interface fc1/33
    FC_switch_B_1(config)# vsan 20 interface fc1/37
    FC_switch_B_1(config)# end
    FC_switch_B_1# copy running-config startup-config

E-port 구성

ISL(E-Port)을 연결하는 스위치 포트를 구성해야 합니다.

사용하는 절차는 사용 중인 스위치에 따라 다릅니다.

Cisco FC 스위치에서 E-포트 구성

ISL(Inter-Switch Link)을 연결하는 FC 스위치 포트를 구성해야 합니다.

이러한 포트는 E-port 이며 각 포트에 대해 구성해야 합니다. 이렇게 하려면 올바른 개수의 BBC(Buffer-to-Buffer Credit)를 계산해야 합니다.

Fabric의 모든 ISL은 동일한 속도 및 거리 설정으로 구성해야 합니다.

이 작업은 각 ISL 포트에서 수행해야 합니다.

단계
  1. 다음 표를 사용하여 포트 속도를 위해 킬로미터당 필요한 BBC를 조정합니다.

    올바른 BBC 수를 결정하려면 필요한 조정된 BBC(다음 표에서 결정)에 스위치 간 거리(킬로미터)를 곱합니다. FC-VI 프레임 동작을 고려하려면 조정 계수 1.5가 필요합니다.

    속도(Gbps)

    킬로미터당 BBC가 필요합니다

    조정된 BBC 필요(Km당 BBC x 1.5)

    1

    0.5

    0.75

    2

    1

    1.5

    4

    2

    3

    8

    4

    6

    16

    8

    12

예를 들어, 4Gbps 링크에서 30km 거리에 필요한 크레딧 수를 계산하려면 다음 계산을 수행합니다.

  • '1Gbps 속도’는 4입니다

  • 조정된 BBC는 3입니다

  • 스위치 간 거리(km)는 30km다

  • 3 x 30 = 90

    1. 구성 모드 시작:

      구성

    2. 구성할 포트를 지정합니다.

      interface_port-name _

    3. 포트를 종료합니다.

      '허틀다운'

    4. 포트의 속도 모드를 "Dedicated"로 설정합니다.

      '위츠포트 속도 모드 전용’입니다

    5. 포트의 속도를 설정합니다.

      'switchport speed_speed-value_'

    6. 포트에 대한 버퍼 대 버퍼 크레딧을 설정합니다.

      'switchport fcrxbcredit_number_of_buffers_'

    7. 포트를 E 모드로 설정합니다.

      스치포트 모드 E

    8. 포트에 대해 트렁크 모드를 활성화합니다.

      '위츠포트 트렁크 모드 켜짐

    9. ISL VSAN(Virtual Storage Area Network)을 트렁크에 추가합니다.

      위츠포트 트렁크는 VSAN 10을 허용했습니다

      "위츠포트 트렁크는 VSAN을 20으로 추가했다"고 말했다

    10. 포트를 포트 채널 1에 추가합니다.

      채널 그룹 1

    11. Fabric의 파트너 스위치에 있는 일치하는 ISL 포트에 대해 이전 단계를 반복합니다.

      다음 예에서는 30km 및 8Gbps의 거리에 대해 구성된 포트 FC1/41을 보여 줍니다.

      FC_switch_A_1# conf t
      FC_switch_A_1# shutdown
      FC_switch_A_1# switchport rate-mode dedicated
      FC_switch_A_1# switchport speed 8000
      FC_switch_A_1# switchport fcrxbbcredit 60
      FC_switch_A_1# switchport mode E
      FC_switch_A_1# switchport trunk mode on
      FC_switch_A_1# switchport trunk allowed vsan 10
      FC_switch_A_1# switchport trunk allowed vsan add 20
      FC_switch_A_1# channel-group 1
      fc1/36 added to port-channel 1 and disabled
      
      FC_switch_B_1# conf t
      FC_switch_B_1# shutdown
      FC_switch_B_1# switchport rate-mode dedicated
      FC_switch_B_1# switchport speed 8000
      FC_switch_B_1# switchport fcrxbbcredit 60
      FC_switch_B_1# switchport mode E
      FC_switch_B_1# switchport trunk mode on
      FC_switch_B_1# switchport trunk allowed vsan 10
      FC_switch_B_1# switchport trunk allowed vsan add 20
      FC_switch_B_1# channel-group 1
      fc1/36 added to port-channel 1 and disabled
    12. 두 스위치에서 다음 명령을 실행하여 포트를 다시 시작합니다.

      "종료 안 함"

    13. Fabric의 다른 ISL 포트에 대해 이전 단계를 반복합니다.

    14. 동일한 Fabric에 있는 두 스위치의 포트 채널 인터페이스에 기본 VSAN을 추가합니다.

      'interface port-channel_number_'

      'switchport 트렁크는 VSAN add_native_san_id_'를 허용했습니다

    15. 포트 채널의 구성을 확인합니다.

      'SHY interface port-channel_number_'

    포트 채널에는 다음과 같은 속성이 있어야 합니다.

  • 포트 채널은 "트렁킹"입니다.

  • 관리 포트 모드는 E이고 트렁크 모드는 ON입니다.

  • 속도는 모든 ISL 링크 속도의 누적 값을 표시합니다.

    예를 들어, 4Gbps에서 작동하는 2개의 ISL 포트는 8Gbps의 속도를 나타냅니다.

  • 트렁크 VSAN(admin allowed and active)은 허용된 VSAN을 모두 보여줍니다.

  • 트렁크 VSAN(UP)은 허용된 VSAN을 모두 보여줍니다.

  • 구성원 목록에는 포트 채널에 추가된 모든 ISL 포트가 표시됩니다.

  • 포트 VSAN 번호는 ISL(일반적으로 기본 VSAN 1)이 포함된 VSAN과 같아야 합니다.

    FC_switch_A_1(config-if)# show int port-channel 1
    port-channel 1 is trunking
        Hardware is Fibre Channel
        Port WWN is 24:01:54:7f:ee:e2:8d:a0
        Admin port mode is E, trunk mode is on
        snmp link state traps are enabled
        Port mode is TE
        Port vsan is 1
        Speed is 8 Gbps
        Trunk vsans (admin allowed and active) (1,10,20)
        Trunk vsans (up)                       (1,10,20)
        Trunk vsans (isolated)                 ()
        Trunk vsans (initializing)             ()
        5 minutes input rate 1154832 bits/sec,144354 bytes/sec, 170 frames/sec
        5 minutes output rate 1299152 bits/sec,162394 bytes/sec, 183 frames/sec
          535724861 frames input,1069616011292 bytes
            0 discards,0 errors
            0 invalid CRC/FCS,0 unknown class
            0 too long,0 too short
          572290295 frames output,1144869385204 bytes
            0 discards,0 errors
          5 input OLS,11  LRR,2 NOS,0 loop inits
          14 output OLS,5 LRR, 0 NOS, 0 loop inits
        Member[1] : fc1/36
        Member[2] : fc1/40
        Interface last changed at Thu Oct 16 11:48:00 2014
    1. 두 스위치에서 인터페이스 구성을 종료합니다.

      "끝"

    2. 두 Fabric의 시작 구성에 업데이트된 구성을 복사합니다.

      'copy running-config startup-config’를 선택합니다

    FC_switch_A_1(config-if)# end
    FC_switch_A_1# copy running-config startup-config
    
    FC_switch_B_1(config-if)# end
    FC_switch_B_1# copy running-config startup-config
    1. 두 번째 스위치 패브릭에서 이전 단계를 반복합니다.

ONTAP 9.1 이상을 사용할 때 FC 스위치에 케이블을 연결할 때 지정한 포트 할당을 사용하고 있는지 확인해야 합니다. 을 참조하십시오 "ONTAP 9.1 이상을 사용할 경우 FC 스위치에 대한 포트 할당"

Cisco 9250i FC 스위치에서 단일 ISL에 대한 FCIP 포트 구성

FCIP 프로파일과 인터페이스를 생성한 다음 이를 IPStorage1/1GbE 인터페이스에 할당하여 ISL(E-port)을 연결하는 FCIP 스위치 포트를 구성해야 합니다.

이 작업은 각 스위치에서 IPStorage1/1 인터페이스를 사용하는 스위치 패브릭당 단일 ISL을 사용하는 구성에만 해당됩니다.

이 작업은 각 FC 스위치에서 수행해야 합니다.

각 스위치에 2개의 FCIP 프로파일이 생성됩니다.

  • 패브릭 1

    • FC_SWITCH_A_1은 FCIP 프로파일 11 및 111로 구성됩니다.

    • FC_SWITCH_B_1은 FCIP 프로파일 12 및 121로 구성됩니다.

  • 패브릭 2

    • FC_SWITCH_A_2는 FCIP 프로파일 13 및 131로 구성됩니다.

    • FC_SWITCH_B_2는 FCIP 프로파일 14 및 141로 구성됩니다.

단계
  1. 구성 모드 시작:

    구성

  2. FCIP 설정:

    FCIP 기능

  3. IPStorage1/1GbE 인터페이스 구성:

    1. 구성 모드 시작:

      "구성"

    2. IPStorage1/1 인터페이스를 지정합니다.

      인터페이스 IPStorage1/1

    3. IP 주소 및 서브넷 마스크를 지정합니다.

      'interface_ip-address__subnet-mask_'

    4. MTU 크기를 2500:

      스치포트 MTU 2500

    5. 포트 활성화:

      "종료 안 함"

    6. 구성 모드 종료:

      종료

    다음 예에서는 IPStorage1/1 포트의 구성을 보여 줍니다.

    conf t
    interface IPStorage1/1
      ip address 192.168.1.201 255.255.255.0
      switchport mtu 2500
      no shutdown
    exit
  4. FC-VI 트래픽에 대한 FCIP 프로파일 구성:

    1. FCIP 프로파일 구성 및 FCIP 프로파일 구성 모드 입력:

      'FCIP profile_FCIP-profile-name_'

      프로파일 이름은 구성 중인 스위치에 따라 다릅니다.

    2. IPStorage1/1 인터페이스의 IP 주소를 FCIP 프로필에 할당합니다.

      IP address_ip-address _

    3. FCIP 프로파일을 TCP 포트 3227에 할당합니다.

      포트 3227

    4. TCP 설정을 지정합니다.

      TCP keepalive-timeout 1

      TCP 최대 재전송 3

      max-bandwidth-Mbps 5000 min-available-bandwidth-Mbps 4500 round-trip-time-ms 3"

      TCP 최소 재전송 시간 200

      TCP keepalive-timeout 1

      'TCP PMTU - ENABLE RESET - TIMEOUT 3600'

      TCP wack-enable TCP cwm 없음

    다음 예에서는 FCIP 프로파일의 구성을 보여 줍니다.

    conf t
    fcip profile 11
      ip address 192.168.1.333
      port 3227
      tcp keepalive-timeout 1
    tcp max-retransmissions 3
    max-bandwidth-mbps 5000 min-available-bandwidth-mbps 4500 round-trip-time-ms 3
      tcp min-retransmit-time 200
      tcp keepalive-timeout 1
      tcp pmtu-enable reset-timeout 3600
      tcp sack-enable
      no tcp cwm
  5. 스토리지 트래픽에 대한 FCIP 프로파일 구성:

    1. 이름이 111인 FCIP 프로파일을 구성하고 FCIP 프로파일 구성 모드로 전환합니다.

      FCIP 프로파일 111

    2. IPStorage1/1 인터페이스의 IP 주소를 FCIP 프로필에 할당합니다.

      IP address_ip-address _

    3. FCIP 프로파일을 TCP 포트에 할당 3229:

      포트 3229

    4. TCP 설정을 지정합니다.

      TCP keepalive-timeout 1

      TCP 최대 재전송 3

      max-bandwidth-Mbps 5000 min-available-bandwidth-Mbps 4500 round-trip-time-ms 3"

      TCP 최소 재전송 시간 200

      TCP keepalive-timeout 1

      'TCP PMTU - ENABLE RESET - TIMEOUT 3600'

      TCP wack-enable TCP cwm 없음

    다음 예에서는 FCIP 프로파일의 구성을 보여 줍니다.

    conf t
    fcip profile 111
      ip address 192.168.1.334
      port 3229
      tcp keepalive-timeout 1
    tcp max-retransmissions 3
    max-bandwidth-mbps 5000 min-available-bandwidth-mbps 4500 round-trip-time-ms 3
      tcp min-retransmit-time 200
      tcp keepalive-timeout 1
      tcp pmtu-enable reset-timeout 3600
      tcp sack-enable
      no tcp cwm
  6. FCIP 인터페이스 2개 중 첫 번째 생성:

    인터페이스 FCIP 1

    이 인터페이스는 FC-IV 트래픽에 사용됩니다.

    1. 이전에 생성된 프로파일 11을 선택합니다.

      사용-프로파일 11

    2. 파트너 스위치에서 IPStorage1/1 포트의 IP 주소 및 포트를 설정합니다.

      'peer-info ipaddr_partner-switch-port-ip_port 3227'

    3. TCP 연결 2 선택:

      TCP 연결 2

    4. 압축 해제:

      IP 압축 없음

    5. 인터페이스를 활성화합니다.

      "종료 안 함"

    6. 48로 제어 TCP 연결을 구성하고 데이터 연결을 26으로 구성하여 해당 DSCP(Differentiated Services Code Point) 값에 있는 모든 패킷을 표시합니다.

      QoS 제어 48 데이터 26

    7. 인터페이스 구성 모드를 종료합니다.

      종료

    다음 예에서는 FCIP 인터페이스 구성을 보여 줍니다.

    interface fcip  1
      use-profile 11
    # the port # listed in this command is the port that the remote switch is listening on
     peer-info ipaddr 192.168.32.334   port 3227
      tcp-connection 2
      no ip-compression
      no shutdown
      qos control 48 data 26
    exit
  7. 두 개의 FCIP 인터페이스 중 두 번째 인터페이스를 생성합니다.

    인터페이스 FCIP 2

    이 인터페이스는 스토리지 트래픽에 사용됩니다.

    1. 이전에 작성된 프로파일 111을 선택합니다.

      사용-프로파일 111

    2. 파트너 스위치에서 IPStorage1/1 포트의 IP 주소 및 포트를 설정합니다.

      'peer-info ipaddr_partner-switch-port-ip_port 3229

    3. TCP 연결 2 선택:

      TCP 연결 5

    4. 압축 해제:

      IP 압축 없음

    5. 인터페이스를 활성화합니다.

      "종료 안 함"

    6. 48에 대한 제어 TCP 연결 및 26에 대한 데이터 연결을 구성하여 해당 DSCP(Differentiated Services Code Point) 값에 있는 모든 패킷을 표시합니다.

      QoS 제어 48 데이터 26

    7. 인터페이스 구성 모드를 종료합니다.

      종료

    다음 예에서는 FCIP 인터페이스 구성을 보여 줍니다.

    interface fcip  2
      use-profile 11
    # the port # listed in this command is the port that the remote switch is listening on
     peer-info ipaddr 192.168.32.33e  port 3229
      tcp-connection 5
      no ip-compression
      no shutdown
      qos control 48 data 26
    exit
  8. FCIP 1 인터페이스에서 스위치 포트 설정을 구성합니다.

    1. 구성 모드 시작:

      구성

    2. 구성할 포트를 지정합니다.

      인터페이스 FCIP 1

    3. 포트를 종료합니다.

      '허틀다운'

    4. 포트를 E 모드로 설정합니다.

      스치포트 모드 E

    5. 포트에 대해 트렁크 모드를 활성화합니다.

      '위츠포트 트렁크 모드 켜짐

    6. 트렁크 허용 VSAN을 10으로 설정합니다.

      위츠포트 트렁크는 VSAN 10을 허용했습니다

    7. 포트의 속도를 설정합니다.

      'switchport speed_speed-value_'

  9. FCIP 2 인터페이스에서 스위치 포트 설정을 구성합니다.

    1. 구성 모드 시작:

      구성

    2. 구성할 포트를 지정합니다.

      인터페이스 FCIP 2

    3. 포트를 종료합니다.

      '허틀다운'

    4. 포트를 E 모드로 설정합니다.

      스치포트 모드 E

    5. 포트에 대해 트렁크 모드를 활성화합니다.

      '위츠포트 트렁크 모드 켜짐

    6. 트렁크 허용 VSAN을 20으로 설정합니다.

      위츠포트 트렁크는 VSAN 20을 허용했습니다

    7. 포트의 속도를 설정합니다.

      'switchport speed_speed-value_'

  10. 두 번째 스위치에 대해 이전 단계를 반복합니다.

    유일한 차이점은 적절한 IP 주소와 고유한 FCIP 프로파일 이름입니다.

    • 첫 번째 스위치 패브릭을 구성할 때 FC_SWITCH_B_1은 FCIP 프로파일 12 및 121로 구성됩니다.

    • 첫 번째 스위치 패브릭을 구성할 때 FC_SWITCH_A_2는 FCIP 프로파일 13 및 131로 구성되고 FC_SWITCH_B_2는 FCIP 프로파일 14 및 141로 구성됩니다.

  11. 두 스위치에서 포트를 다시 시작합니다.

    "종료 안 함"

  12. 두 스위치에서 인터페이스 구성을 종료합니다.

    "끝"

  13. 업데이트된 구성을 두 스위치의 시작 구성으로 복사합니다.

    'copy running-config startup-config’를 선택합니다

    FC_switch_A_1(config-if)# end
    FC_switch_A_1# copy running-config startup-config
    
    FC_switch_B_1(config-if)# end
    FC_switch_B_1# copy running-config startup-config
  14. 두 번째 스위치 패브릭에서 이전 단계를 반복합니다.

Cisco 9250i FC 스위치의 이중 ISL용 FCIP 포트 구성

FCIP 프로파일과 인터페이스를 생성한 다음 IPStorage1/1 및 IPStorage1/2 GbE 인터페이스에 할당하여 ISL(E-Port)을 연결하는 FCIP 스위치 포트를 구성해야 합니다.

이 작업은 각 스위치에서 IPStorage1/1 및 IPStorage1/2 GbE 인터페이스를 사용하는 스위치 패브릭당 이중 ISL을 사용하는 구성에만 해당됩니다.

이 작업은 각 FC 스위치에서 수행해야 합니다.

FCIP 포트 이중 ISL

작업 및 예제에서는 다음 프로파일 구성 테이블을 사용합니다.

스위치 패브릭

IPStorage 인터페이스

IP 주소

포트 유형입니다

FCIP 인터페이스

FCIP 프로파일

포트

피어 IP/포트입니다

vSAN ID입니다

fc_switch_a_1

IPStorage1/1

a.a.a.a 를 참조하십시오

FC-VI

FCIP 1

15

3220

C.C. c/3230

10

스토리지

FCIP 2

20

3221을 참조하십시오

C.C. c/3231

20

IPStorage1/2

b.b.b.b

FC-VI

FCIP 3

25

3222

  1. d. d. d. d. d. d/3232

10

스토리지

FCIP 4

30

3223

  1. d. d. d. d. d/3233

20

fc_switch_B_1

IPStorage1/1

c.c.c.c

FC-VI

FCIP 1

15

3230

  1. a. a. a/3220

10

스토리지

FCIP 2

20

3231

  1. a. a. a/3221

20

IPStorage1/2

d.d.d.d

FC-VI

FCIP 3

25

3232

  1. b. b. b. b. b/3222

10

스토리지

FCIP 4

  • 패브릭 2 프로파일 구성 표 *

스위치 패브릭

IPStorage 인터페이스

IP 주소

포트 유형입니다

FCIP 인터페이스

FCIP 프로파일

포트

피어 IP/포트입니다

vSAN ID입니다

fc_switch_a_2

IPStorage1/1

e.e

FC-VI

FCIP 1

15

3220

  1. g. g/3230

10

스토리지

FCIP 2

20

3221을 참조하십시오

  1. g. g/3231

20

IPStorage1/2

f.f.f.f

FC-VI

FCIP 3

25

3222

  1. H. H. H. H. h/3232

10

스토리지

FCIP 4

30

3223

  1. H. H. H. H. h/3233

20

fc_switch_B_2

IPStorage1/1

g.g.g.g

FC-VI

FCIP 1

15

3230

예: e/3220

10

스토리지

FCIP 2

20

3231

예: e/3221

20

IPStorage1/2

h.h.h.h

FC-VI

FCIP 3

25

3232

  1. F.F.f/3222

10

스토리지

FCIP 4

단계
  1. 구성 모드 시작:

    구성

  2. FCIP 설정:

    FCIP 기능

  3. 각 스위치에서 두 개의 IPStorage 인터페이스(""IPStorage1/1"" 및 ""IPStorage1/2"")를 구성합니다.

    1. [[substep_a, Substep""a"] 설정 모드 진입:

      "구성"

    2. 생성할 IPStorage 인터페이스를 지정합니다.

      'interface_ipstorage_'

      'ipstorage' 파라미터 값은 IPStorage1/1 또는 IPStorage1/2’입니다.

    3. 이전에 지정한 IPStorage 인터페이스의 IP 주소 및 서브넷 마스크를 지정합니다.

      'interface_ip-address__subnet-mask_'

    참고 각 스위치에서 IPStorage 인터페이스 IPStorage1/1, IPStorage1/2 등의 IP 주소가 서로 달라야 합니다.
    1. MTU 크기를 2500으로 지정합니다.

      스치포트 MTU 2500

    2. 포트 활성화:

      "종료 안 함"

    3. 설정 모드 종료:

      종료

    4. 반복합니다 [substep_a] 부터 까지 Substep""f" 다른 IP 주소를 사용하여 IPStorage1/2 GbE 인터페이스를 구성합니다.

  4. 프로파일 구성 표에 지정된 프로파일 이름을 사용하여 FC-VI 및 스토리지 트래픽에 대한 FCIP 프로파일을 구성합니다.

    1. 구성 모드 시작:

      "구성"

    2. 다음 프로파일 이름으로 FCIP 프로파일을 구성합니다.

      'FCIP profile_FCIP-profile-name_'

      다음 목록에는 'FCIP-profile-name' 매개 변수의 값이 나와 있습니다.

      • IPStorage1/1의 FC-VI용 15

      • IPStorage1/1에 대한 스토리지의 경우 20

      • IPStorage1/2의 FC-VI의 경우 25

      • IPStorage1/2에 대한 스토리지의 경우 30

    3. 프로파일 구성 표에 따라 FCIP 프로파일 포트를 할당합니다.

      'PORT_PORT_NUMBER_'

    4. TCP 설정을 지정합니다.

      TCP keepalive-timeout 1

      TCP 최대 재전송 3

      max-bandwidth-Mbps 5000 min-available-bandwidth-Mbps 4500 round-trip-time-ms 3"

      TCP 최소 재전송 시간 200

      TCP keepalive-timeout 1

      'TCP PMTU - ENABLE RESET - TIMEOUT 3600'

      'TCP sack-enable'

    TCP가 없습니다

  5. FCIP 인터페이스 생성:

    인터페이스 FCIP_FCIP_INTERFACE _

    프로파일 설정 테이블에 표시된 "FCIP_INTERFACE" 매개변수 값은 ""1"", ""2"", ""3"" 또는 ""4""입니다.

    1. 인터페이스를 이전에 만든 프로필에 매핑합니다.

      'use-profile_profile_'

    2. 피어 IP 주소 및 피어 프로필 포트 번호 설정:

      'peer-info_peer_IPstorage_ipaddr_port_peer_profile_port_number_'

    3. TCP 연결을 선택합니다.

      'TCP-CONNECTION_CONNECTION-#_'

    'connection-#' 매개 변수 값은 FC-VI 프로파일의 경우 ""2", 스토리지 프로파일의 경우 ""5""입니다.

    1. 압축 해제:

      IP 압축 없음

    2. 인터페이스를 활성화합니다.

      "종료 안 함"

    3. DSCP(Differentiated Services Code Point) 값을 갖는 모든 패킷을 표시하기 위해 제어 TCP 연결을 ""48""으로 구성하고 데이터 연결을 ""26""으로 설정한다.

      QoS 제어 48 데이터 26

    4. 구성 모드 종료:

      종료

  6. 각 FCIP 인터페이스에서 스위치 포트 설정을 구성합니다.

    1. 구성 모드 시작:

      구성

    2. 구성할 포트를 지정합니다.

      인터페이스 FCIP 1

    3. 포트를 종료합니다.

      '허틀다운'

    4. 포트를 E 모드로 설정합니다.

      스치포트 모드 E

    5. 포트에 대해 트렁크 모드를 활성화합니다.

      '위츠포트 트렁크 모드 켜짐

    6. 특정 VSAN에 허용되는 트렁크를 지정합니다.

      'Switchport 트렁크는 VSAN_VSAN_id_'를 허용했습니다

    vsan_id_parameter 값은 FC-VI 프로파일의 경우 ""vsan 10"", 스토리지 프로파일의 경우 ""vsan 20""입니다.

    1. 포트의 속도를 설정합니다.

      'switchport speed_speed-value_'

    2. 구성 모드 종료:

      종료

  7. 업데이트된 구성을 두 스위치의 시작 구성으로 복사합니다.

    'copy running-config startup-config’를 선택합니다

다음 예에서는 패브릭 1 스위치 FC_SWITCH_A_1 및 FC_SWITCH_B_1의 이중 ISL에 대한 FCIP 포트 구성을 보여 줍니다.

FC_SWITCH_A_1 * 의 경우:

FC_switch_A_1# config t
FC_switch_A_1(config)# no in-order-guarantee vsan 10
FC_switch_A_1(config-vsan-db)# end
FC_switch_A_1# copy running-config startup-config

# fcip settings

feature  fcip

conf t
interface IPStorage1/1
#  IP address:  a.a.a.a
#  Mask:  y.y.y.y
  ip address <a.a.a.a   y.y.y.y>
  switchport mtu 2500
  no shutdown
exit
conf t
fcip profile 15
  ip address <a.a.a.a>
  port 3220
  tcp keepalive-timeout 1
tcp max-retransmissions 3
max-bandwidth-mbps 5000 min-available-bandwidth-mbps 4500 round-trip-time-ms 3
  tcp min-retransmit-time 200
  tcp keepalive-timeout 1
  tcp pmtu-enable reset-timeout 3600
  tcp sack-enable
  no tcp cwm

conf t
fcip profile 20
  ip address <a.a.a.a>
  port 3221
  tcp keepalive-timeout 1
tcp max-retransmissions 3
max-bandwidth-mbps 5000 min-available-bandwidth-mbps 4500 round-trip-time-ms 3
  tcp min-retransmit-time 200
  tcp keepalive-timeout 1
  tcp pmtu-enable reset-timeout 3600
  tcp sack-enable
  no tcp cwm

conf t
interface IPStorage1/2
#  IP address:  b.b.b.b
#  Mask:  y.y.y.y
  ip address <b.b.b.b   y.y.y.y>
  switchport mtu 2500
  no shutdown
exit

conf t
fcip profile 25
  ip address <b.b.b.b>
  port 3222
tcp keepalive-timeout 1
tcp max-retransmissions 3
max-bandwidth-mbps 5000 min-available-bandwidth-mbps 4500 round-trip-time-ms 3
  tcp min-retransmit-time 200
  tcp keepalive-timeout 1
  tcp pmtu-enable reset-timeout 3600
  tcp sack-enable
  no tcp cwm

conf t
fcip profile 30
  ip address <b.b.b.b>
  port 3223
tcp keepalive-timeout 1
tcp max-retransmissions 3
max-bandwidth-mbps 5000 min-available-bandwidth-mbps 4500 round-trip-time-ms 3
  tcp min-retransmit-time 200
  tcp keepalive-timeout 1
  tcp pmtu-enable reset-timeout 3600
  tcp sack-enable
  no tcp cwm
interface fcip  1
  use-profile 15
# the port # listed in this command is the port that the remote switch is listening on
 peer-info ipaddr <c.c.c.c>  port 3230
  tcp-connection 2
  no ip-compression
  no shutdown
  qos control 48 data 26
exit

interface fcip  2
  use-profile 20
# the port # listed in this command is the port that the remote switch is listening on
 peer-info ipaddr <c.c.c.c>  port 3231
  tcp-connection 5
  no ip-compression
  no shutdown
  qos control 48 data 26
exit

interface fcip  3
  use-profile 25
# the port # listed in this command is the port that the remote switch is listening on
 peer-info ipaddr < d.d.d.d >  port 3232
  tcp-connection 2
  no ip-compression
  no shutdown
  qos control 48 data 26
exit

interface fcip  4
  use-profile 30
# the port # listed in this command is the port that the remote switch is listening on
 peer-info ipaddr < d.d.d.d >  port 3233
  tcp-connection 5
  no ip-compression
  no shutdown
  qos control 48 data 26
exit

conf t
interface fcip  1
shutdown
switchport mode E
switchport trunk mode on
switchport trunk allowed vsan 10
no shutdown
exit

conf t
interface fcip  2
shutdown
switchport mode E
switchport trunk mode on
switchport trunk allowed vsan 20
no shutdown
exit

conf t
interface fcip  3
shutdown
switchport mode E
switchport trunk mode on
switchport trunk allowed vsan 10
no shutdown
exit

conf t
interface fcip  4
shutdown
switchport mode E
switchport trunk mode on
switchport trunk allowed vsan 20
no shutdown
exit

FC_SWITCH_B_1 * 용:

FC_switch_A_1# config t
FC_switch_A_1(config)# in-order-guarantee vsan 10
FC_switch_A_1(config-vsan-db)# end
FC_switch_A_1# copy running-config startup-config

# fcip settings

feature  fcip

conf t
interface IPStorage1/1
#  IP address:  c.c.c.c
#  Mask:  y.y.y.y
  ip address <c.c.c.c   y.y.y.y>
  switchport mtu 2500
  no shutdown
exit

conf t
fcip profile 15
  ip address <c.c.c.c>
  port 3230
  tcp keepalive-timeout 1
tcp max-retransmissions 3
max-bandwidth-mbps 5000 min-available-bandwidth-mbps 4500 round-trip-time-ms 3
  tcp min-retransmit-time 200
  tcp keepalive-timeout 1
  tcp pmtu-enable reset-timeout 3600
  tcp sack-enable
  no tcp cwm

conf t
fcip profile 20
  ip address <c.c.c.c>
  port 3231
  tcp keepalive-timeout 1
tcp max-retransmissions 3
max-bandwidth-mbps 5000 min-available-bandwidth-mbps 4500 round-trip-time-ms 3
  tcp min-retransmit-time 200
  tcp keepalive-timeout 1
  tcp pmtu-enable reset-timeout 3600
  tcp sack-enable
  no tcp cwm

conf t
interface IPStorage1/2
#  IP address:  d.d.d.d
#  Mask:  y.y.y.y
  ip address <b.b.b.b   y.y.y.y>
  switchport mtu 2500
  no shutdown
exit

conf t
fcip profile 25
  ip address <d.d.d.d>
  port 3232
tcp keepalive-timeout 1
tcp max-retransmissions 3
max-bandwidth-mbps 5000 min-available-bandwidth-mbps 4500 round-trip-time-ms 3
  tcp min-retransmit-time 200
  tcp keepalive-timeout 1
  tcp pmtu-enable reset-timeout 3600
  tcp sack-enable
  no tcp cwm

conf t
fcip profile 30
  ip address <d.d.d.d>
  port 3233
tcp keepalive-timeout 1
tcp max-retransmissions 3
max-bandwidth-mbps 5000 min-available-bandwidth-mbps 4500 round-trip-time-ms 3
  tcp min-retransmit-time 200
  tcp keepalive-timeout 1
  tcp pmtu-enable reset-timeout 3600
  tcp sack-enable
  no tcp cwm

interface fcip  1
  use-profile 15
# the port # listed in this command is the port that the remote switch is listening on
 peer-info ipaddr <a.a.a.a>  port 3220
  tcp-connection 2
  no ip-compression
  no shutdown
  qos control 48 data 26
exit

interface fcip  2
  use-profile 20
# the port # listed in this command is the port that the remote switch is listening on
 peer-info ipaddr <a.a.a.a>  port 3221
  tcp-connection 5
  no ip-compression
  no shutdown
  qos control 48 data 26
exit

interface fcip  3
  use-profile 25
# the port # listed in this command is the port that the remote switch is listening on
 peer-info ipaddr < b.b.b.b >  port 3222
  tcp-connection 2
  no ip-compression
  no shutdown
  qos control 48 data 26
exit

interface fcip  4
  use-profile 30
# the port # listed in this command is the port that the remote switch is listening on
 peer-info ipaddr < b.b.b.b >  port 3223
  tcp-connection 5
  no ip-compression
  no shutdown
  qos control 48 data 26
exit

conf t
interface fcip  1
shutdown
switchport mode E
switchport trunk mode on
switchport trunk allowed vsan 10
no shutdown
exit

conf t
interface fcip  2
shutdown
switchport mode E
switchport trunk mode on
switchport trunk allowed vsan 20
no shutdown
exit

conf t
interface fcip  3
shutdown
switchport mode E
switchport trunk mode on
switchport trunk allowed vsan 10
no shutdown
exit

conf t
interface fcip  4
shutdown
switchport mode E
switchport trunk mode on
switchport trunk allowed vsan 20
no shutdown
exit

Cisco FC 스위치에서 조닝 구성

스위치 포트를 별도의 영역에 할당하여 스토리지(HBA) 및 컨트롤러(FC-VI) 트래픽을 격리해야 합니다.

이러한 단계는 두 FC 스위치 Fabric 모두에서 수행해야 합니다.

다음 단계에서는 4노드 MetroCluster 구성에서 FiberBridge 7500N에 대한 영역 지정 섹션에 설명된 조닝을 사용합니다. 을 참조하십시오 "FC-VI 포트를 위한 조닝".

단계
  1. 기존 존 및 존 세트(있는 경우)를 지웁니다.

    1. 활성 영역 및 영역 세트를 확인합니다.

      "조소네의 활성 상태"

      FC_switch_A_1# show zoneset active
      
      FC_switch_B_1# show zoneset active
    2. 이전 단계에서 확인한 활성 영역 세트를 비활성화합니다.

      "no zoneset activate name_zoneset_name_vsan_vsan_id_"

      다음 예는 비활성화된 두 가지 영역 세트를 보여 줍니다.

      • VSAN 10의 FC_SWITCH_A_1에 Zoneset_A가 있습니다

      • VSAN 20의 FC_SWITCH_B_1에 Zoneset_B가 있습니다

      FC_switch_A_1# no zoneset activate name ZoneSet_A vsan 10
      
      FC_switch_B_1# no zoneset activate name ZoneSet_B vsan 20
    3. 모든 영역 세트를 비활성화한 후 영역 데이터베이스를 지웁니다.

      clear zone database_zone-name _

    FC_switch_A_1# clear zone database 10
    FC_switch_A_1# copy running-config startup-config
    
    FC_switch_B_1# clear zone database 20
    FC_switch_B_1# copy running-config startup-config
  2. 스위치 WWN(Worldwide Name) 확보:

    WWN 스위치 사용

  3. 기본 영역 설정을 구성합니다.

    1. 기본 조닝 정책을 ""허가""로 설정합니다.

      시스템 기본 구역 기본 구역 허용 안 함

    2. 전체 영역 배포 활성화:

      '시스템 디폴트 영역이 가득 참’으로 표시됩니다

    3. 각 VSAN에 대한 기본 조닝 정책을 설정합니다.

      "영역 default-zone permit_vsanid_ 없음.

    4. 각 VSAN에 대한 기본 전체 영역 분포를 설정합니다.

      "zoneset div분산 full_vsanid_"

    FC_switch_A_1# conf t
    FC_switch_A_1(config)# no system default zone default-zone permit
    FC_switch_A_1(config)# system default zone distribute full
    FC_switch_A_1(config)# no zone default-zone permit 10
    FC_switch_A_1(config)# no zone default-zone permit 20
    FC_switch_A_1(config)# zoneset distribute full vsan 10
    FC_switch_A_1(config)# zoneset distribute full vsan 20
    FC_switch_A_1(config)# end
    FC_switch_A_1# copy running-config startup-config
    
    FC_switch_B_1# conf t
    FC_switch_B_1(config)# no system default zone default-zone permit
    FC_switch_B_1(config)# system default zone distribute full
    FC_switch_B_1(config)# no zone default-zone permit 10
    FC_switch_B_1(config)# no zone default-zone permit 20
    FC_switch_B_1(config)# zoneset distribute full vsan 10
    FC_switch_B_1(config)# zoneset distribute full vsan 20
    FC_switch_B_1(config)# end
    FC_switch_B_1# copy running-config startup-config
  4. 스토리지 영역을 생성하여 스토리지 포트를 추가합니다.

    참고 각 Fabric에 있는 스위치 하나에서만 이 단계를 수행합니다.

    조닝은 사용 중인 FC-to-SAS 브릿지 모델에 따라 다릅니다. 자세한 내용은 모델 브리지의 섹션을 참조하십시오. 이 예에는 Brocade 스위치 포트가 표시되어 있으므로 그에 따라 포트를 조정하십시오.

    각 스토리지 존은 모든 컨트롤러의 HBA 이니시에이터 포트와 FC-to-SAS 브리지를 연결하는 단일 포트를 포함합니다.

    1. 스토리지 영역을 생성합니다.

      "Zone name_Stor-zone-name_vsanid_"

    2. 영역에 스토리지 포트 추가:

      ember portswitch WWN

    3. 영역 세트를 활성화합니다.

      "zoneset activate name_Stor-zone-name-setname_vsan_vsan-id_"

    FC_switch_A_1# conf t
    FC_switch_A_1(config)# zone name STOR_Zone_1_20_25 vsan 20
    FC_switch_A_1(config-zone)# member interface fc1/5 swwn 20:00:00:05:9b:24:cb:78
    FC_switch_A_1(config-zone)# member interface fc1/9 swwn 20:00:00:05:9b:24:cb:78
    FC_switch_A_1(config-zone)# member interface fc1/17 swwn 20:00:00:05:9b:24:cb:78
    FC_switch_A_1(config-zone)# member interface fc1/21 swwn 20:00:00:05:9b:24:cb:78
    FC_switch_A_1(config-zone)# member interface fc1/5 swwn 20:00:00:05:9b:24:12:99
    FC_switch_A_1(config-zone)# member interface fc1/9 swwn 20:00:00:05:9b:24:12:99
    FC_switch_A_1(config-zone)# member interface fc1/17 swwn 20:00:00:05:9b:24:12:99
    FC_switch_A_1(config-zone)# member interface fc1/21 swwn 20:00:00:05:9b:24:12:99
    FC_switch_A_1(config-zone)# member interface fc1/25 swwn 20:00:00:05:9b:24:cb:78
    FC_switch_A_1(config-zone)# end
    FC_switch_A_1# copy running-config startup-config
  5. 스토리지 영역 세트를 생성하고 스토리지 존을 새 세트에 추가합니다.

    참고 Fabric에 있는 스위치 하나에서만 이 단계를 수행합니다.
    1. 스토리지 영역 세트를 생성합니다.

      'zoneset name_Stor-zone-set-name_vsan_vsan-id_'

    2. 영역 세트에 스토리지 영역 추가:

      Member_Stor-zone-name _

    3. 영역 세트를 활성화합니다.

      'zoneset activate name_Stor-zone-set-name_vsanid_'

    FC_switch_A_1# conf t
    FC_switch_A_1(config)# zoneset name STORI_Zoneset_1_20 vsan 20
    FC_switch_A_1(config-zoneset)# member STOR_Zone_1_20_25
    ...
    FC_switch_A_1(config-zoneset)# exit
    FC_switch_A_1(config)# zoneset activate name STOR_ZoneSet_1_20 vsan 20
    FC_switch_A_1(config)# exit
    FC_switch_A_1# copy running-config startup-config
  6. FCVI 영역을 만들고 FCVI 포트를 추가합니다.

    각 FCVI 영역에는 하나의 DR 그룹의 모든 컨트롤러에 있는 FCVI 포트가 포함되어 있습니다.

    참고 Fabric에 있는 스위치 하나에서만 이 단계를 수행합니다.

    조닝은 사용 중인 FC-to-SAS 브릿지 모델에 따라 다릅니다. 자세한 내용은 모델 브리지의 섹션을 참조하십시오. 이 예에는 Brocade 스위치 포트가 표시되어 있으므로 그에 따라 포트를 조정하십시오.

    각 스토리지 존은 모든 컨트롤러의 HBA 이니시에이터 포트와 FC-to-SAS 브리지를 연결하는 단일 포트를 포함합니다.

    1. FCVI 영역을 생성합니다.

      "Zone name_FCVI-zone-name_vsanid_"

    2. FCVI 포트를 영역에 추가합니다.

      Member_FCVI-zone-name _

    3. 영역 세트를 활성화합니다.

      "zoneset activate name_FCVI-zone-name-set-name_vsanid_"

    FC_switch_A_1# conf t
    FC_switch_A_1(config)# zone name FCVI_Zone_1_10_25 vsan 10
    FC_switch_A_1(config-zone)# member interface fc1/1 swwn20:00:00:05:9b:24:cb:78
    FC_switch_A_1(config-zone)# member interface fc1/2 swwn20:00:00:05:9b:24:cb:78
    FC_switch_A_1(config-zone)# member interface fc1/1 swwn20:00:00:05:9b:24:12:99
    FC_switch_A_1(config-zone)# member interface fc1/2 swwn20:00:00:05:9b:24:12:99
    FC_switch_A_1(config-zone)# end
    FC_switch_A_1# copy running-config startup-config
  7. FCVI 영역 세트를 생성하고 FCVI 영역을 추가합니다.

    참고 Fabric에 있는 스위치 하나에서만 이 단계를 수행합니다.
    1. FCVI 영역 세트를 생성합니다.

      'zoneset name_FCVI_ZONE_SET_NAME_VSAN_VSAN-id_'

    2. FCVI 영역을 영역 세트에 추가합니다.

      Member_FCVI_zonename_'입니다

    3. 영역 세트를 활성화합니다.

      "zoneset activate name_FCVI_ZONE_SET_NAME_VSAN_VSAN-id_"

    FC_switch_A_1# conf t
    FC_switch_A_1(config)# zoneset name FCVI_Zoneset_1_10 vsan 10
    FC_switch_A_1(config-zoneset)# member FCVI_Zone_1_10_25
    FC_switch_A_1(config-zoneset)# member FCVI_Zone_1_10_29
        ...
    FC_switch_A_1(config-zoneset)# exit
    FC_switch_A_1(config)# zoneset activate name FCVI_ZoneSet_1_10 vsan 10
    FC_switch_A_1(config)# exit
    FC_switch_A_1# copy running-config startup-config
  8. 조닝 확인:

    '조수 구역'

  9. 두 번째 FC 스위치 패브릭에서 이전 단계를 반복합니다.

FC 스위치 구성이 저장되었는지 확인합니다

모든 스위치에서 FC 스위치 구성이 시작 구성에 저장되었는지 확인해야 합니다.

두 FC 스위치 패브릭에서 다음 명령을 실행합니다.

'copy running-config startup-config’를 선택합니다

FC_switch_A_1# copy running-config startup-config

FC_switch_B_1# copy running-config startup-config