Upgrade the Element Plug-in for vCenter Server

Contributors netapp-pcarriga netapp-yvonneo

For existing vSphere environments with a registered NetApp Element Plug-in for VMware vCenter Server, you can update your plug-in registration after you first update the management services package that contains the plug-in service.

You can update the plug-in registration on vCenter Server Virtual Appliance (vCSA) or Windows using the registration utility. You must change your registration for the vCenter Plug-in on every vCenter Server where you need to use the plug-in.

This upgrade procedure covers the following upgrade scenarios.

Note Management services 2.22.7 includes NetApp Element Plug-in for VMware vCenter Server 5.0 which contains the remote plug-in. If you use the Element plug-in, you should upgrade to version 5.0 to comply with the VMware directive that removes support for local plug-ins. Learn more. If you do not use the plug-in, this is an optional upgrade.
Element vCenter Plug-in 5.0 or later

Beginning with Element Plug-in for VMware vCenter Server 5.0, this upgrade procedure covers the following upgrade scenarios:

  • You are upgrading to Element Plug-in for vCenter Server 5.0.

  • You are upgrading to a 8.0 or 7.0 HTML5 vSphere Web Client.

    Important Element Plug-in for vCenter 5.0 and later is not compatible with vCenter Server 6.7 and 6.5.
Note When you upgrade from Element Plug-in for vCenter Server 4.x to 5.0, the clusters already configured with the plug-in are lost because the data cannot be copied from a vCenter instance to a remote plug-in. You must re-add the clusters to the remote plug-in. This is a one-time activity when upgrading from a local plug-in to a remote plug-in.
Element vCenter Plug-in 4.10 or earlier

For Element Plug-in for vCenter Server 4.10 or earlier, this upgrade procedure covers the following upgrade scenarios:

  • You are upgrading to Element Plug-in for vCenter Server 4.10, 4.9, 4.8, 4.7, 4.6, 4.5, or 4.4.

  • You are upgrading to a 7.0, 6.7, or 6.5 HTML5 vSphere Web Client.

    Important
    • The plug-in is not compatible with VMware vCenter Server 8.0 for Element Plug-in for VMware vCenter Server 4.x.

    • The plug-in is not compatible with VMware vCenter Server 6.5 for Element Plug-in for VMware vCenter Server 4.6, 4.7, and 4.8.

  • You are upgrading to a 6.7 Flash vSphere Web Client.

    Important The plug-in is compatible with vSphere Web Client version 6.7 U2 for Flash, 6.7 U3 (Flash and HTML5), and 7.0 U1. The plug-in is not compatible with version 6.7 U2 build 13007421 of the HTML5 vSphere Web Client and other 6.7 U2 builds released prior to update 2a (build 13643870). For more information about supported vSphere versions, see the release notes for your version of the plug-in.
What you’ll need
  • Admin privileges: You have vCenter Administrator role privileges to install a plug-in.

  • vSphere upgrades: You have performed any required vCenter upgrades before upgrading the NetApp Element Plug-in for vCenter Server. This procedure assumes that vCenter upgrades have already been completed.

  • vCenter Server: Your vCenter Plug-in version 4.x or 5.x is registered with a vCenter Server. From the registration utility (https://<ManagementNodeIP>:9443), select Registration Status, complete the necessary fields, and select Check Status to verify that the vCenter Plug-in is already registered and the version number of the current installation.

  • Management services updates: You have updated your management services bundle to the latest version. Updates to the vCenter plug-in are distributed using management services updates that are released outside of major product releases for NetApp SolidFire all-flash storage.

  • Management node upgrades:

    • Beginning with Element vCenter plug-in 5.0, you are running a management node that has been upgraded to version 12.3.x or later.

    • For Element vCenter plug-in 4.4 to 4.10, you are running a management node that has been upgraded to version 11.3 or later. vCenter Plug-in 4.4 or later requires an 11.3 or later management node with a modular architecture that provides individual services. Your management node must be powered on with its IP address or DHCP address configured.

  • Element storage upgrades:

    • Beginning with Element vCenter plug-in 5.0, you have a cluster running NetApp Element software 12.3.x or later.

    • For Element vCenter plug-in 4.10 or earlier, you have a cluster running NetApp Element software 11.3 or later.

  • vSphere Web Client: You have logged out of the vSphere Web Client before beginning any plug-in upgrade. The web client will not recognize updates made during this process to your plug-in if you do not log out.

Steps
  1. Enter the IP address for your management node in a browser, including the TCP port for registration:
    https://<ManagementNodeIP>:9443
    The registration utility UI opens to the Manage QoSSIOC Service Credentials page for the plug-in.

    depicts the registration utility UI for the plug-in
  2. Select vCenter Plug-in Registration.

    • The vCenter Plug-in Registration page for Element Plug-in for vCenter Server 5.0:

      depicts the registration utility UI for the plug-in
    • The vCenter Plug-in Registration page for Element Plug-in for vCenter Server 4.10 or earlier:

      depicts the registration utility UI for the plug-in
  3. Within Manage vCenter Plug-in, select Update Plug-in.

  4. Confirm or update the following information:

    1. The IPv4 address or the FQDN of the vCenter service on which you will register your plug-in.

    2. The vCenter Administrator user name.

      Note The user name and password credentials you enter must be for a user with vCenter Administrator role privileges.
    3. The vCenter Administrator password.

    4. (For in-house servers/dark sites) Depending on your Element Plug-in for vCenter version, a custom URL for the plug-in JSON file or plug-in ZIP:

      1. Beginning with Element Plug-in for vCenter Server 5.0, a custom URL for the plug-in JSON file.

        Note You can select Custom URL to customize the URL if you are using an HTTP or HTTPS server (dark site) or have modified the JSON file name or network settings. For additional configuration steps if you intend to customize a URL, see Element Plug-in for vCenter Server documentation about modifying vCenter properties for an in-house (dark site) HTTP server.
      2. For Element Plug-in for vCenter Server 4.10 or earlier, a custom URL for the plug-in ZIP.

        Note You can select Custom URL to customize the URL if you are using an HTTP or HTTPS server (dark site) or have modified the ZIP file name or network settings. For additional configuration steps if you intend to customize a URL, see Element Plug-in for vCenter Server documentation about modifying vCenter properties for an in-house (dark site) HTTP server.
  5. Select Update.

    A banner appears in the registration utility UI when the registration is successful.

  6. Log in to the vSphere Web Client as a vCenter Administrator. If you are already logged in to the vSphere Web Client, you must first log out, wait two to three minutes, and then log in again.

    Note This action creates a new database and completes the installation in the vSphere Web Client.
  7. In the vSphere Web Client, look for the following completed tasks in the task monitor to ensure installation has completed: Download plug-in and Deploy plug-in.

  8. Verify that the plug-in extension points appear in the Shortcuts tab of the vSphere Web Client and in the side panel.

    • Beginning with Element Plug-in for vCenter Server 5.0, the NetApp Element Remote Plugin extension point appears:

      depicts the plug-in extension points after a successful upgrade or install for ELement Plug-in 5.10 or later
    • For Element Plug-in for vCenter Server 4.10 or earlier, the NetApp Element Configuration and Management extension points appear:

      depicts the plug-in extension points after a successful upgrade or install for ELement Plug-in 4.10 or earlier
      Note

      If the vCenter Plug-in icons are not visible, see Element Plug-in for vCenter Server documentation about troubleshooting the plug-in.

      After upgrading to NetApp Element Plug-in for vCenter Server 4.8 or later with VMware vCenter Server 6.7U1, if the storage clusters are not listed or a server error appears in the Clusters and QoSSIOC Settings sections of the NetApp Element Configuration, see Element Plug-in for vCenter Server documentation about troubleshooting these errors.

  9. Verify the version change in the About tab in the NetApp Element Configuration extension point of the plug-in.

    You should see the following version details or details of a more recent version:

    NetApp Element Plug-in Version: 5.0
    NetApp Element Plug-in Build Number: 37
Note The vCenter Plug-in contains online Help content. To ensure that your Help contains the latest content, clear your browser cache after upgrading your plug-in.