Host requirements to install SnapCenter Plug-ins Package for Windows

Contributors netapp-nsriram Download PDF of this page

Before you install the SnapCenter Plug-ins Package for Windows, you should be familiar with some basic host system space requirements and sizing requirements.

Item Requirements

Operating Systems

Microsoft Windows

For the latest information about supported versions, see the NetApp Interoperability Matrix Tool.

Minimum RAM for the SnapCenter plug-in on host

1 GB

Minimum install and log space for the SnapCenter plug-in on host

5 GB

Note You should allocate sufficient disk space and monitor the storage consumption by the logs folder. The log space required varies depending on the number of the entities to be protected and the frequency of data protection operations. If there is no sufficient disk space, the logs will not be created for the recently run operations.

Required software packages

  • Microsoft .NET Framework 4.5.2 or later

  • Windows Management Framework (WMF) 4.0 or later

  • PowerShell 4.0 or later

For the latest information about supported versions, see the NetApp Interoperability Matrix Tool.